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Debugging ARMv7 Applications in
Environment Initialized by U-Boot / ROM

Target Debug

1.Introduction

This document describes the necessary steps required to
use CodeWarrior for QorlIQ LS series - ARM V7 ISA for
debugging applications running in an environment
initialized by U-Boot.
This document explains:

¢ How to build U-Boot to add bootelf support

¢ How to load the application to the target

¢ How to debug from the entry point using
CodeWarrior, an application started using the
bootelf command

¢ How to debug from the entry point using
CodeWarrior, an application flashed in NOR

¢ How to debug a secure ROM target application

* How to debug ROM applications on some
specific LS1 boards
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Debugging applications started from U-Boot

2.Debugging applications started from U-Boot

2.1. Add bootelf support to U-Boot

The bootelf command allows booting an ELF image in memory after the U-Boot is loaded. To add
bootelf support to U-Boot, perform these steps:

1. Install SDK with Yocto and build U-Boot. For more details, see Freescale Infocenter.

S bitbake u-boot

2. Go to the U-Boot source location and edit config cmd_default. h, to add the bootelf
command.

Figure 1. Edit config_cmd_default.h file

B/
* Olphabetical list of all commands that are configured by defaunlct.
* Thiz is essentially all commands minus those that are considered
* "non-standard" for some reason (memory hogs, requires special
* hardware, not fully tested, gLg.) .
#define CONFIG CMD EBDI /* bdinfo =/
B * bootd *
/* ELF (VxWorks) load/boot cmd */ ||
1 X | * coninfo =
#define CONFIG_CMD ECHC /* echo arguments =/

3. Rebuild U-Boot:

S bitbake -c compile -f u-boot

This adds bootelf support to the U-Boot image available in the u-boot folder.

2.2. Run and debug application

First, you need to create an ARMv7 application, starting from stationary project. The project must be
created with UART 1/O support, to display messages on U-Boot console. The steps are:

Create an ARMv7 project and build it using a RAM target.
Power on the board and stop at U-Boot prompt.

Copy the ELF file to a TFTP server location.

Load the ELF to RAM, using U-Boot commands.

el S
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Debugging applications started from U-Boot

Figure 2. Load ELF to RAM

5. To start debugging from the entry point, connect to the target board using Attach launch
configuration and set a hardware breakpoint at _startCustom, using Debugger Shell command

bp -hw _startCustom.

Figure 3. Set a hardware breakpoint at _startCustom

%5 Debugger Shell &3 =5 Progress w = — 0

¥>bp -hw _startCustom

id instance address  type enabled? process
description
#28 #1  w:0x308088330 -hw ENABLED Bx@ crt@.s,

line 167 [lslqds_crt@_uart-core@.elf]
x>

6. From U-Boot prompt, run the bootelf command. This executes the ELF from RAM.

Figure 4. Run bootelf command

7. Breakpoint will be hit and you can perform debugging from the entry point.
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Debugging applications started from U-Boot

Figure 5. Perform debugging from entry point

[8] crt0.5 E2 =5

add s1, r2, #256
#endif
LLC27:
#else
/* Set up the stack pointer to a fixed value */
/* Changes by teralf:
- Allow linker script to provide stack via _ stack symbol - see
defintion of .Lstack a
- Provide "hooks" that may be used by the application to add
custom init code - see .Lhwinit and .Lswinit
- Go through all executicn modes and set up stack for each of them.
Loosely based on init.s from ARM/Motorola example code.
Note: Mode switch wia CPSR is not allowed once in nen-privileged
mode, so we take care not to enter “"User” to set up its sp,
and also skip most operations if already in that mode. */

o ldr r3, .Lstack
cmp r3, #@
#ifdef _ thumb2__
it eq
#endif
#ifdef _ ARM_ARCH 6M_
bne .LC28 o8

8. To continue debugging from main function, set a breakpoint using Debugger Shell command bp
main and resume the core.

Figure 6. Set a breakpoint at main function

(s, = *oor=:| Tl

¥>bp -hw _startCustom

id instance address  type enabled? process
descriptien
£268 #1 x:@xB00083a8 -hw ENABLED @xé crt@.s,
line 167 [lslqds_crt@_uart-core@.elf]
*>bp main
id instance address  type enabled? process
description
#21 #1 x:8x88808344 -autc ENABLED @x@ main.c,
line 37, main [lslqds_crt@_uart-core@.elf]
¥xgo

%3

Breakpoint will be hit, as shown in the figure below.
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Debugging applications flashed in NOR

Figure 7. Application stopped at main function
(5] crtds Le| main.c &3 = O
{ -

ret = Recursive(iteration ¥ 28);
}

return ret;

nt main{void)

1

int iteration = @;
float nr = 3.1415926;

printf ("This is CodeWarricr for ARMY7!h\rin™);
printf ("The number PI has the walue: %1f.\r\n", nr);

for(s;)

Performancekork(iteration);
iteration++;

m

}

return 8;

9. Continue debugging (step, run, or breakpoint) till the end of the application.

Figure 8. Debug application

= I

NOTE To debug the application from the entry point, a copy of the startup file (crt0. S)

needs to be included in source form. This is not applicable to CodeWarrior for ARM
v710.0.3 release.

3.Debugging applications flashed in NOR

To debug an application flashed in NOR, perform these steps:

Create an ARMv7 project.

Choose Project > Properties to open the Properties window for the project.

Select C/C++ Build > Settings to open project settings.

On the Tool Settings tab, select Additional Tools to open the Additional Tools page.
Select the Create Flash Image checkbox, as shown in the figure below.

M
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Debugging applications flashed in NOR

Figure 9. Select Create Flash Image option

-
¥ Properties for Is1qds_uart_rom-cored
type filter text Settings - Islqds_uart_rom-core0
- Resource
Builders
a C/C++ Build Configuration: [RAM [ Active ]
Build Variables
Discovery Options
Environment & Tool Settings ‘ 2 Build Steps | Build Artifact | Binary Parsers I 3 Error Parsers | Build Tool Versions
Logging
Settings @ Target Processor Create Flash Image
Tool Chain Editor (#2 Debugging [7] Create Extended Listing
- C/C++ General (# Additional Tools [7] Print Size
Run/Debug Settings B3 ARM Sourcery GCC Assembler

6. On the Tool Settings tab, select ARM Sourcery GNU Create Flash Image > Output to open
the Output page.

7. Choose binary as the output file format, as shown in the figure below.

Figure 10. Choose output file format

B9 Tool Settings | # Build Steps I Build Artifact | Binary Parsers I @ Error Parsers | Build Tool Versions

(% Target Processor Output file format (-0) Ibinary b I
@ Debugging
@ Additional Tools
53 ARM Sourcery GCC Assembler
(%2 Preprocessor
@ Directories
(22 Warnings
(2 Miscellaneous
%3 ARM Sourcery GCC C Compiler
(22 Preprocessor
(22 Directories
(2 Optimization
2 Warnings
2 Miscellaneous
B4 ARM Sourcery GCC C Linker
& General
2 Libraries
@ Miscellaneous
83 ARM Sourcery GCC C Preprocessor
@ Preprocessor Settings
%3 ARM Sourcery GCC C++ Preprocessor
@ Preprocessor Settings
% ARM Sourcery GNU Create Flash Image
2 Output
@ Section
@ Miscellaneous

8. Click Apply, and then click OK.
9. Build the application using ROM target. Beside the ELF file, a binary file will be produced.

\=| lslgds_uart_rom-corel.bin B2KE
%5 Islqds_uart_rom-cored.elf 166 KB

10. Connect to the target board and load the application binary file to NOR flash, using Flash
Programmer, as shown in the figure below.
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Debugging applications flashed in NOR

Figure 11. Add Program / Verify Action dialog

Add Program / Verify Action

Flash Devices

Base Address
0x60000000

Device Name
JS28F00AM29EWHA (B4 Maclbxl)

=l
[] Use File from Launch Configuration
File: S{workspace_loc:/1s1021 atwr-cored/ROM/ 151021 atwr-cored.bin}
File Type: ’Workspace...] ’File System...] "u’ariables...]
Erase sectors before program [ Verify after program

[] Restrict to Addresses in this Range Apply Address Offset

Address: Ox  6TEE0000

67FFFFFF

Update Program Action | | Update Verify Action

NOTE

The binary file will be flashed in NOR at the same address where U-Boot is usually

placed. Because of this, if U-Boot is present on the target board, it will be
overwritten by the application. The address is specified in the ROM linker file.

At the board reset, the application will run and it can be debugged.

11. To start debugging from the entry point, connect to the target board using ROM Attach launch
configuration, and then reset the board with no initialization file.

Figure 12. Reset dialog

ﬁl Reset

&3

Execute a target reset:

Target Run out of reset
L510214 [
Cortex-A7-0 ]
Cortex-AT-1 |

@)

WS

Note: Target initialization files only apply to debugged cores.

Reload settings from the target configuration:

Initialize target Initialize target script

B
]
c

[ Reset Cancel ]

12. Set a hardware breakpoint at _

shown in the figure below.

start, using Debugger Shell command bp -hw _start, as
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Debugging applications flashed in NOR

Figure 13. Set a hardware breakpoint at _start

55 Debugger Shell &3 = =0

CodeWarrior Debugger Shell vi1.@
#xbp -hw _start

id instance address  type enabled? process
description

#3 #1 x:8x67230294 -hw ENABLED Bx@ crt@.s,
line 167 [lsl@2latwr-core@.elf]
EE

13. Resume the core. Breakpoint will be hit and you can perform debugging from the entry point.

Figure 14. Perform debugging from entry point

[ ertds 22 =B

add sl, r2, #256
#endif
LLC27:
#else
/* Set up the stack peinter to a fixed value */
/* Changes by toralf:
- Allow linker script to provide stack via _ stack symbol - see
defintion of .Lstack A
- Provide "hooks™ that may be used by the application to add
custom init code - see .Lhwinit and .Lswinit
- Go through all execution modes and set up stack for each of them.
Loosely based on init.s from ARM/Motorola example code.
Note: Mode switch wia CPSR is not allowed once in nen-privileged
mode, so we take care not to enter "User" to set up its sp,
and also skip most operations if already in that mode. */

» ldr r3, .Lstack
cmp r3, #@
#ifdef _ thumb2__
it eq
#endif
#ifdef _ ARM_ARCH 6M__
bne .LC28 e

4

14. To continue debugging from the ma in function, set a breakpoint using Debugger Shell
command bp main and resume the core.
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Debugging applications flashed in NOR

Figure 15. Set a breakpoint at main function

[%5 Debugger Shell 3 w = — 0

CodeWarrior Debugger Shell v1.@
¥>bp -hw _start

id instance address  type enabled? process
description

#3 #1 x:@x67e30294 -hw ENABLED Bx@ crt@.s,
line 167 [1lsl@2latwr-core@.elf]
¥rgo
¥:bp -hw main

id instance address  type enabled? process
description

#4 #1  w:@xE7e30280 -hw ENABLED @x8® main.c,
line 39, main [lsl@2latwr-core@.elf]
¥>go

B

Breakpoint will be hit, as shown in the figure below.

Figure 16. Application stopped at main function

lg] main.c &2 =g
} -
return ret;
}
int gl;

int main(void)

int iteration = @;
float nr = 3.1415926;

printf ("This is CodeWarrior for ARMVZIWPANn");
printf ("This is the ROM target!'rin");
printf ("The number PI has the value: ¥1f.\r\n", nr);

m

for(s;)
PerformanceWork(iteration);
iteration++;
gl++;
¥ -

NOTE To debug the application from the entry point, a copy of startup file (crt0. S) needs

to be included in source form. In addition, the LCF file needs to be modified to
include changes necessary for application to be loaded to ROM. This is not
applicable to CodeWarrior for ARM v7 10.0.3 release.
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Debugging secure ROM target applications

4.Debugging secure ROM target applications

Debugging a ROM target application signed with Code Signing Tool (CST) involves, besides the steps

from Debugging applications flashed in NOR, signing the application and generating the application
header. For details on CST, see Freescale Infocenter.

To sign a ROM target application with CST, perform these steps:

1.
2.

3.

Generate private key - public key pair.

Copy ROM target application to /tmp/sysroots/x86_64-1inux/usr/bin/cst.
Specify the name of the application and command sequence file (CSF) header in the
input_files/uni_sign/1sl/input_uboot_nor_ secure file.

Figure 17. Specify application name and CSF header

4 Specify IMAGE, Max © images are possible. DST_ADDR is required only for Non-PBL Platform. [Mandatory]
# USAGE : IMAGE NO = {IMAGE NAME, SRC ADDR, DST_ADDR}

TMAGE 1={1s1021 rom.bin, 67£80000, fELEEELE}
DMAGE_2={,,}

# Specify CEM AND F5SL ID to be populated in header. [Optionall]
# e.g FSL_UID=11111111

FSL_UID=

FSL UID 1=

OEM_UID=

OEM UID 1=

+ Specify the file names of header and gg table. (Default :hdr.out) [Cptional]

CUTPUT_HDR_FILENAME=hdr_ls1021_rom.out

Execute the . /uni_sign
input_files/uni_sign/1lsl/input_uboot_nor_secure command.
Connect to the target board and load the application binary file and CSF header to NOR flash,

using Flash Programmer.
Start debugging (step, run, or breakpoint) using the steps from Debugging applications flashed in
NOR.

NOTE For secure boot in RCW, set SB_EN = 1. Also, PBI commands must contain
reference to CSF header address.
The binary file will be flashed in NOR at the same address where U-Boot is usually
placed. Because of this, if U-Boot is present on the target board, it will be
overwritten by the application.
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Debugging ROM target applications - Use cases

5.Debugging ROM target applications - Use cases

5.1.

Debugging an LS102MARDB ROM target application

To debug a ROM application running on an LS102MARDB target, perform these steps:

D=

5.2.

Create an ARMv7 project for LS102MARDB with ROM Attach launch configuration.

Set the board for 12C boot (SW1[6:7]).

Power on the board and interrupt the autoboot sequence.

Connect to the target board using ROM Attach launch configuration. If the target is in the
Running mode, then suspend the target.

Set the PC at the value 0x20000000 (this is the entry point of application) using Debugger Shell
command reg PC=0x20000000.

Start debugging (step, run, or breakpoint).

NOTE  After the application is built using CodeWarrior, use Flash Programmer to write the
application to ROM, ensuring that the Apply Address Offset checkbox is not
selected.

Debugging an LS1024ARDB ROM target application

To debug a ROM application running on an LS1024ARDB target, follow these steps:

AU e

Create an ARMvV7 project.

Ensure that the LS1024ARDB SDK is available.

Choose Project > Properties to open the Properties window for the project.

Select C/C++ Build > Settings to open project settings.

On the Tool Settings tab, select Additional Tools to open the Additional Tools page.
Select the Create Flash Image checkbox, as shown in the figure below.

Figure 18. Select Create Flash Image option

7.

8.

Fﬁ Properties for Islqds_uart_rom-coreQ
type filter text Settings - Islqds_uart_rom-core0
Resource
Builders
4 C/C++ Build Configuration: |RAM [ Active ]

Build Variables
Discovery Options
Environment & Tool Settings ‘ Build Steps | Build Artifact | |n_ﬂ, Binary Parsers I 3 Error Parsers | Build Tool Versions
Legging
Settings (22 Target Processor | /| Create Flash Image I
Tool Chain Editor g Debugging Create Extended Listing

C/C++ General # Additional Tools Print Size

Run/Debug Settings B ARM Sourcery GCC Assembler

On the Tool Settings tab, select ARM Sourcery GNU Create Flash Image > OQutput to open
the Output page.
Choose binary as the output file format, as shown in the figure below.
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Figure 19. Choose output file format

& Tool Settings | 4 Build Steps I Build Artifact | Binary Parsers I @ Error Parsers | Build Tool Versions

(2 Target Processor Qutput file format (-0) | binary -
2 Debugging
2 Additional Toals
B3 ARM Sourcery GCC Assembler
(22 Preprocessor
(2 Directories
# Warnings
# Miscellaneous
% ARM Sourcery GCC C Compiler
@ Preprocessor
@ Directories
@ Optimization
@ Warnings
@ Miscellaneous
% ARM Sourcery GCC C Linker
@ General
@ Libraries
@ Miscellaneous
%3 ARM Sourcery GCC C Preprocessor
(22 Preprocessor Settings
B ARM Sourcery GCC C++ Preprocessor
(22 Preprocessor Settings
53 ARM Sourcery GNU Create Flash Image
2 Output
(22 Section
# Miscellaneous

9. On the Tool Settings tab, select ARM Sourcery GNU Create Flash Image > Section to open
the Section page.
10. Select the checkboxes labeled Section: -j .text and Section: -j .data.

Figure 20. Select Section page options

& Tool Settings | = Build Steps | Build Ar‘tifactl Binary Parsersl & Error Parsers | Build Tool Versions

(3 Target Processor Section: -j text
@ Debugging Section: -] .data
i Additional Tools —_— -
g ARM Sourcery GCC Assembler Other () a8 8
(22 Preprocessor
(22 Directories
(2 Warnings
(2 Miscellaneous
B3 ARM Sourcery GCC C Compiler
@ Preprocessor
@ Directories
@ Optimization
(# Warnings
@ Miscellanecus
3 ARM Sourcery GCC C Linker
(2 General
(2 Libraries
(2 Miscellaneous
B3 ARM Sourcery GCC C Preprocessor
@ Preprocessor Settings
@) ARM Sourcery GCC C++ Preprocessor
@ Preprocessor Settings
3 ARM Sourcery GNU Create Flash Image
(& Output
(22 Section
(2 Miscellaneous

11. Click Apply, and then click OK.

12. Build the application using ROM target. Besides the ELF file, a binary file will be produced.
13. Rename the binary image to uImage and place it in the

/target/linux/comcerto2000/image/ImageGenarator/ folder of the
LS1024ARDB SDK.

Debugging ARMv7 Applications in Environment Initialized by U-Boot / ROM Target Debug Application Note

12 Freescale Semiconductor



Debugging ROM target applications - Use cases

14. Sign the application using kernel_gen. sh script. Singing the application will make it
recognized by the microloader.
A new uImagel will be produced.

15. Connect to the target board and using Flash Programmer, load the application binary file to NOR
flash, at address 0xC0020000.

16. Reset the board and microloader will recognize and run the application.
17. Start debugging (step, run, or breakpoint).

NOTE To debug the application from the entry point, connect to the target after reset,
suspend the target, and set the PC at the value 0x01000000, using Debugger Shell

command reg PC=0x01000000.
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