Freescale Semiconductor Document Number: ANS277

Application Note

Using an External GCC Toolchain with
CodeWarrior for Power Architecture

1.Introduction Contents

. . INtroducCtion ..., 1
This document explains how to use an external GNU Preliminary BACKGrOUNG....ooeeroern 5

1
2.
compiler collection (GCC) toolchain with CodeWarrior 3. Installing SDK standalone toolchain............... 2
for Power Architecture. This process is only applicable 4. Working with a Power Architecture Linux

to the Linux version of CodeWarrior. PPHCALION PrOJECT..cvvvvrrrrrrssssssissss v 2
5. Importing existing code as a Makefile project9

This document provides steps to:

¢ Build the toolchain supplied with Freescale
Linux SDK

¢ (Customize a Linux project to work with an SDK
standalone toolchain

¢ Build the project using an external toolchain

¢ Import existing code as a makefile project

© 2016 Freescale Semiconductor, Inc. All rights reserved.

h -
P ]



Preliminary background

2. Preliminary background

CodeWarrior for Power Architecture may or may not include the Freescale PPC or GCC binary
toolchain. If you are developing a Linux user space application with CodeWarrior, then you should use
the toolchain supplied with the Freescale Linux SDK.

3.Installing SDK standalone toolchain

You can use the standalone toolchain provided in SDK to build a Linux user space application with
CodeWarrior. To build and install the standalone toolchain with Yocto, perform these steps:

$ cd <sdk install path>

$ source ./fsl-setup-env -m <machine>

$ cd build <machine> release

$ bitbake fsl-toolchain

$ cd build <machine> release/tmp/deploy/sdk

$ ./fsl-networking-eglibc-<host-system>-<core>-toolchain-
<release>.sh

NOTE The default installation path for the standalone toolchain is: /opt/fsl-
networking/. You need to specify this path while installing the standalone
toolchain.

For additional information about building and installing the standalone toolchain
with Yocto, see SDK Knowledge Center.

See Change toolchain for using SDK standalone toolchain as the default build tool in CodeWarrior.

4.Working with a Power Architecture Linux application
project
This section contains the following subsections:
¢ C(reate a stationary project for Linux application
¢ Change toolchain
¢ Verify build settings

* Build project using an external toolchain

4.1. Create a stationary project for Linux application

To create a Power Architecture stationary project for Linux application, follow these steps:

1. Start CodeWarrior for Power Architecture.
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Working with a Power Architecture Linux application project

2. Choose File > New > CodeWarrior Linux Project Wizard from the CodeWarrior IDE menu
bar. CodeWarrior Linux Project Wizard starts.

Specify the project name and location.
Select the processor and project output.

Configure the build settings.

AN

Configure the connection details and click Finish to create the Linux application project.

NOTE To create Linux application projects, you need to install Linux build tool.

CodeWarrior does not provide Linux project wizard for the MPC8323 processor. If
you need to create a new Linux project using the 8323 processor, then choose any
processor at step 4 and follow the steps from next section.

Importing an example project can also be a starting point for creating a Linux
application.

4.2. Change toolchain

By default, the stationary project for Linux application includes the Freescale PPC or GCC binary
toolchain. In case, CodeWarrior does not provide the required toolchain, then you can add a default
toolchain and an external build tool, by following these steps:

1. Choose Project > Properties from the CodeWarrior IDE menu bar. The Properties dialog
appears.

2. Select C/C++ Build > Discovery Options in the left pane and specify Freescale Linux SDK
standalone toolchain path in the Compiler invocation command field in the right pane.
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Working with a Power Architecture Linux application project

Figure 1. Specify Freescale Linux SDK standalone toolchain path

™ Properties For Linux_App

I Discovery Options - Linux_App Sw -
® Resource

Builders Configuration: | Linux_Application [Active]
¥ C/C++Build
Build variables

- | |[Manage C.onfigurations..._|

| Discovery Options | Discovery profiles scope
Environment | Per Language = .
Logging
Settings Tools: Automated discovery of paths and symbols
Tool Chain Editor Power Linux Compiler [& Automate discovery of paths and symbols
» C/C++General [ Report path detection problems
Run/Debug Settings i ; - -
Discovery profile: | Power Linux Cdiscon 7 |
Clear discovered entries now: | Clear |

Discovery profile options

& Enable generate scanner info command

Compiler invocation command

Jopt/Fsl-networking/QorlQ-SDK-V1.7-MPC832XMDS/sysro| |Browsew:

NOTE Compiler invocation command should be something like this: /opt/fsl-
networking/QorIQ-SDK-

<release>/sysroot/<target architecture>-fsl-linux.

3. Click Apply to apply the new settings.
4. Select C/C++ Build > Tool Chain Editor in the left pane and:

e For an active configuration, choose Power Architecture Linux C Debug Tool Chain
from the Current toolchain menu in the right pane

e For arelease configuration, choose Power Architecture Linux C Release Tool Chain
from the Current toolchain menu in the right pane
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Working with a Power Architecture Linux application project

Figure 2. Specify toolchain type
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-
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¥ C/C++Build
Build variables
Discovery Options [& Display compatible toolchains only
Environment
Logging
Settings
Current builder: | Power Linux Debug Builder =
¥ C/C++ General
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Current toolchain: I Power Architecture Linux C Debug Tool Chain I 5

Used tools

Power Linux Linker

Power Linux Compiler
Power Linux Assembler
Power Linux Preprocessor
Power Linux Disassembler

| select Tools... |

NOTE A dialog appears, asking you whether you want to copy tool settings or not. You are
recommended to copy compatible tool settings into the current toolchain.

5. Click Apply to apply the new toolchain.

6. Select C/C++ Build > Settings in the left pane and click the Build Tool Versions tab in the right
pane, as shown in the figure below.

Figure 3. Add new toolchain
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Sektings Edit

4.41 ${CROSS5_TOOLS_HOME}/powerpc-linux/bin -
Tool Chain Editor f - - e P /b -
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7. Click Add and browse for the new toolchain location. The default installation path for Freescale
Linux SDK standalone toolchain is: /opt/fsl-networking/QorIQ-SDK-
<release>/sysroot/<host-system>/usr/bin/powerpc-fsl-linux/

8. Click Apply to apply the new toolchain.

9. Select the new toolchain and click Set As Default, as shown in the figure below. This will make
the new toolchain as the default toolchain for the project.
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Working with a Power Architecture Linux application project

Figure 4. Change default toolchain
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4.3. Verify build settings

After setting the external toolchain as the default toolchain and before building your project, you should
verify the build settings of the project. To verify build settings, follow these steps:

1. Select C/C++ Build > Settings in the left pane of the Properties dialog and click the Tool

Settings tab in the right pane, as shown in the figure below.
Figure 5. Verify build settings
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2. Choose the correct architecture type from the Architecture menu on the Architecture page of the
Tool Settings page. If the desired architecture type is not available for selection, then choose
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Working with a Power Architecture Linux application project

none and specify the architecture type as compiler options on the Miscellaneous page, as shown
in the figure below.

Figure 6. Specify architecture type as compiler options

(& Architecture IOther flags |-c-fmessage-length=0-m32 -msoft-float -mcpu=e300c2 —sysroot:”l =
¥ & power Linux Linker
2 General
2 Libraries

[] verbose (-v)

[] Support ANSI programs (-ansi)

# Miscellaneous [ Position Independent Code (-fPIC)
?&"ﬁ " ]
¢ Shared Library Settings Other Assembler options (-Xassembler [option]) &

(2 PowerPC Environment
¥ & Power Linux Compiler

2 Preprocessor

& symbols

# Includes

(2 Optimization

2 Debugging

# Warnings
I # Miscellaneous I

NOTE The example shown in the figure above is for the MPC8323 processor.

3. For PowerPC Linux assembler, compiler, linker, preprocessor, and disassembler, verify if the
command is same as in the external toolchain (see the figure below).
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Working with a Power Architecture Linux application project

Figure 7. Verify linker command
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Run/Debug Settings

4. Click OK to save the project settings.

Settings - Linux_App

& Architecture

5% Power Linux Linker
& General
& Libraries
& Miscellaneous
2 shared Library Settings
& powerPC Environment

¥ % Power Linux Compiler

2 Preprocessor
& symbols

& Includes

& Optimization
22 Debugging

2 warnings

& Miscellaneous

¥ i Power Linux Assembler

# General

¥ & Power Linux Preprocessor

= Preprocessor Settings

¥ @ Power Linux Disassembler

(% Disassembler Settings

Command: Ipowerpc—fsl—linux—gcc I =

Alloptions: -Fno-use-linker-plugin

Expert settings:

Command [, . . "
e ot ${PAGccLinuxDir}/S{COMMAND}" ${FLAGS} S{OUTPUT_FLAG}S{t

NOTE

Some build options may not be valid for a specific toolchain. For example, -
fdebug-unwind-tables is not a valid option for the e300c2 toolchain. You can
remove this option using the Other flags field on the C/C++ Build > Settings >

Tool Settings > Power Linux Compiler > Miscellaneous page of the Properties
dialog.

The SDK toolchain is a sysrooted toolchain. It means that toolchain will start to look for target fragments

and libraries starting from the path specified by the sysroot option. To have a working build
configuration, follow these steps:

1. Go to the C/C++ Build > Settings > Tool Settings > Power Linux Compiler > Miscellaneous

page of the Properties dialog and specify ~—-sysroot="<path to target sysroot>”
in the Other flags field.

2. Go to the C/C++ Build > Settings > Tool Settings > Power Linux Linker > Miscellaneous
page and specify --sysroot="<path to target sysroot>”inthe Linker flags field.

4.4. Build project using an external toolchain

To build the project, choose Project > Build Project from the CodeWarrior IDE menu bar. The project
starts building and the Console view displays the progress of building the project, as shown in the figure
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4
Importing existing code as a Makefile project

below.

Figure 8. Build project

B Problems | ¥ Tasks | B Console 52 ™. E Properties | 48 Remote Systems = L
CDT Build Console [Linux_App] T r= N [y = = T

*++% Build of configuration Linux Application for project Linux App **#*#

/sdk/Freescale/CodeWarrior PA 10.5.1/gnu/bin/make -j8 all

Building file: ../Sources/main.c

Executing target #1 ../Sources/main.c

Invoking: Power Linux Compiler

"fopt/fsl-networking/QorIQ-SDK-V1.7-MPC832XMDS/sysroots/x86 64-fslsdk-linux/usr/bin/
powerpc-fsl-linux/powerpc-fsl-linux-gcc" @"Sources/main.args" -MMD -MP -MF"Sources/main.d"
-o"Sources/main.o" "../Sources/main.c"

Finished building: ../Sources/main.c

Building target: Linux App.elf

Executing target #2 Linux_ App.elf

Invoking: Power Linux Linker
"/opt/fsl-networking/QorIQ-SDK-V1.7-MPC832XMDS/sysroots/x86 64-fslsdk-linux/usr/bin/
powerpc-fsl-linux/powerpc-fsl-linux-gcc" -o"Linux App.elf" @'Linux App.args"
Finished building target: Linux App.elf

5.Importing existing code as a Makefile project

This section contains the following subsections:
¢ Import Makefile project

¢ Build imported Makefile project using an external toolchain

5.1. Import Makefile project

To import a Makefile Project into CodeWarrior, follow these steps:

1. Choose File > Import from the CodeWarrior IDE menu bar. The Import wizard starts,
displaying the Select page.

2. Choose C/C++ > Existing Code as Makefile Project and click Next. The wizard name and page
name changes to Import Existing Code.

3. Specify project name, existing code location, language, and toolchain, as shown in the figure
below.

Using an External GCC Toolchain with CodeWarrior for Power Architecture Application Note
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Importing existing code as a Makefile project

Figure 9. Specify toolchain

Import Existing Code

Import Existing Code

Create a new Makefile project from existing code in that same directory

Project Name

|:Impnrt_Makefile |

Existing Code Location

|:fsdk,ftest | lBrnwse...‘

Languages
B C ] C++

Toolchain For Indexer Settings

-

<none>
Linux GCC | _ |
Power Architecture Linux C Release Tool Chain
Power Architecture Linux C Static Library Debug Tool Chain
Power Architecture Linux C Static Library Release Tool Chain
Power Architecture Linux C++ Debug Tool Chain
Power Architecture Linux C++ Release Tool Chain
Power Architecture Linux C++ Static Library Debug Tool Chain
Power Architecture Linux C++ Static Library Release Tool Chain

[ show only available toolchains that support this platform

@ < Back Next > Cancel ‘ H

4. Click Finish. The Makefile Locations dialog appears asking for Makefile.
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Importing existing code as a Makefile project

™ Makefile Locations

Makefile(s) are found in the project, please select which makefile to use as the
é default Build Location. The Build Location setting can be modified later as well

in Properties dialog under C/C++ Build panel.

Project location (default/no makefile present)

Jimport_Makefile/Makefile

—

Click OK. The project is created.
Follow the steps from Change toolchain, to change the compiler invocation command and add

the external build tool.

SAINd

5.2. Build imported Makefile project using an external toolchain

To build the project, choose Project > Build Project from the CodeWarrior IDE menu bar. The project
starts building and the Console view displays the progress of building the project, as shown in the figure
below.

Figure 10. Build project

¢ Problems (-E. Tasks (E Console ¥ ~ E Properties} 48 Remote Systems}

= m

CDT Build Console [Import_Makefile] 4 & @ O BE B o Bv v

#*##* Build of configuration Power Linux C Debug for project Import Makefile ##*#
/sdk/Freescale/CodeWarrior PA 10.5.1/gnu/bin/make -j8 all

fsl-linux/powerpc-fsl-linux-gcc -m32 -msoft-float -mcpu=e3@6c2 --sysroot=/opt/fsl-
networking/QorIQ-SDK-V1.7-MPC832XMDS/sysroots/ppce380c2-fsl-linux -0 main.o -c main.c

fsl-linux/powerpc-fsl-linux-gcc -m32 -msoft-float -mcpu=e3@6c2 --sysroot=/opt/fsl-
networking/QorIQ-SDK-V1.7-MPC832XMDS/sysroots/ppce3@0c2-fsl-linux -o test main.o

Jopt/Tsl-networking/QorIQ-SDK-V1.7-MPCB32XMDS/sysroots/x86 64-Tslsdk-linux/usr/bin/powerpc-

Jopt/Tsl-networking/QorIQ-SDK-V1.7-MPCB32XMDS/sysroots/x86 64-Tslsdk-linux/usr/bin/powerpc-
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