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Building Linux Kernel in
CodeWarrior ARMv8

1 Introduction

This application note defines guidelines for configuring

CodeWarrior for ARMvS for Linux Kernel development.

This document explains:

* Installing standalone toolchain supplied with NXP
Linux SDK

* Configuring CodeWarrior for ARMv8 for building
Linux Kernel

* Building Linux Kernel with CodeWarrior for ARMv8

2 Requirements

For building Kernel using CodeWarrior for ARMvS, you need
a host computer with Linux OS and CodeWarrior for ARMvS8

Linux version installed.
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Installing SDK standalone toolchain

3 Installing SDK standalone toolchain

Linux SDK provides a standalone toolchain that can be used for building different application outside Yocto. In our case, we
can use the standalone toolchain for building U-Boot using CodeWarrior for ARMvVS.

To build and install the standalone toolchain with Yocto, perform these steps:

$ cd build <machine> release

$ bitbake fsl-toolchain

$ cd build <machine> release/tmp/deploy/sdk

$ ./fsl-gorig-glibec-<host-system>-<core>-toolchain-<release>.sh

NOTE
The default installation path for the standalone toolchain is: /opt/fsl-qorig/. You need to
specify this path while installing the standalone toolchain. For additional information
about building and installing the standalone toolchain with Yocto, see https://
freescale.sdlproducts.com/LiveContent/web/ui.xql?
action=html&resource=publist_home.html

4 Configuring CodeWarrior for ARMv8 for building Linux
Kernel

To create a project for building U-Boot inside CodeWarrior for ARMv8, perform these steps:

Select File > New > C Project.

Specify the project name and select Empty Project as Project type.

Uncheck the Use default location and click the Browse button to find the location for Linux Kernel source.
Select Cross GCC as Toolchain.

Click Next.
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4
Configuring CodeWarrior for ARMv8 for building Linux Kernel

: C Project

C Project —
{1y Directory with specified name already exists. [
Project name: |U—Boot |
[ Use default location
Location: |f’sdk,’LSEDBBA—SDK—2D16()}'1}yoctof’build_lsEDBBardetmpfwork,*’ﬂ [ Browse... ]
Choose file system: [ default - ]
Project type: Toolchains:
» (= GNU Autotools ~ Cross ARM GCC
® = Yocto Project ADT Autotools Project Cross GCC
¥ (= Executable Linux GCC

® Empty Project
® Hello world ANSI C Project
& Hello world ARM C Project
» = Shared Library
b (= Static Library
® = Yocto Project ADT CMake Project
» (= Others
» (= Makefile project
» (= Remote Makefile Proiect =

[ show project types and toolchains only if they are supported on the platform

® < Back [“][ Cancel | Finish

Figure 1. C Project
6. Select both Debug and Release configurations and click Next.
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Configuring CodeWarrior for ARMv8 for building Linux Kernel

Select Configurations —

Select platforms and configurations you wish to deploy on

Project type:  Executable
Toolchains: Cross GCC
Configurations:

& % Debug

| Select all |
& = Release ; :

|_ Deselect all l

| Advanced settings...

Use "Advanced settings" button to edit project's properties.

Additional configurations can be added after project creation.
Use "Manage configurations" buttons either on toolbar or on property pages.

@ <Back ||  Next> | Cancel | Finish

Figure 2. Select configurations
7. Specity the Cross compiler prefix, Cross compiler path and click Finish.
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4
Configuring CodeWarrior for ARMv8 for building Linux Kernel

Cross GCC Command p—>

Configure the Cross GCC path and prefix

Cross compiler prefix: |aarch64-fsl-linux-

Cross compiler path: |/opt/fsl-qoriq/LS2088A-SDK/sysroots/x86_64-fslsdk-linux/usr/bin/aarch64-fsl-linux | | Browse... |

@ <Back Next > | Cancel || Finish

Figure 3. Cross GCC Command

8. Project is created and will appear in the Project Explorer view.
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Configuring CodeWarrior for ARMv8 for building Linux Kernel

[t5 Project Explorer &2 B8 Target Connecti = O

S -

¥ =t > Kernel [kernel-source |s1088a_ls2088a_layersc
B zxarch

» B Archives

» 4 Binaries

» 3 block

> Eycrypto

b 3 = Debug

B =y Documentation
B Gy drivers

b i firmware

L

» xinclude

* & Includes

B Gxinit

P Gxipc

b kernel

» c lib

* 3 mm

» 3 net

» zysamples

> % scripts =

Figure 4. Project Explorer
9. Go to Project > Properties > C/C++ build, select Builder settings and uncheck Generate Makefiles automatically.
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Configuring CodeWarrior for ARMv8 for building Linux Kernel

El Builder Settings | @Behavior | «*Refresh Policy
Builder
Builder type: External builder

[1 Use default build command

Build command: |make | |Variables... |

Makefile generation

[ ] Generate Makefiles automatically Expand

Build location

Build directory: |,"sdk_fLS:ZDBBA—SDK—ZMﬁO?1Q—yoctofbuild_lsZOBBardb;’tmp;’work,’lszOBBardb—Fsl—linux,”lid

IWorkspace...] [File system... | [Variables...]

|Restore Defaults] [ Apply J

| cancel || 0K |

Figure 5. Builder settings
10. Update the Build directory with Linux Kernel source code path.

11. Select Behavior, empty the Build (incremental build) field and change clean to distclean in Clean field.
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Configuring CodeWarrior for ARMv8 for building Linux Kernel

ElBuilder Settings | @ Behavior | & Refresh Policy

Build settings
[& stop on first build error Enable parallel build

Workbench Build Behavior
workbench build type: Make build target:

Build on resource save (Auto build) Variables

Note: See Workbench automatic build preference

B Build (Incremental build) I\.-’ariables... |
&4 Clean distclean | Variables...
|Restore Defaults | | Apply l
Cancel oK

Figure 6. Behavior
12. Go to Project > Properties > C/C++ build > Environment and add environmental variables for:

Name: CROSS_COMPILE
Value: aarch64-fsl-linux-

Click Add to all configuration

Name: ARCH
Value: arm64

Click Add to all configuration

Name: PATH

Value: /opt/fsl-qoriq/LS2088A -SDK/sysroots/x86_64-fslsdk-linux/usr/bin:/opt/fsl-qoriq/LS2088A-SDK/sysroots/
x86_64-fslsdk-linux/usr/bin/aarch64-fsl-linux:/usr/sbin:/usr/bin:/bin

Click Add to all configuration

NOTE
When SDK standalone toolchain is built in other location than default, it is possible
that other environmental variables must be set. Check the error from Console view
and add the necessary variables.

13. Go to Project > Properties > C/C++ build > Settings and uncheck EIf Parser and select GNU EIf Parser.
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Building Linux Kernel using CodeWarrior for ARMv8

& Binary Parsers | @ Error Parsers

Binary parser:
EIf Parser

| Move Up
Mach-O 64 Parser
PE Windows Parser | Move Down

HP-UX 50M Parser

Mach-0 Parser (Deprecated)
Cyagwin PE Parser

AlX XCOFF32 Parser

Binary Parser Options
addr2line Command:

\addr2line | |Browse... |

c4++Filt Command:

| c++filt | | Browse... |

Figure 7.

5 Building Linux Kernel using CodeWarrior for ARMv8

In order to build Linux Kernel using CodeWarrior for ARMvS, two build activities must be created under Project > Make
Target > Build from the menu bar.
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Building Linux Kernel using CodeWarrior for ARMv8

™ Create Make Target

Target name: [distclean l

Make Target

Same as the target name

Make targek:

Build Command
Use builder settings

Build command:
Build Settings

Stop on first build error

Run all project builders

| Cancel | 0K
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Building Linux Kernel using CodeWarrior for ARMv8

Create Make Target

Target name: | config

Make Target

] same as the target name

Make targek: [Iscriptsfkmnfig,fmerge_mnﬂg.sh arc

Build Command

| Use builder setkings

Build command: |sh

Build Settings

Run all project builders

| Cancel | oK

Figure 8. Create Make Target

Once configured we have two build targets.
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Building Linux Kernel using CodeWarrior for ARMv8

Make Targets

Make Targets for: Kernel

Target Location - Add...
@) distclean
- . | Remove |
® config s
| Edit.. |
Cancel Build

Figure 9. Make Targets

Go to Project > Make Target > Build, select distclean and click Build. A “make distclean” command will run
removing all the object and temporary files. Below message will be displayed when build is complete in the Console view.
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Building Linux Kernel using CodeWarrior for ARMv8

El console 2 i

4 olal B =

= O

mE -0~

;‘ul'

CDT Build Console [Kernel]

17:32:42 #*##** Build of configuration Debug for project Kernel #*##
make distclean

CLEAN scripts/basic

CLEAN  scripts/kconfig

CLEAN  .config

17:32:44 Build Finished (took 2s.176ms)

Figure 10. Console view

Go again to Project > Make Target > Build, select config and click Build. A sh scripts/kconfig/merge config.sh

arch/armé64/configs/defconfig arch/armé4/configs/freescale.config command will run and configure the
Linux Kernel to be built for LS2088 ARDB board in this case.
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Building Linux Kernel using CodeWarrior for ARMv8

£l console 2 H

4 ¢ |%| CERE =B =B i~
CDT Build Console [Kernel]
Value requested for CONFIG SENSORS INA2XX not in final .config -
Requested value: CONFIG SENSORS INA2XX=y
Actual value:

Value requested for CONFIG VFIO FSL MC not in final .config
Requested value: CONFIG VFIO FSL MC=y
CONFIG VFIO FSL MC=y

Actual value: CONFIG VFIO FSL MC=y

Value requested for CONFIG VFIO FSL MC not in final .config
Requested value: CONFIG VFIO FSL MC=y
CONFIG VFIO FSL MC=y

Actual value: CONFIG VFIO FSL MC=y

17:34:84 Build Finished (took 2s5.373ms)

Figure 11. Console view

To build Linux Kernel, go to Project > Build Project from the menu bar. Below message will be displayed when build is
complete in the Console view.
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Building Linux Kernel using CodeWarrior for ARMv8

010

Problems ¢ Tasks | & Console 52 [ Properties i Call Graph & Connectio = O

L o(g EEEE mMBY0-

CDT Build Console [Kernel]
Building modules, stage 2.
MODPOST & modules

cC
LD
cC
LD
cC
LD
cC
LD
cC
LD
cC
LD

[M]

17:43:59

drivers/staging/fsl-dpaa2/dce/fsl-dce-api-time-trial.mod.o
drivers/staging/fsl-dpaa2/dce/fsl-dce-api-time-trial.ko
net/802/p8622.mod.o

net/802/p8022.ko

net/802/psnap.mod.o

net/802/psnap.ko

net/802/stp.mod.o

net/802/stp.ko

net/bridge/bridge.mod.o

net/bridge/bridge.ko

net/1lc/1llc.mod.o

net/1Llc/1llc.ko

Build Finished (took 8m:47s.747ms)

Figure 12. Console view
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implementers to use Freescale products. There are no express or implied
copyright licenses granted hereunder to design or fabricate any integrated
circuits based on the information in this document. Freescale reserves the right
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suitability of its products for any particular purpose, nor does Freescale assume
any liability arising out of the application or use of any product or circuit, and
specifically disclaims any and all liability, including without limitation
consequential or incidental damages. “Typical’ parameters that may be provided
in Freescale data sheets and/or specifications can and do vary in different
applications, and actual performance may vary over time. All operating
parameters, including “typicals,” must be validated for each customer application
by customer's technical experts. Freescale does not convey any license under its
patent rights nor the rights of others. Freescale sells products pursuant to
standard terms and conditions of sale, which can be found at the following
address: nxp.com/SalesTermsandConditions.

Freescale, the Freescale logo, CodeWarrior, and QorlQ are trademarks of
Freescale Semiconductor, Inc., Reg. U.S. Pat. & Tm. Off. ARM, Cortex, Cortex-
A53, Cortex-A57, and TrustZone are registered trademarks of ARM Limited (or
its subsidiaries) in the EU and/or elsewhere. All rights reserved.
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