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Chapter 1
Introduction
This document explains how to install the CodeWarrior Development Studio for QorIQ LS series - ARM V7 ISA.
In addition, it describes how to prepare the boards and how to use CodeWarrior to create, build, and debug a
simple project.

This chapter contains the following sections:

• System requirements on page 5

• Supported devices on page 6

1.1 System requirements
This section provides operating platform requirements for installing CodeWarrior software.

Table 1: System Requirements

Processor Intel® Pentium® 4 processor, 2 GHz or faster, Intel Xeon™, Intel Core™,
AMD Athlon™ 64, AMD Opteron™, or higher

Memory 2 GB RAM

Hardware • CD-ROM drive for CD installation

• Internet connectivity for web downloads and update access

Operating system See Table 2. Supported operating systems on page 5

Disk space At least 3 GB of free disk space

Table 2: Supported operating systems

Windows (32-bit) Windows (64-bit) Linux (64-bit)

Windows 7 Service Pack 1 (SP1) Windows 7 SP1 Ubuntu 14.04 LTS

Windows 10 Windows 8.1 Update 1 (U1) Ubuntu 15.04

Windows 2012 Server Fedora 22

Windows 10 OpenSUSE 13.2

RedHat Enterprise Linux 6.5

RedHat Enterprise Linux / CentOS
7.1

Mint 15

Mint 17.2
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1.2 Supported devices
This section describes the device families and targets that are supported by the CodeWarrior software.

Table 3: Supported target devices

Device Family Description

LS102x family

LS102MA Supports generation of multi-core target projects for LS102MARDB.

LS1020A Supports generation of multi-core target projects for LS1020AQDS and
LS1020ATWR.

LS1021A Supports generation of multi-core target projects for LS1021AIOT,
LS1021AQDS, and LS1021ATWR.

LS1022A Supports generation of multi-core target projects for LS1022AQDS and
LS1022ATWR.

LS1024A Supports generation of multi-core target projects for LS1024ARDB.

Introduction
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Chapter 2
Configuring Target Hardware
This chapter explains how to use the CodeWarrior IDE for configuring the boards supported by the CodeWarrior
Development Studio for QorIQ LS series - ARM V7 ISA software.

This chapter contains the following sections:

• Preparing LS1021AQDS board on page 7

• Preparing LS1021ATWR board on page 9

• Preparing LS1021AIOT board on page 11

2.1 Preparing LS1021AQDS board
This section explains steps to configure the LS1021AQDS board.

Perform the following steps to configure an LS1021AQDS board:

1. Ensure that board is not connected to the power.

2. Ensure that the power to the chassis or the standalone power supply is OFF.

Configuring Target Hardware
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Figure 1: Connecting LS1021AQDS board

3. Check the default switch positions and jumper settings.

a. Attach ATX power cables to board.

• Plug-in the main 24 pin ATX cable into J1.

• Attach the 2x2 power connector into J2.

b. Attach UART cable to top port.

c. Ethernet cable (optional): if using Ethernet, attach Ethernet cable to ETSEC3 port.

d. JTAG/CWTAP (optional): if using JTAG, connect the cable from the CWTAP to J27.

e. Verify if the board is operational.

Configuring Target Hardware
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For more details, see “Connection Setup” chapter from “LS1021QDS-DDR3 Setup
Guide”.

  NOTE  

4. Perform an initial board check and look for correct LED functioning: LED D33, POVDD, XVDD and SVDD
are a steady green color; LED ALARM could flicker with a red color.

5. Power-on the board by pressing the POWER push button switch (SW17).

6. Check for completion of the PRESET (Power-on-Reset) sequence indicated by the LEDs. The LEDs on the
board follow the below sequence:

a. LED OVDD and VDD display steady green light.

b. LED PASS display steady blue light.

c. LED POVDD is closed.

7. Push the POWER push button (SW17) to power off the board.

2.2 Preparing LS1021ATWR board
This section explains steps to configure the LS1021ATWR board.

Perform the following steps to configure an LS1021ATWR board:

1. Ensure that board is not connected to the power.

2. Ensure that the power to the chassis or the standalone power supply is OFF.
Figure 2: Connecting LS1021ATWR board
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Figure 3: Connecting LS1021ATWR board

3. Check the default switch positions.

a. Attach the mini USB cable to USB-serial connector, J5. This will provide serial connectivity and CMSIS-
DAP connection (optional).

 
You need to install the USB driver on the host PC before using the serial terminal. You
can download this driver from: https://mbed.org/handbook/Windows-serial-
configuration

  NOTE  

b. Ethernet cable (optional): if using Ethernet, attach Ethernet cable to eTSEC3 port.

c. JTAG/CWTAP (optional): if using JTAG, connect the cable from the CWTAP to J12.

4. Power up the board through the barrel connector, J3. The board should be powered with a 5 V at 5 A supply.

5. Perform an initial board check and look for correct LED functioning:

a. LED D1 turns ON.

b. LED D2 turns ON.

c. LED D5 turns ON and then OFF.

6. Remove the power supply from the J3 connector to power off the board.

Configuring Target Hardware
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2.3 Preparing LS1021AIOT board
This section explains steps to configure the LS1021AIOT board.

Perform the following steps to configure an LS1021AIOT board:

1. Ensure that board is not connected to the power.

2. Ensure that the power to the chassis or the standalone power supply is OFF.
Figure 4: Connecting LS1021A IOT board

3. Check the default switch positions.

a. If you want to enable CMSIS-DAP you must change SW2[8] = 1. Make sure that your CW TAP device is
not plugged in. Attach the micro USB cable to USB-serial connector, J26. This will provide serial
connectivity and CMSIS-DAP connection (optional).

Configuring Target Hardware
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You can find more information about how to install CMSIS-DAP (Linux/Windows) in
readme_cmsisdap.txt, which is located in [CWInstallDir]/Common/CCS/
drivers/usb.

  NOTE  

b. To boot from SD card, you have to change SW2[0] = 0.

c. Ethernet cable (optional): If using Ethernet, attach Ethernet cable to eTSEC3 port. ETHx where x is from
0 to 5.

d. JTAG/CW TAP (optional): If using JTAG, connect the cable from the CW TAP to J21.

4. Power-up the board through barrel connector, J3. The barrel should be supplied by a 12V at 5A supply.

5. Perform an initial board check and look for correct LED functioning: LED D1 turns ON; LED D2 turns ON;
LED D5 turns ON then OFF.

6. D7 and D8 are ON. D5 is ON if CMSISDAP (micro-usb) cable is connected. Remove the supply connector
from J3, to power off the board.

Configuring Target Hardware
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Chapter 3
Installing CodeWarrior and Working with Projects
This chapter explains how to install CodeWarrior tools to create and work with projects.

 
The scope of this chapter is limited to the use of the CodeWarrior IDE to write and debug
applications for the target platform.

  NOTE  

This chapter contains the following sections:

• Installing and registering CodeWarrior on page 13

• Creating and building bareboard project on page 14

• Debugging bareboard project on page 21

3.1 Installing and registering CodeWarrior
This section provides the steps required to install and register the CodeWarrior software.

Microsoft® Windows OS installation

Administrator rights are required to install CodeWarrior on Microsoft Windows 7 operating system. The default
CodeWarrior installation folder is C:\Freescale. Your project workspace needs to be set up in any folder that you
can fully access.

To install CodeWarrior for ARMv7 on a Windows machine, perform these steps:

1. Insert the CodeWarrior Development Studio installation CD into the CD-ROM drive.

The CodeWarrior installation menu appears.

 
If autorun is disabled on your computer, click Start > Run and enter cd_drive:
\Launch.exe where cd_drive is the drive letter assigned to the CD-ROM drive.

  NOTE  

2. Run the installer.

The install wizard appears.

3. Follow the wizard’s on-screen instructions to install the CodeWarrior.

When installation completes, the InstallShield Wizard Completed page appears.

4. Click Finish.

The wizard closes. A browser starts and displays the Documentation page. This page contains tabs that group
the CodeWarrior documentation into categories.

You have successfully installed CodeWarrior Development Studio for QorIQ LS series - ARM V7 ISA, Version
10.0.x.

Linux OS installation

Eclipse needs read/write access to the installation folder. Make sure the eclipse installation folder has the
appropriate permissions for all users. Make sure your project workspace has read and write permissions. If the
CodeWarrior software does not restart automatically after a successful CodeWarrior update operation, run ‘./
eclipse -clean' to launch the CodeWarrior software.

To install CodeWarrior for ARMv7 on a Linux machine, perform these steps:

Installing CodeWarrior and Working with Projects
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1. Insert the CodeWarrior Development Studio installation CD into the Linux host computer’s CD-ROM drive.

2. On the host computer, open a new terminal window.

A shell session starts.

3. Mount the CD-ROM media on the Linux file system.

4. Change the working directory to the CD-ROM mount directory.

 
See README.txt file in the mount directory. This file contains installation instructions
of different Linux distributions.

  NOTE  

5. Issue the command xhost +.

6. Issue the command ./setuplinux.sh.

The install wizard starts and displays its welcome page.

7. Follow the wizard’s on-screen instructions to install the CodeWarrior software.

When the software installation completes, the wizard displays its installation summary page.

8. Click Finish.

The wizard closes and a shortcut for Linux-hosted CodeWarrior is created on the desktop. The shortcut is
not created if CodeWarrior was installed as a root user.

 
CodeWarrior service packs are installed with the Eclipse Updater. To start the Eclipse
Updater, choose Help > Install New Software from the CodeWarrior IDE menu bar.

  NOTE  

Licensing

Both Windows and Linux installers generate an Evaluation license for the Architect edition that is valid for 15
days. The license is generated regardless of other product versions that may have been installed on the same
host. The certificate generated is valid only on the machine where the product has been installed. During the
installation, the user is informed that the evaluation key is node-locked and number of days the key is valid.
Node-locking element is by default Ethernet ID. In case no Ethernet ID is found, the disk ID is used.

To obtain a suitable license, see the CodeWarrior Development Studio for QorIQ LS series for ARM v7 ISA
product summary page.

3.2 Creating and building bareboard project
This section explains how to create and build CodeWarrior projects on Windows and Linux environments.

The steps are as follows:

1. Launch the CodeWarrior IDE:

On Windows:

a. Choose Start > All Programs > Freescale CodeWarrior > CW4NET [CWVersion] > CodeWarrior for
ARMv7.

On Linux:

a. Open a new terminal window and change the working directory to: [CWInstallDir]/eclipse/, where
[CWInstallDir] is the path to your CodeWarrior installation.

b. Issue the command ./cwide.

Installing CodeWarrior and Working with Projects
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The Workspace Launcher dialog appears.

2. If you wish to change the location of your project’s workspace, clear Use default location checkbox and
click Browse to select the new path.

The Select Workspace Directory dialog appears.

3. Select the required folder. Alternatively, to create a new workspace directory:

• On Windows, click Make New Folder.

• On Linux, click Create Folder.

4. Click OK.

The Select Workspace Directory dialog closes.

5. Click OK to store the project at the specified location.

6. Create a new project:

a. Choose File > New > CodeWarrior Bareboard Project Wizard from the CodeWarrior IDE menu bar.
Figure 5: Create sample project

b. In Project name text box, type FirstProjectTest.

 
The Location text box shows the default workspace location. To change this location,
clear the Use default location checkbox and click Browse to select a new location.

  NOTE  

c. Click Next.

The Processor page appears, as shown in the figure below.

Installing CodeWarrior and Working with Projects
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Figure 6: Processor page

d. Select a target processor (LS1021A), for the new project, from the Processor list.

e. Select Application from the Project Output group to create an application with the .elf extension that
includes information required to debug the project.

f. Click Next.

The Debug Target Settings page appears.

g. Select a connection type (hardware or emulator) from the Debugger Connection Types group.

h. Choose the board you are targeting from the Board menu. Based on your requirements, choose QDS or
Tower board.

i. Select the launch configurations and the corresponding connection to be included in your project, from
the Launch group.

Installing CodeWarrior and Working with Projects
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Figure 7: Debug target settings - QDS board

j. On the Debug Target Settings page, choose a connection type from the Connection Type menu.

k. Enter the IP address of the TAP device in the TAP address text box. This option is disabled and cannot
be edited, if you choose USB TAP from the Connection Type menu. CodeWarrior TAP works with both
types of board, QDS and Tower, but CMSIS-DAP is the default connection type for Tower board (as
shown below).

Installing CodeWarrior and Working with Projects
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Figure 8: Debug target settings - Tower board

l. Click Next.

The Build Settings page appears.

Installing CodeWarrior and Working with Projects
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Figure 9: Build settings

m. Select a programming language, from the Language group.

The language you select determines the libraries that are linked with your program and the contents of
the main source file that the wizard generates.

n. Select I/O Support.

o. Select a toolchain from the Toolchain group.

Selected toolchain sets up the default compiler, linker, and libraries used to build the new project. Each
toolchain generates code targeted for a specific platform.

p. Choose an option from the Floating Point menu to prompt the compiler to handle the floating-point
operations, by generating instructions for the chosen floating-point unit.

q. Click Next.

The Configurations page appears.

Installing CodeWarrior and Working with Projects
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Figure 10: Configurations page

r. Select a processing model option from the Processing Model group.

 
The SMP option is disabled for this release.

  NOTE  

s. Select the processor core that executes the project, from the Core index list.

t. Click Finish.

The new project appears in the Project Explorer view according to your specifications.

Installing CodeWarrior and Working with Projects
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Figure 11: CodeWarrior projects view

7. Build the program.

a. Select the newly created project in the Project Explorer view.

b. Select Project > Build Project to build the project. Alternatively, right-click the project in the Project
Explorer view and select Build Project from the context menu that appears.

The IDE compiles the project's source code files and links resulting object code into an ELF-format
executable file.

3.3 Debugging bareboard project
This section explains how to change the debugger settings and how to debug a CodeWarrior bareboard
application project.

The CodeWarrior Bareboard Project wizard sets the debugger settings of the project's launch configurations to
default values. You can change these default values based on your requirements.

To modify the debugger settings and start debugging a CodeWarrior project, perform these steps:

1. Launch the CodeWarrior IDE.

2. Debug the program.

a. From the CodeWarrior IDE menu bar, select Run > Debug Configurations.

The Debug Configurations dialog appears.

Installing CodeWarrior and Working with Projects
Debugging bareboard project

CodeWarrior for ARMv7 Getting Started Guide, Rev. 10.0.8, 01/2016
Freescale Semiconductor, Inc. 21



Figure 12: Debug configurations dialog

b. On the Main page, choose a remote system from the Connection menu.

c. Select a core, or multiple cores in case of SMP, from the Target list.

d. Click Edit.

The Properties for <Connection> window appears.

e. Choose a connection type from the Connection type menu. For Tower board, CMSIS-DAP is the default
connection type.

f. Configure the CCS server settings on the <Connection> tab.

Installing CodeWarrior and Working with Projects
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Figure 13: Properties for <Connection> window

g. Click OK.

The Properties for<Connection> window closes.

h. Click Apply.

The IDE saves your settings.

3. Debug the program.

a. Click Debug.

b. The IDE switches to the Debug perspective. The debugger downloads your program to the target board
and halts execution at the first statement of main().

 
To download multiple projects on each core, you can click the pull-down menu next to
the debug icon. From this menu, pick the next core you wish to debug.

  NOTE  

c. Click a thread in the Debug view.

The program counter icon  (on the marker bar) points to the next statement to be executed.

d.
In the Debug view, click Step Over .

Installing CodeWarrior and Working with Projects
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The debugger executes the current statement and halts at next statement.

4. Set breakpoint and execute program to breakpoint.

a. In the editor area, scroll to a statement.

b. Double-click the marker bar next to the statement.

A breakpoint indicator  appears next to the statement.

c. In the Debug view, click Resume .

The debugger executes all statements up to, but not including the breakpoint statement.

5. Control the program:

a.
In the Debug view (top-left of perspective), click Step Over .

The debugger executes the current statement and halts at the next statement.

b. In the Debug view, click Resume .

c. In the Debug view, click Terminate .

The program terminates and the debug session ends.

6. Select File > Exit.

The CodeWarrior IDE window closes.

Installing CodeWarrior and Working with Projects
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Chapter 4
Installing Service Pack
To update CodeWarrior with the latest version, you need to install service pack.

To install the service pack:

1. Choose Help > Install New Software from the CodeWarrior IDE menu bar. The Install dialog with the
Available Software page appears.

2. Choose the software site or service pack archive you have added from the Work with menu.

3. Check the details of the service pack in the Details section.

4. Click Next. The Install Details page appears.

5. Click Next. The Review Licenses page appears.

6. Accept the terms of license agreement. Click Finish.

The installation of the service pack dependencies begins.

7. Click OK. The installation proceeds.

A message box appears asking for your permission to restart the CodeWarrior Development Studio.

 
Ensure that you restart CodeWarrior for the service pack to be installed completely.

  NOTE  

8. Click Yes. Without restarting the CodeWarrior software, new plug-ins will not be registered.

The CodeWarrior software restarts and the Workspace Launcher dialog appears.

 
For Linux, if the CodeWarrior software does not restart automatically after a successful
update operation, run /cwide with -clean option.

  NOTE  

9. Specify the workspace in the Workspace Launcher dialog and click OK.

10.Open the New Project wizard and browse to the Hardware page to verify the installation of the service
pack for the specific release. The ARMv7 10.x service pack adds the new targets to this page.

Now, you should know how to install the service pack updater archive for your CodeWarrior software running
on the Windows or Linux platform.

To install a service pack archive for your CodeWarrior tool, you need to perform these steps.

• Add the service pack archive to the available software list in CodeWarrior.

• Install the service pack. You can install it in two modes. They are online and offline modes.

• Online mode on page 26

• Offline mode on page 27

Installing Service Pack

CodeWarrior for ARMv7 Getting Started Guide, Rev. 10.0.8, 01/2016
Freescale Semiconductor, Inc. 25



4.1 Online mode
If your computer is connected to Internet, you can install the service pack directly from the software site where
the service pack is available.

 
The Codewarrior IDE maintains a list of URLs, which is accessed for updates. Ensure
that you select the right URL for the CodeWarrior tools. If you select an incorrect URL,
the update process will not work. These instructions show you how to manipulate that
list to ensure that you focus on the correct URL for the CodeWarrior tools update.

  NOTE  

1. Open the CodeWarrior IDE.

2. Choose Help > Install New Software from the CodeWarrior IDE menu bar. The Install dialog appears.

 
Do not use the Check for Updates option from the Help menu. The Install New Software
option is more comprehensive as it locates new service packs that are considered new
software and are not the usual product updates.

  NOTE  

3. From the Work with menu, choose the URL where the service pack you wish to install is available.

 
The Work with menu is populated by the Available Software Sites page of the
Preferences window. Only the sites that are enabled in the Preferences window are
listed. A quick solution is to enter the URL of the target site in the Work with field. The
service packs for CodeWarrior for ARMv7 for Windows and Linux are available at the
following links:

• http://freescale.com/lgfiles/updates/Eclipse/ARMv7_10_0_8/
com.freescale.armv7.updatesite_win

• http://freescale.com/lgfiles/updates/Eclipse/ARMv7_10_0_8/
com.freescale.armv7.updatesite_lin

  NOTE  

If the required software site is not available in the Work with menu, add the web site to the list of the available
software sites using the Available Software Sites preferences window.

a. Click the Available Software Sites link provided below the Work with drop-down list. The Preferences
window appears with the available software sites.

 
You can use the Preferences window to add, edit, remove, or disable the software sites.

  NOTE  

Installing Service Pack
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Figure 14: Preferences window

b. Click Add. The Add Site dialog appears.

c. In the Name text box, specify the name of the software site you want to add, such as FSL ARMv7
Eclipse Update Site.

d. In the Location text box, specify the web site address. Click OK.

e. The list of the available software on the selected web site appears in the Install dialog.

 
You can select the Show only the latest versions of software available and Hide items
that are already installed checkboxes. This limits the items displayed and you can focus
on selecting items based on your requirements. You can also select the Group items
by category checkbox to classify and identify the nature of the update. It is a good
practice to have the features in a service pack specified according to categories. This
helps in a scenario where a service pack includes many features. If features are grouped
by categories it allows you to install the category as per your requirements. If this
checkbox is clear, all the features will be visible and will be automatically installed.

  NOTE  

4.2 Offline mode
If your computer is not connected to Internet and you want to install the service pack either from an archive,
USB drive, or DVD, then add the archive to the list of the available software sites.

1. Download a patch or update file.

2. Open the CodeWarrior IDE.

3. Select Help > Install New Software from the CodeWarrior IDE menu bar. The Install dialog appears.

4. Click Add. The Add Site dialog appears.

5. In the Name text box, specify a name for the service pack archive you want to add, such as FSL ARMv7
Update Site.

6. Click Archive. Browse to the location of the service pack archive you have downloaded.

7. Click Open. The Location text box in the Add Site dialog populates with the selected path.

Installing Service Pack
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8. Click OK. The list of the available software in the selected service pack appears in the Install dialog.

Installing Service Pack
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