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L5 Jarrior Development Studio
for StarCore DSP SC3900FP

Architectures
Quick Start for the Windows® Edition

SYSTEM REQUIREMENTS

Hardware Intel® Pentium® 4 processor, 2 GHz or faster,
Intel Xeon™, Intel Core™, AMD Athlon™ 64,
AMD Opteron™, or later
2 GB RAM
CD-ROM drive for CD installation
Microsoft Mouse compliant pointing device
Internet connectivity for web downloads and
update access

Operating System Microsoft® Windows 7 (32/64-bit) Home Premium,
Professional, Ultimate Operating System
or
Windows Server 2012 R2

Disk Space 2 GB, additional space required during installation

This Quick Start explains how to install the CodeWarrior software on a
Windows PC. Also, the document explains how to use this software to
create, build, and debug a simple StarCore DSP project.

NOTE In the procedures that follow, advanced users can use
numbered steps. Novices may use the more detailed
instructions provided by substeps.
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: Installing Software

NOTE CodeWarrior Eclipse usage on a Microsoft® Windows
system:

Administrator rights are required to install CodeWarrior
software on Microsoft Windows 7 systems, since the installer
copies files into the system folder.

The default CodeWarrior installation folder is
C:\Freescale\CW_SC_3900FP_v10.x.x. To protect
against malware, Windows 7 do not allow normal processes to
change files in the Program Files folder; therefore, you must
have administrator rights to install and run CodeWarrior
software from this location. If you will be running CodeWarrior
software with a non-administrative user account, then you need
to install CodeWarrior software in another folder (e.g.,
C:\Users\Freescale).

In addition, your project workspace must be created in a folder
to which you have full access rights.

1. Install the CodeWarrior software

NOTE If you are installing from a CD, insert the Development Studio
for StarCore CD into the CD-ROM drive — auto install begins,
proceed directly to substep b.

a. Runthe installer — the install wizard appears.

b. Follow the wizard’s on-screen instructions to install the
CodeWarrior software.

When installation completes, the InstallShield Wizard Completed page
appears.

Check the Display Documentation box.
Click Finish.
The wizard closes.

A browser starts and displays the Documentation page. This page
contains tabs that group the CodeWarrior documentation into categories.
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Documentation Page

Documentation - CodeWarrior Development Studio for StarCore DSP Architectures
freescale*
Installed as part of CodeWarrior installation

Overview of Documentation | Getting Started Guides

A
s
AL

| Comprenensive User Guides | Cheat sheets

[Revised: March 21, 2013]

Quick Links Thank you for installing GodeWarrior Development Studio!
Whats New in Documentation
Product Releass Notes B selecting Documentation as one of the components during installation, you now have access fiom this page fo all PDFs available n this

Linkto Application Notes | V15100 of CodelWartor Development Stusio.

Linkto Technical Suppart
Getting Started Guides

CodeWarrior for StarCore DSPs - Geting Started™

Explains how to install CodeWarrior Development Studio, configure target hardware, and work with StarCore projects.
Using the Ethernet TAP Probe - Quick Star'™

Explains how to set up the Ethemet TAP prode and crete, build, and debug a simple StarCore project that uses this device.

see all getting started guides >
Comprehensive User Guides

Targeting StarCore DSPS™h UPDATED

Explains how to use the GodeWarrior IDE to develop software that targets the StarGore DSP architecturs; includes examples and a debugging
utorial

StarCore GIC++ Gompiler User Guide ™2

Explains how to use the StarCore C/C+= compiler to develap Software for the StarCore architecture.

StarCore SC3000 Linker User Guide T

T
Explains howto use the new, SC3000 StarCore linker to dsvelop software that targets the StarCors architecture.

StarCore Simulator User Guide™%:

Explains howto use runsim andthe StarCore simulators: also explains howto use runsimto profile code and perform speed and size
tradeoff analyses.

see all comprehensive user guides >
Cheat Sheets [can run only within CodeWarrior IDE]

Making C/C++ the IDEs Default Perspective NEW

Shows you owto make the C/C++ perspeciive the CodeWarrior IDE's default perspective. The default perspecive is the one the IDE displays
each time it starts

Target Management via RSE
Shows you how to psrform targst managementvia remote system explorer. It provides data models and framsworks to configure and manage

2. Browse the CodeWarrior documentation.

a. Click any tab in the Documentation page.

A page appears that lists and briefly describes each document in the
chosen category.

b. To read a document listed in the selected page, click the document’s link.
c.  When finished, exit the browser.

You have successfully installed CodeWarrior Development Studio for
StarCore DSPs.

NOTE For licensing and activation of your CodeWarrior Development
Studio for Freescale StarCore DSP Architectures, refer to the
CodeWarrior Development Suite Quick Start. Save the license
file, license.dat to the installation root folder, the default is

CWInstallDir\SC,where CWInstallDiristhe path to your
CodeWarrior installation.




3: Creating, Building, and Debugging a Project

1. Launch the CodeWarrior IDE

a.

b.

Select Start > Programs > Freescale CodeWarrior > CW for StarCore
< number> > CodeWarrior, where number is the version number of your
product.

The Workspace Launcher dialog box appears.
Workspace Launcher Dialog Box

# Workspace Launcher

Select a workspace

Freescale CodeWarrior stores your projectsin a folder called a workspace.
Choose a workspace folder to use for this session.

Workspace: |D:'-Froﬁles‘-:;-'orkspace1 v| | Browse... |

[Juse this as the default and do not ask again

If you wish to change the location of your project's Workspace, click
Browse to select a new path.

The Select Workspace Directory dialog box appears.
Select Workspace Directory Dialog Box

Select Workspace Directory

Select the workspace directory to use.

|23 Workspace2
(5 workspace3
[C) Workspace4
(2 Workspace5
|2 Workspace6
|5 Workspace7 —
[ workspaces

|

3

|

Folder: | Werkspacel |

[ Make New Folder l I oK H Cancel ]

Select the required folder or click Make New Folder to create a new
folder for storing your projects.

Click OK.
The Select Workspace Directory dialog box closes.
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‘ { OK to store the project at the specified location.
CodeWarrior launches and displays the Welcome page.

Welcome Page

¢ /\’ New Project Wizard What’s New Product Release Notes
A
of' Example Projects @7 Web Resources Service Packs, Updates, Patches
" Go to Workbench [A] Tutorials
-,
>
3 -
=" freescale 1
CodeWarrior

o <

NOTE The Welcome page is displayed when CodeWarrior is run for
the first time. You can always return to this page by selecting
Help > Welcome from the CodeWarrior IDE menu bar.

2. Create a new project

a. From CodeWarrior IDE menu bar, select File > New > CodeWarrior
Bareboard Project Wizard.
The CodeWarrior Bareboard Project Wizard dialog box appears.
b. In the Project name field, type B4860ISSDemo.



2 CodeWarrjor Bareboard Project Wizard

Create a Codewarrior Bareboard Project

Chaose the lacation For the new praject

Project name: | B4860I550emo

Use default location

@) [ Mext > H Finish ][ Cancel

Click Next.

The Processor page appears.

Expand the Qonverge Family tree control and select B4860.
Select the Application option from the Project Output group.



Processor Page

¥2 CodeWarrior Bareboard Project Wizard = 2=

Processor

Choose the processor for this project

Processor

type filter text

StarCore Family

Qonverge
BA40GO
B4420
BA460
B4860
64860

S€3900

Project Output
@ Application
“) Component Library
) Self-Centained Library
) Simple Library

@ <Back |[ Net> || Fnish |[ concel

Click Next.
The Debug Target Settings page appears.

Select the Simulator option, from Debugger Connection Types group,
to include simulator launch configurations in your project.

Select B4860ISS, from the Board drop-down list.

Select the launch configurations, that you want to include in your project
and the corresponding remote system configuration using Connection
dropdown list.



Debug Target Settings Page

¥3 CodeWarrior Bareboard Project Wizard o -5z
Debug Target Settings
Target Settings

Debugger Connection Types:
Hardware
® Simulator

Emulator

Board B4860155 v

Launch Connection

/| Dewnload | & Default ol

Connection Type | CCSSIM2ISS -

@ <Beck [ bNet> [ Enmsh  |[ cancel

j. Click Next.
The Build Settings page appears.
k. Select the programming language for this project.

NOTE The language option selected on this page also sets up the
default compiler/linker options for the toolchain.

I.  Select a toolchain from the Toolchain group.

m. Select a Hardware or Software option from the Floating Point dropdown
list.

n. Check the Fused multiply and accumulate checkbox to enable fused
multiply and add generation option. The option is only applicable if
hardware floating point support is enabled on the SC3900FP compiler.

NOTE For more details about exceptions to hardware and software

floating point support, refer the StarCore C/C++ Compiler User
Guide.



Build Settings Page

¥2 CodeWarrior Bareboard Project Wizard = [F= =]
Build Settings
Choose the build settings for the project

Language
@C
® e+

) ASM

Mote:

I the toolchain you want te use is disabled, please install the corresponding package for
adding the build tools support.

Toolchain
@) StarCore 3900

Floating Peint

[ Fused multiply and accumulate

@ <Back | met> |[ Emsh  |[  cancel

o. Click Finish.
The newly created project appears in the CodeWarrior Projects view.
CodeWarrior Projects View

[ Codewarrior Projects £

=0
5GPl T

File Mame Size | Type Build

(= Application_File
%, Binaries
= CFG

(= Debug
[ LCF
1= Sources

3. Build the program
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‘ k t the project in the CodeWarrior Projects view.

b. Select Project > Build Project to build the project. Alternatively, right-
click on the project in the CodeWarrior Projects view and select Build
Project from the context menu that appears.

The IDE compiles the project's source code files and links resulting object
code into an ELF-format executable file.

NOTE B4860 ISS simulator is supported on both Linux 64-bit and
Windows operating system. To debug the project on a Linux
PC, you need to launch the simulator remotely. Follow the
instructions given in Step 4, to launch the simulator on a Linux
PC.

4. Launch simulator on a Linux PC

a. Copy and extract the contents of the sc_swsim_linux64.tgz archive to a
Linux PC (64-bit).

NOTE The sc_swsim_linux64.tgz archive is available in the
CWInstallDir\SC\bin\linux64 folder, where
CWInstallDir is the path to your CodeWarrior installation.

b. Navigate to the sc_swsim_linux64/linux64 folder.
c. Start ccssim2 in a terminal window.

./ccssim2 -port 41475

NOTE For more information about the optional flags supported by
ccssim2, refer to the StarCore Simulator User Guide.

5. Debug the program
a. From the CodeWarrior IDE menu bar, select Run > Debug
Configurations.
The Debug Configurations dialog box appears.

b. From the left pane of this dialog box, expand the CodeWarrior group and
select B4860ISSDemo_Debug_B4860_Download_core00.

The Main page appears in the right pane.
c. Select a remote system from the Connection dropdown list.
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Debug Configurations Dialog Box

3 Debug Configurations

Create, manage, and run configurations
Debug or run an application to a terget,

CEXx[E3%- Nome: , Debug_B4860_Download_cored0
type filter text Main - Arguments| %5 Debugger| = Trace and Profile | & Source| I%§ Environment | ] Common|
4 [2] CodeWarrior Debug session type -

[[E] B48601SSDemo,Debus
] B4260ISSDemo_Debug_B4860_Download.<c
] B4860ISSDemo_Debug_B4860_ Download.cc
] B4860ISSDemo_Debug_B4860_ Download.cc
] B4860ISSDemo_Debug_BI860_Download.cc || ¥ C/C++ application
] B4260ISSDemo_Debug_B4860_Download.cc
» B Launch Group.

1B e commanicaionFamenrk Appcton Oebug/BaRDemocld | (s

» Build (f required) before launching

Choose a predefined debug session type or custom type for maxdmum flexbilty

Broject: BASGOISSDemo

~ Target settings

Bxecute reset sequence

Bxecute initialzation script(s)
‘The connection s for a multicore target. Please select a core:
Target

1860

Fiter matched 13 of 13 tems.

Filter by Project:

& B4860ISSDemo

] 5C390-1
] 5C390-2

Apply Reyert

®

d. Click Debug.

The Debug perspective appears and the execution halts at the first
statement of main ().

Debug Perspective

= o . =]
File Edit Source Refactor Navigate Search Project Run Window Help
| % & i QiF - WM $-0-% Q- S~ B c/cer
(%5 Debug 52 = 51 (09= Variables &3 eakpoints| () Cache | iff Registers| B Modules =8
M| B[~ §& % %3~
% it © > 2 || S| | Name Value Lod
=335 | e pro 0 o
i | e prodrer 0 os
2] B48601SSDemo_Debug_84850_Downlozd_cored0 [CodeWarrior] | oo oy e o pos
88 SterCore DS, BABRDISSDemo.cld cored (Suspendec) | cor mumber of eror values o 08
o» - ol recived.Descpt | @ x 00020000000 0af
main bA8BD_main <100 DB00025E) | &Y fossesses ot
_startup bSO
F : —
Marker | J .
Bar o ol Fi
(6] b4860_main.c &3 isassembly 51
st srs_2F((ord16 *)res, sun_ro, sus_i); B
} 1 y
B int main()  800025¢0: | adda.Lin #528,5p o
L] : adda-1in #50,5p,r0
" int number_of_error_values=o, my_error; | e int nunber_of_error_values=0, my_error;
| Prpec it Gove2ses:  cor.x do,d0,d nop.dalu
|| RS socesto:  st-1 do, (sp 520 ul
(# Commander 52 4 = 0B Console | Z Tesks| ) Memory 4 Remate Syst 6] Trget Tk [[2 Problems [ Bxecutables ¢ @ Softwore An| = O
~ Project Creation ~ Build/Debug XD
23 Import project | (Al || Executable Name. Project Location  “ | Source File Name Location
¥ CodeWarrior Bareboard Project o (an B4B60ISSDemo.eld B4860ISSDemo. Ci\Users\b3. =]
i €1_B4B60ISSDemo.eld BAB6OISSDemo C:\Users\b3.
AlTes Traceld Tes Trace CUsersi3
QiSSDemosld  BASAISDemo CAUseras3
[ i)
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on the thread in the Debug view.

The program counter icon | % on the marker bar points to the next
statement to be executed.
In the Debug view, click Step Over ‘i .

The debugger executes the current statement and halts at next
statement.

Set breakpoint and execute program to breakpoint.

a.

In the editor area, scroll to a line of command statement, for example:
if (prod!=prod_ref)

Double-click on the marker bar next to the statement.
The breakpoint indicator (blue dot) appears next to the statement.

In the Debug view, click Resume L.

The debugger executes all statements up to but not including the
breakpoint statement.

Control program

a.

In the Debug view, click Step Over ‘2 .

The debugger executes the breakpoint statement and halts at the next
statement.

In the Debug view, click Resume [,
The program outputs to the Console window at the bottom.

In the Debug view, click Terminate [H| .

The debug session ends.

Close the Console window

a.

Select File > Exit.
The CodeWarrior IDE window closes.

Congratulations!

You have created, built, and debugged a StarCore DSP

Simulator project using CodeWarrior!
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‘ k “reescale logo, CodeWarrior, PowerQUICC, QorlQ, Qorivva, StarCore are

‘reescale Semiconductor, Inc., Reg. U.S. Pat. & Tm. Off. QorlQ Qonverge,
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Information in this document is provided solely to enable system and software implementers to
use Freescale Semiconductor products. There are no express or implied copyright licenses
granted hereunder to design or fabricate any integrated circuits or integrated circuits based on
the information in this document.

Freescale Semiconductor reserves the right to make changes without further notice to any
products herein. Freescale Semiconductor makes no warranty, representation or guarantee
regarding the suitability of its products for any particular purpose, nor does Freescale
Semiconductor assume any liability arising out of the application or use of any product or
circuit, and specifically disclaims any and all liability, including without limitation consequential
or incidental damages. “Typical” parameters that may be provided in Freescale Semiconductor
data sheets and/or specifications can and do vary in different applications and actual
performance may vary over time. All operating parameters, including “Typicals”, must be
validated for each customer application by customer's technical experts. Freescale
Semiconductor does not convey any license under its patent rights nor the rights of others.
Freescale Semiconductor products are not designed, intended, or authorized for use as
components in systems intended for surgical implant into the body, or other applications
intended to support or sustain life, or for any other application in which the failure of the
Freescale Semiconductor product could create a situation where personal injury or death may
occur. Should Buyer purchase or use Freescale Semiconductor products for any such
unintended or unauthorized application, Buyer shall indemnify and hold Freescale
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regarding the design or manufacture of the part.

How to Contact Us

Corporate Freescale Semiconductor, Inc.
Headquarters 6501 William Cannon Drive West
Austin, Texas 78735
US.A.
World Wide Web http://www.freescale.com/codewarrior
Technical Support http://www.freescale.com/support
X/
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