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0 Before Starting 

0.1 Important Notice to Users 

While every effort has been made to ensure the accuracy of all information in 
this document, SofTec Microsystems assumes no liability to any party for 
any loss or damage caused by errors or omissions or by statements of any 
kind in this document, its updates, supplements, or special editions, whether 
such errors are omissions or statements resulting from negligence, 
accidents, or any other cause. 

0.2 Required Skills 

In order to beneficially use the Starter Kit, you should be acquainted with 
certain skills, ranging from hardware to software design. In particular, you 
should possess knowledge of the following: 
 
� Microcontroller systems; 
� HC08 architecture knowledge; 
� Programming knowledge (Assembly and C).
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1 Overview 

1.1 Main Features 

The SK-HC08 and ZK-HC08 Series Starter Kits are full-featured, ready-to-
use evaluation boards for the Freescale HC08 family. The Starter Kits have 
been designed for the evaluation and the debugging of user applications. 
The Starter Kits take advantage of CodeWarrior Development Studio (which 
groups an Editor, Assembler, C Compiler and Debugger) and the Freescale 
MON08 interface, which allows the download and debug of the user 
application into the microcontroller’s FLASH memory. 
Together with CodeWarrior, the Starter Kits provide you with everything you 
need to write, compile, download, in-circuit emulate and debug user code. 
Full-speed program execution allows you to perform hardware and software 
testing in real time. The Starter Kits are connected to the host PC through a 
USB interface. A prototyping area allows you to wire your own small 
application. 
 

i 
 

 
Note: on ZK Series, a ZIF (Zero Insertion Force) socket is 
provided which allows easy microcontroller insertion/extraction. 
 

 
The Starter Kits offer you the following benefits: 
 
� Real-time code execution; 
� In-circuit debugging/programming; 
� In-system programming and debugging through a MON08-compatible 

interface; 
� Demo area with push-buttons, potentiometer, DIP-switches and user 

LEDs; 
� Where available: RS-232 ports, CAN transceivers, LIN transceivers and 

other target-specific peripheral; 
� Flexible oscillator configuration; 
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� Prototyping area; 
� CodeWarrior for HC(S)08 Development Studio, Special Edition, with 

editor, assembler, C compiler and debugger. 
 

i 
 

 
Note: this user’s manual explains methods and procedures 
common to all of the SK-HC08 and ZK-HC08 Series Starter Kits. 
For a detailed list of the hardware features of your specific Starter 
Kit, please refer to the Starter Kit’s specific user’s manual, 
available in PDF format on the SofTec Microsystems’ “System 
Software” CD-ROM. 
 

1.2 Monitor ROM (MON08) 

All MCUs in the HC08 family contain a monitor ROM which enables in-circuit 
programming of on-chip non-volatile memory and debug capabilities. 
The Starter Kits feature a USB to MON08 circuitry which allows the host PC 
to communicate with the target microcontroller’s monitor ROM (and therefore 
in-circuit program and debug the target application) through a standard USB 
cable. 
Contrariwise to traditional in-circuit emulation (where the target application is 
executed and emulated inside the emulator), the Starter Kits use the very 
same target microcontroller to carry on in-circuit execution. This means that 
all microcontroller’s peripherals (timers, A/D converters, I/O pins, etc.) are 
not reconstructed or simulated by an external device, but are the very same 
target microcontroller’s peripherals. Moreover, the Starter Kits’ debugging 
approach ensures that the target microcontroller’s electrical characteristics 
(pull-ups, low-voltage operations, I/O thresholds, etc.) are 100% guaranteed. 

1.3 CodeWarrior Development Studio Special 
Edition 

The Starter Kits come with CodeWarrior Development Studio, Special 
Edition. 
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CodeWarrior Development Studio is a powerful and easy-to-use tool suite 
designed to increase your software development productivity. It provides 
unrivalled features such as Processor Expert application design tool, full chip 
simulation, data visualization and project manager with templates to help you 
concentrate on the added value of your application. 
The comprehensive, highly visual CodeWarrior Development Studio enables 
you to build and deploy HC08 systems quickly and easily. This tool suite 
provides the capabilities required by every engineer in the development 
cycle, from board bring-up to firmware development to final application 
development. 
Without a license key, the product will run in a 1 KB code-size limited 
demonstration mode. 
To break the 1 KB limit, you have two options: 
 
1. Contact Metrowerks to request an unlimited period, free license key to 

increase the code size limit to 16 KB; 
2. Contact Metrowerks to request a 30-day limited, free license key to run 

the compiler without limitations. 
 
This documentation covers the basic setup and operation of CodeWarrior 
Development Studio, but does not cover all of its functions. For further 
information, please refer to the CodeWarrior online help and online 
documentation provided. 

1.4 Recommended Reading 

This documentation describes how to use the Starter Kits and how to set up 
basic debugging sessions with CodeWarrior. Additional information can be 
found in the following documents: 
 
� Microcontroller Datasheets; 
� Starter Kit’s Specific User’s Manual; 
� Starter Kit’s Specific Schematic. 
 
Additionally, we suggest to read Freescale Application Notes and 
Engineering Bulletins available on the Freescale website 



1

Overview 

Page 10 

(www.freescale.com) for updated documentation about the microcontroller 
that you are using. 

1.5 Software Upgrades 

The latest version of the Starter Kits’ system software is always available 
free of charge from our website: http://www.softecmicro.com. 
When installing the Starter Kits’ system software you have the option to 
electronically register the product. If you register the product, you will be 
automatically notified by e-mail every time a new version of the system 
software is available. 

1.6 Getting Technical Support 

Technical assistance is provided to all customers. For technical assistance, 
documentation and information about products and services, please refer to 
your local SofTec Microsystems partner. 
SofTec Microsystems offers its customers a technical support service at 
support@softecmicro.com. Before getting in contact with us, we advise you 
to check that you are working with the latest version of the Starter Kits’ 
system software (upgrades are available free of charge at 
http://www.softecmicro.com). 
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2 Hardware Features 

2.1 Standard Features 

Every SK-HC08 and ZK-HC08 Series Starter Kit features a common set of 
functions, listed below. 
 
� MCU section 
� Power supply section 
� USB to MON08 interface 
� MON08 connectors 
� Reset section 
� Inputs section 
� Outputs section 
� Prototype area 
 
Additionally, each Starter Kit may feature special additional functions. 
 

i 
 

 
Note: for a detailed list of the hardware features of your specific 
Starter Kit, please refer to the Starter Kit’s specific user’s manual, 
available in PDF format in the SofTec Microsystems’ “System 
Software” CD-ROM. 
 

 
The standard functions are explained in the following sections. 

2.1.1 MCU Section 
This section contains the following components: 
 
� The microcontroller (installed on a ZIF socket on ZK-HC08 series); 
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� Header connectors to access the I/O pins of the microcontroller; 
� An oscillator area to configure the clock source of the microcontroller; 
� Jumpers for setting other microcontroller’s functions (A/D converter, 

PLL, etc.)  

2.1.2 Power Supply Section 
The Power Supply section takes a 12 V DC voltage and, thanks to the built-
in power supply, provides a regulated voltage for the rest of the board. 

2.1.3 USB to MON08 Interface 
The USB to MON08 interface is a circuitry that electrically and logically 
translates MON08-like commands sent by the host PC through the USB 
cable to the MON08 interface of the microcontroller. 
 

i 
 

 
Note: to bypass the built-in USB to MON08 interface when using 
an external in-circuit debugger (via one of the provided MON08 
connectors), please remove all of the “ENA” jumpers in the “USB 
TO MON08 INTERFACE” section. 
 

2.1.4 MON08 Connectors 
Even though the SK-HC08 and ZK-HC08 Series Starter Kits feature a built-in 
USB to MON08 interface, two additional, separate MON08 connectors are 
present which allow an external in-circuit debugger to be used. The 
EMON08 (Enhanced MON08) is used by in-circuit debugging tools such as 
the Freescale ICS system or the SofTec Microsystems inDART-HC08; other 
tools, instead, use the MON08 connector. 
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2.1.5 Reset Section 
This section groups a reset push-button and a reset circuitry to generate a 
suitable reset signal for the microcontroller and for the peripherals connected 
to it. 

2.1.6 Inputs Section 
All of the SK-HC08 and ZK-HC08 Series Starter Kits feature an input area 
with various input controls like a potentiometer, DIP-switches and push-
buttons. Some Starter Kits may feature additional functions. 

2.1.7 Outputs Section 
This section features high-efficiency (low-current) LEDs connected to the 
microcontroller. Some Starter Kits may feature additional functions. 

2.1.8 Prototype Area 
The prototype section features both a standard, thru-hole area (for mounting 
traditional components) and a SMD area (for soldering SMD components). 
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3 Getting Started 

3.1 Package Contents 

The Starter Kit includes the following items: 
 
� A full-featured evaluation board; 
� An AC adapter; 
� A USB cable; 
� The SofTec Microsystems “System Software” CD-ROM; 
� The CodeWarrior Development Studio Special Edition CD-ROM; 
� A QuickStart Tutorial poster; 
� A registration card; 
� This user’s manual. 

3.2 Operating Mode: Standalone Mode 

The Starter Kit can work in two ways: Standalone mode and Host mode. 
In Standalone mode, no PC connection is required. The microcontroller is 
factory programmed with a sample application which reads the 
potentiometer value and displays the results on the output area. 
To work in standalone mode: 
 
� All jumpers in the “USB TO MON08 INTERFACE” section must be 

removed; 
� All of the “EMON08” jumpers in the “MON08 CONNECTORS” section 

must be correctly inserted; 
� You must verify that no MON08-based in-circuit emulator/ programmer 

is connected to the “MON08” connector. 
 
To run the built-in example: 
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1. Verify that all jumpers are in their default position. See the “Summary of 

Jumper and Connector Settings” chapter on the Starter Kit’s specific 
user’s manual. 

2. Power up the Starter Kit. The power connector accepts a 12 V DC wall 
plug-in power supply with a 2.1 mm pin and sleeve plug with positive in 
the center and sleeve as ground. The green “POWER” LED on the 
board should turn on. 

3. By rotating the potentiometer, you affect the results of the A/D 
conversion, and the value of each conversion is displayed on the output 
area. 

3.3 Operating Mode: Host Mode 

In Host mode the program execution is controlled by the host PC. You can 
use the PC to debug the application by, for example, executing the program 
step by step and watching how the microcontroller registers vary, using 
CodeWarrior Development Studio provided. 
In Host mode the Starter Kit can be controlled via the built-in USB to MON08 
interface or in conjunction with a MON08-based debugger/programmer. 

3.3.1 Technical Overview 
All of the HC08 family devices feature a monitor code resident in ROM 
which, through a serial communication line, allows the programming and the 
in-circuit debugging of the user application. The monitor code is executed in 
“monitor mode”; the user application is executed in “user mode”. To enter the 
monitor mode some microcontroller lines must be properly driven (for further 
details please refer to the microcontroller’s data sheet). 
The Starter Kit’s “USB TO MON08 INTERFACE” section groups the 
circuitry needed to generate the required signals to enter the monitor mode 
and to communicate with the host PC’s USB port. In particular, to enter the 
monitor mode, the “USB TO MON08 INTERFACE” circuitry: 
 
� Generates a high-level voltage signal (VTST) on the IRQ pin of the 

microcontroller; 
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� Generates a high-level voltage and an appropriate reset signal on the 
RST pin of the microcontroller; 

� Drives some pins of the microcontroller to specific levels; 
� Drives the microcontroller’s VDD on and off, with specific timing, in 

order to enter the monitor mode; 
� Handles a single-wire, bi-directional serial communication line on a 

specific pin of the microcontroller. 

3.3.2 Host Control via the Built-In USB to MON08 Interface 
To debug the target application using the built-in USB to MON08 interface: 
 
� Make sure that all of the jumpers in the “USB TO MON08 

INTERFACE” section are inserted; 
� Make sure that nothing is connected to the “MON08” connector; 
� Make sure that all of the “EMON08” connector jumpers are inserted 

(see the “Summary of Jumper and Connector Settings” chapter on the 
Starter Kit’s specific user’s manual); 

� Power the board through the power plug; 
� Connect the host PC to the board through the provided USB cable. 
 
This manual explains how to debug the application using the built-in USB to 
MON08 interface. Please refer to your development tool’s user’s manual if 
you need to control the Starter Kit via the “MON08” connector. 

3.3.3 Host Control via the “MON08” Connector 
To debug the target application using an external in-circuit 
debugger/programmer via the “MON08” connector: 
 
� Make sure that all of the jumpers in the “USB TO MON08 

INTERFACE” section are removed; 
� Make sure that all of the “EMON08” connector jumpers are inserted 

(see the “Summary of Jumper and Connector Settings” chapter on the 
Starter Kit’s specific user’s manual); 
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� Make sure that your debugger/programmer is compatible with the 
“MON08” connector; 

� Connect the external in-circuit debugger/programmer to the “MON08” 
connector; 

� Power the board through the power plug. 

3.3.4 Host Control via the “EMON08” Connector 
To debug the target application using an external in-circuit 
debugger/programmer via the “EMON08” connector: 
 
� Make sure that all of the jumpers in the “USB TO MON08 

INTERFACE” section are removed; 
� Check that nothing is connected to the “MON08” connector; 
� Make sure that your debugger/programmer is compatible with the 

“EMON08” connector; 
� Remove all of the jumpers in the “EMON08” connector; 
� Connect the external in-circuit debugger/programmer to the “EMON08” 

connector; 
� If your external in-circuit debugger/programmer provides automatic 

target power control, you can take advantage of the “VDD CTRL” 
connector and let the external in-circuit debugger/programmer control 
the target board’s power as necessary; 

� Power the board through the power plug. 

3.4 Host System Requirements 

The Starter Kit is controlled by CodeWarrior Development Studio. The 
following hardware and software are required to run the CodeWarrior user 
interface together with the Starter Kit: 
 

1. A 200 MHz (or higher) PC compatible system running Windows 98, 
Windows 2000 or Windows XP; 

2. 128 MB of available system RAM plus 500 MB of available hard disk 
space; 
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3. A USB port; 
4. CD-ROM drive for installation. 

3.5 Installing the Software 

i 
 

 
Note: before connecting the Starter Kit to the PC, it is 
recommended that you install all of the required software first (see 
below), so that the appropriate USB driver will be automatically 
found by Windows when you connect the Starter Kit. 
 

 
The Starter Kit requires that both CodeWarrior Development Studio Special 
Edition and SofTec Microsystems Additional Components be installed in the 
host PC. 
 

i 
 

 
Note: CodeWarrior Development Studio for HC(S)08 must be 
installed first. 
 

3.5.1 Installing CodeWarrior Development Studio 
To install the CodeWarrior Development Studio Special Edition, insert the 
CodeWarrior CD-ROM into your computer’s CD-ROM drive. A startup 
window will automatically appear. Follow the on-screen instructions. 

3.5.2 Installing SofTec Microsystems Additional Components 
The SofTec Microsystems Additional Components install all of the other 
required components to your hard drive. These components include: 
 
� The Starter Kit’s USB driver; 
� The software plug-in for CodeWarrior; 
� DataBlaze programming utility; 
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� Examples; 
� Starter Kit’s specific user’s manual; 
� Starter Kit’s specific schematic; 
� Additional documentation. 
 
To install the SofTec Microsystems Additional Components, insert the 
SofTec Microsystems “System Software” CD-ROM into your computer’s 
CD-ROM drive. A startup window will automatically appear. Choose “Install 
Instrument Software” from the main menu. A list of available software will 
appear. Click on the “Additional Components” option. Follow the on-
screen instructions. 
 

i 
 

 
Note: to install the Additional Components on Windows 2000 or 
Windows XP, you must log in as Administrator. 
 

3.6 Installing the Hardware 

The Starter Kit is connected through a USB port to a host PC. Connection 
steps are listed below in the recommended flow order: 
 
1. Install all the required system software as described in the previous 

section. 
2. Power up the Starter Kit. The power connector accepts a 12 V DC, wall 

plug-in power supply with a 2.1 mm pin and sleeve plug with positive in 
the center and sleeve as ground. The green “POWER” LED on the 
board should turn on. 

3. Insert one end of the USB cable into a free USB port on the host PC. 
4. Insert the other end of the USB cable into the USB connector on the 

Starter Kit board. 
5. The first time the Starter Kit is connected to the PC, Windows 

recognizes the instrument and starts the “Found New Hardware 
Wizard” procedure, asking you to specify the driver to use for the 
instrument. On Windows XP (SP2) the following dialog box will appear, 
asking you to search for a suitable driver on the web. 
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Select the “No, not this time” option and click the “Next >” button. 
6. The following dialog box will appear. 
 

 
 
Click the “Next >” button. 

7. Depending on your Windows settings, the following warning may 
appear. 
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i  
Note: this warning is related to the fact that the USB driver 
used by the Starter Kit is not digitally signed by Microsoft, 
and Windows considers it to be potentially malfunctioning 
or dangerous for the system. However, you can safely 
ignore the warning, since every kind of 
compatibility/security test has been carried out by SofTec 
Microsystems. 
 

 
Click the “Continue Anyway” button. 

8. Windows will install the driver files to your system. At the end of the 
installation, the following dialog box will appear. 
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Click the “Finish” button to exit from the “Found New Hardware 
Wizard” procedure. 

9. The Starter Kit’s USB driver is now installed on your system. 

3.7 Application Tutorial 

This section will provide a step-by-step guide on how to launch your project 
and get started with the CodeWarrior user interface. 
 
1. Ensure that the Starter Kit is connected to the PC (via the USB cable) 

and that the board is powered. 
2. Make sure that all of the Starter Kit’s jumpers are set to their factory 

position (see the “Summary of Jumper and Connector Settings” section 
in the Starter Kit’s specific manual). 

3. Start CodeWarrior Development Studio by selecting “Start > Programs 
> SofTec Microsystems > SK and ZK-HC08 Series > CodeWarrior 
Development Studio”. CodeWarrior Development Studio will open. 

4. From the main menu, choose “File > Open”. Select the “Demo.mcp” 
workspace file that is located under the “\Program Files\SofTec 
Microsystems\SK and ZK-HC08 Series\CodeWarrior Examples 
\[Your Starter Kit Code]\[Your Target Microcontroller]\Demo” 
directory. Click “Open”. The following window will appear. 
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5. The C code of this example is contained in the “main.c” file. Double 
click on it to open it. The following window will appear. 
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6. From the main menu, choose “Project > Debug”. This will compile the 
source code, generate an executable file and download it to the Starter 
Kit board. 

7. A new debugger environment will open. 
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8. From the main menu, choose “Run > Start/Continue”. The program 
will be executed in real-time. By rotating the potentiometer on the 
Starter Kit board, you affect the results of the A/D conversion, and the 
result of each conversion is displayed on the Starter Kit’s output 
section. 

9. From the main menu, choose “Run > Halt”. The program execution will 
stop. The next instruction to be executed is highlighted in the Source 
window. 

10. From the main menu, choose “Run > Single Step”. The instruction 
highlighted in the Source window will be executed, and the program 
execution will be stopped immediately after. 

11. From the main menu, choose “Run > Start/Continue”. The application 
will restart from where it was previously stopped. 

 
Congratulations! You have successfully completed this tutorial! You can 
continue to experiment with the CodeWarrior user interface and discover by 
yourself its potentialities. For an in-depth guide of all of the user interface 
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features, select “Help > CodeWarrior Help” from the CodeWarrior 
Development Studio’s main menu. 
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4 Debugging Features  

4.1 Creating Your Own Application 

4.1.1 Using the Project Wizard to Create Your Application Skeleton 
CodeWarrior Development Studio helps you get started with your own 
application by including a project wizard specific for HC08-based SofTec 
Microsystems boards. To create a new project: 
 
1. From the main menu, select “File > New”. 
2. A dialog box will appear. Select “HC(S)08 New Project Wizard”. 
3. Follow the Project Wizard steps, making sure you select the correct 

microcontroller derivative you are working with and that the “SofTec 
Microsystems” target connection is used.  

4.1.2 Starting your First Debugging Session 
The first time you enter a debugging session (by selecting “Project > 
Debug” from the CodeWarrior’s main menu) the MCU Configuration dialog 
box will open, asking you to select the debugging hardware connected to the 
PC and the target microcontroller you are working with. 
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First, ensure that the “HW code” parameter is set to your Starter Kit code, 
then set the “Device code” parameter to the specific target microcontroller 
you are working with. Additional communication parameters can be specified 
by clicking the “Communication Settings” button (if the button is enabled). 

4.2 GDI Target Interface Notes 

The Starter Kit’s built-in USB to MON08 interface is based on the SofTec 
Microsystems’ inDART debugging engine. CodeWarrior is interfaced to the 
inDART engine through a so-called “GDI Target Interface”. 
If your project has been targeted to an emulator/simulator other than a SK-
HC08 or ZK-HC08 Series Starter Kit and you wish to use this Starter Kit as 
the debugger for your project, please do the following: 
 
1. From the CodeWarrior debugger interface, select “Component > Set 

Target” and choose “HC08” as processor and “GDI Target Interface” 
as target interface. 
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2. A dialog box will appear asking you to locate the GDI DLL file needed to 
interface with the Starter Kit. Select the “inDART-HC08.dll” file located 
in the “\Program Files\Metrowerks\CodeWarrior CW08\prog\” 
directory (the Starter Kit is based on the SofTec Microsystems’ inDART 
debugging engine).  

 

 
 

3. The MCU Configuration dialog box will appear allowing you to select the 
Starter Kit board as the hardware debugger. You must also specify the 
target microcontroller you are working with. 
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4. On the CodeWarrior debugger interface a new menu (“inDART-HC08”) 
will be created. From this menu, select “Load” and locate the file your 
project is based on. 

4.3 Limitations 

Since the debugger is based on the on-chip debugging features of the HC08 
family of microcontrollers, some hardware and software limitations apply. 
The main ones are listed below; for the complete list of limitations please 
refer to the microcontroller’s data sheet. 
 
� The pin dedicated to the host communication is reserved—in 

particular, the corresponding bit in the Data Direction Register must 
not be changed (must be left to input); 

� The Break Module peripheral is reserved, and only one hardware 
breakpoint is available—however, you can insert a “swi” instruction 
into your code to generate a software breakpoint; 

� The “swi” instruction is reserved and can only be used to generate a 
software breakpoint; 

� Step commands which involve the execution of two or more Assembly 
instructions waste one hardware breakpoint—therefore, if one 
breakpoint was already set by the user, the step command cannot be 
executed; 

� The “Halt” debugging command (in the CodeWarrior IDE) will not 
work unless the IRQ interrupt is properly handled; 
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� 13 bytes of stack are wasted by the on-chip monitor—therefore the 
addresses from SP-13 to SP are reserved; 

� Registers which affect the target microcontroller’s clock speed must 
not be changed during debugging sessions. 

4.4 Trimming Feature 

Some microcontrollers in the HC08 family feature an internal, trimmable 
oscillator designed to be used without additional external components (no 
crystals, resonators, or passive components are required), thus reducing 
production costs and eliminating the need for dedicated clock circuitry 
microcontroller pins. 
Some devices (e.g. MC68HC908QT/QY) are factory pre-programmed with a 
default trimming value in a dedicated FLASH location (specified in the 
datasheet). However, due to the different real-world conditions of the user’s 
system, it is always suggested to recalibrate the internal oscillator to reflect 
the actual working conditions. 
The Trimming Settings dialog box allows you to enable/disable the trimming 
feature. If enabled, it is possible to specify whether to save the calculated 
trimmed value in the default location (the location suggested either by 
Freescale or SofTec Microsystems, restorable at any moment via the 
“Restore” button) or into a different location (specified by the “Flash 
Trimming Location” parameter). The calculation of the trimmed value and 
its writing to the specified address are carried out transparently when 
programming the device (or during download when debugging). 
If you don’t want to reserve a FLASH location for the calibration, but use it as 
“normal” memory instead, it is possible to disable the trimming feature and 
therefore free the trimming FLASH location for application purposes. 
To open the Trimming Settings dialog box choose “inDART-HC08 > MCU 
Configuration > Communication Settings > Trimming Settings” from the 
CodeWarrior main menu, after entering a debugging session. 
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4.5 Notes and Tips 

4.5.1 Stop Command Handling 
The “Halt” debugging command will not work unless the IRQ interrupt is 
properly handled. In particular, the following precautions must be taken in 
the application’s source code. 
 
1. Global interrupts must be enabled (use the “cli” instruction); 
2. The IRQ interrupt must be enabled; 
3. The IRQ interrupt vector must be handled; 
4. The IRQ handling routine must include the following code: 
 

irq_isr: bil irq_isr ; Waits for the IRQ signal to go high 

swi    ; Jumps to monitor code 

rti 
 

5. Under these conditions, the TGT_IRQ# line is reserved; when it is 
driven low, a “Halt” debugging command is automatically recognized. 

Reading Peripheral Status 
Care must be taken when reading some peripheral’s status/data registers, 
since a reading operation may cause the clearing of flags. This may happen 
when the Memory window or the Data window is open, since these windows 
read microcontroller’s resources during refresh operations. 

4.5.2 Breakpoints and Swi Instruction 
The SWI Assembly instruction forces the target microcontroller to enter the 
Monitor mode, stopping program execution. CodeWarrior recognizes this 
event as a breakpoint and updates the contents of registers, memory, etc. 
Successive commands (Start/Continue, Single Step, etc.) will continue the 
execution of the program from the next instruction. The HC08’s on-chip 
debug module only handles one hardware breakpoint. However, you can 
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force the program execution to stop at other specific locations by inserting 
the “swi” Assembly instruction on your source code. 

4.5.3 Interrupt Execution during Steps 
When issuing stepping instructions (Single Step, Step Over, etc.) when there 
are pending interrupts, the debugger will not step inside the interrupt 
handling routine—instead, the whole interrupt handling routine will be 
executed. An exception is when you single step on an Assembly instruction 
which branches to itself: in this case, interrupts which may occur will not be 
handled. 

4.5.4 Peripheral Status during Steps 
When single stepping on an Assembly instruction which branches to itself, 
peripheral status is frozen. 

4.5.5 Hardware Breakpoints and Software Breakpoints 
A “hardware” breakpoint is set by taking advantage of the microcontroller’s 
integrated break peripheral. A hardware breakpoint doesn’t waste system 
resources, you can set/remove them at any time, but the number of available 
hardware breakpoints is limited (to one in the case of HC08 family). 
A “software” breakpoint, on the other hand, does not take advantage of the 
microcontroller’s integrated break peripheral. 
To set a software breakpoint in a FLASH location, you have to insert the 
“swi” Assembly instruction into your application’s source code, recompile 
the code and restart a debug session. The program execution will stop as 
soon as the “swi” instruction is fetched. 

4.6 DataBlaze Programming Utility 

A full-featured programming utility (DataBlaze) is also provided with the 
Starter Kit. To start the DataBlaze utility select “Start > Programs > SofTec 
Microsystems > SK and ZK-HC08 Series > DataBlaze Programmer”. 
DataBlaze offers the following advanced features: 
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� Code/data memory editing; 
� Blank check/erase/program/verify/read operations; 
� Project handling; 
� One-button, multiple-operations programming (“Auto” feature); 
� Serial numbering. 
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5 Troubleshooting 

5.1 Common Problems and Solutions 

This section reports solutions to some common problems that may arise 
during general use. 

5.1.1 USB Driver Problems 
If you connected the Starter Kit board to the PC before installing the 
CodeWarrior user interface and the SofTec Microsystems Additional 
Components, the Starter Kit USB driver may not have been correctly 
installed on your system. Unplugging and replugging the USB cable is of no 
use, since Windows has marked the device as “disabled”. As a 
consequence, CodeWarrior cannot communicate with the Starter Kit board. 
To restore the USB driver (provided both CodeWarrior and SofTec 
Microsystems Additional components have been installed), perform the 
following steps under Windows XP: 
 
1. Make Sure the Starter Kit is powered on. 
2. Connect the Starter Kit to the PC (via USB). 
3. Open the Control Panel (“Start > Settings > Control Panel”). 
4. Open  the “System” options. 
5. Select the “Hardware” tab. 
6. Click the “Device Manager” button. 
7. The “uDART In-Circuit Debugger” device will be shown with an 

exclamation mark next to it. Double click on this device. 
8. In the “General” tab, click the “Reinstall Driver” button. Follow the on-

screen instructions. 
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5.1.2 Communication Errors when Using a MON08 Tool 
When using an external in-circuit debugger/programmer, the built-in USB to 
MON08 interface must be bypassed. To bypass the built-in USB to MON08 
interface, please remove all of its “ENA” jumpers. 
For more information on how to set up the “MON08” and “EMON08” 
connectors, see the “Operating Mode: Host Mode” section of this manual on 
page 16. 

5.1.3 Communication Can’t Be Established with the Board (Via the 
Integrated USB to MON08 Interface) 

1. Make sure the Starter Kit is connected to the PC and powered on. 
2. Make sure that all of the “ENA” jumpers in the “USB TO MON08 

INTERFACE” section are inserted; 
3. Make sure that nothing is connected to the “MON08” connector; 
4. Make sure that all of the “EMON08” connector jumpers are inserted 

(see the “Summary of Jumper and Connector Settings” chapter on the 
Starter Kit’s specific user’s manual); 

5. Make sure you are working with the correct hardware model. To 
view/change the hardware model in use, choose “inDART-HC08 > 
MCU Configuration” from the CodeWarrior debugger’s main menu. 

6. If the “inDART-HC08” menu is not present in the CodeWarrior 
debugger’s main menu, this is because the target has not been 
recognized by CodeWarrior (“No link to Target” appears in the status 
bar). In this case, from the “GDI” menu, choose “MCU Configuration” 
and verify that the hardware code is set correctly. 

7. Make sure the target microcontroller is working. Programming and 
debugging rely on a MON08 communication between the USB to 
MON08 interface and the target microcontroller. This means that, in 
order to work correctly, the target microcontroller must be running. In 
particular: 

 
� On ZK-HC08 Series Starter Kits, make sure that the target 

microcontroller is correctly inserted in the ZIF socket; 
� On ZK-HC08 Series Starter Kits which feature a “VDD SEL” 

jumper (in the “POWER SUPPLY” section), make sure that this 
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jumper selects the appropriate voltage for the specific 
microcontroller you are working with; 

� The oscillator circuitry must be working according to the 
microcontroller specifications. 

 
8. For other problems, please refer to your Starter Kit’s specific user’s 

manual.  

5.2 Getting Technical Support 

Technical assistance is provided free to all customers. For technical 
assistance, documentation and information about products and services, 
please refer to your local SofTec Microsystems partner. 
SofTec Microsystems offers its customers a free technical support service at 
support@softecmicro.com. Before getting in contact with us, we advise you 
to check that you are working with the latest version of the Starter Kit system 
software (upgrades are available free of charge at 
http://www.softecmicro.com). Additional resources can be found on our 
HC(S)08 online discussion forum. 
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