## Contents

<table>
<thead>
<tr>
<th>Section number</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.1</td>
<td>System Requirements</td>
<td>5</td>
</tr>
<tr>
<td>1.2</td>
<td>Installing CodeWarrior</td>
<td>5</td>
</tr>
<tr>
<td>1.3</td>
<td>Supported Devices</td>
<td>7</td>
</tr>
<tr>
<td>2.1</td>
<td>Configuring B4860 QDS Board</td>
<td>9</td>
</tr>
<tr>
<td>2.2</td>
<td>Configuring B4420 QDS Board</td>
<td>11</td>
</tr>
<tr>
<td>3.1</td>
<td>Creating Projects</td>
<td>13</td>
</tr>
<tr>
<td>3.1.1</td>
<td>Creating Target Board Project</td>
<td>14</td>
</tr>
<tr>
<td>3.2</td>
<td>Building Projects</td>
<td>16</td>
</tr>
<tr>
<td>3.2.1</td>
<td>Manual-Build Mode</td>
<td>17</td>
</tr>
<tr>
<td>3.2.2</td>
<td>Auto-Build Mode</td>
<td>17</td>
</tr>
<tr>
<td>3.3</td>
<td>Debugging Projects</td>
<td>17</td>
</tr>
<tr>
<td>3.4</td>
<td>Deleting a Project</td>
<td>19</td>
</tr>
</tbody>
</table>
Chapter 1
Introduction

This Getting Started guide explains how to install the CodeWarrior software, prepare the boards supported by the current release, and then create, build, and debug a simple project.

This chapter contains:

- System Requirements
- Installing CodeWarrior
- Supported Devices

1.1 System Requirements

This section provides operating platform requirements for installing CodeWarrior software.

<table>
<thead>
<tr>
<th>Processor</th>
<th>Intel® Pentium® 4 processor - 2 GHz or faster, Intel Xeon™, Intel Core™, AMD Athlon™ 64, AMD Opteron™, or higher</th>
</tr>
</thead>
<tbody>
<tr>
<td>Memory</td>
<td>2 GB RAM</td>
</tr>
<tr>
<td>Hardware</td>
<td>• CD-ROM drive for CD installation</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Mouse compliant pointing device</td>
</tr>
<tr>
<td></td>
<td>• Internet connectivity for web downloads and update access</td>
</tr>
<tr>
<td>Operating System</td>
<td>• Windows Server 2012 R2</td>
</tr>
<tr>
<td></td>
<td>• Microsoft® Windows 7 (32/64-bit) Home Premium, Professional, Ultimate Operating System</td>
</tr>
<tr>
<td>Disk space</td>
<td>2 GB, additional space required during installation</td>
</tr>
</tbody>
</table>
1.2 Installing CodeWarrior

This section provides the steps required to install the CodeWarrior software.

**CodeWarrior usage on a Microsoft® Windows operating system:**

Administrator rights are required to install CodeWarrior software on Microsoft Windows 7 operating system, since the installer copies files into the System folder. The default CodeWarrior installation folder is `C:\Freescale\CW_SC_3900FP_v10.x.x`.

In addition, your project workspace must be created in a folder to which you have full access rights.

To install the CodeWarrior software, perform the following steps:

1. Run the installer - the install wizard appears.

   **NOTE**
   To develop software that supports the Power® Architecture processor using the B4860QDS board, you must install **CodeWarrior Development Studio for Power Architecture Processors**.

2. Follow the wizard's on-screen instructions to install the CodeWarrior software.
3. When installation completes, the **InstallShield Wizard Completed** page appears.
4. Check the Display Documentation checkbox.
5. Click **Finish**.

   The wizard closes. A browser starts and displays the **Documentation** page. This page contains tabs that group the CodeWarrior documentation into categories.
Thank you for installing CodeWarrior Development Studio!

By selecting Documentation as one of the components during installation, you now have access from this page to all PDFs available in this version of CodeWarrior Development Studio.

### Getting Started Guides
- CodeWarrior for StarCore DSPs - Getting Started
  - Explains how to install CodeWarrior Development Studio, configure target hardware, and work with StarCore projects.
- Using the Ethernet TAP Probe - Quick Start
  - Explains how to set up the Ethernet TAP probe and create, build, and debug a simple StarCore project that uses this device.

### Comprehensive User Guides
- Targeting StarCore DSPs
  - Explains how to use the CodeWarrior IDE to develop software that targets the StarCore DSP architecture, includes examples and a debugging tutorial.
- StarCore C/C++ Compiler User Guide
  - Explains how to use the StarCore C/C++ compiler to develop software for the StarCore architecture.
- StarCore SC3000 Linker User Guide
  - Explains how to use the new, SC3000 StarCore linker to develop software that targets the StarCore architecture.
- StarCore Simulator User Guide
  - Explains how to use runsim and the StarCore simulators, also explains how to use runsim to profile code and perform speed and size tradeoff analyses.

### Cheat Sheets [can run only within CodeWarrior IDE]
- Making C/C++ the IDE’s Default Perspective
  - Shows you how to make the C/C++ perspective the CodeWarrior IDE’s default perspective. The default perspective is the one the IDE displays each time it starts.
- Target Management via RSE
  - Shows you how to perform target management via remote system explorer. It provides data models and frameworks to configure and manage

---

**Figure 1-1. Documentation Page**

**NOTE**

Click any tab in the **Documentation** page to browse the CodeWarrior documentation.

You have successfully installed CodeWarrior Development Studio.

**NOTE**

For licensing and activation of your CodeWarrior Development Studio for Freescale StarCore DSPs, see **CodeWarrior Development Suite Quick Start**. Save the license file, `license.dat`, to the installation root folder; the default location is `<CodeWarrior-Install-Dir>\SC`, where `<CodeWarrior-Install-Dir>` is the path to your CodeWarrior installation.

### 1.3 Supported Devices

---

Freescale Semiconductor, Inc.
This section talks about the device families and targets supported by CodeWarrior Developer Studio for StarCore DSPs.

<table>
<thead>
<tr>
<th>Device Family</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Qonverge Family</td>
<td>Supports generation of multi-core target projects for B4060 QDS.</td>
</tr>
<tr>
<td>B4060</td>
<td>Supports generation of multi-core target projects for B4420 ISS and B4420 QDS.</td>
</tr>
<tr>
<td>B4420</td>
<td>Supports generation of multi-core target projects for B4460 QDS.</td>
</tr>
<tr>
<td>B4460</td>
<td>Supports generation of multi-core target projects for B4460 QDS.</td>
</tr>
<tr>
<td>B4860</td>
<td>Supports generation of multi-core target projects for B4860 ISS, B4860 QDS and B4860 Palladium.</td>
</tr>
<tr>
<td>G4860</td>
<td>Supports generation of multi-core target projects for G4860 QDS.</td>
</tr>
<tr>
<td>Targets</td>
<td>Select to generate projects for the single-core targets: SC3900 Platform ISS and SC3900 Platform PACC.</td>
</tr>
</tbody>
</table>
Chapter 2
Configuring Target Hardware

This chapter explains how to configure the boards supported by the CodeWarrior for StarCore DSPs software. You can configure these boards using an integrated development environment (IDE), such as Freescale's CodeWarrior IDE.

This chapter contains these topics:

- Configuring B4860 QDS Board
- Configuring B4420 QDS Board

2.1 Configuring B4860 QDS Board

This section tells how to configure a B4860 QDS board.

Perform the following steps to configure a B4860 QDS board:

1. Ensure that board is not connected to the power.
2. Ensure that the power to the chassis or the standalone power supply is OFF.

   **NOTE**
   It is recommended that you wear a wrist strap before handling the B4860 QDS board to protect the board from electrical charges.
3. Check the default switch positions and jumper settings and verify if the board is operational.

**NOTE**

The board is shipped with default settings. See *Quick Start Guide for B4860QDS* to verify the default switch and jumper settings.

4. Assemble the power supply.
   a. Ensure that all power is turned OFF.
   b. Connect the power supply, power cable, and country-specific wall outlet plug.
   c. Connect the power-supply cable to the 12-volt board jack (P2).
   d. Connect the USB cable between the B4860 QDS USB socket (J2) and the USB port of the PC.

   This setting relates to the internal debug probe, eCWTAP usage.

   e. Connect an ETH cable between a network plug and the RJ-45 eCWTAP (J16) jack.
   f. Connect a second ETH cable between a network plug and the RJ-45GE1 (J18) jack.
Figure 2-2. Connecting the B4860 QDS Board

g. Plug power supply cable into the wall outlet.

5. Perform an initial board check and look for correct LED functioning.
   a. LED LD9 and LED LD10 are a steady green color.
   b. LED D1 (eCWTAP) flashes orange and if the CodeWarrior TAP establishes a link via the Ethernet, D1 changes to a steady green color, after several seconds of charging.

6. Move the power switch (SW6) to the ON position.

7. Check for completion of the PRESET (Power-on-Reset) sequence indicated by the LEDs. The LEDs on the board follow the below sequence:
   a. LED LD1 and LED LD2 flash green.
   b. LED LD8 (12 V) displays steady green light indicating that the SoC has exited reset and is now in a Ready state.

   NOTE
   Some RCW combinations can change SOC ASLEEP signal functionality to GPIO. In this case, LED LD8 enters an OFF state following the reset sequence.

8. Move the power switch (SW6) to the OFF position to power off the system.

   NOTE
   See Quick Start Guide for B4860QDS for more information about the B4860 QDS board.

2.2 Configuring B4420 QDS Board
This section describes the configuration of a B4420 QDS board.

Perform the following steps to configure a B4420 QDS board:

1. Ensure that the board is not connected to the power.
2. Ensure that the power to the chassis or the standalone power supply is OFF.

   **NOTE**
   It is recommended that you wear a wrist strap before handling the B4420 QDS board to protect the board from electrical charges.

3. Check the default switch positions and jumper settings and verify if the board is operational.

   **NOTE**
   The board is shipped with default settings. See the document shipped with the board to verify the default switch and jumper settings.

4. Assemble the power supply.
   a. Ensure that all power is turned OFF.
   b. Connect the power supply, power cable, and country-specific wall outlet plug.
   c. Connect the power-supply cable to the 12-volt board jack.
   d. Plug power supply cable into the wall outlet.

5. Perform an initial board check and look for correct LED functioning.

6. Move the power switch to the **ON** position.

7. Check for completion of the PRESET (Power-on-Reset) sequence indicated by the LEDs.

8. Move the power switch to the **OFF** position to power off the system.

   **NOTE**
   For more information, see the documentation shipped with the B4420 QDS board.
Chapter 3
Working with Projects

This chapter explains how to use CodeWarrior tools to create and work with projects.

NOTE
The scope of this chapter is limited to the use of the CodeWarrior IDE to write and debug applications for the target platform.

This chapter explains:

• Creating Projects
• Building Projects
• Debugging Projects
• Deleting a Project

3.1 Creating Projects

This section explains how to use the CodeWarrior Bareboard Project Wizard to quickly create new projects with default settings (build and launch configurations).

After the project has been created, you can easily change any default setting to suit your needs.

NOTE
For detailed information on various wizard options, see CodeWarrior Development Studio for StarCore 3900FP DSP Architectures Targeting Manual.

In this section:

• Creating Target Board Project
3.1.1 Creating Target Board Project

You can create a project that targets a board, using the Codewarrior Bareboard Project Wizard.

To create a CodeWarrior bareboard application project, perform the following steps:

1. Select Start > Programs > Freescale CodeWarrior > CW for StarCore number > CodeWarrior IDE, where number is the version number of your product to launch the CodeWarrior IDE.

   The WorkSpace Launcher dialog box appears.

2. Click OK.

   The default workspace is accepted. The CodeWarrior IDE launches and the Welcome page appears.

   **NOTE**

   The Welcome page appears only if the CodeWarrior IDE or the selected Workspace is opened first time. Otherwise, the Workbench window appears.

3. In the Welcome page, click Go to Workbench.

   The workbench window appears.


   The CodeWarrior Bareboard Project wizard launches and the Create a CodeWarrior Bareboard Project page appears.

5. Specify a name for the new project.

   For example, enter the project name as board_project.

6. If you do not want to create your project in the default workspace:
   a. Clear the Use default location checkbox.
   b. Click Browse and select the desired location from the Browse For Folder dialog box.
   c. In the Location text box, append the location with the name of the directory in which you want to create your project.
NOTE
An existing directory cannot be specified for the project location.

7. Click Next.

The Processor page appears.

8. Select the target processor you want to use, from the Processor list.
9. Select Application, from the Project Output group.
10. Click Next.

The Debug Target Settings page appears.

11. Select a supported connection type hardware or simulator, from the Debugger Connection Types group. Your selection determines the launch configurations that you can include in your project.
12. From the Board list, select the board you are targeting.

NOTE
Hardware or Simulators that supports the target processor selected on the Processors page are only available for selection.

13. Select the launch configurations, that you want to include in your project and the corresponding Remote System Configuration from the Connection dropdown list.

NOTE
For more information on remote systems, see CodeWarrior Development Studio Common Features Guide.

14. Select the interface to communicate with the hardware, from the Connection Type dropdown list.
15. Enter the IP address of the TAP device in the TAP address textbox. This option is disabled and cannot be edited, if you select USB TAP from the Connection Type dropdown list.

NOTE
For more information on connection types, see CodeWarrior Development Studio for StarCore 3900FP DSP Architectures Targeting Manual.

16. Click Next.

The Build Settings page appears.
17. Select the programming language you want to use. The language you select determines the libraries that are linked with your program and the contents of the main source file that the wizard generates.

**NOTE**
If you select C++, you can still add C source files to the project and vice versa.

18. Select a toolchain from the **Toolchain** group.

Selected toolchain sets up the default compiler, linker, and libraries used to build the new project. Each toolchain generates code targeted for a specific platform.

19. Select a Hardware or Software option from the **Floating Point** dropdown list.
20. Check the **Fused multiply and accumulate** checkbox to enable fused multiply and add generation option. The option is only applicable if hardware floating point support is enabled on the SC3900FP compiler.

**NOTE**
For more details about exceptions to hardware and software floating point support, refer the *CodeWarrior Development Studio for StarCore 3900FP DSPs C/C++ Compiler Reference Manual*.

21. Click Next.

The SmartDSP OS page appears.

22. Select the SmartDSP OS option you want to use.
   - Select **No** to exclude SmartDSP OS support from your project.
   - Select **Yes** to include SmartDSP OS support in your project.

23. Click **Finish**.

The wizard creates a project according to your specifications.

The new hardware project is ready for use. You can now customize the project by adding your own source code files, changing debugger settings, adding libraries, and so on.

### 3.2 Building Projects

CodeWarrior IDE supports two modes of building projects, manual-build mode and auto-build mode.
3.2.1 Manual-Build Mode

In large workspaces, building the entire workspace can take a long time if users make changes with a significant impact on the dependent projects. Often there are only a few projects that really matter to a user at a given time.

To build only the selected projects, and any prerequisite projects that need to be built in order to correctly build the selected projects, select **Project > Build Project** from the CodeWarrior IDE menu bar. Alternatively, select **Project > Build All**.

**Tip**
You can also right-click on the selected project in the **CodeWarrior Projects** view and select **Build Project** from the context menu.

3.2.2 Auto-Build Mode

CodeWarrior IDE takes care of compiling source files automatically. Builds occur automatically in the background every time you change files in the workspace (for example, saving an editor), if auto-build is enabled.

To automatically build all the projects in a workspace, select **Project > Build Automatically** from the CodeWarrior IDE menu bar.

If auto-build is taking too long and is interfering with ongoing development, it can be turned off. Select **Project > Build Automatically** from the CodeWarrior IDE menu bar to disable auto-build mode.

**NOTE**
It is advised that you do not use the **Build Automatically** option for C/C++ development. Using this option will result in building the entire project whenever you save a change to the makefile or source files. This can take a significant amount of time for very large projects.

3.3 Debugging Projects
This section explains how to change the debugger settings and how to debug a CodeWarrior bareboard application project.

The **CodeWarrior Bareboard Project** wizard sets the debugger settings of the project's launch configurations to default values. You can change these default values based on your requirements.

To modify the debugger settings and start debugging a CodeWarrior project, perform these steps:

1. Launch the CodeWarrior IDE.
2. From the CodeWarrior IDE menu bar, select **Run > Debug Configurations**. The CodeWarrior IDE uses the settings in the launch configuration to generate debugging information and initiate communication with the target board.

   The **Debug Configurations** dialog box appears. The left side of this dialog box has a list of debug configurations that apply to the current application.

   **NOTE**
   For more information on how to use the debugger, see *CodeWarrior Development Studio Common Features Guide*.

3. Expand the **CodeWarrior** configuration.
4. From the expanded list, select the debug configuration that you want to modify.

   The **Main** page appears in the right panel.

5. Click **Debug** to start the debugging session.
   a. The **Debug** perspective appears and the execution halts at the first statement of **main**().
   b. Click a thread in the **Debug** view.

      The program counter icon on the marker bar points to the next statement to be executed.

   c. In the **Debug** view, click **Step Over**.

      The debugger executes the current statement and halts at next statement.

6. Set breakpoint and execute program to breakpoint.
   a. In the editor area, scroll to a line of command statement.

      For example: if (prod!=prod_ref)

   b. Double-click the marker bar next to the statement.

      The breakpoint indicator (blue dot) appears next to the statement.
c. In the **Debug** view, click **Resume**.
   The debugger executes all statements up to but not including the breakpoint statement.

7. Control the program:
   a. In the **Debug** view, click **Step Over**.
      The debugger executes the breakpoint statement and halts at the next statement.
   b. In the **Debug** view, click **Resume**.
      The program outputs to the Console window at the bottom.
   c. In the **Debug** view, click **Terminate**.
      The debug session ends.

8. Close the **Console** window:
   a. Select **File > Exit**.
      The CodeWarrior IDE window closes.

### 3.4 Deleting a Project

This section provides the steps required to delete a CodeWarrior project.

To delete a project, follow these steps:

1. Select the project you want to delete in the **CodeWarrior Projects** view.
2. Select **Edit > Delete**.
   The **Delete Resources** dialog box appears.

   **NOTE**
   Alternatively, you can also select **Delete** from the context menu that appears when you right-click the project.

3. Select the **Delete project contents on disk (cannot be undone)** checkbox to delete the project contents permanently.
4. Click **OK**.

You just finished deleting a project using the CodeWarrior IDE.
Index

A

Auto-Build Mode 17

B

B4420 QDS Board Configuration 11
B4860 QDS Board Configuration 9
Building Projects 16

C

Configuring B4420 QDS Board 11
Configuring B4860 QDS Board 9
Configuring Target Hardware 9
Creating Projects 13
Creating Target Board Project 14

D

Debugging Projects 17
Deleting a Project 19

I

Installing CodeWarrior 6
Introduction 5

M

Manual-Build Mode 17

S

Supported Devices 7
System Requirements 5

W

Working with Projects 13
How to Reach Us:

Home Page: freescale.com

Web Support: freescale.com/support

Information in this document is provided solely to enable system and software implementers to use Freescale products. There are no express or implied copyright licenses granted hereunder to design or fabricate any integrated circuits based on the information in this document. Freescale reserves the right to make changes without further notice to any products herein.

Freescale makes no warranty, representation, or guarantee regarding the suitability of its products for any particular purpose, nor does Freescale assume any liability arising out of the application or use of any product or circuit, and specifically disclaims any and all liability, including without limitation consequential or incidental damages. “Typical” parameters that may be provided in Freescale data sheets and/or specifications can and do vary in different applications, and actual performance may vary over time. All operating parameters, including “typicals,” must be validated for each customer application by customer’s technical experts. Freescale does not convey any license under its patent rights nor the rights of others. Freescale sells products pursuant to standard terms and conditions of sale, which can be found at the following address: freescale.com/SalesTermsandConditions.

Freescale, the Freescale logo, CodeWarrior, QorIQ, QorIQ Qonverge, and StarCore are trademarks of Freescale Semiconductor, Inc., Reg. U.S. Pat. & Tm. Off. All other product or service names are the property of their respective owners. The Power Architecture and Power.org word marks and the Power and Power.org logos and related marks are trademarks and service marks licensed by Power.org.

© 2012–2015 Freescale Semiconductor, Inc.