CodeWarrior Development Studio
for eTPU v10.x
Quick Start
SYSTEM REQUIREMENTS
Hardware

Intel® Pentium® 4 processor, 2 GHz or faster,
Intel® Xeon™, Intel® Core™, AMD Athlon™ 64,
AMD Opteron™, or later
1 GB RAM
CD-ROM drive for CD installation
Microsoft Mouse compliant pointing device
Internet connectivity for web downloads and
update access

Operating System

Microsoft® Windows 7 (32/64-bit) Home Premium,
Professional, Ultimate or Windows® XP
Professional (SP3) (32/64-bit) Home, Professional

Software

Java 1.6 update 11 or newer

Disk Space

500 MB, additional space required during
installation

This document explains how to install the CodeWarrior Development
Studio for eTPU v10.x software and how to create, build, and debug a
demo ETPU project.
NOTE

In the procedures that follow, advanced users can use the
numbered steps. Novices should use the more detailed
instructions provided by the sub-steps.

Section A: Installing CodeWarrior Development Studio for
eTPU v10.x Software
1. Install the software.
a. Launch the Installer — the welcome page is displayed.
b. Follow the wizard instructions to install the software to the desired
location.
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c.

When software installation is finished, wizard displays the installation
complete page.

d. In the installation complete page, you can clear the Launch Application
checkbox to start the application later.
e. Click Finish to exit the installer.
.

Section B: Creating Project
1. Launch the CodeWarrior Development Studio for eTPU v10.x
a. For Windows, select Start > Programs > Freescale CodeWarrior > CW
for eTPU v10.x > CodeWarrior IDE — the Workspace Launcher dialog
box appears.

Workspace Launcher Dialog Box

b. Click Browse to change the location of your project's Workspace.
Select Workspace Directory dialog box appears.

Select Workspace Directory Dialog Box

c.

Select the required folder or click Make New Folder to create a new
folder for storing your projects.
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d. Click OK — the Select Workspace Directory dialog box closes.
e. Click OK — the application launches and the Welcome page appears.
Click Help > Welcome to view the welcome page at any time.

Welcome Page

f.

In the Welcome page, click Go to Workbench — the Workbench window
appears.
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Workbench Window

2. Create a new project
a. From the IDE menu bar, select File > New > Project — the New Project
wizard starts; the Select a wizard page appears.

Select a wizard Page

b. Select ETPU Project and click Next — the New ETPU Project wizard
appears and displays Create an ETPU Project page.
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Create an ETPU Project Page

c.

NOTE

Enter hello_world in the Project name field.

The Location field shows the default project location. If you do
not want to use the default location, clear the Use default
location checkbox. In the Location text box, enter the full path
of the directory in which you want to create your project
including the project name.
Alternatively, click Browse and select the desired location from
the Browse For Folder dialog box and click OK. Ensure that
you append the path with the name of the project to create a
new location for your project.

d. Click Next — the ETPU device page appears.

ETPU Device Page

e. Select eTPU2+ — the wizard configures the project settings for eTPU2+
architecture.
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NOTE

The target architecture can be changed anytime. To change
the target architecture, right-click the project and select
Properties.
- Expand C/C++ Build and select Settings.
- In the Tool Settings tab, expand ETPU Compiler and select
Compiler Settings.
- Change the architecture from the Architecture drop-down
list.
- Clean and Recompile the project.
To use the simulator in ETPU mode, you have to change the
Target Processor also. You can change the target processor
setting from Run > Debug configurations > CodeWarrior
Download > hello_world_ETPU2P configuration_ETPU2P >
Debugger.

f.

Click Next — Project format page appears.

Project format Page

g. Select the project fromat you want, default is Example template.

NOTE

The empty project contains the minimum code, requirements to
build, debug simulate an etpu/etpu2/etpu2+ project.

h. Click Next - ETPU function selection page appears.
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ETPU function selection Page

i.

NOTE

j.

Select the function you want, default is Output function.

The Output and input functions (C only) is a more complex
project including both functions, and is available only in C
language.
Click Next — ETPU project type page appears.

ETPU project type Page

k.

NOTE

l.

Select the project type you want, default is C project type.

The assembler project is a simplified version of the C project
type.
Click Finish — IDE creates and builds the project; you can view the
newly created project in the CodeWarrior Projects view in the IDE.

7

CodeWarrior Projects View

3. Expand the project to view all the project files.
4. Open Example Projects page from the Welcome screen for
instructions about how to import set1 project.

Section C: Debugging Project
1. Enter debug mode
NOTE

To debug, select a project from the CodeWarrior Projects
view and click Debug
. Alternatively, you can perform the
following steps.

a. Select the desired project in the CodeWarrior Projects view.
b. Select Project > Build Project to build the project. Alternatively, rightclick on the project and select Build Project from the context menu.
c.

From the IDE menu bar, select Run > Debug Configurations — the
Debug Configurations dialog box appears.
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Debug Configurations

d. Expand the CodeWarrior Download tree control in the left pane and
select hello_world_ETPU2 configuration_ETPU2P — A set of tabbed
configuration panels appear in the right pane of the dialog box.
e. Click Debug — program downloads to the simulator and the Confirm
Perspective Switch dialog box appears and the execution halts.
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Debug Perspective

NOTE

When the debug session starts:
A new icon appears in the system tray -ccssim2.exe, this
program is used to simulate the eTPU processor. Right-click on
it and you can see the ccssim2 menu: Show console, Hide
console, About ccssim2 and Quit.

NOTE

To debug more than one project simultaneously, you will need
to configure the CCS server port number and the visualization
bind port manually such that each project will have its own
distinct ports. To configure the CCS server port, edit the
Remote system configuration in Main tab of the Debug
Configurations dialog box. To configure vizualization bind port,
edit the ETPU simulator options in the Debugger tab of the
Debug Configurations dialog box.
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NOTE

eTPU processing is event-driven, in the sense that eTPU
microcode only runs to service a request from an event. For
more information, refer to the chapter Functions and Threads
of the eTPU Reference Manual.
The projects generated by the new project wizard contains an
init.tcl script that is responsible for the initialization of the
simulator. This initialization script is customized such that the
initialization thread of the configured functions with
corresponding parameters also start when the project debug
initiates.
The initialization TCL script is automatically executed when
entering debug and the result of the execution can be observed
in Debugger Shell view. The TCL script allows among other
things the change of parameters at the run-time. For more
information, refer to the step Configure Visualization plug-in.
Modifying the script or C code might result in an uninitialized
simulator on which debug operations will not work. When
changing the init.tcl files or files included by the simulator
ensure that no errors are shown in the Debugger Shell view.

NOTE

To debug more than one project simultaneously, the CCS
server port number from remote system configuration. You can
configure the remote system from the Main tab of the Debug
Configuration dialog box. The visualization bind port from
simulator options (Debugger panel from Launch configuration )
need to be manually changed so that each project will have its
own distinct ports.

Also when two projects are in debug simultaneously the script command
from debugger shell are executed on default connection. This can be
observed and changed with the help of switchtarget command
f.

Click on the thread in the Debug view — the program counter icon
the marker bar points to the next statement to be executed.

on

g. In the Debug view, click Step Over
— the debugger executes the
current statement and halts at the next statement.
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2. Set breakpoint and execute program to breakpoint.
a. In the editor area, double-click on the marker bar next to the statement —
the breakpoint indicator (blue dot) appears next to the statement.
b. From the Debug view, click Resume
— the debugger executes all
statements up to but not including the breakpoint statement.

3. Control the execution of the program
a. From the Debug view, click Step Over
— the debugger executes
the breakpoint statement and halts at the next statement.
b. From the Debug view, click Resume
resumes.
c.

From the Debug view, click Terminate

— the program execution

- the debug session ends.

4. Visualize the eTPU signals
a. Select eTPU > New Signal Viewer — the eTPU Signal view appears.
b. Click the
button and move the mouse over the signals to use the
signal color indication fetaure.
All the signals that have events in the corresponding selection will appear
along with their names.

NOTE

The visualization plug-in can also be used in debug mode.
The signal view does not display spike signals (MRLA, MRLB).
They are shown in Execution Trace View.
Scenarios with multiple projects per workspace were not tested
and might result in unpredictable behavior.
The visualization plug-in stores data in a circular buffer. When
the buffer is full, the oldest events are overwritten. By default,
the buffer size is 10000. See Logging options below for
options.
Please note that for this release TCR1 is by default disabled.
You can enable it from Logging options.
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eTPU Signal View

c.

Customize view to your needs:
- Select a signal in signal tree to add the signal at the bottom of the view
and deselect a signal to remove the signal from the view.
- Expand the tree to view and select the overlapped signals of the
channels.

Overlapped signals enabled by default

- After selecting the signals, you can hide the signal tree using Show
Signal Tree button from the toolbar menu
d. Zoom in and zoom out:

.

.

e. There are two time markers, blue and green, which can be used for
measurement purpose. Click on signal charts to set a time marker at that
corresponding timestamp, by default the closest marker near the mouse
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is moved to the mouse position. The time markers can also be dragged to
another timestamp using the mouse.

Time Markers

f.

Go to left marker using
button or to right marker using
button.
Double-click the marker value to edit the timestamps of the markers.

g. Zoom Markers

, make the area between markers to fill the view.

h. Use up and down arrow keys to change the active waveform selection.
The background of the active waveform changes to grey. In the above
image, CIN0 is the active waveform.
i.

Use left and right arrow keys to snap the selected marker to the nearest
transition in the active waveform. In the above image, the blue marker is
selected. The markers selection can be changed using Ctrl+Left arrow to
select left marker, and Ctrl+Right arrow for right marker.

5. Visualize the execution trace
a. Select eTPU > Execution Trace — the Execution Trace view appears.

Execution Trace View

b. Select an event in execution trace view to put a red marker in signal view
at the corresponding timestamp.
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c.

NOTE

The event selection can also be changed using Up/Down arrow keys or
Page Up/Page Down keys.

To be able to view both execution trace and signal view you
can move a view by dragging the title into another area, or you
can right-click on view's title and select Detached.
The Execution Trace View uses 255 to mark an event that is
not related to a channel.

6. Configure Visualization plug-in
a. Select eTPU > Options — the Visualization Properties view appears.

Visualization Properties View

b. In Logging Options panel you can select the desired signals to be
logged and visualized.

Logging Options View

c.

In the Initialization Script panel you can disable the automatic script
execution, and can change the initialization script that is executed when
entering debug. By default the first (alphabetical) .tcl file found in the
Script folder of the project is executed.
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Initialization Script View

NOTE

Click Apply to save the changes.
Disabling events in Logging Options view will not delete the
events already logged.

7. Virtual timers
a. Virtual timers allow the measurement of the execution time in the system
cycles.
b. Right-click on the left editor vertical ruler to configure the start and stop
points.
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Virtual Timers Window

c.

Open the Timers View from eTPU > eTPU Analysis > Timers.

Timers View

d. Run the code, the value filed from the Timers view will be updated with
the most recent value.
e. You can reconfigure the start and stop points from right click menu.
f.

Alternatively, the virtual timer’s data can be observed in the execution
trace and in the signal view in the Timers and Counters group.
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NOTE

In this version only one timer can be used from eclipse. To use
all available virtual timers, read the simulator manual.

8. Watchpoints
a. Watchpoints allow execution break when the watchpoint condition is met.
b. Follow the steps to set a watchpoint on a variable:
- Select eTPU > eTPU Analysis > Watchpoints from the IDE menu bar
to display the Watchpoints View.

Watchpoints View

- Select New watchpoint.
- Write the variable name and select the access type than click OK.
- The execution breaks when the variable is written or read, depending on
the selected access type.
- The variable that causes the break is highlighted yellow in the
watchpoints view.
c.

To delete a single watchpoint, select the desired watchpoint in the
Watchpoints View and click the Delete selected watchpoint button

d. To delete all watchpoints, click the Delete All button

.

.

9. Flags View
a. Flags view window allows the visualization of all channels flags during
execution.
b. Select eTPU > eTPU Analysis > Flags Viewer from the IDE menu bar to
display the Flags View.
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Flags View

c.

Select the channel to watch or the Active Channel from the drop-down
menu from the right corner of the view.

Select Channel

d. A list of updated values of all the flags is available in the view.
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10. Simulator Options
a. Open Run > Debug Configurations > CodeWarrior Download >
hello_world_ETPU2P configuration_ETPU2P > Debugger > ETPU
Simulator.

ETPU Simulator options

b. From this page, you can configure trace, coverage dump and VCD
output.These features are described in the simulator manual.

11. Graphical Coverage
a. Can be enabled from Run > Debug Configurations > CodeWarrior
Download > hello_world_ETPU2P configuration_ETPU2P >
Debugger > ETPU Simulator.
b. If enabled, the trace coverage information is displayed in the left editor
vertical ruler.

NOTE

This feature is subject to changes.

12. Save and Load History.
a. Select eTPU > Save History to save the content of the data buffer.
b. Select eTPU > Load History to load the saved data in buffer.
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13. Exit from application
a. Select File > Exit — the application window closes.

Congratulations!
You have created, built, and debugged an ETPU project using
CodeWarrior Development Studio for eTPU v10.x!
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How to Contact Us
Corporate
Headquarters

Freescale Semiconductor, Inc.
6501 William Cannon Drive West
Austin, Texas 78735
U.S.A.

World Wide Web

http://www.freescale.com/codewarrior

Technical Support

http://www.freescale.com/support
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