
1 Overview
Processor Expert software for i.MX is a suite of configuration
tools targeted for the i.MX family of processors. This
document introduces you to the Processor Expert and Pin
Settings components. In addition, the document describes how
to create a new Processor Expert project and configure
embedded components and Pin Settings component. In the
end, it provides instructions on generating the code after
configuring the components.

2 Configuration Tools
This version of the product includes the PinSettings tool. This
tool helps you configure signals to pins multiplexing and
electrical properties of pins.

NOTE
For a list of supported
devices see the Release
Notes.

3 System Requirements
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The following are the minimum system requirements:
• Windows 32-bit or 64-bit or Linux 64-bit (Windows 7 and 8 are supported)
• 500MB of free disk space

4 Working with Projects
This chapter explains how to create and work with projects in Processor Expert for i.MX Processors.

4.1 Launching the workbench

To launch the Processor Expert Software IDE:
1. Select Start > All Programs > Freescale Processor Expert > PEx for i.MX Processors <version> > Processor

Expert for i.MX Processors <version>.
Alternatively, navigate to <product installation directory>\eclipse and launch eclipse.exe.

Figure 1. Launch eclipse.exe

The WorkSpace Launcher dialog appears and prompts you to select a workspace to use.
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Figure 2. Workspace Launcher
2. Click OK to accept the default workspace.
3. To use a workspace different from the default, click Browse and specify the desired workspace.

NOTE
You can also select the Use this as the default and do not ask again checkbox to set
default/selected path as a default location for storing all your projects. However,
ensure that you create the workspace folder in any folder that you can fully access.
For example, C:\Profiles\<username> \workspace on Windows or /home/
<username>/ workspace on linux.

4. Click the Go to Workbench link.
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Figure 3. Go to the workbench

The Workbench window appears.
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Figure 4. Workbench window

4.2 Creating a new project

To create a new Processor Expert project:
1. Launch the Workbench. For information about launching the Workbench, see Launching the workbench.
2. Select File > New > Processor Expert Project, from the IDE menu bar.
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Figure 5. Select Processor Expert Project from the menu

The Create a Processor Expert page of the New Processor Expert Project wizard appears.
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Figure 6. Create a Processor Expert project
3. Specify a name for the new project. For example, enter the project name as Project_1.

NOTE
If you do not want to use the default location, clear the Use default location
checkbox. In the Location text box, enter the full path of the directory in which you
want to create your project including the project name. Alternatively, click Browse
and select the desired location from the Browse For Folder dialog box and click
OK. Ensure that you append the path with the name of the project to create a new
location for your project.

4. Click Next.

The Devices page appears.

NOTE
You can either select a project template for a Freescale develoment board (node
Boards) or a processor without any additional board awareness information (node
i.MX).

5. Expand the tree control and select the derivative you want to use. For example, select Processors > i.MX6SL.
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Figure 7. Select the derivative
6. Click Next.
7. Select a target compiler.

Figure 8. Select a target compiler
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8. Click Finish.
The wizard creates a new Processor Expert project according to your specifications. You can access the project from
the Project Explorer view in the Workbench window.

NOTE
You may see some error messages reported for the newly created project based on
a board template. It is intentional. By fixing the signals to pins multiplexing
problems you actually select one of multiple configurations variants.

Figure 9. Project Explorer view
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4.3 Configuring the Processor Expert perspective

Before you start working with a Processor Expert project, you need to first configure the Processor Expert perspective and
the related views.

A perspective defines the initial set and layout of views in the Workbench window. Within the window, each perspective
shares the same set of editors. Each perspective provides a set of functionality aimed at accomplishing a specific type of task
or works with specific types of resources.

The Processor Expert perspective lets you add and manage embedded components in your project.

To configure the Processor Expert perspective:
1. Select Window > Open Perspective > Other from the IDE menu bar.
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Figure 10. Select perspective

The Open Perspective dialog appears.

Figure 11. Open Perspective dialog
2. Select Processor Expert and click OK.
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The Processor Expert perspective appears. The Processor Expert perspective button appears on the top-right corner of
the main Eclipse window. You can click the Processor Expert perspective button to switch back from any other
perspective.

NOTE
If you have the Processor Expert perspective open but cannot see the Processor
Expert views, ensure that you reset the perspective. To reset the perspective, select
Window > Reset Perspective from the IDE menu bar. For details on how to add
views, see Configuring the Component Inspector view.

By default, the Processor Expert perspective include the following views:
• Project Explorer view - Structured list of projects in you workspace and all the project files.
• Components View - Structure of your currently focused Processor Expert project. You can see the following objects in

the Components Views:
• Generator Configurations - Each project can contain multiple configurations. Each configuration can contain a

separate set of Processor Expert components.
• OSs - Operating Systems – Not used in Processor Expert for i.MX Processors.
• Processor component - Model of the processor used in your project. There can be more Processor Components

present in one project, but only one can be enabled in each project configuration.
• Components - Tools you use in the project.

• Components Inspector view- Provides detailed list of configuration items of each component and allows you to modify
the items.

• Components Library view- Library of all Processor Expert components in a product. You can add components into
your project from Component Library.

• Editor - Allows edit to project code.
• Problems view - Lists configuration and generation process errors, warnings and hints reported.
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Figure 12. Processor Expert perspective

4.4 Configuring the Component Inspector view

The Component Inspector view enables you to access and manage component information of your project.

To add the Component Inspector view, select Window > Show View > Component Inspector from the IDE menu bar.

If the Component Inspector view is not available in the show view list:
1. Select Window > Show View > Other from the IDE menu bar.
2. In the Show View dialog, navigate to Processor Expert. Select Component Inspector.
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Figure 13. Select Component Inspector view
3. Click OK.

The selected view will appear in the current perspective.

Alternatively, you can right-click on a component in the Components view and select Inspector.

Figure 14. Select Inspector from Components view

4.5 Configuring embedded components
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Embedded components are basic elements of a Processor Expert project. The following are available in Processor Expert
Software for i.MX Processors.

• Processor components – Represent models of supported processors. There is a component for every supported i.MX
processor.

• PinSettings component – Represents the Pin Settings or the Pin Muxing tool. For details, see Configuring the
PinSettings component.

A component can be configured by a set of its configuration items also referred as component properties.

Component properties can be seen and modified in the Component Inspector view.

Figure 15. PinSettings component in the Component Inspector view

4.5.1 Launching the Configuration Registers view

The Configuration Registers view shows overview of the peripheral initialization settings for the current target processor. It
displays initialization values of all control, status and data registers of the selected peripheral/device including single bits.

The values are grouped into two parts:
• Peripheral registers — Containing registers that are directly related to the selected peripheral/device.
• Additional registers — Containing registers that are influenced by the component but are not listed for the peripheral

currently selected in this view.

The initialization information reflects:
• Processor default settings — When the on-chip peripheral is not utilized by any Embedded Component.
• Embedded Component settings — When the on-chip peripheral is utilized by an Embedded Component and the

component settings are correct.

The Configuration Registers view shows initialization as required by the component settings.

Working with Projects

Processor Expert Software for i.MX Processors, Rev 1.1, 02/2015

Freescale Semiconductor, Inc. 15



Figure 16. Configuration Registers view

To launch the Configuration Registers view:
1. Select and right-click on a component in the Components view.
2. Select Configurations Registers.

The Configuration Registers view appears.

The following table describe the options in the Configuration Registers view:

Table 1. Configuration Registers view details

Option Description

Peripheral Registers

Reg. Name Specifies name of the registers.

Init. value Specifies the initialization value of a register or bit computed according to the settings in the
Component Parameters panel. This is the last value written by the initialization function to the
register. For some registers, the value read from the register can be different than the last written
value. For example, some interrupt flags are cleared by writing. If the row is active, the value can be
changed using the keyboard. The field also contains a radix button (H,D,B) that allows to switch
between Hexadecimal, Decimal and Binary formats of the value. The value that contains undefined
bits is always shown in binary format.

After reset Specifies the default value that is in the register after the reset. The values of the registers are
displayed in the hexadecimal and binary form. If the value of the register (or bit) is not defined, an
interrogation mark "?" is displayed instead of the value.

Address Specifies address of a register.

Additional Registers These rows can be unfolded under each register contain values and the names of individual bits.
Bits are sorted from the highest to lowest weight. The bit rows of a register can be shown or hidden
using the plus/minus icons.
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NOTE
For some registers, the value read from the register afterwards can be different than the
last written value. For example, some interrupt flags are cleared by setting value as 1. If
the on-chip peripheral is allocated by a component and the setting of the component is
incorrect, the initialization values are not displayed in the Configuration Registers view.

4.5.2 Configuring the PinSettings component

ThePinSettings component allows you to configure:
• Signals to pins routing (signals to pins multiplexing)
• Electrical properties of pins
• Voltage levels of pin power groups

NOTE
The term Default used in this section means that there is no user requirement for setting a
value of the parameter in the PinSettings component. The default values are displayed in
italic. The values of such parameters are either reset values or values determined by other
properties of the component or by other components in the project.

4.5.2.1 Configuring signals to pins routing

There three view modes available for configuration of signals to pins routing:
• Expanded
• Collapsed
• Pins

Expanded view mode
There is a list of all peripheral modules and all their signals as the primary information in this view mode. You can assign
pins to the signals. Pins are represented by their package coordinates. Pins are arranged into two columns: Input, Output
according to the signal’s direction.

Figure 17. Expanded view mode

Collapsed view mode
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There is a list of all peripheral modules and all their signals as the primary information in this view mode. You can assign
pins to the signals. Pins are represented by their names. Default names of pins are their datasheet names. You can change the
names using the user Pin/Signal Name column. To delete a user-defined signal routing, select the parameter value, erase it,
and press the Enter key.

Figure 18. Collapsed view mode

Pins view mode
This mode lists all the processor pins as the primary information in this view mode. You can assign signals to the pins.

Figure 19. Pins view mode

4.5.2.2 Resolving signals to pins routing conflicts
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The Processor Exper software for i.MX indicates conflicting signal to pin routing requirements. However, it is not possible to
automatically resolve the conflicts. You need to revise your requirements and change them to resolve the conflicts. The
conflicting items are indicated by error decorators.

Figure 20. Error decorators

4.5.2.3 Configuring electrical properties of pins

To remove any electrical properties setting from the PinSettings component , select the parameter value, erase it, and press
the Enter key.

Removing the user-defined electrical property lets the PinSettings component use the default value, which does not generate
any configuration code for the property.

Figure 21. Configuring electrical properties of pins
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4.5.2.4 Validating power group voltage settings

Each pin belongs to a power group. It is possible to connect pins from different power groups to one peripheral module. If the
power groups of such pins have different voltage levels, it may be a potential erroneous situation and is reported as a
warning.

Figure 22. Warnings reported if voltage levels conflict

4.6 Generating output

After the configuration of the components is completed the expected output of the components can be obtained by the code
generation operation.

To generate output:
1. Select the Project menu in the IDE menu bar.
2. Select the option Generate Processor Expert Code.

Alternatively, click the  icon in the Components view.

This initiates the code generation process. During the code generation process source code modules containing
functionality of the components and peripherals contained in the project are generated. During this process source code
modules containing functionality of the components contained in the project are generated. The project must be set-up
correctly for successful code generation. If the generation is error-free all generated source code files are saved to the
destination directory.

To see the generated code files:
1. Navigate to the Project Explorer view
2. Expand the tree control of the Project for which you generated the code.
3. Open the contents of the Generated_Code folder.
4. The generated code appears in *.c or *.h files within the pin_init folder.
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Figure 23. Generated output

4.6.1 Pin configuration routines

The PinSettings component generates pin configuration routines into the following files:
• Generated_Code/<PinSettings component name>/iomux_config.c.

The main pin configuration function iomux_config() which contains calls of the peripheral modules’ pin configuration
functions.

• Generated_Code/<PinSettings component name>/iomux_config.h.

Header containing the iomux_config() function’s declaration and declarations of all peripheral modules’ pin
configuration functions.

• Generated_Code/<PinSettings component name>/<peripheral module name>.c.

Each of this C files contains the configure_<peripheral module name>_pins(uint32_t instance) function which
configure pins on the given peripheral module.

The pin configuration functions use register access macros from the i.MX SDK IO map (memory map headers). The tool
generates the IO map header file for the current processor component in the project:

• sdk/include/<processor name>/fsl_bitaccess.h
• sdk/include/<processor name>/<processor name>_registers.h
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