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Chapter 1
Introduction
This FAQ Guide lists most frequently asked or most anticipated questions about
Microcontrollers V10.x. In this document, the FAQs are divided into various categories
based on the Microcontrollers V10.x feature they are associated with, such as Installation,
IDE, Editor, Project Management, Project, Compiler, Assembler, Linker, Debugger,
Debugger Shell, USBTAP, Ethernet TAP, and Profiling and Analysis Tools.

In this chapter:

° Contents of this Manual - Describes the contents of this manual.
° What s New - Lists new FAQs in this manual.
° Accompanying Documentation - Describes supplementary CodeWarrior

documentation, third-party documentation, and references.

1.1 Contents of this Manual
The following table lists and describes each chapter in this manual. Each chapter lists a
specific category of FAQs.

Table 1-1. Manual Contents

Chapter Description

IDE and Installation Lists IDE related FAQs

Project Management Lists project management related FAQs

Project Lists project related FAQs

Compiler Lists compiler related FAQs

Linker Lists linker related FAQs

Debugger Lists debugger related FAQs

Debugger Shell Lists debugger shell related FAQs

Profiling and Analysis Tool Lists profiler related FAQs
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1.2 What s New for Microcontrollers 10.5
The manual includes these new FAQs.

° What are the features of freedom board FRDM-K20D50M?
° What are the disadvantages of using printf() in the embedded system

programming?
° The OpenSDA connection is not available in the Connection page of the wizard.

What do I do?
° My bootloader resides in the first lower flash pages. How do I avoid it to get

destroyed and overwritten by the application?
° I am debugging FRDM-KL05Z with USBDM, but I received a  Failed to resume

target process., Downloading binary to target..  error message. What do I do?
° How does a bootloader work?
° How do I use printf() with the FRDM-KL25Z Board without using the Processor

Expert?
° How do I use Freedom board as SWD programmer?
° How do I use CMSIS-DAP with IAR on KL25Z Freedom Board?
° How do I set up criteria for bootloader to decide if it shall run the bootloader or

the application at the startup?
° How do I make sure that the bootloader gets linked only into its specified space?
° How do I make sure that application does not overlap with the FLASH area of the

bootloader?
° How do I load the Debug Application on my FRDM-K20D50M board?
° How do I install open source USBDM?
° How do I fix the 3.3V voltage drop on FRDM-KL25Z Board?
° How do I decode S19 Files?
° How do I bootload an application?
° How can I add my own code to be inserted as part of the system startup?
° For my bootloader I need a way to send a file with a terminal program. As my

serial connection has only Tx and Rx, but no RTSCTC lines for flow control, it is
useful if the terminal program either implements software flow control (XONXOFF),
or a delay value for sending a file. What do I do?

° Do I need to initialize my port pin?
° Can MCU10.4 recover a bricked OpenSDA Freedom Board?
° Can I program a different Freedom Board using Freedom board as SWD

programmer?
° What Bootloader Shell commands I can use?
° What is a bootloader?
° What is Bootloader Sequence?

What s New for Microcontrollers 10.5
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° What is the code size required for the bootloader for FRDM-KL25Z board?
° Where can I find the software for my FRDM-K20D50M board?
° Which device should I use to create a new project for my FRDM-K20D50M

board using CodeWarrior?
° How do I add/remove floating point format for S08 Projects?
° How do I restore deleted files in Eclipse with local history?
° What are the points to consider while using Stepping Backwards feature in

Debugging?

1.3 Accompanying Documentation
The Documentation page describes the documentation included in the CodeWarrior
Development Studio for Microcontrollers v10.x.

You can access the Documentation by:

° opening the START_HERE.html in <CWInstallDir>\MCU\Help folder,
° selecting Help > Documentation from the IDE s menu bar, or selecting the Start >

Programs > Freescale CodeWarrior > CW for MCU v10.x > Documentation
from the Windows taskbar.

NOTE
To view the online help for the CodeWarrior tools, first
select Help > Help Contents from the IDE s menu bar.
Next, select required manual from the Contents list. For
general information about the CodeWarrior IDE and
debugger, refer to the Codewarrior Common Features
Guide in this folder: <CWInstallDir>\MCU\Help\PDF
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Chapter 2
IDE and Installation

In this chapter, you find Frequently Asked Questions (FAQs) related to the CodeWarrior
IDE.

The FAQs listed in this chapter are divided into five categories:

° Updating and Installing Software
° Editor
° Workbench Window
° CVS
° Search and Replace Action
° Miscellaneous

2.1 Updating and Installing Software

In this topic, installation related FAQs are listed.

° I have installed CodeWarrior for Microcontrollers on Linux Ubuntu 8.04, 64-bit.
However, Multilink drivers are not working. What do I do?

° I want to install updates for the CodeWarrior software. However, when I check for
updates, no updates are found. What do I do?

° I am facing issues in accessing the updater sites. How do I resolve this?
° My attempt to install the CodeWarrior tool fails with the error "Another version of

this product is already installed". What do I do?
° How do I uninstall the third party plugins?
° After updating the CodeWarrior, I receive the following error while restarting the

application, " Initialize RSE  has encountered a problem". What should I do?
° How do I know what updates/patches are already installed?

CodeWarrior Development Studio for Microcontrollers V10.x FAQ Guide, Rev. 10.6, 02/2014

Freescale Semiconductor, Inc. 23



° I have installed the CodeWarrior patches on Windows 7. The patches have installed
correctly, however the CodeWarrior software generates error while building the
libraries. Is there any way to resolve this?

° How can I check if the compiler updater is successfully installed?

2.1.1 I have installed CodeWarrior for Microcontrollers on Linux
Ubuntu 8.04, 64-bit. However, Multilink drivers are not
working. What do I do?

64-bit drivers for P&E Devices are not supported for CodeWarrior for Microcontrollers
v10.1. However, this support is available for CodeWarrior for Microcontrollers v10.2.

2.1.2 I want to install updates for the CodeWarrior software.
However, when I check for updates, no updates are found.
What do I do?

If you are using Help > Check for Updates option to check for new service packs or
patches, you may get the message "There is nothing to update", even when patches and
service packs are available.

This happens because the Check for Updates option, checks for updates available for
already installed packages or features. The Check for Updates option scans through the
list of the installed plugins and contacts the configured and enabled update sites (for your
reference, see the image listed below).
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Figure 2-1. Available Software Sites

For example, if you have installed a service pack, the CodeWarrior software will search
for an update available for the service pack. However, it will not search for the recent
Kinetis compiler, as the Kinetis compiler has not been installed previously as a separate
package or feature.

To install new service packs or patches, use the Help > Install New Software option.
While installing new software, make sure that you clear the Contact all update sites
during install to find required software checkbox.

Also, note that if the CodeWarrior software needs to access updates through proxy, you
need to configure the network connections.
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Figure 2-2. Network Connections

2.1.3 I am facing issues in accessing the updater sites. How do I
resolve this?

The Install New Software option requires minor modification to the CodeWarrior V10.x
site pointers to enable correct behavior.

If you have problem to access an updater site, add a backslash to the end.

For example, add a backslash at the end of the Freescale update site:

http://freescale.com/lgfiles/updates/Eclipse/MCU10_1/com.freescale.mcu.updatesite/

Similarly, for SVN Connectors site:

http://www.polarion.org/projects subversive download/eclipse/2.0/update-site/

For other sites, such as:

http://download.gna.org/eclox/update

backslash is not required, however it seems to be a safe practice to add µ/  at the end of all
the updater sites.
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2.1.4 My attempt to install the CodeWarrior tool fails with the
error "Another version of this product is already installed".
What do I do?

This happens when while un-installing the CodeWarrior tool, the installer crashes in
between. The files are removed from the hard drive and the icons are removed from the
Start menu. Also, the CodeWarrior tool does not appear in the Add/Remove Programs
panel. But, your system will not let you install another version of the CodeWarrior tool,
as there are still some files remaining.

To remove the remaining CodeWarrior files:

1. Open a command prompt and go to the folder containing the setup.exe of the
CodeWarrior tool you want to uninstall.

2. In this folder, edit the setup.ini file and search for the value, ProductCode.
3. Enter the following command at the command prompt:

msiexec /i[ProductCode]

The CodeWarrior setup dialog box appears.

4. Repair or remove the current installation.
5. Remove the remaining files.
6. Re-launch the setup of the CodeWarrior tool you want to install.

You can now successfully install another version of the CodeWarrior tool.

2.1.5 How do I uninstall the third party plugins?

To uninstall a third party plugin, follow the steps listed below:

1. Select Help > Install New Software from the IDE menu bar.

The Install dialog box appears.
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Figure 2-3. Install Dialog Box
2. Click the What is already installed? option.

The Codewarrior Development Studio Installation Details dialog box appears.

3. Select the desired plugin and click Uninstall .

The Uninstall dialog box appears.
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4. Click Finish .

The IDE uninstalls the selected plugin.

2.1.6 After updating the CodeWarrior, I receive the following
error while restarting the application, " Initialize RSE  has
encountered a problem". What should I do?

You have to check that whether all the features available into the MCU10.1 Update
package has been installed or not.

For this, open the Install dialog box by selecting Help > Install New Software from the
IDE menu bar. When you check the Group items by category and Hide items that are
already installed checkboxes, the All Items are installed message (refer to the image
listed below) appears under the CW MCU v10.1 Update category.

If this is not the case, you have to install all the other features that are appearing in the
list.

Figure 2-4. MCU Update - Install Dialog Box
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2.1.7 How do I know what updates/patches are already installed?

To view the list of installed updates/patches, follow the steps listed below:

1. Select Help > Install New Software from the IDE menu bar.

The Install dialog box appears.

2. Select All Available Sites from the Work with drop-down list.

The already installed updates/patches appears in gray icons.

Figure 2-5. Install dialog box - Listing Installed Updates

2.1.8 I have installed the CodeWarrior patches on Windows 7.
The patches have installed correctly, however the
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CodeWarrior software generates error while building the
libraries. Is there any way to resolve this?

If you install patches under non-admin privileges, all looks like it goes well. It shows that
the patches are installed. However, when you build the libraries, you still get the error.
Also, there is no way to uninstall the patches so you can re-install them with the admin
privileges.

There are two ways to work this around:

° Install the Codewarrior with RUN AS ADMIN and run the updates with admin
privileges when you install patches.

° Install the CodeWarrior in the non-default location (means, not in the Windows
default Program Files folder) but install it in a directory that you can have admin rights
(IE-Users/profile etc).

2.1.9 How can I check if the compiler updater is successfully
installed?

Follow the steps listed below for CodeWarrior for Microcontrollers v10.1:

Select Help > About CodeWarrior Development Studio > Configuration Details from
the IDE menu bar and search for the Configured Features . The
com.freescale.mcu10_1.buildtools.win.sp feature (refer to the image listed below) in the list
shows that the compiler updater is successfully installed.
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Figure 2-6. Configuration Details Dialog Box

Follow the steps listed below for CodeWarrior for Microcontrollers v10.2:

Select Help > About CodeWarrior Development Studio > Installation Details from
the IDE menu bar.

All installed softwares are listed in the Installation Details dialog box.
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Figure 2-7. Installation Details Dialog Box

2.2 Editor

In this topic, Editor related FAQs are listed.

° How can I quickly open declaration of any variable, function name, macro, or header
file from within Editor?

° How can I open definition of a function or header file from within the editor?
° If I am using a Macintosh computer, what is the alternate to using the F3 key in

Editor to open declarations?
° How can I change the color that highlights the current line in a source code file?
° Is it possible to view definition of a macro or a variable in the source code file?
° Can the CodeWarrior IDE assist me in writing the source code?
° How can I change the tab width/size?
° Is it possible to display line numbers in Editor?
° Is it possible to change the default code format settings?
° How can I quickly switch to a header file from within the source code file?
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° How does the CodeWarrior IDE differentiate between enabled and disabled macros?
° How can I configure predefined macros in the CodeWarrior IDE?
° Is it possible to view evaluated expansion of a macro in the CodeWarrior IDE?
° Is it possible to roll back the changes I did to my source code?
° Is there a way to change the default color of comments that span across multiple

lines?
° Is there a way to revert to the original contents of a source code file?
° How do I convert Line Delimiters to the Unix format?
° Why do I get the following error message when I try to edit a source code file?
° What does an asterisk on the Editor title bar mean?
° How can I find out where a function is declared in my source code?
° How can I open .tcl extension files in the Editor window?
° Is it possible to condense a large source file by folding/unfolding different portions

of code?
° How can I generate S19, Intel Hex, and Binary files for my project?
° How can I use the Burner for the Kinetis derivatives?
° I have created two build configurations one for debug and another for release. How

can I specify a burner bbl file for each build configuration?
° Is there a way to determine in which workspace I am working currently?
° How can I share same installation of the CodeWarrior software with multiple users?
° How can I comment/uncomment a block of code in the editor?
° How can I compare files in CodeWarrior IDE?
° Is there a way to compare files that are not in project?
° How do I switch between the source files in the Editor view?
° I want to edit my source files, but all the other views are using the space as well.

How do I maximize the editor view to have better working area?
° How do I remove blank lines in the Editor view?

2.2.1 How can I quickly open declaration of any variable,
function name, macro, or header file from within Editor?

To quickly open declaration of any variable, function name, macro or header file from
within Editor, press the Ctrl key and click the text. Alternatively, place the mouse cursor
on the text and perform either of the following:

° press F3,
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° right-click and select Open Declaration (as the figure, Open Declaration listed
below shows), or

° select Navigate > Open Declaration from the IDE menu bar ( as the figure,
Navigate Menu listed below shows).

This will open the logical file associated with the selected text. For example, for a header
file include, the header file will open. For variables, the file containing the definition or
declaration of the variable will open.

Figure 2-8. Open Declaration

Figure 2-9. Navigate Menu

The Navigate menu lets you perform various navigation actions in the source file, such
as opening header files, viewing macro or variable definitions, navigating to the last edit
location or previous source file. You can also perform these actions using the keyboard
shortcuts.
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2.2.2 How can I open definition of a function or header file from
within the editor?

The CodeWarrior Eclipse IDE uses an indexer to build index of all sources in the
background. To open definition, you need to configure indexer preferences. The indexer
can be configured per project or per workspace basis.

1. Select Window > Preferences .

The Preferences dialog box appears.

2. Type indexer as the filter text to narrow down the list of preferences.
3. Select C/C++ > Indexer .

The Indexer page appears in the right panel.

Figure 2-10. Indexer Page
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4. From the Select indexer drop-down list, select the Full C/C++ Indexer option.
5. Click OK .
6. Right-click the project with which the source file is associated in the CodeWarrior

Projects view and select Index > Rebuild .
7. Press F3, definiton will open.

Figure 2-11. Function Definition
8. Press F3 again to switch to the function declaration.

Figure 2-12. Function Declaration
9. Press ALT + Left to switch to the original location.

Repeat step 7-9 to open function declarations and definitions of other functions in the
source file.

2.2.3 If I am using a Macintosh computer, what is the alternate to
using the F3 key in Editor to open declarations?

If you are using a Macintosh computer, just keep the CTRL key pressed and move the
mouse cursor over the header file or function whose declaration or definition you want to
open. The hyperlink for that header file or function enables.

Click the hyperlink to switch to the required declaration or definition, as the following
figure shows:

Figure 2-13. Hyperlink in Source Files
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By default, the modifier key for hyperlinks in editor is Ctrl; however, you can change the
modifier key as per your preference.

1. Select Window > Preferences.

The Preferences dialog box appears.

2. Type Hyperlink as the filter text to narrow down the list of preferences.
3. Select General > Editors > Text Editors > Hyperlinking.

The Hyperlinking page appears in the right panel.

Figure 2-14. Hyperlinking Page
4. Enter the required modifier key in the Default modifier key text box.
5. Click OK.

The modifier key changes, as specified.

2.2.4 How can I change the color that highlights the current line
in a source code file?

To change the color for the current line highlight in a source file:

1. Select Window > Preferences .

The Preferences dialog box appears.

2. Type text editor as the filter text to narrow down the list of preferences.
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3. Select General > Editors > Text Editors .

The Text Editors page appears in the right panel.

4. Ensure that Highlight current line checkbox is checked.
5. Select Current line highlight in the Appearance color options list.

Figure 2-15. Text Editors Page > Current line highlight Selected
6. Click the Color button to open the color panel, and select the required color.
7. Click OK to close the color panel.
8. Click OK to save the settings.

The current line highlight color changes, as specified.
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2.2.5 Is it possible to view definition of a macro or a variable in
the source code file?

Yes, you can open definition of a macro or variable by hovering the mouse cursor over
the macro or variable. A small popup window displaying the definition of the macro
( refer to the image, Macro Definition as listed below) or variable ( refer to the image,
Variable Declarations and Occurrences as listed below) appears.

Also, the IDE highlights all the occurrences of the variable in the source file, so you do
not need to search for it manually.

Figure 2-16. Macro Definition

Figure 2-17. Variable Declaration and Occurrences
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2.2.6 Can the CodeWarrior IDE assist me in writing the source
code?

Yes, CodeWarrior IDE can parse the source files in the background. Therefore, it
provides you the code completion feature. To use the code completion feature, select
Edit > Content Assist from the IDE menu bar.

Figure 2-18. Edit > Content Assist

The Content Assist feature allows you to view the list of the field member of a structure,
class, or union. The list of the field members appears automatically the moment you type
µ.  following the structure, class, or union name (refer to the image listed below). You can
also press Ctrl+Space to view the list.
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Figure 2-19. View Field Members of Structure

If you press Ctrl+Space without typing anything or by placing the cursor in a blank line
in the source file, the complete list appears, as shown in the figure listed below.

Figure 2-20. Content Assist - Without Typing Anything

You can also view the list of bitfields using Content Assist, as shown in the figure listed
below.
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Figure 2-21. Bitfields

2.2.7 How can I change the tab width/size?

By default, the tab size in the CodeWarrior IDE is 4. To change the default tab size:

1. From the IDE menu bar, select Window > Preferences .
2. Type tab as the filter text to narrow down the list of preferences.
3. Select Text Editors .

The Text Editors preference page appears in the right panel of the Preferences
dialog box.

Figure 2-22. Text Editors Preferences Page
4. Enter the desired tab size in the Displayed tab width text box.
5. Click OK .

The default tab size changes.
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2.2.8 Is it possible to display line numbers in Editor?

Yes, to display line numbers in the editor area:

1. From the IDE menu bar, select Window > Preferences .

The Preferences dialog box appears.

2. Type number as the filter text to narrow down the list of preferences.
3. Select Text Editors . The Text Editors preference page appears in the right panel of

the Preferences dialog box.
4. Check the Show line numbers checkbox.

Figure 2-23. Text Editors Preference Page
5. Click OK .
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The editor will display line numbers.

2.2.9 Is it possible to change the default code format settings?

Yes, to change the default code format settings:

1. From the IDE menu bar, select Window > Preferences.

The Preferences dialog box appears.

2. Type code as the filter text to narrow down the list of preferences.
3. Select Code Style in the left pane to modify the code formatting.

Figure 2-24. Code Style Preference Page
4. Select a predefined profile from the Select a profile drop-down list. Each of the

profile specify different ways of formatting the code.
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If the predefined profiles does not suit your requirements, you can create a new
profile.

a. Click the New button.

The New Code Formatter Profile dialog box appears.

b. Enter the name of the new profile in the Profile name text box.
c. Select the profile based on which you want to create the new profile from the

Initialize settings with the following profile drop-down list.
d. Click OK.

The edit dialog box appears.

e. Specify the code formatting settings as required and click OK.
5. Click OK to close the Preferences dialog box.

The editor will now use the selected profile to format the code.

2.2.10 How can I quickly switch to a header file from within the
source code file?

If you are working in an implementation (*.c/*.cpp) file, and you quickly want to open
the corresponding header file, perform either of the following:

° press CTRL+  or
° right-click and select Toggle Source/Header .

Similarly, you can also toggle back to the source file from the header file.

2.2.11 How does the CodeWarrior IDE differentiate between
enabled and disabled macros?

CodeWarrior IDE automatically marks the disabled macros in gray to help you determine
which macros are active and which not.
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Figure 2-25. Disabled Macros Marked in Gray

2.2.12 How can I configure predefined macros in the
CodeWarrior IDE?

To configure predefined macros in the CodeWarrior IDE:

1. Select the project for which you want to configure the predefined macros in the
CodeWarrior Projects view.

2. Select Project > Properties in the IDE menu bar.

The Properties dialog box appears.

3. Select C/C++ General > Paths and Symbols .

The Paths and Symbols properties page opens in the right panel of the Properties
dialog box.

4. Select the Symbols tab.
5. Configure the symbols listed in the Symbols tab page.
6. Click OK .

The predefined macros are configured for the selected project.

2.2.13 Is it possible to view evaluated expansion of a macro in
the CodeWarrior IDE?

Yes, if you hover mouse cursor over a complex macro, the CodeWarrior IDE shows the
evaluated expression (refer to the image listed below).

Figure 2-26. Pop-up Window Displaying Macro Expansion
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Press F2 to bring in focus the macro expansion (refer to the image listed below).

Figure 2-27. Focus over Macro Expansion

Using Alt+Left and Alt+Right you can step through the macro expansion. This gives
you details of the steps in the macro expansion (refer to the image listed below).

Figure 2-28. Macro Expansion Steps

2.2.14 Is it possible to roll back the changes I did to my source
code?

Yes, local history can help roll back the changes you make to your source code.

To roll back the changes, perform these steps.

1. Right-click the updated source code in the editor.
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2. From the context menu, select the Replace with > Local History command.

The Compare dialog box appears. The dialog box lists the date and time of the
changes you saved.

Figure 2-29. Compare Dialog Box
3. From the Revision Time options, select the desired date and time.
4. Click the Replace button.

The changes made to the file will be roll backed to the selected date and time.

NOTE
The local history is maintained for files only and not for
projects or folders.

2.2.15 Is there a way to change the default color of comments
that span across multiple lines?

Yes, in order to change the default color of comments that span across multiple lines in
source code follow steps below:

1. From C/C++ perspective toolbar, select Preferences.

The Preferences window appears.

2. Select C/C++ > Editor > Syntax Coloring.

The Syntax Coloring page appears in the right panel (refer to the image listed
below).

Chapter 2 IDE and Installation

CodeWarrior Development Studio for Microcontrollers V10.x FAQ Guide, Rev. 10.6, 02/2014

Freescale Semiconductor, Inc. 49



3. Select Comments > Multi-line comment.

Figure 2-30. Preferences Dialog Box - Syntax Coloring
4. Select Color.

The color palette window appears.

5. From Color Palette, select a color of your choice.
6. Click OK.
7. Click Apply.
8. Click OK.

NOTE
If you want to change the color of a comment that is across
a single line, then follow the steps given above, except
selecting Single-line comment instead of Multi-line
comment.

The color of the comments in the source code changes, as specified.
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2.2.16 Is there a way to revert to the original contents of a source
code file?

Yes, if undesired changes were made to source file, there is a way to revert to the
previous file. In order to do this follow steps below:

1. Right-click the source file and select Replace With > Local History f rom the
context menu.

The Compare view appears.

2. Double-click Revision Time .
3. Double-click Revision Time tab.

The Compare window appears.

4. Select Replace .

The file is replaced.

NOTE
Another way to replace the file is to select Replace With >
Previous from Local History from context menu and this
command replaces the file with the last file that you saved.

2.2.17 How do I convert Line Delimiters to the Unix format?

The Default is Windows. To change to UNIX, select File > Convert Line Delimiters To
> Unix from the IDE menu bar.

2.2.18 Why do I get the following error message when I try to edit
a source code file?

  File  /../../filename.c  is read-only.  Do you wish to make 
  it writable?
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You get this error message because the file that you are trying to edit is read-only. If you
do not want to make it writable then select No . If you want to find out the settings for
this file, follow steps below:

1. From the CodeWarrior Projects window, right-click on the source file.

A context menu appears.

2. From context menu, select Properties .

The Properties window appears.

3. Select Resource .

On the right-hand side, the settings for the file appear.

2.2.19 What does an asterisk on the Editor title bar mean?

The asterisk on the editor s toolbar indicates there are unsaved changes.

2.2.20 How can I find out where a function is declared in my
source code?

To find out where a function is declared in source file, follow steps below:

1. Double-click on source file.

Source file appears in the Editor view.

2. In Source file, right-click the function name.

A context menu appears.

3. From context menu, select Open Declaration .

The source file that contains the function declaration appears.

2.2.21 How can I open .tcl extension files in the Editor window?
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In order to open .tcl extension files in the Editor window, a File Association needs to be
created. To create a File Association, follow steps below:

1. From the CodeWarrior toolbar, select Window > Preferences.

The Preferences dialog box appears.

2. Select General > Editors > File Associations.

The File Associations preferences appear on the right hand side.

3. Select File Associations.

The File Associations pane appears.

Figure 2-31. Preferences Dialog Box - File Association
4. Click Add.

The New File Type dialog box appears.

5. In the File Type textbox, enter .tcl.
6. Click OK.

The .tcl extension appears under File Types .

7. Under Associated editors pane, Click Add.

The Editor Selection dialog box appears.
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Figure 2-32. Editor Selection Dialog Box
8. Click OK.

The .tcl extension file types get associated with a Text Editor (as the following
figure shows).

Figure 2-33. Preferences Dialog Box - File Association
9. Click OK.

You can now open the tcl extension files in the Editor window.
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2.2.22 Is it possible to condense a large source file by folding/
unfolding different portions of code?

Yes, you can enable folding in editor and specify levels of folding and which portion of
code needs to be folded. To enable and configure folding/unfolding, perform these steps.

1. From the IDE menu bar, select Window > Preferences.

The Preferences dialog box appears.

2. Type folding as the filter text to narrow down the list of preferences.
3. Select C/C++ > Editor > Folding. The Folding preference page appears in the right

panel of the Preferences dialog box.

Figure 2-34. Folding Preference Page
4. Check the Enable folding when opening a new editor checkbox.
5. Configure level of folding and select which regions of code should be automatically

folded.
6. Click OK and reopen your source file.
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Now you can fold/unfold portions in your source code, as the figure listed below shows.
The fold/unfold functionality is added with new markers (+/-) at the left side in the source
file. This improves readability of the source code.

Figure 2-35. Editor With Folding Enabled

To preview what is inside a folded region, you do not need to unfold it again. Hover your
mouse cursor over a folded region and a popup appears displaying the details.

Figure 2-36. Folded Region Preview
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2.2.23 How can I generate S19, Intel Hex, and Binary files for my
project?

For many embedded applications, you not only want the file to debug the target, that is
generate *.abs or *.elf file, but you also need an S19 (Motorola S-Record) file, an Intel
Hex file, or a Binary file of the application. Very likely you need these files for
production programming or as input to other tools.

The wizard generated 8/16 bit projects for MCU10 includes a burner.bbl file for exactly
this purpose. BBL stands for Batch Burner Language and is a simple batch/script
language to generate and process S-Records, Intel Hex, and Binary files.

You can find the burner.bbl file within the Project_settings\Linker_Files folder in the
project.

Figure 2-37. Burner File

The file includes a script to generate an S19 file.

Listing: Burner file contents

OPENFILE "%ABS_FILE%.s19"
format=motorola

busWidth=1

origin=0

len=0x1000000

destination=0

SRECORD=Sx

SENDBYTE 1 "%ABS_FILE%"
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CLOSE

The script in burner file opens/creates a .s19 file, configures some settings, such as the
output file format, sends all bytes from the application .abs file to the output file, and then
closes it.

The *.bbl file is processed by the make file after linking the application binary. There is a
graphical way to configure or create such a script file.

NOTE
For more information about the burner file, refer to the
Microcontrollers V10.x HC(S)08/RS08 Build Tools Utilities
Manual.

To configure burner script file graphically, perform these steps.

1. Browse to the CWInstallDir\MCU\prog folder.
2. Double-click burner.exe.

The Burner Default Configuration dialog box appears.

3. Click the Burner Dialog button on the toolbar (as the image, Burner Default
Configuration Dialog Box listed below shows).

The Burner dialog box appears (as the image, Burner Dialog Box - Input/Output Tab
listed below shows).

Figure 2-38. Burner Default Configuration Dialog Box
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Figure 2-39. Burner Dialog Box - Input/Output Tab
4. Configure the input file in the Input/Output tab.
5. Click the Content tab and configure the output format in the Content tab page.

Figure 2-40. Burner Dialog Box - Content Tab
6. Click the Command File tab.
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The Command File tab page displays the script as per the settings done in the Input/
Output and Content tabs.

Figure 2-41. Burner Dialog Box - Command File Tab
7. Copy the commands from the Command File tab page and paste the commands in

your script file.

Now, you can easily create a burner.bbl file that can generate three different output files,
S19, Intel Hex, and Binary, as shown in the following listing.

Listing: Script for generating S19, Intel Hex, and Binary files

busWidth=1
origin=0

len=0x1000000

destination=0

SRECORD=Sx

undefByte=0xff

format=motorola

OPENFILE "%ABS_FILE%.s19"

SENDBYTE 1 "%ABS_FILE%"

CLOSE

format=binary

OPENFILE "%ABS_FILE%.bin"
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SENDBYTE 1 "%ABS_FILE%"

CLOSE

format=intel

OPENFILE "%ABS_FILE%.hex"

SENDBYTE 1 "%ABS_FILE%"

CLOSE

Also, the BBL file allows you to merge multiple files. For example, you can take a
Binary file as input and convert it into an S-Record file. Or you add additional
information to your files.

For example, if there is an S19 file that defines a firmware signature, and you want to
make sure this signature is included into the S19 file for production.

You can implement the burner.bbl file as shown in the following listing.

Listing: Adding additional information to file using burner file

OPENFILE "%ABS_FILE%.s19"
format=motorola

busWidth=1

origin=0

len=0x1000000

destination=0

SRECORD=Sx

SENDBYTE 1 "%ABS_FILE%"

SENDBYTE 1 "MyFirmwareSignature.S19"

CLOSE

2.2.24 How can I use the Burner for the Kinetis derivatives?

In the CodeWarrior for Microcontrollers v10.x, the Burner Utility integrated with RS08,
S08 and ColdFire projects, but not for e200 yet. But you can use it, using a post-build
step. Post-build is something similar as the post-linker in the classic CodeWarrior. It
allows you to do something (whatever you want) at the end of the build process.

We are using it here for Kinetis to create an S19 file with the Burner utility after the file
has been linked. To use the Burner for Kinetis derivatives:
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° First, make sure that the Kinetis linker does not produce the S-Record, as we are
going to generate it with the burner.

° Next, create or add your burner file to the project. The location or name does not
matter, you just need to reference it properly in the next steps.

You might go with the default burner.bbl content as listed below:

  OPENFILE "%ABS_FILE%.s19"

  

  format=motorola

  

  busWidth=1

  

  origin=0

  

  len=0x1000000

  

  destination=0

  

  SRECORD=Sx

  

  SENDBYTE 1 "%ABS_FILE%"

  

  CLOSE

  

Notice the " %ABS_FILE%" which is a variable to tell the burner, what file ( .elf/.afx/.abs) is
to use. You need to pass this to the burner.

In the Build Steps, define the Post-build steps, with something like this:

  "${MCU_TOOLS_HOME}\prog\Burner.exe" 
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  -F="${PROJECT_LOC}\Sources\burner.bbl" 

  

  -env"ABS_FILE=${BuildArtifactFileName}"

  

The first item specifies the executable, the -F option tells the burner which command file
it has to use, and the -env option passes the environment variable used in the .bbl.

Now if you run a make/build, you can see the result in the Console view (and of course
having the S19).

2.2.25 I have created two build configurations one for debug and
another for release. How can I specify a burner bbl file for
each build configuration?

Suppose, you have created two Build Configurations for a bareboard project, one for
debug and another one for release, in CodeWarrior for Microcontrollers. You want to
configure the build configurations such that each one can use a different burner bbl file.
This way the IDE will generate different binaries depending on the active configuration.

To specify a burner bbl file for each build configuration:

1. Create two .bbl files.

Figure 2-42. Burner Files
2. Assign each .bbl file to the corresponding build configuration.

a. Right-click the file and select Resource Configurations > Exclude from build .

The Exclude from build dialog box appears.

b. Check the build configurations from which you want to exclude the file.
c. Click OK .

Alternatively, open the file properties dialog box. Check the Exclude resource
from build checkbox.

Similarly assign build configuration to the second bbl file.
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Now, if you build the Debug configuration, the debug.bbl file will be used. And, if you
build the Release configuration, the release.bbl file will be used.

2.2.26 Is there a way to determine in which workspace I am
working currently?

Yes, there is a command line switch to help you determine the location of the workspace
your CodeWarrior IDE is using currently. You may need this information if you have
multiple instances of CodeWarrior IDE open and if you switch workspaces frequently.

Add the -showlocation command line shortcut to the properties of the CodeWarrior IDE
shortcut, as the following figure shows.

Figure 2-43. Determine Workspace Location

The current workspace location gets displayed on the title bar of your CodeWarrior IDE.

Figure 2-44. Current Workspace Location

2.2.27 How can I share same installation of the CodeWarrior
software with multiple users?

By default, CodeWarrior IDE opens with the previously used workspace. However, you
can configure the CodeWarrior IDE to open with the user-specific workspace, that is
depending upon the user logged on to the system.

You can specify workspace path by passing the following command switch to the
CodeWarrior IDE on startup.
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  -

  data workspace path

  

If you want to open workspace folder per user basis, pass the following command line
switch to the CodeWarrior IDE.

  -dat

  a "%USERPROFILE%\perUser_workspace 

  

Figure 2-45. Specify User-Specific Workspace

2.2.28 How can I comment/uncomment a block of code in the
editor?

In ANSI C, you use /* and */ for commenting a code line. For example:

  /* this is a comment */

  

You can also span a comment over multiple code lines.

  /*

  

  do {
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  EVNT1_HandleEvent();

  

  cnt--;

  

  } while (EVNT1_EventsPending() && cnt>0);

  

  */

  

However, you cannot nest comments with /* */ comments. CodeWarrior IDE marks it
with µ ?  symbol.

In addition, most compilers, if not put into the strict ANSI C mode, also allow the usage
of the // characters for commenting a code line.

  // this is a comment too

  

This also allows you to comment out a line with comments.

  //  Function(); /* this is a call to my function*/

  

However, if you want to comment a whole code block, for example, the following code
lines, commenting may not work for all the code lines in the block.

  do {

  

  EVNT1_HandleEvent();

  

  cnt--; /* limit number of iterations */

  

  } while (EVNT1_EventsPending() && cnt>0);
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One way to comment a code block is to use #if 0 ... #endif.

Figure 2-46. Commenting Code Block

The source file parser in CodeWarrior IDE automatically detects the µfalse  condition and
grays out the code for better readability.

Another way is to comment/uncomment is to select the code lines you want to comment/
uncomment and right-click. The following figure shows the context menu that appears.

Figure 2-47. Editor Context Menu

Select Source > Comment/Uncomment from the editor context menu. The selected
code lines are commented using the // characters.

  cnt = 16;

  

  //do {
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  //EVNT1_HandleEvent();

  

  //cnt--; /* limit number of iterations */

  

  //} while (EVNT1_EventsPending() && cnt>0);

  

  } else {

  

Similarly, you can also uncomment the code block.

To comment code block using the /* */ characters and uncomment , use Add Block
Comment and Remove Block Comment in the editor context menu.

  cnt = 16;

  

  /*

  

  do {

  

  EVNT1_HandleEvent();

  

  cnt--;  limit number of iterations 

  

  } while (EVNT1_EventsPending() && cnt>0);

  

  */

  

  } else {
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But note that, nested /* */ comments are not allowed. The CodeWarrior IDE removes the
nested comment tokens, as shown in the example above. You need to check the
comments in the code block after applying comment using the /* */ characters.

In addition, CodeWarrior IDE editors include comment auto-templates. For example, if
you type /* in the editor and press enter, editor automatically creates a comment block for
you.

Figure 2-48. Comment Block

You can immediately start typing your comment text inside the comment block.

To configure comment template settings:

1. Select Window > Preferences .

The Preferences dialog box appears.

2. Type "comment" as the filter text to narrow down the list of the preferences.
3. Select Code Style > Code Templates.
4. Make the required settings in the Code Template preference panel and click OK .

The template settings are configured, as specified.

2.2.29 How can I compare files in CodeWarrior IDE?

To compare files:

1. Hold the CTRL key and select the files you want to compare.
2. Right-click and select Compare With > Each Other.

The Compare view appears.
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Figure 2-49. Compare View

The C Compare area displays the list of items added or removed from the files. The
items are marked with specific addition and deletion icons. Double-click an item to
navigate to it in the files.

Using the toolbar, you can:

° Copy all changes, or only the not conflicting ones
° Copy the current change to left or right
° Go to the next or previous change or difference

Similarly, you can also compare more than two files in CodeWarrior IDE. To compare
more than two files, you need to specify which file should be used as the common
ancestor.

Figure 2-50. Specify Common Ancestor File
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Figure 2-51. Compare More Than Two Files

Using the Show Ancestor Pane and Two-Way Compare (Ignore Ancestor) toolbar
buttons, you can display or close the Ancestor view.

2.2.30 Is there a way to compare files that are not in project?

To compare files that are not in a project, you need to use an external diff tool, for
example KDiff, which is an open source tool.

1. Download and install KDiff from the following location:

http://kdiff3.sourceforge.net/

2. Download the plugin file from the following location:

http://externaldiff.sourceforge.net/

3. Select Window > Preferences to configure the tool.
4. Type µcompare  as the filter text and select Compare/External Tool panel.
5. Browse to the location where KDiff is installed and select kdiff.exe .
6. Click OK .
7. Select the files you want to compare using KDiff.
8. Right click and select Compare With > Each Other (external tool) .
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The result of comparison appears in the KDiff editor.

2.2.31 How do I switch between the source files in the Editor
view?

To switch between the source files in the Editor view while creating your project:

1. Press Ctrl+Tab .

A small pop-up window appears listing all open source files in the Editor view.

Figure 2-52. Switching Between Source Files in Editor View
2. Press Ctrl+Tab repeatedly to iterate through the source files list.

By using this shortcut, you can quickly swap between different source files.

2.2.32 I want to edit my source files, but all the other views are
using the space as well. How do I maximize the editor
view to have better working area?

To maximize the views in the CodeWarrior IDE, just double-click on the view tab to
toggle between maximized view and the normal view. Alternatively, right-click on the
view tab and select Maximize from the context-menu to maximize the view. Similary,
right-click on the maximized view tab select Minimize from the context-menu to to
return to the normal view.
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2.2.33 How do I remove blank lines in the Editor view?
You can remove the empty or blank lines in the Editor view by following any of these
methods:

° By using the keyboard shortcut

Place the cursor on a line and press Ctrl+D (for line Delete). You can also use Ctrl+D
to delete multiple selected line.

Tip
To get more commands for deleting the blank lines, press
Ctrl+3 , enter delete in the textbox, the related commands
with their keyboard shortcut appears in the Commands list.

° By using the search and replace method
a. Select Edit > Find/Change from IDE menu bar, alternatively press Ctrl+F .

The Find/Replace dialog box appears.

Figure 2-53. Find/Replace Dialog Box
b. Enter ^\s*\n in the Find textbox and leave the Replace with textbox empty.
c. Check the Regular expressions checkbox.
d. Click Replace All .

The editor removes the blank lines.
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2.3 Workbench Window

In this topic, Workbench window related FAQs are listed.

° What controls the initial layout of a view in a Workbench window?
° Is it possible to restrict the number of resources that appear on my Workbench

window?
° How do I minimize a Workbench window?
° How do I customize my Workspace perspectives?
° How do I enable full screen mode in my CodeWarrior IDE?
° How do I hide the toolbar from the IDE for better visibilty of other views that I am

currently working with?
° How can I view all keyboard shortcuts available in the CodeWarrior IDE?
° How do I edit the keyboard shortcuts in the CodeWarrior IDE?

2.3.1 What controls the initial layout of a view in a Workbench
window?

A perspective defines the initial layout of the views in a workbench window. One
workbench window contains many perspectives. Each of the perspectives is task oriented.

2.3.2 Is it possible to restrict the number of resources that
appear on my Workbench window?

Yes, working sets help reduce the number of resources displayed. A working set is a
group of elements you want to display.

To create or define a new working set, perform the following steps.

1. Click  in the CodeWarrior Projects view or Project Explorer view toolbar.

The pull-down menu appears.

2. Select the Select Working Set command.

The Select Working Set dialog box appears.

3. Click the New button.

Workbench Window
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The New Working Set wizard appears.

4. From the Working set type options, select the appropriate working set. For example,
select C/C++.

5. Click Next.

The <selected> Working Set page appears. For example, C/C++ Working Set.

6. In the Working set name field, enter an appropriate name for the working set. For
example, Demo_Set.

7. In the Working set content tree, check the items you want in your view. For
example, check Project_1 and Project_3 (refer to the image listed below).

Figure 2-54. New Working Set Wizard - C/C++ Working Set Page
8. Click Finish to close the New Working Set wizard.
9. The Select Working Set dialog box reappears with the newly created working set.

Figure 2-55. Select Working Set Dialog Box
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10. Check the checkbox corresponding to the desired working set and click OK.

The CodeWarrior Projects view or Project Explorer view will now display the
selected resources only.

NOTE
To deselect an active working set, select the Deselect Working
Set command from the view pull-down menu.

NOTE
To edit an active working set, select the Edit Active Working
Set command from the view pull-down menu.

2.3.3 How do I minimize a Workbench window?

When initiated for the first time, the Workbench window tends to appear in a peculiar
state. The window seems to stretch to fit the entire screen but might not be maximized.
This generally happens, because the window takes the dimensions of the last application
window you opened. To minimize such a window, ensure that the Maximize button
indicates an unmaximized window. Next, drag the window edge (the cursor will appear
as a left-right arrow  ) to the desired width.

2.3.4 How do I customize my Workspace perspectives?
To customize your Workspace perspectives:

1. Create a new workspace. This way you have a clean start for customization and no
changes from an existing modified workspace.

2. Close the views that you do not want to use for your project manually.
3. For customizing the buttons and menus visibility in the desired perspective:

a. Select Window > Customize Perspective from the IDE menu bar.

The Customize Perspective - <perspective name> dialog box appears.

Workbench Window
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Figure 2-56. Customize Perspective - <perspective name> Dialog Box
b. Click the desired tab to select the desired settings for tool bar, menu, command

groups and shortcuts visibility.
c. Click OK.

The Customize Perspective - <perspective name> dialog box closes.

4. To save the changes you have made to the IDE s perspective, select Window > Save
Perspective As from the IDE menu bar.

The Save Perspective As dialog box appears.

Figure 2-57. Save Perspective As Dialog Box
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5. Select OK.
6. The Overwrite Perspective dialog box appears.
7. Click Yes to overwrite the previous default setting with the changes you made.

2.3.5 How do I enable full screen mode in my CodeWarrior IDE?
To change your CodeWarrior IDE to full screen mode:

1. The Eclipse full screen plugin is available at http://code.google.com/p/eclipse-
fullscreen/ web address.

2. Download the zip file.
3. Extract the cn.pande.eclipsex.fullscreen_<version>.jar file from the zip file you have

downloaded.
4. Copy the extracted jar file in the <CWInstallDir>\CW MCU v10.x\eclipse\plugins folder,

where <CWInstallDir> is the installation directory of your CodeWarrior software.

The full screen mode option is now available in your CodeWarrior Eclipse IDE.

To use the full screen mode feature:

1. Open the CodeWarrior IDE.
2. Select Window > Full Screen from the IDE menu bar, alternatively, press Ctrl+Alt

+Z to switch to the full screen mode.

Figure 2-58. Full Screen Menu Option

The CodeWarrior Eclipse IDE switches to full screen mode, hiding the toolbar, menu
bar and status bar from the screen.
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Figure 2-59. CodeWarrior Eclipse IDE - Full Screen Mode
3. Press Esc , or Ctrl+Alt+Z to exit the full screen mode.

The CodeWarrior Eclipse IDE switches back to the normal screen mode.

NOTE
The Ctrl+Alt+Z is the default shortcut to toggle between
normal and the full screen mode for the CodeWarrior
Eclipse IDE.

2.3.6 How do I hide the toolbar from the IDE for better visibility of
other views that I am currently working with?

To hide the toolbar from the IDE, right-click on the toolbar and select Hide Toolbar
from the context-menu. The following figure shows the IDE toolbar context-menu:
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Figure 2-60. Hide Toolbar - Toolbar Context-menu Option

To display the toolbar again in the IDE, select Window > Show Toolbar from the IDE
menu bar. The following figure shows the Show Toolbar menu option:

Figure 2-61. Show Toolbar - Menu Option

2.3.7 How can I view all keyboard shortcuts available in the
CodeWarrior IDE?

To view all keyboard shortcuts available in the CodeWarrior IDE:

1. Open the CodeWarrior IDE.
2. Press Ctrl+Shift+L .

The drop-down list containing the commands and their keyboard shortcuts appears in
the IDE.
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Figure 2-62. Keyboard Shortcuts Drop-down List

2.3.8 How do I edit the keyboard shortcuts in the CodeWarrior
IDE?

To edit the keyboard shortcuts available in the CodeWarrior IDE:

1. Press Ctrl+Shift+L twice.
2. The Preferences dialog box with the Keys page appears.
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Figure 2-63. Preferences Dialog Box - Keys Page
3. Select the desired command.
4. Click the Copy Command , Unbind Command , and Restore Command buttons

to copy, unbind or restore the selected command respectively.
5. Click Apply .
6. Click Ok .

The IDE saves and applies the changes you made.

2.4 CVS

In this topic, CVS related FAQs are listed.

° Does the CodeWarrior IDE support version control systems?
° How can I add my project to CVS from within the CodeWarrior IDE?

CVS
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2.4.1 Does the CodeWarrior IDE support version control
systems?

Yes, CodeWarrior IDE does provide support for the version control systems. One of the
version control system supported by the CodeWarrior IDE is CVS.

To use CVS with the CodeWarrior IDE:

1. From the IDE menu bar, select Window > Show View > Other.

The Show View dialog box appears.

2. Expand the CVS tree control and select CVS Repositories.
3. Click OK.

The CVS Repositories view appears.

4. Click the Add CVS Repository command on the CVS Repositories view toolbar.

The Add CVS Repository dialog box appears (refer to the image, Add CVS
Repository Dialog Box listed below).

5. Enter host name and path of the repository that you want to browse through in the
Host and Repository path text boxes respectively.

6. Enter user name and password in the User and Password text boxes respectively.
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Figure 2-64. Add CVS Repository Dialog Box
7. Click Finish.

You can browse through the specified repository in the CVS Repository view.

8. Right-click the desired folder and select the desired action from the context menu to
perform CVS actions, such as Check Out (refer to the image listed below).

CVS
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Figure 2-65. CVS Repository View

You can now use CVS with the CodeWarrior IDE.

2.4.2 How can I add my project to CVS from within the
CodeWarrior IDE?

To add a project to the CVS:

1. Right-click the project in the CodeWarrior Projects view and select Team >
ShareProject.

If you have already configured a CVS repository with the CodeWarrior IDE, the
Share Projectwith CVS Repository page of the Share Project wizard appears.
Otherwise, the Enter Repository Location Information page appears.

2. Specify the repository to which you want to add the project and click Next.

The Enter Module Name page appears.
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Figure 2-66. Enter Module Name Page
3. Specify name of the module in the CVS repository and click Next.

The Share Project Resources page appears.

Figure 2-67. Share Project Resources Page
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4. Select the files that you want to add to the CVS.

If the project includes generated file, then you may not want to add them to the CVS
module. You can add such files to the .cvsignore list. The .cvsignore is a special text
file which specifies all the files that should be ignored/filtered out. The .cvsignore file
can also use wildcards, such as *.tmp for filtering.

5. Check the Launch the Commit wizard checkbox and click Finish.

The Commit Files wizard starts displaying the list of unknown files.

Figure 2-68. Commit Files Wizard
6. Specify whether these files are binary or ASCII Text. In this example, CVS does not

identify three file extensions and assumes them as binary files. However, as *.mem,
*.tcl, and *.cwGeneratedFileSetLog are text files, the file type is changed to ASCII Text.

Chapter 2 IDE and Installation

CodeWarrior Development Studio for Microcontrollers V10.x FAQ Guide, Rev. 10.6, 02/2014

Freescale Semiconductor, Inc. 87



Figure 2-69. Specify How to Store Unknown Files
7. Click Next.

The Commit page appears.

Figure 2-70. Commit Page
8. Enter appropriate comment for the commit action and click Finish.

The icons of the files and folders in the project change, which specify that the project
is now under CVS control.
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Figure 2-71. Project Under CVS Control

Now, if you have done changes to a source file, and you need to view the differences
between your local copy and the repository copy, perform these steps.

1. Right-click the modified file and select Team > Synchronize with Repository. The
C Compare Viewer opens displaying comparison between the files (refer to the
image listed below).

Figure 2-72. C Compare Viewer
2. Review the changes. If you are ready to commit the changes, right-click the file and

select Team > Commit.
3. Enter the appropriate comment and click Finish.

You can also perform the synchronization in the Synchronize view in the Team
Synchronizing perspective (refer to the image listed below).
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Figure 2-73. Synchronize View

The Synchorize view displays what has been changed either locally or remotely. For
example, in the Synchorize view (in the following figure), the file main.c is on revision
1.2 with some outgoing changes, that is some changes are done locally in the file, and
there is a new file test.c which is not commited yet.

Figure 2-74. Synchronize View Displaying File Revisions

2.5 Search and Replace Action

In this topic, Search and Replace related FAQs are listed.

° How do I perform a simple search in the CodeWarrior IDE?
° Is it possible to preview the changes of the Replace action?
° Is there a way to change the variable or the function name in a CodeWarrior project?
° How can I search for specific files in a workspace?
° Is there a way to replace a variable easily?
° How can I go back to the previous location if the Editor takes me to another source

or header file when, for example, I select the Open Declaration option?
° Is there a shortcut to open the search window for a specified text that is equivalent to

the Ctrl + Shift + M shortcut key available in the Classic CodeWarrior IDE?
° Which set of files I need to backup or store in a version control system to completely

recover project settings and related debug settings?
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° I want to perform a Regular expressions search, but I do not remember the syntax of
the regular expressions. What do I do?

° How do I merge the multiple empty lines into a single one in the Editors view?

2.5.1 How do I perform a simple search in the CodeWarrior IDE?

You can either use the Search menu in the menu bar or select the Edit > Find/Replace
command. However, there is a difference. The Search menu displays the commands C/C
++ , Search , File , and Text .

° C/C++ - Opens the search dialog on the C/C++ search page
° Search - Opens the search dialog for your current editor
° File - Opens the search dialog on the File search page
° Text - Opens the submenu for full-text search in given scope (workspace, project,

file or working set)

Selecting the Select menu opens the Search dialog box that includes two specialized
tabs: File Search and C/C++ Search .

Whereas, the Find/Replace command displays the Find/Replace dialog box that lets you
search for an expression in the active editor, and replace the expression with a new
expression.

Thus, for a simple find and replace use Edit > Find/Replace .

2.5.2 Is it possible to preview the changes of the Replace action?

Yes, to preview the changes of the Replace action, follow these steps:

1. Select Search > File ( refer to the image, Search Menu as listed below) from the IDE
menu bar.

The File Search tab page of the Search dialog box appears (refer to the image,
Search Dialog Box as listed below).
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Figure 2-75. Search Menu
2. Specify the text that you want to replace in the Containing text text box.

Figure 2-76. Search Dialog Box
3. Click the Replace button. The Replace Text Matches dialog box appears.
4. In the With text box, enter the text with which you want to replace the text entered in

the Replace text box.

Figure 2-77. Replace Text Matches Dialog Box
5. Click the Preview button.
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The dialog box lists the files to which the changes will be performed as a result of the
replace action. You can preview each of the change and check or clear a file to
accept or reject the change as required.

Figure 2-78. Preview Replace Action
6. Click OK.

The Replace Text Matches dialog box is closed.

The changes as a result of the replace action are performed to the selected files.

2.5.3 Is there a way to change the variable or the function name
in a CodeWarrior project?

Yes, you can use the Refactoring feature of the CodeWarrior IDE to replace a function or
a variable name.

1. Select the variable or function and select Refactor > Rename from the IDE menu
bar.
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The Rename global variable <variable name>° dialog box appears.

Figure 2-79. Refactor Menu

Figure 2-80. Rename global variable Dialog Box
2. Specify the new name for the variable.
3. Specify the scope of refactoring, such as all projects, related projects, project, or

working set.
4. Specify where in the source file you want to make the changes, such as source code,

comments, and/or macro definitions.
5. Click the Preview button to preview the changes.
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Figure 2-81. Preview Replace Action
6. Check or clear a file to accept or reject a change as required.
7. Click OK .

The specified changes are performed.

2.5.4 How can I search for specific files in a workspace?

To search for specific files in a workspace, follow these steps:

1. From the IDE menu bar, select the Search > File... option.

The Search dialog box appears.
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Figure 2-82. Search Dialog Box
2. Specify the search string in the Containing Text field. Specify other search options

according to your requirements (refer to the image listed below).

Figure 2-83. Search Dialog Box
3. Click the Search button.

The Search view appears (as the figure listed below shows). The Search view displays
the results of your search. Right-click any item in the Search view to open a pop-up
menu that allows you to remove items from the list, copy search results to the clipboard,
or rerun the search.
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Figure 2-84. Search View

2.5.5 Is there a way to replace a variable easily?

Yes, to replace a variable, follow these steps:

1. From the IDE menu bar, select the Search > File... option.

The Search dialog box appears.

Figure 2-85. Search Dialog Box
2. Specify the search string in the Containing Text field. Specify other search options

according to your requirements (refer to the image listed below).
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Figure 2-86. Search Dialog Box
3. Click Replace.

The Replace Text Matches dialog box appears.

Figure 2-87. Replace Text Matches Window
4. Click Preview.

The Replace Text Matches window appears (refer to the image listed below). This
window gives lets you preview the changes that will be made. This allows you to inspect
each proposed change and accept or deny it individually.
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Figure 2-88. Replace Text Matches Window

2.5.6 How can I go back to the previous location if the Editor
takes me to another source or header file when, for
example, I select the Open Declaration option?

Use the Alt+left shortcut key. This option is also listed under the Navigation menu.

2.5.7 Is there a shortcut to open the search window for a
specified text that is equivalent to the Ctrl + Shift + M
shortcut key available in the Classic CodeWarrior IDE?

You can create a custom key binding for the Ctrl+Shift+M shortcut key in the
Preferences > General > Keys dialog box.
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Figure 2-89. Preferences Dialog Box - Keys Page

NOTE
For more information on key binding, refer to the topic How
can I change a key binding?

2.5.8 Which set of files I need to backup or store in a version
control system to completely recover project settings and
related debug settings?

The files you need to store in a version control system:

° .project and .cproject - contains the list of files and the build tool settings.
° .ttf - targets the needing target tasks for flash programming (ColdFire V2 and

Kinetis IAR JLink)
° .launch - required for the debugger launch configuration
° rseHostSettingsCache.xml- contains the cached RSE settings. You need this to have the

RSE settings imported.
° *.c/*.h/etc source files and linker file, if not using Processor Expert
° If you are using Processor Expert - ProcessorExpert.pe (contains all the settings),

events.c/h, and the ProcessorExpert.c with user modifications
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Any generated folders (like PE Generated_Code, PE Documentation or the folder where the
object/make files are placed (usually named by the CPU name) can be stripped off to
reduce file size.

You can also export/store the workspace settings, like editor/VCS settings/etc, by
selecting, File > Export > Preferences from the IDE menu bar.

2.5.9 I want to perform a Regular expressions search, but I do
not remember the syntax of the regular expressions. What
do I do?

To get the list of regular expressions:

1. Press Ctrl+F .

The Find/Replace dialog box appears.

2. Click the small icon in the beginning of the Find textbox, alternatively press Ctrl
+Space .

Figure 2-90. Find/Replace Dialog Box - Content Assist Icon

The content assist drop-down list appears listing all the regular expressions.

Figure 2-91. Find/Replace Dialog Box - Content Assist Drop-down List
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3. Double-click the expression to insert it in the textbox.

The selected expression appears in the textbox.

You can now perform the search for the selected expression.

2.5.10 How do I merge the multiple empty lines into a single one
in the Editors view?

To merge the multiple empty lines into a single one in the Editors view:

1. Press Ctrl+F.

The Find/Replace dialog box appears.

2. Enter the expression ^\s*\n in the Find textbox.
3. Enter the expression \R in the Replace with dialog box.

Figure 2-92. Merging Multiple Blank Lines into One
4. Click Replace All .

The editor merges the multiple blank lines into one for each appearance.

2.6 Miscellaneous

In this topic, miscellaneous FAQs related to the CodeWarrior IDE are listed.
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° How can I improve the performance of the CodeWarrior IDE I am working with?
° What is the first thing that I see when I start the CodeWarrior IDE?
° What is a perspective?
° How can I find the version of the CodeWarrior that I am using?
° Is it possible to retrieve a file that I deleted accidently from my CodeWarrior project?
° I am using my workspace since long time and adding/removing projects frequently,

this has slowed down my CodeWarrior software. How can I improve the
performance?

° How do I update my local history settings?
° Is there a way to filter the settings in the Preferences window to find a particular

setting?
° How can I change a key binding?
° Is it possible to view the change history of a source code file?
° How can I view a graphical representation of source code in the CodeWarrior IDE

using Dot and Doxygen?
° How can I determine which header files are associated with my source code file?
° How do I view call hierarchy in my source code?
° Why the project that I just created is not visible in the CodeWarrior Projects view?
° I created a new file in Windows Explorer but the file does not appear in the

CodeWarrior Projects view. Why?
° Why does the Rename option appear grayed out?
° Why duplicating a configuration in the debugger perspective does not duplicate the

run configuration?
° Can I still use Ctrl+Tab keys to navigate between open windows?
° How can I change the debugger key bindings to the ones that I used to have in the

Classic CodeWarrior IDE?
° How can I change the name of the executable that is generated when I build my

project?
° How can I see printf output in the console window?
° Why the console view does not display all the warning and error messages by

default?
° Is there a file that contains all the launch configuration settings?
° How the CodeWarrior Project Importer handles recursive access paths?
° Can I disassemble my source code file?
° Where exactly the disassemble file gets created?
° Why the .metadata folder in my workspace stores a huge history?
° How to have projects from different workspaces or locations in a workspace?
° How can I switch to another workspace?
° My workspace takes long to close. How can I resolve this?
° What is the purpose of the Tasks view?
° What is the purpose of the Properties view?

Chapter 2 IDE and Installation

CodeWarrior Development Studio for Microcontrollers V10.x FAQ Guide, Rev. 10.6, 02/2014

Freescale Semiconductor, Inc. 103



° What is the purpose of the Outline view?
° How do I use the Outline View to get an overview of a source file and modify it

directly?
° How can I find out if certain files contain debug information?
° How can I resolve the following error message that I get when I start the

CodeWarrior IDE?
° How can I open an existing project in the CodeWarrior IDE?
° What is the Manage Configurations button in the C/C++ perspective toolbar used

for? Could it be replaced by the Properties button?
° How can I start the post-build steps in the CodeWarrior IDE?
° Is it necessary to have the project name identical to the name of the directory that

contains the .project file?
° Where does the CodeWarrior IDE save the debug configuration as a local file by

default?
° When I save my launch configurations as a local file and then delete the project, all

the local configurations get deleted as well. How can I resolve this issue?
° How can I modify and save the files in GBK encoding using the CodeWarrior IDE?
° How are the PARENT-COUNT-MyVariable definitions defined in the CodeWarrior

IDE?
° Is there a way to instruct the CodeWarrior IDE to use relative paths instead of

absolute ones to store the project file location in a workspace?
° How do I solve the probable mismatch of the OSJTAG Firmware with P&E Virtual

Serial Port Utility?
° I am using CW10.1SE and MQX3.7 with all patches and updates. How can I solve

this problem?
° What is a Working Set? How do I build/compile a Working Set?
° How do I search within the Working Set?
° How do I manage the Working Sets?
° How can I can filter the projects listed in the CodeWarrior Projects view based on

Working Sets?
° How can I import/export a Working Set in the CodeWarrior eclipse IDE?
° What are Icon decorators?
° How do I enable or disable an icon decorator?
° Can the icon decorators be combined?
° When I open a large file in CodeWarrior IDE, an Editor Scalability dialog box

appears, listing the message, "You are opening a large file. Scalability mode has been
turned on for this editor to help improve performance by disabling features requiring
to parse the source file language." What does it mean?

° How do I configure the Scalability settings?
° What is Timing System?
° What are the features of freedom board FRDM-K20D50M?
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° What are the disadvantages of using printf() in the embedded system
programming?

° The OpenSDA connection is not available in the Connection page of the wizard.
What do I do?

° My bootloader resides in the first lower flash pages. How do I avoid it to get
destroyed and overwritten by the application?

° I am debugging FRDM-KL05Z with USBDM, but I received a  Failed to resume
target process., Downloading binary to target..  error message. What do I do?

° How does a bootloader work?
° How do I use printf() with the FRDM-KL25Z Board without using the Processor

Expert?
° How do I use Freedom board as SWD programmer?
° How do I use CMSIS-DAP with IAR on KL25Z Freedom Board?
° How do I set up criteria for bootloader to decide if it shall run the bootloader or

the application at the startup?
° How do I make sure that the bootloader gets linked only into its specified space?
° How do I make sure that application does not overlap with the FLASH area of the

bootloader?
° How do I load the Debug Application on my FRDM-K20D50M board?
° How do I install open source USBDM?
° How do I fix the 3.3V voltage drop on FRDM-KL25Z Board?
° How do I decode S19 Files?
° How do I bootload an application?
° How can I add my own code to be inserted as part of the system startup?
° For my bootloader I need a way to send a file with a terminal program. As my

serial connection has only Tx and Rx, but no RTSCTC lines for flow control, it is
useful if the terminal program either implements software flow control (XONXOFF),
or a delay value for sending a file. What do I do?

° Do I need to initialize my port pin?
° Can MCU10.4 recover a bricked OpenSDA Freedom Board?
° Can I program a different Freedom Board using Freedom board as SWD

programmer?
° What Bootloader Shell commands I can use?
° What is a bootloader?
° What is Bootloader Sequence?
° What is the code size required for the bootloader for FRDM-KL25Z board?
° Where can I find the software for my FRDM-K20D50M board?
° Which device should I use to create a new project for my FRDM-K20D50M

board using CodeWarrior?
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2.6.1 How can I improve the performance of the CodeWarrior IDE
I am working with?

Yes, you can improve the performance of your CodeWarrior IDE by disabling the
features that slow down the software.

1. Disable Indexer Options
a. From the CodeWarrior IDE menu bar, select Window > Preferences.

The Preferences dialog box appears.

b. Type index as the filter text to narrow down the list of preferences.
c. Select C/C++ > Indexer.

The Indexer page appears in the right panel of the Preferences dialog box.

d. Clear the Enable indexer checkbox.
2. Disable Scalability Mode Settings

a. In the Preferences dialog box, type scalability as the filter text.
b. Select C/C++ > Editor > Scalability.

The Scalability page appears in the right panel of the Preferences dialog box.

c. Clear the Enable all scalability mode options checkbox.
3. Disable Content Assist Auto Activation

a. In the Preferences dialog box, type content as the filter text.
b. Select C/C++ > Editor > Content Assist.

The Content Assist page appears in the right panel of the Preferences dialog
box.

c. Clear all checkboxes in the Auto-Activation section.
4. Click OK.

The performance of the CodeWarrior IDE improves.

2.6.2 What is the first thing that I see when I start the
CodeWarrior IDE?

The window that you see when you bring up the IDE is called a workbench. A
workbench consists of perspective, views, and editors. The term workbench refers to the
host development environment.
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2.6.3 What is a perspective?

A perspective is an arrangement of views and editors. You can quickly switch between
different perspectives.

2.6.4 How can I find the version of the CodeWarrior that I am
using?

To find the version of the CodeWarrior that you are using, follow these steps:

1. From the IDE menu bar, select the Help > About CodeWarrior Development
Studio option.

The About CodeWarrior Development Studio dialog box appears.

The dialog box that appears displays the version number and the build number under
Installed Products section.

2.6.5 Is it possible to retrieve a file that I deleted accidently from
my CodeWarrior project?

Yes, you can retrieve your deleted files. However, instead of the system s Recycle Bin
you need to retrieve the file from the local history. The local history maintains a copy of
files you modify or delete.

To restore a deleted file, you need to perform the following steps.

1. In the CodeWarrior Projects view, right-click the project branch you deleted the
file from.

2. From the context menu, select the Restore from Local History command.

The Restore from Local History dialog box appears.

NOTE
The dialog box contains a list of deleted files, along with a
checkbox for each file in the list.
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Figure 2-93. Restore from Local History Dialog Box
3. Check the files you want to restore from the local history.
4. Click the Restore button.

The selected files are restored.

2.6.6 I am using my workspace since long time and adding/
removing projects frequently, this has slowed down my
CodeWarrior software. How can I improve the
performance?

To improve the speed and performance of the CodeWarrior IDE:

1. Close all the unrequired/unrelated projects to improve the performance.
2. Export the workspace settings. To export the workspace settings:

a. Select File > Export from the IDE menu bar.

The Export dialog box appears.

b. Expand the General tree-control and select Preferences .
c. Click Next .

The Export Preferences dialog box appears.

d. Select the file to which want to save the preferences in the To preference file
combo-box.

e. Click Finish .

The current workspace settings are saved in the specified file.

3. Close the CodeWarrior IDE.

Miscellaneous

CodeWarrior Development Studio for Microcontrollers V10.x FAQ Guide, Rev. 10.6, 02/2014

108 Freescale Semiconductor, Inc.



4. Delete the .metadata folder from the workspace.
5. Open the CodeWarrior IDE with that workspace.
6. Import the previously exported workspace settings. To import the previous

workspace settings:
a. Select File > Import from the IDE menu bar.

The Import dialog box appears.

b. Expand the General tree-control and select Preferences .
c. Click Next .

The Import Preferences dialog box appears.

d. Select the file from which want to load the preferences in the From preference
file combo-box.

e. Click Finish .

The previous workspace settings are loaded from the specified file.

2.6.7 How do I update my local history settings?

To update the local history settings or preferences, perform the following steps.

1. From the IDE menu bar, select the Window > Preferences option.

The Preferences dialog box appears.

2. Expand the tree control to select the General > Workspace > Local History option.

The Local History page appears.
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Figure 2-94. Preferences Dialog Box - Local History Page
3. In the Days to keep files field, specify the number of days you want to maintain

changes in the local history. The default value is 7.

NOTE
History state older than the default value will be lost.

4. In the Maximum entries per file field, specify how many history states per file you
want to maintain in the local history. The default value is 50.

NOTE
If you exceed the default value, you will lose older history
to make room for new history.

5. In the Maximum file size (MB) field, specify the maximum size of individual states
in the history store. The default value is 1.

NOTE
If you exceed the default value, the individual states will
not be stored.

6. Click Apply to confirm and save the settings.
7. Click OK.

The Preferences dialog box closes.

The local history settings is updated.
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NOTE
To revert to the default settings, click the Restore Defaults
button in the Preferences dialog box.

2.6.8 Is there a way to filter the settings in the Preferences
window to find a particular setting?

Yes, you can filter settings using the filter text. For example, if you are looking for some
settings to change the color in a view, type color as the filter text in the Preferences
dialog box (refer to the image listed below). The preferences with text color in it are
listed. This reduces the number of preferences to browse through.

Figure 2-95. Filtered Preferences

You can clear the filter text using either the keyboard or the  X  icon.

You can also use wildcards in the filter text.
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° * - Substitutes for zero or more characters
° ? - Substitutes for any one character

For example, if you are looking for a device that has  J  in its name, however you are not
sure if it is a 16k or a 12k device, then you can search for the device using the wildcards
in filter text, refer the following figure.

Figure 2-96. Filtering Using Wildcards

2.6.9 How can I change a key binding?

To change a keyboard shortcut or a keyboard binding:

1. From the IDE menu bar, select Window > Preferences .

The Preferences dialog box appears.

2. Type filter text as key to narrow down the list of the preferences.

The modifications need to be done in the General > Editors > Keys preference
page.
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Figure 2-97. Preferences Dialog Box
3. Select General > Editors > Keys .

The Keys preferences page appears in the right panel of the Preferences dialog box.

Figure 2-98. Keys Preferences Page
4. From the Scheme drop-down list select the require scheme, such as Microsoft

Visual Studio or Emacs .
5. Type content assist as the filter text to filter the list of keys.
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Figure 2-99. Filtered List of Commands in Keys Preference Page
6. Select the entry you want to modify and type the new key binding, such as Ctrl+Alt

+C in the Binding text box. You can also assign multiple key bindings.
7. From the When drop-down list, select the context in which the key binding apply.
8. Click OK .

The Preferences dialog box closes.

The keyboard shortcut or the keyboard binding are modified, as specified.

2.6.10 Is it possible to view the change history of a source code
file?

Yes, you can view the history of the changes done in a source file by following the steps
given below:

1. Right-click the source file and select Compare With > History f rom the context
menu.
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The History view opens displaying the date and time when the changes were made
in the source file.

Figure 2-100. Compare With > History
2. Double-click the required revision time in the History view.

The editor area displays the comparison of different file revisions, and also highlights the
changes. You can determine the changes done in the source file by browsing through the
compared files.

Figure 2-101. Comparison of File Revisions
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2.6.11 How can I view a graphical representation of source code
in the CodeWarrior IDE using Dot and Doxygen?

You need to install doxygen, dot/Graphiz, and Eclox eclipse plugins from the following
locations respectively:

www.doxygen.org

www.graphviz.org

http://download.gna.org/eclox/update

While working with Dot+Doxygen, you can view graphical representation of the source
code. For example, if you have a state machine, describe the state machine (as shown in
the figure, State Machine Description listed below) in the source file.

Dot+Doxygen will then display the graphical representation of the state machine, as
shown in the figure Graphical Representation of State Machine listed below.

Figure 2-102. State Machine Description
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