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MSC8156EVM Software Installation Guide

This document explains how to:

• Obtain the install wizard for
CodeWarrior Development Studio for StarCore DSPs v10.1.5.

• Use the wizard to install this CodeWarrior product.
• Install the MSC8156EVM service pack.
• Update the SmartDSP OS MSC8156EVM Library Patch.

• Extend the software evaluation period.

1. Log into freescale.com.

a. Start a web browser.

Alternatively, click the URL below.

b. Go to this URL: www.codewarrior.com.

The CodeWarrior Development Tools page of freescale.com 
appears.

c. Click the Login link at the top of this page.

Login Link

The Log-in page appears.

SYSTEM REQUIREMENTS

Hardware Intel® Pentium® 4 processor, 2 GHz
2 GB RAM

Operating System Microsoft® Windows Vista® (SP2),
Home Basic, Home Premium, Business, 
Enterprise or Ultimate edition (32 or 64 bit)
or 
Windows® XP Professional (SP3),
Home or Professional edition (32 or 64 bit)

Free Disk Space 1.9 GB, plus space for projects

Section A: Obtaining the SC 10.1.5 Install Wizard 

www.codewarrior.com
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NOTE If you are not a registered member of freescale.com, click 
Register Now and follow the on-screen instructions to register.
You must be a registered member before you can download evaluation 
copies of software.

d. In the upper text box of the Existing Members area, enter your user ID 
(usually your email address).

e. In the lower text box, enter your password.

f. Click Log in.

You are logged in and your My Freescale page appears.

2. Download the install wizard to your PC.

a. From the menu bar at the top of the page, select 
Products > CodeWarrior Development Tools.

The CodeWarrior Development Tools page appears.

b. Click the Download button in the center of this page.

Download Button

The CodeWarrior Downloads page appears.

c. Click the Download Evaluation Versions link (on the left side of the page).

The Evaluation Software page appears.

d. In the table in the center of this page, click this link:
Evaluation: CodeWarrior for StarCore 10.1.5.

The Software Download Agreement page appears.

e. Please read this agreement.

f. Click I Accept.

The File Download dialog box appears.

g. Click Save.

The Save As dialog box appears.

h. Use this dialog box to select the directory on your PC in which to save the 
install wizard.
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i. Click Save.

Download of the install wizard (CW_SC_v10.1.5_b131.exe) begins.

The licensing system sends you an email explaining how to extend the 
product evaluation period.

j. When the Download Complete dialog box appears, click Close.

The install wizard is now in the specified directory of your PC.

NOTE CodeWarrior installation restrictions on
Microsoft Windows Vista and Microsoft Windows 7.

Administrator rights are required to install Eclipse-based CodeWarrior 
software on Windows Vista and Windows 7 systems, since the installer 
copies files into the System and Program Files folders.

The default CodeWarrior installation folder is 
C:\Program Files\Freescale\CW SC v10.1. To protect against 
malware, Windows Vista and Windows 7 do not allow normal 
processes to change files in the Program Files folder; therefore, 
you must have administrator rights to install and run CodeWarrior 
software to this location. If you intend to run this software with a non-
administrative user account, you must install the software in another 
folder (for example, in C:\Freescale\CW SC v10.1). 

In addition, your project workspace must be created in a folder to which 
you have full access rights.

1. Install CodeWarrior Development Studio for StarCore DSPs v10.1.5.

a. Start Windows Explorer.

b. Navigate to the directory in which you saved the install wizard 
(CW_SC_v10.1.5_b131.exe).

c. Double-click on this file name.

The Open File — Security Warning dialog box appears.

d. Click Run.

The first page of the install wizard appears.

Section B: Installing the Software
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Install Wizard—First Page

e. Follow the wizard’s on-screen instructions to install the 
CodeWarrior software 

When installation completes, the wizard’s last page appears.

Install Wizard—Last Page

f. Uncheck the Check for program updates after setup completes box.

g. Check the Display Start Here page box.
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h. Click Finish.

The wizard closes. 

A browser starts and displays the CodeWarrior Documentation 
Overview page. This page contains tabs that group the CodeWarrior 
documentation into categories.

CodeWarrior Documentation Overview Page

2. Browse the CodeWarrior documentation.

a. Click any tab in the CodeWarrior Documentation Overview page.

A page appears that lists and briefly describes each document in the 
chosen category.

b. To read a document listed in the selected page, click the document’s link.

c. When finished, exit the browser.

You have successfully installed CodeWarrior Development Studio for 
StarCore DSPs v10.1.5.

1. Add the software site that hosts the MSC8156EVM service pack to 
your preferences.

a. From the Start menu, select Start > Programs > 
Freescale CodeWarrior > CW for StarCore v10.1.5 > CodeWarrior.

The Workspace Launcher dialog box appears.

b. Click OK.

The IDE displays its workbench window.

NOTE If the Welcome view appears on top of the workbench window, click 
the X in the tab at the top-left of this view to close it.

Section C: Installing the MSC8156EVM Service Pack
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c. From the IDE menu bar, select Window > Preferences.

The Preferences dialog box appears.

d. From the tree control on the left of this dialog box, select 
Install/Update > Available Software Sites.

The Available Software Sites preference panel appears on the right side 
of the Preferences dialog box.

Available Software Sites Preference Panel

e. Click Add.

The Add Site dialog box appears.

Add Site Dialog Box

f. In the Name text box, enter Freescale.

g. In the Location text box, enter (or copy-and-paste) this URL:
http://freescale.com/lgfiles/updates/Eclipse/SC/
com.freescale.sc.updatesite 

h. Click OK.

The Add Site dialog box closes and the specified software site is added 
to the software sites list box.

i. In this list box, select the site just added.
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j. Click Test Connection.

The connection between the IDE and the selected software site is tested 
and a message box stating the results appears.

NOTE If this message box says the Freescale software site is not available, 
please contact Freescale support.

k. Click OK.

The message box closes.

l. Click OK. 

The Preferences dialog box closes.

2. Install the MSC8156EVM service pack.

a. From the IDE menu bar, select Help > Install New Software.

The Available Software page of the install wizard appears.

Available Software Page

b. From the Work with dropdown menu, select the Freescale software site 
set up previously.

The list of software available on the Freescale software site appears in the 
list box below the dropdown menu.

c. Check the Group items by category box.

The list box organizes the available software by category.

d. In the CW StarCore v10.1.5 Service Pack category, check the 
CW SC 10.1.5 Service Pack for MSC8156EVM Board box.
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e. Click Next.

The Install Details page of the install wizard appears.

Install Details Page

f. From the list box, select the item named
CW SC 10.1.5 Service Pack for MSC8156EVM Board.

g. Click Finish.

The Install dialog box appears and displays the progress of the 
software installation.

h. When the Security Warning dialog box appears, click OK.

The installation continues. When installation completes, a dialog box 
prompting you to restart the CodeWarrior IDE appears.

i. Click Yes.

The IDE closes and redisplays the Workspace Launcher dialog box. 

j. Click OK.

The IDE displays the workbench window.

You have successfully installed the MSC8156EVM service pack.

NOTE For users who plan to use SmartDSP OS with the 
MSC8156EVM board, please follow the instructions in 
section D to update the SmartDSP OS part of the service pack.
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1. Start the CodeWarrior IDE.

a. From the Start menu, select Start > Programs > 
Freescale CodeWarrior > CW for StarCore v10.1.5 > CodeWarrior.

The Workspace Launcher dialog box appears.

b. Click OK.

The IDE displays its workbench window.

2. Import the SmartDSP OS MSC8156EVM support project.

a. Select File > Import.

The Import dialog box appears.

b. In this dialog box, expand the General group.

c. From this group, select Existing Projects into Workspace.

d. Click Next.

The Import Projects page appears.

e. In this page, choose Select root directory.

f. Click Browse.

The Browse for Folder dialog box appears.

g. Use this dialog box to navigate to this folder:
installDir\SC\StarCore_Support\
SmartDSP\Demos\starcore\msc815x\evm_support 

where installDir stands for the path in which you installed 
CodeWarrior Development Studio for StarCore DSPs v10.1.5.

h. Click OK.

The dialog box closes, and the bsp_8156evm project appears in the 
list box in the center of the Import Projects wizard page.

Section D: Updating the SmartDSP OS MSC8156EVM 
Library Patch
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Import Wizard—Import Projects Page

i. Click Finish.

The bsp_8156evm project is imported into your workspace and appears in 
the CodeWarrior Projects view.

CodeWarrior Projects View—bsp_8156evm Project

3. Build the SmartDSP OS MSC8156EVM support project. 

a. In the CodeWarrior Projects view, right-click on the 
bsp_8156evm project.

b. From the context menu that appears, select
Build Configurations > Set Active > bsp_8156_evm.

The bsp_8156_evm build configuration becomes the project’s active 
build configuration.
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Context Menu: Build Configurations > Set Active 

c. Again, right-click on the bsp_8156evm project.

d. From the context menu that appears, select Project > Clean. 

All project build problems and build states are discarded.

e. Again, right-click on the bsp_8156evm project.

f. From the context menu that appears, select Build Project.

The project builds according to settings in the bsp_8156_evm 
build configuration.

g. Again, right-click on the bsp_8156evm project.

h. From the context menu that appears, select
Build Configurations > Set Active > bsp_8156_evm_debug.

The bsp_8156_evm_debug build configuration becomes the project’s 
active build configuration.

i. Again, right-click on the bsp_8156evm project.

j. From the context menu that appears, select Project > Clean.

All project build problems and build states are discarded.

k. Again, right-click on the bsp_8156evm project.

l. From the context menu that appears, select Build Project.

The project builds according to settings in the bsp_8156_evm_debug 
build configuration.

You have successfully built SmartDSP OS for the MSC8156EVM board.
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After 60 days, your evaluation license expires. You can extend this license 
up to two times. To extend your evaluation license, follow these steps:

1. Log into freescale.com.

a. Start a web browser. Alternatively, click the URL below.

b. Go to this URL: www.codewarrior.com.

The CodeWarrior Development Tools page of freescale.com 
appears.

c. Click the Login link at the top of this page.

The Log-in page appears.

d. In the upper text box of the Existing Members area, enter your user ID 
(usually your email address).

e. In the lower text box, enter your password.

f. Click Log in.

You are logged in and your My Freescale page appears.

2. Obtain a new evaluation license.

a. Click the CodeWarrior Licensing link (on the bottom-right of the page).

A page displaying a list of the CodeWarrior products you have registered 
or are evaluating appears.

b. In the Downloaded Evaluations section of this page, find the row with 
the text Evaluation: CodeWarrior for StarCore 10.1.5 in the 
Description column.

c. In this row, click the Extend Evaluation link.

Extend Evaluation Link

The Manage License page appears.

d. Follow the on-screen instructions to obtain and install a new 
evaluation license.

You have now extended the product evaluation period.

Section E: Extending the Product Evaluation Period

www.codewarrior.com
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How to Contact Us

Corporate 
Headquarters

Freescale Semiconductor, Inc.
6501 William Cannon Drive West
Austin, Texas 78735
U.S.A.

World Wide Web http://www.freescale.com/codewarrior

Technical Support http://www.freescale.com/support
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