S32K116 EVB
QUICK START GUIDE

APPLIES FOR: S32K116 EVB (SCH_30003 REV B)
Contents:

• Get to Know S32K116 EVB
• Out of the Box Setup
• Introduction to OpenSDA
• Creating a new S32DS project for S32K116:
  - Download
  - Create a project
  - Create a project from SDK example
• S32DS Debug basics
• Create a P&E debug configuration
Get to know S32K116-EVB

- CAN Communication Bus
- LIN Communication Bus
- OpenSDA USB
- OpenSDA MCU
- Reset Button
- J2 Header
- J1 Header
- J14 SWD connector
- J3 Header
- J4 Header
- Touch electrodes
- SBC UJA1169
- Transceiver TJA1027T
- OpenSDA JTAG
- S32K116 MCU
- RGB LED
- Potentiometer
- User Buttons
- External Power Supply (5-12V)
S32K116 EVB Features:

- Supports **48LQFP and 32QFN** packages
- Small form factor size 4.5" x 2.3"
- Arduino™ UNO footprint-compatible with expansion “shield” support
- Integrated open-standard serial and debug adapter (OpenSDA) with support for several industry-standard debug interfaces
- Easy access to the MCU I/O header pins for prototyping
- On-chip connectivity for CAN, LIN, UART/SCI.
- SBC UJA1169 and LIN phy TJA1027
- Potentiometer for precise voltage and analog measurement
- RGB LED
- Two push-button switches (SW2 and SW3) and two touch electrodes
- Flexible power supply options
  - microUSB
  - external 12V power supply
# Header/Pinout Mapping for S32K116

## Arduino compatible pins
- J3-02 PTB0 GPIO
- J3-04 PTB1 GPIO
- J3-06 PTB6 GPIO
- J3-08 PTB7 GPIO
- J3-10 PTE4 GPIO
- J3-12 PTE5 GPIO
- J3-14 PTA11 GPIO
- J3-16 PTD3 GPIO

## NXP pins
- J3-01 - VDD
- J3-03 - VDD_PERH
- J3-05 PTA5 RESET
- J3-07 - 3.3V
- J3-09 - 5V
- J3-11 - GND
- J3-13 - GND
- J3-15 - VBAT

### J1
- J1-01 PTA2 LPUART0_RX
- J1-02 PTA3 LPUART0_TX
- J1-03 PTA13 FTM1_CH7
- J1-04 PTA12 FTM1_CH6
- J1-05 PTD0 FTM0_CH2
- J1-06 PTD1 FTM0_CH3
- J1-07 PTD2 FXIO_D4
- J1-08 PTE9 FTM0_CH7

### J2
- J2-01 PTC2 FTM0_CH2
- J2-02 PTC3 FTM0_CH3
- J2-03 PTB5 LPSPI0_PCS
- J2-04 PTD4 LPSPI0_SOUT
- J2-05 PTB3 LPSPI0_SIN
- J2-06 PTD2 LPSPI0_SCK
- J2-07 - GND
- J2-08 - AREF
- J2-09 PTA1 LPI2C0_SDA
- J2-10 PTA0 LPI2C0_SCL

### J3
- J3-02 PTB0 GPIO
- J3-04 PTB1 GPIO
- J3-06 PTB6 GPIO
- J3-08 PTB7 GPIO
- J3-10 PTE4 GPIO
- J3-12 PTE5 GPIO
- J3-14 PTA11 GPIO
- J3-16 PTD3 GPIO

### J4
- J4-01 PTA7 ADC0_SE3
- J4-03 PTC8 GPIO
- J4-05 PTC1 ADC0_SE9
- J4-07 PTC14 ADC0_SE12
- J4-09 PTC15 ADC0_SE13
- J4-11 PTC16 ADC0_SE14
- J4-13 PTC9 GPIO
- J4-15 PTB13 GPIO

*0ohm resistor is not connected*
## Jumper Settings

<table>
<thead>
<tr>
<th>Jumper</th>
<th>Configuration</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>J104</td>
<td>1-2</td>
<td>Reset signal to OpenSDA, use to enter into OpenSDA Bootloader mode</td>
</tr>
<tr>
<td></td>
<td>2-3 (Default)</td>
<td>Reset signal direct to the MCU, use to reset S32K116.</td>
</tr>
<tr>
<td>J107</td>
<td>1-2 (Default)</td>
<td>S32K116 powered by 12V power source.</td>
</tr>
<tr>
<td></td>
<td>2-3</td>
<td>S32K116 powered by USB micro connector.</td>
</tr>
<tr>
<td>J10</td>
<td>2-3 (Default)</td>
<td>MCU voltage 5v</td>
</tr>
<tr>
<td></td>
<td>1-2</td>
<td>MCU voltage 3.3v</td>
</tr>
<tr>
<td>J108</td>
<td>1-2 (Default)</td>
<td>Select LIN master option</td>
</tr>
<tr>
<td>J15</td>
<td>1-2 (Default)</td>
<td>Used for current measurement</td>
</tr>
</tbody>
</table>
### HMI mapping

<table>
<thead>
<tr>
<th>Component</th>
<th>S32K116</th>
</tr>
</thead>
<tbody>
<tr>
<td>Red LED</td>
<td>PTD16 (FTM0 CH1)</td>
</tr>
<tr>
<td>Blue LED</td>
<td>PTE8 (FTM0 CH6)</td>
</tr>
<tr>
<td>Green LED</td>
<td>PTD15 (FTM0 CH0)</td>
</tr>
<tr>
<td>Potentiometer</td>
<td>PTA7 (ADC0_SE3)</td>
</tr>
<tr>
<td>SW2</td>
<td>PTD3</td>
</tr>
<tr>
<td>SW3</td>
<td>PTD5</td>
</tr>
<tr>
<td>OpenSDA UART TX</td>
<td>PTB1 (LPUART0_TX)</td>
</tr>
<tr>
<td>OpenSDA UART RX</td>
<td>PTB0 (LPUART0_RX)</td>
</tr>
<tr>
<td>CAN TX</td>
<td>PTE5 (CAN0_TX)</td>
</tr>
<tr>
<td>CAN RX</td>
<td>PTE4 (CAN0_RX)</td>
</tr>
<tr>
<td>LIN TX</td>
<td>PTC7 (LPUART1_TX)</td>
</tr>
<tr>
<td>LIN RX</td>
<td>PTC6 (LPUART1_RX)</td>
</tr>
<tr>
<td>SBC_SCK</td>
<td>PTB2 (LPSPI0_SCK)</td>
</tr>
<tr>
<td>SBC_MISO</td>
<td>PTB3 (LPSPI0_SIN)</td>
</tr>
<tr>
<td>SBC_MOSI</td>
<td>PTB4 (LPSPI0_SOUT)</td>
</tr>
<tr>
<td>SBC_CS</td>
<td>PTB5 (LPSPI0_PCS1)</td>
</tr>
</tbody>
</table>
S32K116 EVB
OUT OF THE BOX
Step 1: Power up the Board – EVB Power Supplies

- The S32K116-EVB evaluation board powers from a USB or external 12V power supply. By default 12V power is enabled with J107 (check slide 5)

- Connect the USB cable to a PC using supplied USB cable.

- Connect other end of USB cable (microUSB) to mini-B port on S32K116-EVB at J7

- Allow the PC to automatically configure the USB drivers if needed

- Debug is done using OpenSDA through J7
Step 2: Power up the Board – Is it powered on correctly?

- When powered through USB, LEDs D2 and D3 should light green
- Once the board is recognized, it should appear as a mass storage device in your PC with the name S32K116EVB.

![Image of device identification](image-url)
Step 3: Power up the Board – Is it powered on correctly?

• Board is preloaded with a software, in which the red, blue and green leds will toggle at different rates.
S32K116 JUMPSTART EXPERIENCE BASED ON THE FREEMASTER TOOL
Install the FreeMASTER tool

- Download and install the FreeMASTER PC application [www.nxp.com/FreeMASTER](http://www.nxp.com/FreeMASTER).
- Open the FreeMASTER application on your PC. You should see the Welcome page:
Power up the EVB board

- Powers the S32K116EVB evaluation board from a USB. By default, the USB power is enabled by J07 jumper.
- Connect the USB cable to a PC and connect micro USB connector of the USB cable to micro-B port J7 on the S32K116EVB.
- Allow the PC to automatically configure the USB drivers if needed.
- When EVB is powered from USB, LEDs D2 and D3 should light green.
- The EVB board is preloaded with a software toggling the RGB LED colors periodically between RED-GREEN-BLUE.
Setup serial connection in the FreeMASTER tool

Setup communication port to "OpenSDA" and speed to 115200 b/s:

- Setup communication manually:
  Go to: "Project > Options > Comm"

  OR

- Setup communication automatically:
  Go to "Tools > Connection Wizard"
The FreeMASTER JumpStart project is loaded
The FreeMASTER JumpStart project description

Pins of the J2 and J1 connectors are configured as outputs. By single click on each pin you can change their logical level to log0 or log1. User can connect e.g. LED diodes to these output pins.

Pins of the J3 and J4 connectors are configured as inputs. Logical level (log0/log1) is visualised for all connector pins. User can connect e.g. push-button keyboard to these input pins.

Links to S32K1xx docs:
- Fact Sheet
- Data Sheet
- Reference Manual
- Product Brief
- S32K116EVB schematic
- S32K116EVB Quick Start Guide

Tools:
- FreeMASTER
- S32 Design Studio IDE
- S32K116EVB JumpStart source files
The FreeMASTER JumpStart oscilloscope feature examples

- Display main project panel “View > Project Tree“.

- Display real-time oscilloscope graph examples such as „Potentiometer“ or „Touch Sense Electrodes“.

Analog values from potentiometer. Responses from touch sense electrodes.
INTRODUCTION TO OPENDSA
Introduction to OpenSDA: 1 of 2

OpenSDA is an open-standard serial and debug adapter. It bridges serial and debug communications between a USB host and an embedded target processor. OpenSDA software includes a flash-resident USB mass-storage device (MSD) bootloader and a collection of OpenSDA Applications. S32K116 EVB comes with the MSD Flash Programmer OpenSDA Application preinstalled. Follow these instructions to run the OpenSDA Bootloader and update or change the installed OpenSDA Application.

Enter OpenSDA Bootloader Mode

1. Unplug the USB cable if attached
2. Set J104 on position 1-2.
3. Press and hold the Reset button (SW5)
4. Plug in a USB cable (not included) between a USB host and the OpenSDA USB connector (labeled “SDA”)
5. Release the Reset button

A removable drive should now be visible in the host file system with a volume label of BOOTLOADER. You are now in OpenSDA Bootloader mode.

IMPORTANT NOTE: Follow the “Load an OpenSDA Application” instructions to update the MSD Flash Programmer on your S32K116 EVB to the latest version.

Load an OpenSDA Application

1. While in OpenSDA Bootloader mode, double-click SDA_INFO.HTML in the BOOTLOADER drive. A web browser will open the OpenSDA homepage containing the name and version of the installed Application. This information can also be read as text directly from SDA_INFO.HTML
2. Locate the OpenSDA Applications
3. Copy & paste or drag & drop the MSD Flash Programmer Application to the BOOTLOADER drive
4. Unplug the USB cable and plug it in again. The new OpenSDA Application should now be running and a S32K116 EVB drive should be visible in the host file system

You are now running the latest version of the MSD Flash Programmer. Use this same procedure to load other OpenSDA Applications.
Introduction to OpenSDA: 2 of 2

The MSD Flash Programmer is a composite USB application that provides a virtual serial port and an easy and convenient way to program applications into the S32K116 MCU. It emulates a FAT file system, appearing as a removable drive in the host file system with a volume label of S32K116EVB. Raw binary and Motorola S-record files that are copied to the drive are programmed directly into the flash of the S32K116 and executed automatically. The virtual serial port enumerates as a standard serial port device that can be opened with standard serial terminal applications.

Using the MSD Flash Programmer
1. Locate the .srec file of your project, file is under the Debug folder of the S32DS project.
2. Copy & paste or drag & drop one of the .srec files to the S32K116EVB drive

The new application should now be running on the S32K116 EVB. Starting with v1.03 of the MSD Flash Programmer, you can program repeatedly without the need to unplug and reattach the USB cable before reprogramming.

Drag one of the .srec code for the S32K116 EVB board over USB to reprogram the preloaded code example to another example.

NOTE: Flash programming with the MSD Flash Programmer is currently only supported on Windows operating systems. However, the virtual serial port has been successfully tested on Windows, Linux and Mac operating systems.

Using the Virtual Serial Port
1. Determine the symbolic name assigned to the S32K116EVB virtual serial port. In Windows open Device Manager and look for the COM port named “PEMicro/Freescale – CDC Serial Port”.
2. Open the serial terminal emulation program of your choice. Examples for Windows include Tera Term, PuTTY, and HyperTerminal
3. Press and release the Reset button (SW5) at anytime to restart the example application. Resetting the embedded application will not affect the connection of the virtual serial port to the terminal program.
4. It is possible to debug and communicate with the serial port at the same time, no need to stop the debug.

NOTE: Refer to the OpenSDA User’s Guide for a description of a known Windows issue when disconnecting a virtual serial port while the COM port is in use.
INSTALLING S32DS
Download S32DS

Download S32DS from:

S32DS for ARM
CREATE A NEW PROJECT IN S32 DESIGN STUDIO
Create New Project: First Time – Select a Workspace

- Start program: Click on “S32 Design Studio for ARM v2.0” icon
- Select workspace:
  - Choose default (see below example) or specify new one
  - Suggestion: Uncheck the box “Use this as the default and do not ask again”
  - Click OK
Create New Project: Top Menu Selection

- File – New – Project
Create New Project: S32DS Project

• Project Name:
  - Example: FirstProject

• Project Type:
  - Select from inside executable or library folder

• Next
Create New Project: S32DS Project

- Select Debugger Support and Library Support
- Click Finish
OpenSDA Configuration

• To Debug your project with OpenSDA, it is necessary to select the OpenSDA in the Debug Configuration.

• Select your project, and click on debug configuration
OpenSDA Configuration

- Select the Debug configuration under GDB PE Micro Interface Debugging
- Click on Debugger tab
OpenSDA Configuration

- Select OpenSDA as the interface, if your board is plugged should appear in the Port field.
- Click Apply and debug to finish.
DEBUG BASICS
Debug Basics: Starting the Debugger

- Debug configuration is only required once. Subsequent starting of debugger does not require those steps.
- Three options to start debugger:
  - If the “Debug Configuration” has not been closed, click on “Debug” button on bottom right
  - Select Run – Debug (or hit F11)

  Note: This method currently selects the desktop target (project.elf) and gives an error. Do not use until this is changed.
  - **Recommended Method**: Click on pull down arrow for bug icon and select …_debug.elf target
Debug Basics: Step, Run, Suspend, Resume

• Step Into (F5)

• Step Over (F6)

• Step Return (F7)

• Run

• Suspend

• Resume (F8)
Debug Basics: View & Alter Variables

- View variables in “Variables” tab.
- Click on a value to allow typing in a different value.
Debug Basics: View & Alter Registers

- View CPU registers in the “Registers” tab
- Click on a value to allow typing in a different value
- View peripheral registers in the EmbSys Registers tab
Debug Basics: View & Alter Memory

• Add Memory Monitor

• Select Base Address to Start at: 0x20000000

• View Memory
Debug Basics: Breakpoints

Add Breakpoint: Point and Click

- light blue dot represents debugger breakpoint
Debug Basics: Reset & Terminate Debug Session

• Reset program counter

• Terminate Ctl+F2()
CREATE A P&E DEBUG CONFIGURATION (OPTIONAL)
New P&E debug configuration

• Click in debug configurations
New P&E debug configuration

- Create a new P&E launch configuration

Click on the debugger tab.

Click to create a new P&E launch
New P&E debug configuration

- Select the device

Select device

- Click Apply and debug your application
USEFUL LINKS
Useful Links

• **Cookbook application note.** This application note contains a bunch of simple examples of how to use different peripherals.

• **S32K1xx community.** Visit this site for request support on the S32K1xx products, you can also look for threads that may contain the answer that you are looking for.