Contents

Chapter 1 Library................................................................................................... 4
  1.1 Introduction........................................................................................................ 4
    1.1.1 Overview....................................................................................................... 4
    1.1.2 Data types..................................................................................................... 4
    1.1.3 API definition............................................................................................... 4
    1.1.4 Supported compilers.................................................................................... 5
    1.1.5 Library configuration................................................................................... 5
    1.1.6 Special issues............................................................................................... 5
  1.2 Library integration into project (MCUXpresso IDE) ........................................... 5
  1.3 Library integration into project (Keil µVision) ................................................... 9
  1.4 Library integration into project (IAR Embedded Workbench).............................. 17

Chapter 2 Algorithms in detail.............................................................................. 23
  2.1 PCLIB_Ctrl2P2Z................................................................................................... 23
    2.1.1 Available versions.......................................................................................... 23
    2.1.2 PCLIB_CTRL_2P2Z_T_F16............................................................................. 24
    2.1.3 Declaration..................................................................................................... 24
    2.1.4 Function use.................................................................................................. 24
  2.2 PCLIB_Ctrl3P3Z................................................................................................... 25
    2.2.1 Available versions.......................................................................................... 26
    2.2.2 PCLIB_CTRL_3P3Z_T_F16............................................................................. 26
    2.2.3 Declaration..................................................................................................... 27
    2.2.4 Function use.................................................................................................. 27
  2.3 PCLIB_CtrlPI........................................................................................................ 28
    2.3.1 Available versions.......................................................................................... 28
    2.3.2 PCLIB_CTRL_PI_T_F16............................................................................... 29
    2.3.3 Declaration..................................................................................................... 29
    2.3.4 Function use.................................................................................................. 30
  2.4 PCLIB_CtrlPIandLPFilter................................................................................... 30
    2.4.1 Available versions.......................................................................................... 31
    2.4.2 PCLIB_CTRL_PI_LP_T_F16.......................................................................... 31
    2.4.3 Declaration..................................................................................................... 32
    2.4.4 Function use.................................................................................................. 32
  2.5 PCLIB_CtrlPID...................................................................................................... 33
    2.5.1 Available versions.......................................................................................... 34
    2.5.2 PCLIB_CTRL_PID_T_F16.............................................................................. 34
    2.5.3 Declaration..................................................................................................... 35
    2.5.4 Function use.................................................................................................. 35

Appendix A Library types....................................................................................... 36
  A.1 bool_t.................................................................................................................. 36
  A.2 uint8_t................................................................................................................. 36
  A.3 uint16_t.............................................................................................................. 37
  A.4 uint32_t.............................................................................................................. 38
  A.5 int8_t.................................................................................................................. 38
  A.6 int16_t................................................................................................................. 39
  A.7 int32_t.................................................................................................................. 39
Chapter 1
Library

1.1 Introduction

1.1.1 Overview

This user's guide describes the Power Control Library (PCLIB) for the family of ARM Cortex M33 core-based microcontrollers. This library contains optimized functions.

1.1.2 Data types

PCLIB supports several data types: (un)signed integer, fractional, and accumulator. The integer data types are useful for general-purpose computation; they are familiar to the MPU and MCU programmers. The fractional data types enable powerful numeric and digital-signal-processing algorithms to be implemented. The accumulator data type is a combination of both; that means it has the integer and fractional portions.

The following list shows the integer types defined in the libraries:

- **Unsigned 16-bit integer**—<0 ; 65535> with the minimum resolution of 1
- **Signed 16-bit integer**—<-32768 ; 32767> with the minimum resolution of 1
- **Unsigned 32-bit integer**—<0 ; 4294967295> with the minimum resolution of 1
- **Signed 32-bit integer**—<-2147483648 ; 2147483647> with the minimum resolution of 1

The following list shows the fractional types defined in the libraries:

- **Fixed-point 16-bit fractional**—<-1 ; 1 - 2⁻¹⁵> with the minimum resolution of 2⁻¹⁵
- **Fixed-point 32-bit fractional**—<-1 ; 1 - 2⁻³¹> with the minimum resolution of 2⁻³¹

The following list shows the accumulator types defined in the libraries:

- **Fixed-point 16-bit accumulator**—<-256.0 ; 256.0 - 2⁻⁷> with the minimum resolution of 2⁻⁷
- **Fixed-point 32-bit accumulator**—<-65536.0 ; 65536.0 - 2⁻¹⁵> with the minimum resolution of 2⁻¹⁵

1.1.3 API definition

PCLIB uses the types mentioned in the previous section. To enable simple usage of the algorithms, their names use set prefixes and postfixes to distinguish the functions' versions. See the following example:

```c
f32Result = MLIB_Mac_F32lss(f32Accum, f16Mult1, f16Mult2);
```

where the function is compiled from four parts:

- **MLIB**—this is the library prefix
- **Mac**—the function name—Multiply-Accumulate
- **F32**—the function output type
- **lss**—the types of the function inputs; if all the inputs have the same type as the output, the inputs are not marked

The input and output types are described in the following table:
Table 1. Input/output types

<table>
<thead>
<tr>
<th>Type</th>
<th>Output</th>
<th>Input</th>
</tr>
</thead>
<tbody>
<tr>
<td>frac16_t</td>
<td>F16</td>
<td>s</td>
</tr>
<tr>
<td>frac32_t</td>
<td>F32</td>
<td>l</td>
</tr>
<tr>
<td>acc32_t</td>
<td>A32</td>
<td>a</td>
</tr>
</tbody>
</table>

1.1.4 Supported compilers
PCLIB for the ARM Cortex M33 core is written in C language or assembly language with C-callable interface depending on the specific function. The library is built and tested using the following compilers:

- MCUXpresso IDE
- IAR Embedded Workbench
- Keil µVision

For the MCUXpresso IDE, the library is delivered in the `pplib.a` file.

For the Kinetis Design Studio, the library is delivered in the `pplib.a` file.

For the IAR Embedded Workbench, the library is delivered in the `pplib.a` file.

For the Keil µVision, the library is delivered in the `pplib.lib` file.

The interfaces to the algorithms included in this library are combined into a single public interface include file, `pplib.h`. This is done to lower the number of files required to be included in your application.

1.1.5 Library configuration
PCLIB for the ARM Cortex M33 core is written in C language or assembly language with C-callable interface depending on the specific function. Some functions from this library are inline type, which are compiled together with project using this library. The optimization level for inline function is usually defined by the specific compiler setting. It can cause an issue especially when high optimization level is set. Therefore the optimization level for all inline assembly written functions is defined by compiler pragmas using macros. The configuration header file `RTCESL_cfg.h` is located in: `specific library folder\MLIB\Include`. The optimization level can be changed by modifying the macro value for specific compiler. In case of any change the library functionality is not guaranteed.

Similarly as optimization level the PowerQuad DSP Coprocessor and Accelerator support can be disable or enable if it has not been done by defined symbol `RTCESL_PQ_ON` or `RTCESL_PQ_OFF` in project setting described in the PowerQuad DSP Coprocessor and Accelerator support cheaper for specific compiler.

1.1.6 Special issues
1. The equations describing the algorithms are symbolic. If there is positive 1, the number is the closest number to 1 that the resolution of the used fractional type allows. If there are maximum or minimum values mentioned, check the range allowed by the type of the particular function version.

2. The library functions that round the result (the API contains `Rnd`) round to nearest (half up).

3. This RTCESL requires the DSP extension for some saturation functions. If the core does not support the DSP extension feature the assembler code of the RTCESL will not be buildable. For example the core1 of the LPC55s69 has no DSP extension.

1.2 Library integration into project (MCUXpresso IDE)

This section provides a step-by-step guide on how to quickly and easily include PCLIB into any MCUXpresso SDK example or new SDK project using MCUXpresso IDE. The SDK based project uses RTCESL from SDK package.
PowerQuad DSP Coprocessor and Accelerator support

Some LPC platforms (LPC55S6x) contain a hardware accelerator dedicated to common calculations in DSP applications. This section shows how to turn the PowerQuad (PQ) support for a function on and off.

1. In the MCUXpresso SDK project name node or in the left-hand part, click Properties or select Project > Properties from the menu. A project properties dialog appears.

2. Expand the C/C++ Build node and select Settings. See Figure 1.

3. On the right-hand side, under the MCU C Compiler node, click the Preprocessor node. See Figure 1.

4. In the right-hand part of the dialog, click the Add... icon located next to the Defined symbols (-D) title.

5. In the dialog that appears (see Figure 2), type the following:
   - RTCESL_PQ_ON—to turn the PowerQuad support on
   - RTCESL_PQ_OFF—to turn the PowerQuad support off

If neither of these two defines is defined, the hardware division and square root support is turned off by default.

6. Click OK in the dialog.

7. Click OK in the main dialog.
8. Ensure the PowerQuad module to be clocked by calling function RTCESL_PQ_Init(); prior to the first function using PQ module calling.

See the device reference manual to verify whether the device contains the PowerQuad DSP Coprocessor and Accelerator support.

Adding RTCESL component to project

The MCUXpresso SDK package is necessary to add any example or new project and RTCESL component. In case the package has not been downloaded go to mcuxpresso.nxp.com, build the final MCUXpresso SDK package for required board and download it.

After package is downloaded, open the MCUXpresso IDE and drag&drop the SDK package in zip format to the Installed SDK window of the MCUXpresso IDE. After SDK package is dropped the message accepting window appears as can be show in following figure.

![Figure 3. MCUXpresso IDE - importing the SDK package to MCUXpresso IDE](image)

Click OK to confirm the SDK package import. Find the Quickstart panel in left bottom part of the MCUXpresso IDE and click New project... item or Import SDK example(s)... to add rtcesl component to the project.
Then select your board, and click Next button.

Find the Middleware tab in the Components part of the window and click on the checkbox to be the rtcesl component ticked. Last step is to click the Finish button and wait for project creating with all RTCESL libraries and include paths.
Type the `#include` syntax into the code where you want to call the library functions. In the left-hand dialog, open the required `.c` file. After the file opens, include the following lines into the `#include` section:

```c
#include "mlib.h"
#include "pclib.h"
```

When you click the Build icon (hammer), the project is compiled without errors.

### 1.3 Library integration into project (Keil µVision)

This section provides a step-by-step guide on how to quickly and easily include PCLIB into an empty project or any MCUXpresso SDK example or demo application projects using Keil µVision. This example uses the default installation path (`C:\NXP\RTCESL\CM33_RTCESL_4.7_KEIL`). If you have a different installation path, use that path instead. If any MCUXpresso SDK project is intended to use (for example hello_world project) go to Linking the files into the project chapter otherwise read next chapter.

#### NXP pack installation for new project (without MCUXpresso SDK)

This example uses the NXP LPC55s69 part, and the default installation path (`C:\NXP\RTCESL\CM33_RTCESL_4.7_KEIL`) is supposed. If the compiler has never been used to create any NXP MCU-based projects before, check whether the NXP MCU pack for the particular device is installed. Follow these steps:

1. Launch Keil µVision.
2. In the main menu, go to Project > Manage > Pack Installer….
3. In the left-hand dialog (under the Devices tab), expand the All Devices > Freescale (NXP) node.
4. Look for a line called "KVxx Series" and click it.
5. In the right-hand dialog (under the Packs tab), expand the Device Specific node.
6. Look for a node called "Keil::Kinetis_KVxx_DFP." If there are the Install or Update options, click the button to install/update the package. See Figure 7.

7. When installed, the button has the "Up to date" title. Now close the Pack Installer.

![Figure 7. Pack Installer](image)

**New project (without MCUExpresso SDK)**

To start working on an application, create a new project. If the project already exists and is opened, skip to the next section. Follow these steps to create a new project:

1. Launch Keil µVision.
2. In the main menu, select Project > New µVision Project…, and the Create New Project dialog appears.
3. Navigate to the folder where you want to create the project, for example C:\KeilProjects\MyProject01. Type the name of the project, for example MyProject01. Click Save. See Figure 8.

![Figure 8. Create New Project dialog](image)

4. In the next dialog, select the Software Packs in the very first box.
5. Type " into the Search box, so that the device list is reduced to the devices.
6. Expand the node.
7. Click the LPC55s69 node, and then click OK. See Figure 9.
8. In the next dialog, expand the Device node, and tick the box next to the Startup node. See Figure 10.

9. Expand the CMSIS node, and tick the box next to the CORE node.

10. Click OK, and a new project is created. The new project is now visible in the left-hand part of Keil µVision. See Figure 11.
11. In the main menu, go to Project > Options for Target 'Target1'…, and a dialog appears.
12. Select the Target tab.
13. Select Not Used in the Floating Point Hardware option. See Figure 11.

PowerQuad DSP Coprocessor and Accelerator support

Some LPC platforms (LPC55S6x) contain a hardware accelerator dedicated to common calculations in DSP applications. This section shows how to turn the PowerQuad (PQ) support for a function on and off.

1. In the main menu, go to Project > Options for Target 'Target1'…, and a dialog appears.
2. Select the C/C++ tab. See Figure 13.
3. In the Include Preprocessor Symbols text box, type the following:
   - RTCESL_PQ_ON—to turn the hardware division and square root support on.
   - RTCESL_PQ_OFF—to turn the hardware division and square root support off.

   If neither of these two defines is defined, the hardware division and square root support is turned off by default.
4. Click OK in the main dialog.

5. Ensure the PowerQuad module to be clocked by calling function RTCESL_PQ_Init(); prior to the first function using PQ module calling.

See the device reference manual to verify whether the device contains the PowerQuad DSP Coprocessor and Accelerator support.

Linking the files into the project

To include the library files in the project, create groups and add them.

1. Right-click the Target 1 node in the left-hand part of the Project tree, and select Add Group… from the menu. A new group with the name New Group is added.

2. Click the newly created group, and press F2 to rename it to RTCESL.

3. Right-click the RTCESL node, and select Add Existing Files to Group ‘RTCESL’… from the menu.

4. Navigate into the library installation folder C:\NXP\RTCESL\CM33_RTCESL_4.7.KEIL\MLIB\Include, and select the mlib.h file. If the file does not appear, set the Files of type filter to Text file. Click Add. See Figure 14.
5. Navigate to the parent folder C:\NXP\RTCESL\CM33_RTCESL_4.7_KEIL\MLIB, and select the mlib.lib file. If the file does not appear, set the Files of type filter to Library file. Click Add. See Figure 15.

6. Navigate into the library installation folder C:\NXP\RTCESL\CM33_RTCESL_4.7_KEIL\PCLIB\Include, and select the pclib.h file. If the file does not appear, set the Files of type filter to Text file. Click Add.

7. Navigate to the parent folder C:\NXP\RTCESL\CM33_RTCESL_4.7_KEIL\PCLIB, and select the pclib.lib file. If the file does not appear, set the Files of type filter to Library file. Click Add.

8. Now, all necessary files are in the project tree; see Figure 16. Click Close.
Library path setup

The following steps show the inclusion of all dependent modules.

1. In the main menu, go to Project > Options for Target ‘Target1’…, and a dialog appears.
2. Select the C/C++ tab. See Figure 17.
3. In the Include Paths text box, type the following (if there are more paths, they must be separated by ‘;’) or add by clicking the … button next to the text box:
   - “C:\NXP\RTCESL\CM33_RTCESL_4.7_KEIL\MLIB\Include"
   - “C:\NXP\RTCESL\CM33_RTCESL_4.7_KEIL\PCLIB\Include”
4. Click OK.
5. Click OK in the main dialog.
Type the `#include` syntax into the code. Include the library into a source file. In the new project, it is necessary to create a source file:

1. Right-click the Source Group 1 node, and Add New Item to Group 'Source Group 1'... from the menu.
2. Select the C File (.c) option, and type a name of the file into the Name box, for example 'main.c'. See Figure 18.
3. Click Add, and a new source file is created and opened up.
4. In the opened source file, include the following lines into the #include section, and create a main function:

```c
#include "mlib.h"
#include "pclib.h"

int main(void)
{
    while(1);
}
```

When you click the Build (F7) icon, the project will be compiled without errors.

1.4 Library integration into project (IAR Embedded Workbench)

This section provides a step-by-step guide on how to quickly and easily include the PCLIB into an empty project or any MCUXpresso SDK example or demo application projects using IAR Embedded Workbench. This example uses the default installation path (C:\NXP\RTCESL\CM33_RTCESL_4.7_IAR). If you have a different installation path, use that path instead. If any MCUXpresso SDK project is intended to use (for example hello_world project) go to Linking the files into the project chapter otherwise read next chapter.

New project (without MCUXpresso SDK)

This example uses the NXP LPC55S69 part, and the default installation path (C:\NXP\RTCESL\CM33_RTCESL_4.7_IAR) is supposed. To start working on an application, create a new project. If the project already exists and is opened, skip to the next section. Perform these steps to create a new project:

1. Launch IAR Embedded Workbench.

2. In the main menu, select Project > Create New Project… so that the "Create New Project" dialog appears. See Figure 19.

![Figure 19. Create New Project dialog](image)

3. Expand the C node in the tree, and select the "main" node. Click OK.

4. Navigate to the folder where you want to create the project, for example, C:\IARProjects\MyProject01. Type the name of the project, for example, MyProject01. Click Save, and a new project is created. The new project is now visible in the left-hand part of IAR Embedded Workbench. See Figure 20.
5. In the main menu, go to Project > Options…, and a dialog appears.

6. In the Target tab, select the Device option, and click the button next to the dialog to select the MCU. In this example, select NXP > LPC55S69 > NXP LPC55S69_core0. Select None in the FPU option. The DSP instructions group is required please check the DSP Extensions checkbox if not checked. Click OK. See Figure 21.

PowerQuad DSP Coprocessor and Accelerator support

Some LPC platforms (LPC55S6x) contain a hardware accelerator dedicated to common calculations in DSP applications. Only functions running faster through the PowerQuad module than the core itself are supported and targeted to be calculated by the PowerQuad module. This section shows how to turn the PowerQuad (PQ) support for a function on and off.

1. In the main menu, go to Project > Options…, and a dialog appears.

2. In the left-hand column, select C/C++ Compiler.

3. In the right-hand part of the dialog, click the Preprocessor tab (it can be hidden in the right-hand side; use the arrow icons for navigation).
4. In the text box (at the Defined symbols: (one per line)), type the following (See Figure 22):
   - RTCESL_PQ_ON—to turn the PowerQuad support on.
   - RTCESL_PQ_OFF—to turn the PowerQuad support off.

If neither of these two defines is defined, the hardware division and square root support is turned off by default.

![Figure 22. Defined symbols]

5. Click OK in the main dialog.

6. Ensure the PowerQuad module to be clocked by calling function RTCESL_PQ_Init(); prior to the first function using PQ module calling.

See the device reference manual to verify whether the device contains the PowerQuad DSP Coprocessor and Accelerator support.

Library path variable

To make the library integration easier, create a variable that will hold the information about the library path.

1. In the main menu, go to Tools > Configure Custom Argument Variables…, and a dialog appears.

2. Click the New Group button, and another dialog appears. In this dialog, type the name of the group PATH, and click OK. See Figure 23.
3. Click on the newly created group, and click the Add Variable button. A dialog appears.

4. Type this name: RTCESL_LOC

5. To set up the value, look for the library by clicking the ‘…”’ button, or just type the installation path into the box: C:\NXP\RTCESL\CM33_RTCESL_4.7_IAR. Click OK.

6. In the main dialog, click OK. See Figure 24.

Linking the files into the project

To include the library files into the project, create groups and add them.

1. Go to the main menu Project > Add Group…

2. Type RTCESL, and click OK.

3. Click on the newly created node RTCESL, go to Project > Add Group…, and create a MLIB subgroup.

4. Click on the newly created node MLIB, and go to the main menu Project > Add Files… See Figure 26.

5. Navigate into the library installation folder C:\NXP\RTCESL\CM33_RTCESL_4.7_IAR\MLIB\Include, and select the mlib.h file. (If the file does not appear, set the file-type filter to Source Files.) Click Open. See Figure 25.
6. Navigate into the library installation folder C:\NXP\RTCESL\CM33_RTCESL_4.7_IAR\MLIB, and select the mlib.a file. If the file does not appear, set the file-type filter to Library / Object files. Click Open.

![Figure 25. Add Files dialog](image)

7. Click on the RTCESL node, go to Project > Add Group…, and create a PCLIB subgroup.

8. Click on the newly created node PCLIB, and go to the main menu Project > Add Files…

9. Navigate into the library installation folder C:\NXP\RTCESL\CM33_RTCESL_4.7_IAR\PCLIB\Include, and select the pclib.h file. If the file does not appear, set the file-type filter to Source Files. Click Open.

10. Navigate into the library installation folder C:\NXP\RTCESL\CM33_RTCESL_4.7_IAR\PCLIB, and select the pclib.a file. If the file does not appear, set the file-type filter to Library / Object files. Click Open.

11. Now you will see the files added in the workspace. See Figure 26.

![Figure 26. Project workspace](image)

Library path setup

1. In the main menu, go to Project > Options…, and a dialog appears.

2. In the left-hand column, select C/C++ Compiler.

3. In the right-hand part of the dialog, click on the Preprocessor tab (it can be hidden in the right; use the arrow icons for navigation).

4. In the text box (at the Additional include directories title), type the following folder (using the created variable):
   - $RTCESL_LOC\MLIB\Include
   - $RTCESL_LOC\PCLIB\Include

5. Click OK in the main dialog. See Figure 27.
Type the #include syntax into the code. Include the library included into the main.c file. In the workspace tree, double-click the main.c file. After the main.c file opens up, include the following lines into the #include section:

```c
#include "mlib.h"
#include "pclib.h"
```

When you click the Make icon, the project will be compiled without errors.
Chapter 2
Algorithms in detail

2.1 PCLIB_Ctrl2P2Z

The PCLIB_Ctrl2P2Z function calculates the compensation block for the controller, which consists of two poles and two zeroes. The s-domain transfer function equation for two-pole two-zero control law is as follows:

\[
\frac{y[s]}{x[s]} = \frac{(s-Z_1)(s-Z_2)}{(s-P_1)(s-P_2)}
\]

Figure 28.

where \(y[s]\) is the output, and \(x[s]\) is the input to the system. This control law has two poles (P1 and P2) and two zeroes (Z1 and Z2). The value or the placement of these poles and zeroes in the bode plot affects the stability and performance of the control loop and the system. The z-domain controller \(G_c(z)\) at sampling time \(T_s\) is expressed using the Tustin method as follows:

\[
\frac{y[z]}{x[z]} = \frac{(z^{2} - b_1 z + b_0)(z^{-2} - b_1 z^{-1} + b_0)}{(z^{2} - a_2 z - a_1 z^{-1})}
\]

Figure 29.

\[
y[n] - a_1 \cdot y[n-1] - a_2 \cdot y[n-2] = b_0 \cdot x[n] + b_1 \cdot x[n-1] + b_2 \cdot x[n-2] - z^{-1}
\]

Figure 30.

where:

- \(y[n]\) is the present output
- \(y[n-1]\) is the previous output
- \(y[n-2]\) is the previous to previous output
- \(x[n]\) is the present error
- \(x[n-1]\) is the previous error
- \(x[n-2]\) is the previous to previous error
- \(b_0, b_1, b_2, a_1,\) and \(a_2\) are the control coefficients and functions of Z1, Z2, P1, P2, and sampling time \(T_s\).

For a proper use of this function, it is recommended to initialize the function’s data by the PCLIB_Ctrl2P2ZInit function, before using the function. This function clears the internal buffers of the 2P2Z controller. You must call this function when you want the 2P2Z controller to be initialized. The init function must not be called together with PCLIB_Ctrl2P2Z, unless a periodic clearing of buffers is required.

2.1.1 Available versions

The available versions of the PCLIB_Ctrl2P2ZInit function are shown in the following table:

<table>
<thead>
<tr>
<th>Function name</th>
<th>Input type</th>
<th>Parameters</th>
<th>Result type</th>
</tr>
</thead>
<tbody>
<tr>
<td>PCLIB_Ctrl2P2ZInit_F16</td>
<td>frac16_t</td>
<td>PCLIB_CTRL_2P2Z_T_F16 *</td>
<td>void</td>
</tr>
</tbody>
</table>

Table continues on the next page...
Table 2. Init function versions (continued)

<table>
<thead>
<tr>
<th>Function name</th>
<th>Input type</th>
<th>Parameters</th>
<th>Result type</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>The inputs are a 16-bit fractional initial value and a pointer to the controller's parameters structure. It clears the internal delay parameter buffers of the controller.</td>
<td></td>
</tr>
</tbody>
</table>

The available versions of the PCLIB_Ctrl2P2Z function are shown in the following table:

Table 3. Function versions

<table>
<thead>
<tr>
<th>Function name</th>
<th>Input type</th>
<th>Parameters</th>
<th>Result type</th>
</tr>
</thead>
<tbody>
<tr>
<td>PCLIB_Ctrl2P2Z_F16</td>
<td>frac16_t</td>
<td>PCLIB_CTRL_2P2Z_T_F16 *</td>
<td>frac16_t</td>
</tr>
</tbody>
</table>

The error input is a 16-bit fractional value within the range <-1 ; 1). The parameters are pointed to by an input pointer. The function returns a 16-bit fractional value in the range <-1 ; 1).

2.1.2 PCLIB_CTRL_2P2Z_T_F16

<table>
<thead>
<tr>
<th>Variable name</th>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>f16CoeffB0</td>
<td>frac16_t</td>
<td>Control coefficient for the present error. The parameter is a 16-bit fractional value within the range &lt;-1 ; 1). Set by the user.</td>
</tr>
<tr>
<td>f16CoeffB1</td>
<td>frac16_t</td>
<td>Control coefficient for the past error. The parameter is a 16-bit fractional value within the range &lt;-1 ; 1). Set by the user.</td>
</tr>
<tr>
<td>f16CoeffB2</td>
<td>frac16_t</td>
<td>Control coefficient for the past to past error. The parameter is a 16-bit fractional value within the range &lt;-1 ; 1). Set by the user.</td>
</tr>
<tr>
<td>f16CoeffA1</td>
<td>frac16_t</td>
<td>Control coefficient for the past result. The parameter is a 16-bit fractional value within the range &lt;-1 ; 1). Set by the user.</td>
</tr>
<tr>
<td>f16CoeffA2</td>
<td>frac16_t</td>
<td>Control coefficient for the past to past result. The parameter is a 16-bit fractional value within the range &lt;-1 ; 1). Set by the user.</td>
</tr>
<tr>
<td>f16DelayX1</td>
<td>frac16_t</td>
<td>Delay parameter for the past error. Controlled by the algorithm.</td>
</tr>
<tr>
<td>f16DelayX2</td>
<td>frac16_t</td>
<td>Delay parameter for the past to past error. Controlled by the algorithm.</td>
</tr>
<tr>
<td>f16DelayY1</td>
<td>frac16_t</td>
<td>Delay parameter for the past result. Controlled by the algorithm.</td>
</tr>
<tr>
<td>f16DelayY2</td>
<td>frac16_t</td>
<td>Delay parameter for the past to past result. Controlled by the algorithm.</td>
</tr>
</tbody>
</table>

2.1.3 Declaration

The available PCLIB_Ctrl2P2Z functions have the following declarations:

```c
void PCLIB_Ctrl2P2ZInit_F16(PCLIB_CTRL_2P2Z_T_F16 *psParam)
frac16_t PCLIB_Ctrl2P2Z_F16(frac16_t f16InErr, PCLIB_CTRL_2P2Z_T_F16 *psParam)
```

2.1.4 Function use

The use of the PCLIB_Ctrl2P2ZInit_F16 and PCLIB_Ctrl2P2Z functions is shown in the following example:

```c
#include "pclib.h"

static frac16_t f16Result, f16InErr;
```
static PCLIB_CTRL_2P2Z_T_F16 sParam;

void Isr(void);

void main(void)
{
    f16InErr = FRAC16(-0.4);
    sParam.f16CoeffB0 = FRAC16(0.1);
    sParam.f16CoeffB1 = FRAC16(0.2);
    sParam.f16CoeffB2 = FRAC16(0.15);
    sParam.f16CoeffA1 = FRAC16(0.1);
    sParam.f16CoeffA2 = FRAC16(0.25);
    PCLIB_Ctrl2P2ZInit_F16(&sParam);
}

/* Periodical function or interrupt */
void Isr()
{
    f16Result = PCLIB_Ctrl2P2Z_F16(f16InErr, &sParam);
}

2.2 PCLIB_Ctrl3P3Z

The PCLIB_Ctrl3P3Z function calculates the compensation block for the controller, which consists of three poles and three zeroes. The s-domain transfer function equation for the three-pole three-zero control law is as follows:

\[
\frac{Y(s)}{X(s)} = \frac{(s - Z_2)(s - Z_3)}{(s - P_1)(s - P_2)(s - P_3)}
\]

Figure 32.

where \(y[s]\) is the output and \(x[s]\) is the input to the system. This control law has three poles (P1, P2, and P3) and three zeroes (Z1, Z2, and Z3). The value or the placement of these poles and zeroes in the bode plot affects the stability and performance of the control loop and the system. The z-domain controller \(G_c(z)\) at sampling time \(T_s\) is expressed using the Tustin method as follows:

\[
\frac{x[n]}{y[n]} = \frac{(a_3 \cdot z^{-3} + b_2 \cdot z^{-2} + b_1 \cdot z^{-1} + b_0)}{(1 - a_3 \cdot z^{-3} - a_2 \cdot z^{-2} - a_1 \cdot z^{-1})}
\]

Figure 33.

\[
y[n] = a_1 \cdot y[n-1] + a_2 \cdot y[n-2] + a_3 \cdot y[n-3] + b_0 \cdot x[n] + b_1 \cdot x[n-1] + b_2 \cdot x[n-2] + b_3 \cdot x[n-3]
\]

Figure 34.

where:

- \(y[n] = y[n]\) is the present output
- \(y[n-1] = y[n-1]\) is the previous output
- \(y[n-2] = y[n-2]\) is the previous to previous output
- \(y[n-3] = y[n-3]\) is the previous to previous to previous output
- \(x[n] = x[n]\) is the present error
- \(x[n-1] = x[n-1]\) is the previous error
- \(x[n-2] = x[n-2]\) is the previous to previous error
- \(x[n-3] = x[n-3]\) is the previous to previous to previous error
• $b_0, b_1, b_2, b_3$ a1, a2, and a3 are the control coefficients and functions of $Z_1, Z_2, Z_3, P_1, P_2, P_3$, and sampling time $T_s$.

$$y[n] = a_3 \cdot y[n-3] + a_2 \cdot y[n-2] + a_1 \cdot y[n-1] + b_3 \cdot x[n-3] + b_2 \cdot x[n-2] + b_1 \cdot x[n-1] + b_0 \cdot x[n]$$

Figure 35.

For a proper use of this function, it is recommended to initialize the function's data by the PCLIB_Ctrl3P3ZInit function, before using the function. This function clears the internal buffers of the 3P3Z controller. You must call this function when you want the 3P3Z controller to be initialized. The init function must not be called together with PCLIB_Ctrl3P3Z, unless a periodic clearing of buffers is required.

2.2.1 Available versions

The available versions of the PCLIB_Ctrl3P3ZInit function are shown in the following table:

<table>
<thead>
<tr>
<th>Function name</th>
<th>Input type</th>
<th>Parameters</th>
<th>Result type</th>
</tr>
</thead>
<tbody>
<tr>
<td>PCLIB_Ctrl3P3ZInit_F16</td>
<td>frac16_t</td>
<td>PCLIB_CTRG_3P3Z_T_F16 *</td>
<td>void</td>
</tr>
</tbody>
</table>

The inputs are a 16-bit fractional initial value and a pointer to the controller's parameters structure. It clears the internal delay parameter buffers of the controller.

The available versions of the PCLIB_Ctrl3P3Z function are shown in the following table:

<table>
<thead>
<tr>
<th>Function name</th>
<th>Input type</th>
<th>Parameters</th>
<th>Result type</th>
</tr>
</thead>
<tbody>
<tr>
<td>PCLIB_Ctrl3P3Z_F16</td>
<td>frac16_t</td>
<td>PCLIB_CTRG_3P3Z_T_F16 *</td>
<td>frac16_t</td>
</tr>
</tbody>
</table>

The error input is a 16-bit fractional value within the range $<-1 ; 1)$. The parameters are pointed to by an input pointer. The function returns a 16-bit fractional value in the range $<-1 ; 1)$.

2.2.2 PCLIB_CTRG_3P3Z_T_F16

<table>
<thead>
<tr>
<th>Variable name</th>
<th>Input type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>f16CoeffB0</td>
<td>frac16_t</td>
<td>Control coefficient for the present error. The parameter is a 16-bit fractional value within the range $&lt;-1 ; 1)$. Set by the user.</td>
</tr>
<tr>
<td>f16CoeffB1</td>
<td>frac16_t</td>
<td>Control coefficient for the past error. The parameter is a 16-bit fractional value within the range $&lt;-1 ; 1)$. Set by the user.</td>
</tr>
<tr>
<td>f16CoeffB2</td>
<td>frac16_t</td>
<td>Control coefficient for the past to past error. The parameter is a 16-bit fractional value within the range $&lt;-1 ; 1)$. Set by the user.</td>
</tr>
<tr>
<td>f16CoeffB3</td>
<td>frac16_t</td>
<td>Control coefficient for the past to past to past error. The parameter is a 16-bit fractional value within the range $&lt;-1 ; 1)$. Set by the user.</td>
</tr>
<tr>
<td>f16CoeffA1</td>
<td>frac16_t</td>
<td>Control coefficient for the past result. The parameter is a 16-bit fractional value within the range $&lt;-1 ; 1)$. Set by the user.</td>
</tr>
<tr>
<td>f16CoeffA2</td>
<td>frac16_t</td>
<td>Control coefficient for the past to past result. The parameter is a 16-bit fractional value within the range $&lt;-1 ; 1)$. Set by the user.</td>
</tr>
<tr>
<td>f16CoeffA3</td>
<td>frac16_t</td>
<td>Control coefficient for the past to past to past result. The parameter is a 16-bit fractional value within the range $&lt;-1 ; 1)$. Set by the user.</td>
</tr>
</tbody>
</table>
### Table continued from the previous page...

<table>
<thead>
<tr>
<th>Variable name</th>
<th>Input type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>f16DelayX1</td>
<td>frac16_t</td>
<td>Delay parameter for the past error. Controlled by the algorithm.</td>
</tr>
<tr>
<td>f16DelayX2</td>
<td>frac16_t</td>
<td>Delay parameter for the past to past error. Controlled by the algorithm.</td>
</tr>
<tr>
<td>f16DelayX3</td>
<td>frac16_t</td>
<td>Delay parameter for the past to past to past error. Controlled by the algorithm.</td>
</tr>
<tr>
<td>f16DelayY1</td>
<td>frac16_t</td>
<td>Delay parameter for the past result. Controlled by the algorithm.</td>
</tr>
<tr>
<td>f16DelayY2</td>
<td>frac16_t</td>
<td>Delay parameter for the past to past result. Controlled by the algorithm.</td>
</tr>
<tr>
<td>f16DelayY3</td>
<td>frac16_t</td>
<td>Delay parameter for the past to past to past result. Controlled by the algorithm.</td>
</tr>
</tbody>
</table>

#### 2.2.3 Declaration

The available `PCLIB_Ctrl3P3Z` functions have the following declarations:

```c
void PCLIB_Ctrl3P3ZInit_F16(PCLIB_CTRL_3P3Z_T_F16 *psParam)
frac16_t PCLIB_Ctrl3P3Z_F16(frac16_t f16InErr, PCLIB_CTRL_3P3Z_T_F16 *psParam)
```

#### 2.2.4 Function use

The use of the `PCLIB_Ctrl3P3ZInit_F16` and `PCLIB_Ctrl3P3Z` functions is shown in the following example:

```c
#include "plib.h"

static frac16_t f16Result, f16InErr;
static PCLIB_CTRL_3P3Z_T_F16 sParam;

void Isr(void);

void main(void)
{
    f16InErr = FRAC16(-0.4);
    sParam.f16CoeffB0 = FRAC16(0.1);
    sParam.f16CoeffB1 = FRAC16(0.2);
    sParam.f16CoeffB2 = FRAC16(0.15);
    sParam.f16CoeffB3 = FRAC16(0.12);
    sParam.f16CoeffA1 = FRAC16(0.1);
    sParam.f16CoeffA2 = FRAC16(0.25);
    sParam.f16CoeffA3 = FRAC16(0.35);

    PCLIB_Ctrl3P3ZInit_F16(&sParam);
}

/* Periodical function or interrupt */
void Isr()
{
    f16Result = PCLIB_Ctrl3P3Z_F16(f16InErr, &sParam);
}
```
2.3 PCLIB_CtrlPI

The PCLIB_CtrlPI function calculates the Proportional-Integral (PI) compensation block for any given control system in power-control and motor-control applications. The integral output of the controller is also limited, and the limit values (IntegralUpperLimit and IntegralLowerLimit) are defined by the user. The controller output is also limited, and the limit values (UpperLimit and LowerLimit) are defined by the user. The integral state is limited by the controller limits in the same way as the controller output.

The PI algorithm in the continuous time domain is expressed as follows:

\[ y(t) = K_p\cdot e(t) + \int_0^t Ki \cdot e(t) \cdot dt \]

Figure 36.

The above equation can be rewritten into the discrete time domain by approximating the integral term. The integral term is approximated by the Backward Euler method, also known as backward rectangular or right-hand approximation, as follows:

\[ y_i(n) = y_i(n-1) + Ki \cdot Ts \cdot e(n) \]

Figure 37.

The discrete time domain representation of the PI algorithms is as follows:

\[ y(n) = K_p \cdot e(n) + y_i(n-1) + Ki \cdot Ts \cdot e(n) \]

Figure 38.

where:

- \( e(n) \) is the input error
- \( y(n) \) is the controller output
- \( K_p \) is the proportional gain
- \( K_i \) is the integral gain
- \( y_i(n-1) \) is the previous integral output
- \( Ts \) is the sampling time

Rewritten as follows:

\[ y(n) = K_p \cdot e(n) + y_i(n-1) + K_i \cdot e(n) \]

Figure 39.

For a proper use of this function, it is recommended to initialize the function's data by the PCLIB_CtrlPIInit functions, before using this function. This function clears the internal buffers of a PI controller. You must call this function when you want the PI controller to be initialized. The init function must not be called together with PCLIB_CtrlPI, unless a periodic clearing of buffers is required.

2.3.1 Available versions

The available versions of the PCLIB_CtrlPIInit function are shown in the following table:
Table 6. Init function versions

<table>
<thead>
<tr>
<th>Function name</th>
<th>Input type</th>
<th>Parameters</th>
<th>Result type</th>
</tr>
</thead>
<tbody>
<tr>
<td>PCLIB_CtrlPIInit_F16</td>
<td>frac16_t</td>
<td>PCLIB_CTRL_PI_T_F16 *</td>
<td>void</td>
</tr>
</tbody>
</table>

The inputs are a 16-bit fractional initial value and a pointer to the controller's parameters structure. It clears the internal integral accumulator buffer.

The available versions of the PCLIB_CtrlPI function are shown in the following table:

Table 7. Function versions

<table>
<thead>
<tr>
<th>Function name</th>
<th>Input type</th>
<th>Parameters</th>
<th>Result type</th>
</tr>
</thead>
<tbody>
<tr>
<td>PCLIB_CtrlPI_F16</td>
<td>frac16_t</td>
<td>PCLIB_CTRL_PI_T_F16 *</td>
<td>frac16_t</td>
</tr>
</tbody>
</table>

The error input is a 16-bit fractional value within the range <-1 ; 1). The parameters are pointed to by an input pointer. The function returns a 16-bit fractional value in the range <f16LowerLimit ; f16UpperLimit>.

2.3.2 PCLIB_CTRL_PI_T_F16

<table>
<thead>
<tr>
<th>Variable name</th>
<th>Input type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>f16Kp</td>
<td>frac16_t</td>
<td>Proportional gain. The parameter is a 16-bit fractional value within the range &lt;-1 ; 1). Set by the user.</td>
</tr>
<tr>
<td>f16Ki</td>
<td>frac16_t</td>
<td>Integral gain. The parameter is a 16-bit fractional value within the range &lt;-1 ; 1). Set by the user.</td>
</tr>
<tr>
<td>f16PreviousIntegralOu tput</td>
<td>frac16_t</td>
<td>Internal integral accumulator. Controlled by the algorithm.</td>
</tr>
<tr>
<td>f16IntegralUpperLimit</td>
<td>frac16_t</td>
<td>Upper limit of the the integral accumulator. These parameters must be greater than f16IntegralLowerLimit. Set by the user.</td>
</tr>
<tr>
<td>f16IntegralLowerLimit</td>
<td>frac16_t</td>
<td>Lower limit of the the integral accumulator. These parameters must be lower than f16IntegralUpperLimit. Set by the user.</td>
</tr>
<tr>
<td>f16UpperLimit</td>
<td>frac16_t</td>
<td>Upper limit of the the controller's output. These parameters must be greater than f16LowerLimit. Set by the user.</td>
</tr>
<tr>
<td>f16LowerLimit</td>
<td>frac16_t</td>
<td>Lower limit of the the controller's output. These parameters must be lower than f16UpperLimit. Set by the user.</td>
</tr>
</tbody>
</table>

2.3.3 Declaration

The available PCLIB_CtrlPI functions have the following declarations:

```c
void PCLIB_CtrlPIInit_F16(PCLIB_CTRL_PI_T_F16 *psParam)
frac16_t PCLIB_CtrlPI_F16(frac16_t f16InErr, PCLIB_CTRL_PI_T_F16 *psParam)
```
2.3.4 Function use

The use of the PCLIB_CtrlPIInit_F16 and PCLIB_CtrlPI functions is shown in the following example:

```c
#include "pclib.h"
static frac16_t f16Result, f16InErr;
static PCLIB_CTRL_PI_T_F16 sParam;

void Isr(void);

void main(void)
{
    f16InErr = FRAC16(-0.4);
    sParam.f16Kp = FRAC16(0.1);
    sParam.f16Ki = FRAC16(0.2);
    sParam.f16IntegralUpperLimit = FRAC16(0.9);
    sParam.f16IntegralLowerLimit = FRAC16(-0.9);
    sParam.f16UpperLimit = FRAC16(0.9);
    sParam.f16LowerLimit = FRAC16(-0.9);
    PCLIB_CtrlPIInit_F16(&sParam);
}

/* Periodical function or interrupt */
void Isr()
{
    f16Result = PCLIB_CtrlPI_F16(f16InErr, &sParam);
}
```

2.4 PCLIB_CtrlPIandLPFilter

The PCLIB_CtrlPIandLPFilter function calculates the Proportional-Integral (PI) compensation block, along with the low-pass filter. The low-pass filter's pole and zero are placed at much higher frequency to compensate for the output capacitor ESR. It can be represented as follows:

\[
Output = (K_p + \frac{K_i}{s}) \cdot \frac{s + a}{s + b}
\]

Figure 41.

It increases the system performance even at the high frequency (in bode plot frequency domain) of system operations. This is equivalent to:

\[
\frac{y[s]}{x[s]} = \frac{-(Z_1 y - Z_2)}{(s - P_1)(s - P_2)}
\]

Figure 42.

where \(y[s]\) is the output, and \(x[s]\) is the input to the system. This control law has two poles (P1 and P2) and two zeroes (Z1 and Z2). The value or the placement of these poles and zeroes in the bode plot influence the stability and performance of the control loop and the system. The z-domain controller \(G_c(z)\) at sampling time \(T_s\) is expressed using the Tustin method as follows:

\[
\frac{y[z]}{x[z]} = \frac{(6s^2 + 2s + 1)s + 60}{(s^2 - 2s + 1)(s^2 - 2s + 12)}
\]

Figure 43.
\[ y[t] - a1 \cdot y[t] \cdot z^{-1} - a2 \cdot y[t] \cdot z^{-2} = b0 \cdot x[t] + b1 \cdot x[t] \cdot z^{-1} + b2 \cdot x[t] \cdot z^{-2} \]

where:

- \( y[t] = y[n] \) is the present output
- \( y[t] \cdot z^{-1} = y[n-1] \) is the previous output
- \( y[t] \cdot z^{-2} = y[n-2] \) is the previous to previous output
- \( x[t] = x[n] \) is the present error
- \( x[t] \cdot z^{-1} = x[n-1] \) is the previous error
- \( x[t] \cdot z^{-2} = x[n-2] \) is the previous to previous error
- \( b0, b1, b2, a1, \) and \( a2 \) are the control coefficients and functions of \( Z1, Z2, P1, P2, \) and sampling time \( Ts. \)

\[ y[n] = a1 \cdot y[n - 1] + a2 \cdot y[n - 2] + b0 \cdot x[n] + b1 \cdot x[n - 1] + b2 \cdot x[n - 2] \]

For a proper use of this function, it is recommended to initialize the function's data by the PCLIB_CtrlPIandLPInit functions, before using the function. This function clears the internal buffers of the PIandLP controller. You must call this function when you want the PIandLP controller to be initialized. The init function must not be called together with PCLIB_CtrlPIandLPFilter, unless a periodic clearing of buffers is required.

### 2.4.1 Available versions

The available versions of the PCLIB_CtrlPIandLPInit function are shown in the following table:

<table>
<thead>
<tr>
<th>Function name</th>
<th>Input type</th>
<th>Parameters</th>
<th>Result type</th>
</tr>
</thead>
<tbody>
<tr>
<td>PCLIB_CtrlPIandLPInit_F16</td>
<td>frac16_t</td>
<td>PCLIB_CTRL_PI_LP_T_F16 *</td>
<td>void</td>
</tr>
</tbody>
</table>

The inputs are a 16-bit fractional initial value and a pointer to the controller's parameters structure. It clears the internal delay parameter buffers of the controller.

The available versions of the PCLIB_CtrlPIandLPFilter function are shown in the following table:

<table>
<thead>
<tr>
<th>Function name</th>
<th>Input type</th>
<th>Parameters</th>
<th>Result type</th>
</tr>
</thead>
<tbody>
<tr>
<td>PCLIB_CtrlPIandLPFilter_F16</td>
<td>frac16_t</td>
<td>PCLIB_CTRL_PI_LP_T_F16 *</td>
<td>frac16_t</td>
</tr>
</tbody>
</table>

The error input is a 16-bit fractional value within the range \(-1 ; 1)\). The parameters are pointed to by an input pointer. The function returns a 16-bit fractional value in the range \(-1 ; 1\).

### 2.4.2 PCLIB_CTRL_PI_LP_T_F16

<table>
<thead>
<tr>
<th>Variable name</th>
<th>Input type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>f16coeffB0</td>
<td>frac16_t</td>
<td>Control coefficient for the present error. The parameter is a 16-bit fractional value within the range (-1 ; 1). Set by the user.</td>
</tr>
</tbody>
</table>

*Table continues on the next page...*
### 2.4.3 Declaration

The available PCLIB_CtrlPIandLPFilter functions have the following declarations:

```c
void PCLIB_CtrlPIandLPInit_F16(PCLIB_CTRL_PI_LP_T_F16 *psParam)
frac16_t PCLIB_CtrlPIandLPFilter_F16(frac16_t f16InErr, PCLIB_CTRL_PI_LP_T_F16 *psParam)
```

### 2.4.4 Function use

The use of the PCLIB_CtrlPIandLPInit_F16 and PCLIB_CtrlPIandLPFilter functions is shown in the following example:

```c
#include "pclib.h"

static frac16_t f16Result, f16InErr;
static PCLIB_CTRL_PI_LP_T_F16 sParam;

void Isr(void);

void main(void)
{
    f16InErr = FRAC16(-0.4);
    sParam.f16CoeffB0 = FRAC16(0.1);
    sParam.f16CoeffB1 = FRAC16(0.2);
    sParam.f16CoeffB2 = FRAC16(0.15);
    sParam.f16CoeffA1 = FRAC16(0.1);
    sParam.f16CoeffA2 = FRAC16(0.25);

    PCLIB_CtrlPIandLPInit_F16(&sParam);
}
/* Periodical function or interrupt */
void Isr()
{
```
2.5 PCLIB_CtrlPID

The PCLIB_CtrlPID function calculates the Proportional-Integral-Derivative (PID) algorithm, according to the proportional (Kp), integral (Ki), and differential (Kd) coefficients. The controller output is limited, and you can define the limit values.

The PID algorithm in the continuous time domain is expressed as follows:

\[ y(t) = K_p \cdot e(t) + \frac{1}{2} \int_0^t (K_i \cdot e(t) \cdot dt) + K_d \cdot \frac{de(t)}{dt} \]

Figure 46.

where:

- e(t) is the input error in the continuous time domain
- y(t) is the controller output in the continuous time domain
- Kp is the proportional coefficient
- Ki is the integral coefficient
- Kd is the differential coefficient

It can be rewritten as:

\[ K_p \cdot e(t) = K_p \cdot x(t) \]

Figure 47.

\[ K_i \int_0^t e(t) \cdot dt = \frac{K_i}{1 - e^{-t}} \cdot x(t) \]

Figure 48.

\[ K_d \cdot \frac{de(t)}{dt} = K_d \cdot (1 - e^{-t}) \cdot x(t) \]

Figure 49.

It can be further simplified as:

- \( K_p + K_i + K_d = KA \)
- \( -K_p - 2K_d = KB \)
- \( K_d = KC \)

therefore:

\[ y(t) = \frac{K_p \cdot x(t) \cdot x(t) \cdot x(t) + K_i \cdot x(t) \cdot x(t) \cdot x(t) + K_d \cdot x(t) \cdot x(t) \cdot x(t)}{1 - x(t)} \]

Figure 51.
where:

- \( y(t) = y[n] \) is the present output
- \( y(t) \cdot z^{-1} = y[n-1] \) is the previous output
- \( x(t) = x[n] \) is the present error
- \( x(t) \cdot z^{-1} = x[n-1] \) is the previous error
- \( x(t) \cdot z^{-2} = x[n-2] \) is the previous to previous error

For a proper use of this function, it is recommended to initialize the function's data by the PCLIB_CtrlPIDInit functions, before using this function. This function clears the internal buffers of the PID controller. You must call this function when you want the PID controller to be initialized. The init function must not be called together with PCLIB_CtrlPID, unless a periodic clearing of buffers is required.

### 2.5.1 Available versions

The available versions of the PCLIB_CtrlPIDInit function are shown in the following table:

**Table 10. Init function versions**

<table>
<thead>
<tr>
<th>Function name</th>
<th>Input type</th>
<th>Parameters</th>
<th>Result type</th>
</tr>
</thead>
<tbody>
<tr>
<td>PCLIB_CtrlPIDInit_F16</td>
<td>frac16_t</td>
<td>PCLIB_CTRL_PID_T_F16 *</td>
<td>void</td>
</tr>
</tbody>
</table>

The inputs are a 16-bit fractional initial value and a pointer to the controller parameters' structure. It clears the internal delay parameter buffers of the controller.

The available versions of the PCLIB_CtrlPID function are shown in the following table:

**Table 11. Function versions**

<table>
<thead>
<tr>
<th>Function name</th>
<th>Input type</th>
<th>Parameters</th>
<th>Result type</th>
</tr>
</thead>
<tbody>
<tr>
<td>PCLIB_CtrlPID_F16</td>
<td>frac16_t</td>
<td>PCLIB_CTRL_PID_T_F16 *</td>
<td>frac16_t</td>
</tr>
</tbody>
</table>

The error input is a 16-bit fractional value within the range \(-1 ; 1\). The parameters are pointed to by an input pointer. The function returns a 16-bit fractional value in the range \(<f16LowerLimit ; f16UpperLimit>\).

### 2.5.2 PCLIB_CTRL_PID_T_F16

<table>
<thead>
<tr>
<th>Variable name</th>
<th>Input type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>f16Ka</td>
<td>frac16_t</td>
<td>Control coefficient for the present error. The parameter is a 16-bit fractional value within the range (-1 ; 1). Set by the user.</td>
</tr>
<tr>
<td>f16Kb</td>
<td>frac16_t</td>
<td>Control coefficient for the past error. The parameter is a 16-bit fractional value within the range (-1 ; 1). Set by the user.</td>
</tr>
</tbody>
</table>

*Table continues on the next page...*
Table continued from the previous page...

<table>
<thead>
<tr>
<th>Variable name</th>
<th>Input type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>f16Kc</td>
<td>frac16_t</td>
<td>Control coefficient for the past to past error. The parameter is a 16-bit fractional value within the range &lt;-1 ; 1). Set by the user.</td>
</tr>
<tr>
<td>f16DelayX1</td>
<td>frac16_t</td>
<td>Delay parameter for the past error. Controlled by the algorithm.</td>
</tr>
<tr>
<td>f16DelayX2</td>
<td>frac16_t</td>
<td>Delay parameter for the past to past error. Controlled by the algorithm.</td>
</tr>
<tr>
<td>f16DelayY1</td>
<td>frac16_t</td>
<td>Delay parameter for the past result. Controlled by the algorithm.</td>
</tr>
<tr>
<td>f16UpperLimit</td>
<td>frac16_t</td>
<td>Upper limit of the controller's output. This parameter must be greater than f16LowerLimit. Set by the user.</td>
</tr>
<tr>
<td>f16LowerLimit</td>
<td>frac16_t</td>
<td>Lower limit of the controller's output. This parameter must be lower than f16UpperLimit. Set by the user.</td>
</tr>
</tbody>
</table>

2.5.3 Declaration

The available PCLIB_CtrlPID functions have the following declarations:

```c
void PCLIB_CtrlPIDInit_F16(PCLIB_CTRL_PID_T_F16 *psParam)
frac16_t PCLIB_CtrlPID_F16(frac16_t f16InErr, PCLIB_CTRL_PID_T_F16 *psParam)
```

2.5.4 Function use

The use of the PCLIB_CtrlPIDInit_F16 and PCLIB_CtrlPID functions is shown in the following example:

```c
#include "pclib.h"

static frac16_t f16Result, f16InErr;
static PCLIB_CTRL_PID_T_F16 sParam;

void Isr(void);

void main(void)
{
    f16InErr = FRAC16(-0.4);
    sParam.f16Ka = FRAC16(0.1);
    sParam.f16Kb = FRAC16(0.2);
    sParam.f16Kc = FRAC16(0.15);
    sParam.f16UpperLimit = FRAC16(0.9);
    sParam.f16LowerLimit = FRAC16(-0.9);
    PCLIB_CtrlPIDInit_F16(&sParam);
}

/* Periodical function or interrupt */
void Isr()
{
    f16Result = PCLIB_CtrlPID_F16(f16InErr, &sParam);
}
```
Appendix A
Library types

A.1 bool_t

The bool_t type is a logical 16-bit type. It is able to store the boolean variables with two states: TRUE (1) or FALSE (0). Its definition is as follows:

```c
typedef unsigned short bool_t;
```

The following figure shows the way in which the data is stored by this type:

Table 12. Data storage

<table>
<thead>
<tr>
<th>Value</th>
<th>Unused</th>
<th>Logical</th>
</tr>
</thead>
<tbody>
<tr>
<td>TRUE</td>
<td>0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1</td>
<td></td>
</tr>
<tr>
<td></td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>FALSE</td>
<td>0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

To store a logical value as bool_t, use the FALSE or TRUE macros.

A.2 uint8_t

The uint8_t type is an unsigned 8-bit integer type. It is able to store the variables within the range <0 ; 255>. Its definition is as follows:

```c
typedef unsigned char uint8_t;
```

The following figure shows the way in which the data is stored by this type:

Table 13. Data storage

<table>
<thead>
<tr>
<th>Value</th>
<th>Integer</th>
</tr>
</thead>
<tbody>
<tr>
<td>255</td>
<td>1 1 1 1 1 1 1 1</td>
</tr>
</tbody>
</table>

Table continues on the next page...
A.3 uint16_t

The uint16_t type is an unsigned 16-bit integer type. It is able to store the variables within the range <0 : 65535>. Its definition is as follows:

```c
typedef unsigned short uint16_t;
```

The following figure shows the way in which the data is stored by this type:

Table 14. Data storage

<table>
<thead>
<tr>
<th>Value</th>
<th>15</th>
<th>14</th>
<th>13</th>
<th>12</th>
<th>11</th>
<th>10</th>
<th>9</th>
<th>8</th>
<th>7</th>
<th>6</th>
<th>5</th>
<th>4</th>
<th>3</th>
<th>2</th>
<th>1</th>
<th>0</th>
</tr>
</thead>
<tbody>
<tr>
<td>65535</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
</tr>
<tr>
<td>6</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>1</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>15518</td>
<td>3</td>
<td>C</td>
<td>9</td>
<td>E</td>
<td>4</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

Table 13. Data storage (continued)
A.4 uint32_t

The uint32_t type is an unsigned 32-bit integer type. It is able to store the variables within the range <0 ; 4294967295>. Its definition is as follows:

```c
typedef unsigned long uint32_t;
```

The following figure shows the way in which the data is stored by this type:

Table 15. Data storage

<table>
<thead>
<tr>
<th>Value</th>
<th>Integer</th>
</tr>
</thead>
<tbody>
<tr>
<td>4294967295</td>
<td>F F F F F F</td>
</tr>
<tr>
<td>2147483648</td>
<td>8 0 0 0 0 0 0</td>
</tr>
<tr>
<td>55977296</td>
<td>0 3 5 6 2 5 0</td>
</tr>
<tr>
<td>3451051828</td>
<td>C D B 2 D F 3 4</td>
</tr>
</tbody>
</table>

A.5 int8_t

The int8_t type is a signed 8-bit integer type. It is able to store the variables within the range <-128 ; 127>. Its definition is as follows:

```c
typedef char int8_t;
```

The following figure shows the way in which the data is stored by this type:

Table 16. Data storage

<table>
<thead>
<tr>
<th>Value</th>
<th>Sign</th>
<th>Integer</th>
</tr>
</thead>
<tbody>
<tr>
<td>127</td>
<td>0 1 1 1 1 1 1 1</td>
<td></td>
</tr>
<tr>
<td>-128</td>
<td>1 0 0 0 0 0 0 0</td>
<td>F</td>
</tr>
<tr>
<td>60</td>
<td>0 0 1 1 1 1 0 0</td>
<td></td>
</tr>
</tbody>
</table>

Table continues on the next page...
Table 16. Data storage (continued)

<table>
<thead>
<tr>
<th>-97</th>
<th>1</th>
<th>0</th>
<th>0</th>
<th>1</th>
<th>1</th>
<th>1</th>
<th>1</th>
<th>1</th>
<th>1</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>9</td>
<td>F</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

A.6  int16_t

The int16_t type is a signed 16-bit integer type. It is able to store the variables within the range <-32768 ; 32767>. Its definition is as follows:

```c
typedef short int16_t;
```

The following figure shows the way in which the data is stored by this type:

Table 17. Data storage

<table>
<thead>
<tr>
<th>Value</th>
<th>Sign</th>
<th>Integer</th>
</tr>
</thead>
<tbody>
<tr>
<td>32767</td>
<td>0111111111111111</td>
<td>F F F F</td>
</tr>
<tr>
<td>-32768</td>
<td>1000000000000000</td>
<td>0 0 0 0</td>
</tr>
<tr>
<td>15518</td>
<td>0011110001111100</td>
<td>3 C 9 E</td>
</tr>
<tr>
<td>-24768</td>
<td>1011110100000000</td>
<td>9 F 4 0</td>
</tr>
</tbody>
</table>

A.7  int32_t

The int32_t type is a signed 32-bit integer type. It is able to store the variables within the range <-2147483648 ; 2147483647>. Its definition is as follows:

```c
typedef long int32_t;
```

The following figure shows the way in which the data is stored by this type:

Table 18. Data storage

<table>
<thead>
<tr>
<th>Value</th>
<th>Sign</th>
<th>Integer</th>
</tr>
</thead>
<tbody>
<tr>
<td>2147483647</td>
<td>01111111111111111111111111111111</td>
<td>F F F F F F F F</td>
</tr>
<tr>
<td>-2147483648</td>
<td>10000000000000000000000000000000</td>
<td>0 0 0 0 0 0 0 0</td>
</tr>
<tr>
<td>0</td>
<td>00000000000000000000000000000000</td>
<td>0 0 0 0 0 0 0 0</td>
</tr>
<tr>
<td>-1</td>
<td>00000000000000000000000000000000</td>
<td>0 0 0 0 0 0 0 0</td>
</tr>
</tbody>
</table>

Table continues on the next page...
### Table 18. Data storage (continued)

<table>
<thead>
<tr>
<th>Value</th>
<th>S</th>
<th>Integer</th>
</tr>
</thead>
<tbody>
<tr>
<td>2147483647</td>
<td>7</td>
<td>F</td>
</tr>
<tr>
<td>-2147483648</td>
<td>8</td>
<td>0</td>
</tr>
<tr>
<td>55977296</td>
<td>0</td>
<td>3</td>
</tr>
<tr>
<td>-843915468</td>
<td>C</td>
<td>D</td>
</tr>
</tbody>
</table>

A.8  `frac8_t`

The `frac8_t` type is a signed 8-bit fractional type. It is able to store the variables within the range \([-1 ; 1)\). Its definition is as follows:

```c
typedef char frac8_t;
```

The following figure shows the way in which the data is stored by this type:

### Table 19. Data storage

<table>
<thead>
<tr>
<th>Value</th>
<th>Sign</th>
<th>Fractional</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.99219</td>
<td>0 1 1 1 1 1 1 1</td>
<td>7 F</td>
</tr>
<tr>
<td>-1.0</td>
<td>1 0 0 0 0 0 0 0</td>
<td>8 0</td>
</tr>
<tr>
<td>0.46875</td>
<td>0 0 1 1 1 1 0 0</td>
<td>3 C</td>
</tr>
<tr>
<td>-0.75781</td>
<td>1 0 0 1 1 1 1 1</td>
<td>9 F</td>
</tr>
</tbody>
</table>

To store a real number as `frac8_t`, use the `FRAC8` macro.
A.9 frac16_t

The frac16_t type is a signed 16-bit fractional type. It is able to store the variables within the range <-1 ; 1). Its definition is as follows:

```c
typedef short frac16_t;
```

The following figure shows the way in which the data is stored by this type:

<table>
<thead>
<tr>
<th>Value</th>
<th>Sign</th>
<th>Fractional</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.99997</td>
<td>1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1</td>
<td>F F F F F F F F F F F F F F</td>
</tr>
<tr>
<td>-1.0</td>
<td>1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0</td>
<td>0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0</td>
</tr>
<tr>
<td>0.47357</td>
<td>0 0 1 1 1 0 0 1 0 0 1 1 1 1 0 1</td>
<td>C E 9 3 9 3 9 3 9 3 9 3 9 3 9 3</td>
</tr>
<tr>
<td>-0.75586</td>
<td>1 0 0 1 1 1 1 1 0 1 0 0 0 0 0 0</td>
<td>F F 4 9 4 9 4 9 4 9 4 9 4 9 4 9</td>
</tr>
</tbody>
</table>

To store a real number as frac16_t, use the FRAC16 macro.

A.10 frac32_t

The frac32_t type is a signed 32-bit fractional type. It is able to store the variables within the range <-1 ; 1). Its definition is as follows:

```c
typedef long frac32_t;
```

The following figure shows the way in which the data is stored by this type:

<table>
<thead>
<tr>
<th>Value</th>
<th>S</th>
<th>Fractional</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.9999999995</td>
<td>7</td>
<td>F F F F F F F F</td>
</tr>
</tbody>
</table>

Table continues on the next page...
To store a real number as frac32_t, use the FRAC32 macro.

A.11 acc16_t

The acc16_t type is a signed 16-bit fractional type. It is able to store the variables within the range <-256 ; 256). Its definition is as follows:

```
typedef short acc16_t;
```

The following figure shows the way in which the data is stored by this type:

### Table 22. Data storage

<table>
<thead>
<tr>
<th>Value</th>
<th>15</th>
<th>14</th>
<th>13</th>
<th>12</th>
<th>11</th>
<th>10</th>
<th>9</th>
<th>8</th>
<th>7</th>
<th>6</th>
<th>5</th>
<th>4</th>
<th>3</th>
<th>2</th>
<th>1</th>
<th>0</th>
</tr>
</thead>
<tbody>
<tr>
<td>255.9921875</td>
<td>0</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>7</td>
<td>F</td>
<td>F</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>-256.0</td>
<td>1</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>8</td>
<td>0</td>
<td>0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1.0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>1</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>0</td>
<td>0</td>
<td>0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>-1.0</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>8</td>
<td>F</td>
<td>F</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13.7890625</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>1</td>
<td>1</td>
<td>0</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>0</td>
<td>0</td>
<td>1</td>
<td>0</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>0</td>
<td>6</td>
<td>E</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>-89.71875</td>
<td>1</td>
<td>1</td>
<td>0</td>
<td>1</td>
<td>0</td>
<td>0</td>
<td>1</td>
<td>1</td>
<td>0</td>
<td>1</td>
<td>0</td>
<td>0</td>
<td>1</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>D</td>
<td>3</td>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
To store a real number as acc16_t, use the ACC16 macro.

**A.12 acc32_t**

The acc32_t type is a signed 32-bit accumulator type. It is able to store the variables within the range <-65536 ; 65536). Its definition is as follows:

```c
typedef long acc32_t;
```

The following figure shows the way in which the data is stored by this type:

<table>
<thead>
<tr>
<th>Value</th>
<th>31</th>
<th>24</th>
<th>23</th>
<th>16</th>
<th>15</th>
<th>8</th>
<th>7</th>
<th>0</th>
</tr>
</thead>
<tbody>
<tr>
<td>65535.999969</td>
<td>S</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
</tr>
<tr>
<td>-65536.0</td>
<td>7</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
</tr>
<tr>
<td>1.0</td>
<td>8</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>-1.0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>8</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>23.789734</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>8</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>-1171.306793</td>
<td>F</td>
<td>0</td>
<td>0</td>
<td>B</td>
<td>E</td>
<td>5</td>
<td>1</td>
<td>6</td>
</tr>
</tbody>
</table>

To store a real number as acc32_t, use the ACC32 macro.

**A.13 FALSE**

The FALSE macro serves to write a correct value standing for the logical FALSE value of the bool_t type. Its definition is as follows:

```c
#define FALSE    ((bool_t)0)
```

```c
#include "mlib.h"
static bool_t bVal;
void main(void)
{
    bVal = FALSE;               /* bVal = FALSE */
}
```
A.14  TRUE

The TRUE macro serves to write a correct value standing for the logical TRUE value of the bool_t type. Its definition is as follows:

```c
#define TRUE     ((bool_t)1)
```

```c
#include "mlib.h"
static bool_t bVal;
void main(void)
{
    bVal = TRUE;               /* bVal = TRUE */
}
```

A.15  FRAC8

The FRAC8 macro serves to convert a real number to the frac8_t type. Its definition is as follows:

```c
#define FRAC8(x) ((frac8_t)((x) < 0.9921875 ? ((x) >= -1 ? (x)*0x80 : 0x80) : 0x7F))
```

The input is multiplied by 128 (=2^7). The output is limited to the range <0x80 ; 0x7F>, which corresponds to <-1.0 ; 1.0-2^-7>.

```c
#include "mlib.h"
static frac8_t f8Val;
void main(void)
{
    f8Val = FRAC8(0.187);               /* f8Val = 0.187 */
}
```

A.16  FRAC16

The FRAC16 macro serves to convert a real number to the frac16_t type. Its definition is as follows:

```c
#define FRAC16(x) ((frac16_t)((x) < 0.999969482421875 ? ((x) >= -1 ? (x)*0x8000 : 0x8000) : 0x7FFF))
```

The input is multiplied by 32768 (=2^15). The output is limited to the range <0x8000 ; 0x7FFF>, which corresponds to <-1.0 ; 1.0-2^-15>.

```c
#include "mlib.h"
static frac16_t f16Val;
void main(void)
{
    f16Val = FRAC16(0.736);               /* f16Val = 0.736 */
}
```
A.17 FRAC32

The FRAC32 macro serves to convert a real number to the frac32_t type. Its definition is as follows:

```c
#define FRAC32(x) ((frac32_t)((x) < 1 ? ((x) >= -1 ? (x)*0x80000000 : 0x80000000) : 0x7FFFFFFF))
```

The input is multiplied by 2147483648 (=2^{31}). The output is limited to the range <0x80000000 ; 0x7FFFFFFF>, which corresponds to <-1.0 ; 1.0-2^{-31}>.

```c
#include "mlib.h"
static frac32_t f32Val;
void main(void)
{
    f32Val = FRAC32(-0.1735667);               /* f32Val = -0.1735667 */
}
```

A.18 ACC16

The ACC16 macro serves to convert a real number to the acc16_t type. Its definition is as follows:

```c
#define ACC16(x) ((acc16_t)((x) < 255.9921875 ? ((x) >= -256 ? (x)*0x80 : 0x8000) : 0x7FFF))
```

The input is multiplied by 128 (=2^{7}). The output is limited to the range <0x8000 ; 0x7FFF> that corresponds to <-256.0 ; 255.9921875>.

```c
#include "mlib.h"
static acc16_t a16Val;
void main(void)
{
    a16Val = ACC16(19.45627);               /* a16Val = 19.45627 */
}
```

A.19 ACC32

The ACC32 macro serves to convert a real number to the acc32_t type. Its definition is as follows:

```c
#define ACC32(x) ((acc32_t)((x) < 65535.999969482421875 ? ((x) >= -65536 ? (x)*0x8000 : 0x80000000) : 0x7FFFFFFF))
```

The input is multiplied by 32768 (=2^{15}). The output is limited to the range <0x80000000 ; 0x7FFFFFFF>, which corresponds to <-65536.0 ; 65536.0-2^{-15}>.

```c
#include "mlib.h"
static acc32_t a32Val;
void main(void)
```
{ 
a32Val = ACC32(-13.654437); /* a32Val = -13.654437 */
}

Limited warranty and liability — Information in this document is provided solely to enable system and software implementers to use NXP products. There are no express or implied copyright licenses granted hereunder to design or fabricate any integrated circuits based on the information in this document. NXP reserves the right to make changes without further notice to any products herein.

NXP makes no warranty, representation, or guarantee regarding the suitability of its products for any particular purpose, nor does NXP assume any liability arising out of the application or use of any product or circuit, and specifically disclaims any and all liability, including without limitation consequential or incidental damages. “Typical” parameters that may be provided in NXP data sheets and/or specifications can and do vary in different applications, and actual performance may vary over time. All operating parameters, including “typicals,” must be validated for each customer application by customer’s technical experts. NXP does not convey any license under its patent rights nor the rights of others. NXP sells products pursuant to standard terms and conditions of sale, which can be found at the following address: nxp.com/SalesTermsandConditions.

Right to make changes - NXP Semiconductors reserves the right to make changes to information published in this document, including without limitation specifications and product descriptions, at any time and without notice. This document supersedes and replaces all information supplied prior to the publication hereof.

Security — Customer understands that all NXP products may be subject to unidentified or documented vulnerabilities. Customer is responsible for the design and operation of its applications and products throughout their lifecycles to reduce the effect of these vulnerabilities on customer’s applications and products. Customer’s responsibility also extends to other open and/or proprietary technologies supported by NXP products for use in customer’s applications. NXP accepts no liability for any vulnerability. Customer should regularly check security updates from NXP and follow up appropriately. Customer shall select products with security features that best meet rules, regulations, and standards of the intended application and make the ultimate design decisions regarding its products, regardless of any information or support that may be provided by NXP. NXP has a Product Security Incident Response Team (PSIRT) (reachable at PSIRT@nxp.com) that manages the investigation, reporting, and solution release to security vulnerabilities of NXP products.

NXP, the NXP logo, NXP SECURE CONNECTIONS FOR A SMARTER WORLD, COOLFLUX, EMBRACE, GREENCHIP, HITAG, ICODE, JCOP, LIFE, VIBES, MIFARE, MIFARE CLASSIC, MIFARE DESFire, MIFARE PLUS, MIFARE FLEX, MANTIS, MIFARE ULTRALIGHT, MIFARE MOBILE, MIGLO, NTAG, ROADLINK, SMARTLX, SMARTMX, STARPLUG, TOPFET, TRENCHMOS, UCODE, Freescale, the Freescale logo, Altiview, CodeWarrior, ColdFire, ColdFire+, the Energy Efficient Solutions logo, Kinetics, Layerscape, MagniV, mobileGT, PEG, PowerQUICC, Processor Expert, QorIQ, QorIQ Qonverge, SafeAssure, the SafeAssure logo, StarCore, Symphony, VortiQa, Vybrid, Airfast, BeeKit, BeeStack, CoreNet, Flexis, MXC, Platform in a Package, QUICC Engine, Tower, TurboLink, EdgeScale, EdgeLock, eIQ, and Immersive3D are trademarks of NXP B.V. All other product or service names are the property of their respective owners. AMBA, Arm, Arm7, Arm7TDMI, Arm9, Arm11, Artisan, big.LITTLE, Cordic, CoreLink, CoreSight, Cortex, DesignStart, DynamIQ, Jazelle, Keil, Mali, Mbed, Mbed Enabled, NEON, POP, RealView, SecurCore, Socrates, Thumb, TrustZone, ULINK, ULINK2, ULINK-ME, ULINK-PLUS, ULINKpro, µVision, Versatile are trademarks or registered trademarks of Arm Limited (or its subsidiaries) in the US and/or elsewhere. The related technology may be protected by any or all of patents, copyrights, designs and trade secrets. All rights reserved. Oracle and Java are registered trademarks of Oracle and/or its affiliates. The Power Architecture and Power.org word marks and the Power and Power.org logos are trademarks and service marks licensed by Power.org. M, M Mobileye and other Mobileye trademarks or logos appearing herein are trademarks of Mobileye Vision Technologies Ltd. in the United States, the EU and/or other jurisdictions.