Contents

Chapter 1 Library.......................................................................................................................... 4
  1.1 Introduction............................................................................................................................. 4
    1.1.1 Overview......................................................................................................................... 4
    1.1.2 Data types....................................................................................................................... 4
    1.1.3 API definition.................................................................................................................... 4
    1.1.4 Supported compilers.......................................................................................................... 5
    1.1.5 Library configuration......................................................................................................... 5
    1.1.6 Special issues..................................................................................................................... 5
  1.2 Library integration into project (MCUXpresso IDE) .............................................................. 5
  1.3 Library integration into project (Keil µVision).......................................................................... 8
  1.4 Library integration into project (IAR Embedded Workbench)............................................... 15

Chapter 2 Algorithms in detail..................................................................................................... 22
  2.1 AMCLIB_AngleTrackObsrv.................................................................................................... 22
    2.1.1 Available versions............................................................................................................. 24
    2.1.2 AMCLIB_ANGLE_TRACK_OBSRV_T_F32..................................................................... 25
    2.1.3 Declaration....................................................................................................................... 26
    2.1.4 Function use..................................................................................................................... 26
  2.2 AMCLIB_CtrlFluxWkng......................................................................................................... 27
    2.2.1 Available versions............................................................................................................. 29
    2.2.2 AMCLIB_CTRL_FLUX_WKNG_T_A32............................................................................ 30
    2.2.3 Declaration....................................................................................................................... 30
    2.2.4 Function use..................................................................................................................... 30
  2.3 AMCLIB_PMSMBemfObsrvDQ.............................................................................................. 31
    2.3.1 Available versions............................................................................................................. 34
    2.3.2 AMCLIB_BEMF_OBSRV_DQ_T_A32 type description....................................................... 35
    2.3.3 Declaration....................................................................................................................... 36
    2.3.4 Function use..................................................................................................................... 37
  2.4 AMCLIB_PMSMBemfObsrvAB.............................................................................................. 37
    2.4.1 Available versions............................................................................................................. 40
    2.4.2 AMCLIB_BEMF_OBSRV_AB_T_A32 type description....................................................... 41
    2.4.3 Declaration....................................................................................................................... 42
    2.4.4 Function use..................................................................................................................... 42
  2.5 AMCLIB_TrackObsrv............................................................................................................. 43
    2.5.1 Available versions............................................................................................................. 44
    2.5.2 AMCLIB_TRACK_OBSRV_T_F32.................................................................................. 45
    2.5.3 Declaration....................................................................................................................... 46
    2.5.4 Function use..................................................................................................................... 46

Appendix A Library types.............................................................................................................. 48
  A.1 bool_t................................................................................................................................. 48
  A.2 uint8_t............................................................................................................................... 48
  A.3 uint16_t.............................................................................................................................. 49
  A.4 uint32_t.............................................................................................................................. 50
  A.5 int8_t.................................................................................................................................... 50
  A.6 int16_t.................................................................................................................................... 51
  A.7 int32_t.................................................................................................................................... 51
Chapter 1
Library

1.1 Introduction

1.1.1 Overview
This user's guide describes the Advanced Motor Control Library (AMCLIB) for the family of ARM Cortex M4 core-based microcontrollers. This library contains optimized functions.

1.1.2 Data types
AMCLIB supports several data types: (un)signed integer, fractional, and accumulator. The integer data types are useful for general-purpose computation; they are familiar to the MPU and MCU programmers. The fractional data types enable powerful numeric and digital-signal-processing algorithms to be implemented. The accumulator data type is a combination of both; that means it has the integer and fractional portions.

The following list shows the integer types defined in the libraries:
- **Unsigned 16-bit integer**—<0 ; 65535> with the minimum resolution of 1
- **Signed 16-bit integer**—<-32768 ; 32767> with the minimum resolution of 1
- **Unsigned 32-bit integer**—<0 ; 4294967295> with the minimum resolution of 1
- **Signed 32-bit integer**—<-2147483648 ; 2147483647> with the minimum resolution of 1

The following list shows the fractional types defined in the libraries:
- **Fixed-point 16-bit fractional**—<-1 ; 1 - 2 \(^{-15}\)> with the minimum resolution of 2\(^{-15}\)
- **Fixed-point 32-bit fractional**—<-1 ; 1 - 2 \(^{-31}\)> with the minimum resolution of 2\(^{-31}\)

The following list shows the accumulator types defined in the libraries:
- **Fixed-point 16-bit accumulator**—<-256.0 ; 256.0 - 2 \(^{-7}\)> with the minimum resolution of 2\(^{-7}\)
- **Fixed-point 32-bit accumulator**—<-65536.0 ; 65536.0 - 2 \(^{-15}\)> with the minimum resolution of 2\(^{-15}\)

1.1.3 API definition
AMCLIB uses the types mentioned in the previous section. To enable simple usage of the algorithms, their names use set prefixes and postfixes to distinguish the functions' versions. See the following example:

```c
f32Result = MLIB_Mac_F32lss(f32Accum, f16Mult1, f16Mult2);
```

where the function is compiled from four parts:
- **MLIB**—this is the library prefix
- **Mac**—the function name—Multiply-Accumulate
- **F32**—the function output type
- **lss**—the types of the function inputs; if all the inputs have the same type as the output, the inputs are not marked

The input and output types are described in the following table:
<table>
<thead>
<tr>
<th>Type</th>
<th>Output</th>
<th>Input</th>
</tr>
</thead>
<tbody>
<tr>
<td>frac16_t</td>
<td>F16</td>
<td>s</td>
</tr>
<tr>
<td>frac32_t</td>
<td>F32</td>
<td>l</td>
</tr>
<tr>
<td>acc32_t</td>
<td>A32</td>
<td>a</td>
</tr>
</tbody>
</table>

### 1.1.4 Supported compilers
AMCLIB for the ARM Cortex M4 core is written in C language or assembly language with C-callable interface depending on the specific function. The library is built and tested using the following compilers:

- MCUXpresso IDE
- IAR Embedded Workbench
- Keil µVision

For the MCUXpresso IDE, the library is delivered in the `amclib.a` file.

For the IAR Embedded Workbench, the library is delivered in the `amclib.a` file.

For the Keil µVision, the library is delivered in the `amclib.lib` file.

The interfaces to the algorithms included in this library are combined into a single public interface include file, `amclib.h`. This is done to lower the number of files required to be included in your application.

### 1.1.5 Library configuration
AMCLIB for the ARM Cortex M4 core is written in C language or assembly language with C-callable interface depending on the specific function. Some functions from this library are inline type, which are compiled together with project using this library. The optimization level for inline function is usually defined by the specific compiler setting. It can cause an issue especially when high optimization level is set. Therefore the optimization level for all inline assembly written functions is defined by compiler pragmas using macros. The configuration header file `RTCESL_cfg.h` is located in: specific library folder\MLIB\Include. The optimization level can be changed by modifying the macro value for specific compiler. In case of any change the library functionality is not guaranteed.

### 1.1.6 Special issues
1. The equations describing the algorithms are symbolic. If there is positive 1, the number is the closest number to 1 that the resolution of the used fractional type allows. If there are maximum or minimum values mentioned, check the range allowed by the type of the particular function version.

2. The library functions that round the result (the API contains Rnd) round to nearest (half up).

3. This RTCESL requires the DSP extension for some saturation functions. If the core does not support the DSP extension feature the assembler code of the RTCESL will not be buildable. For example the core1 of the LPC55s69 has no DSP extension.

### 1.2 Library integration into project (MCUXpresso IDE)
This section provides a step-by-step guide on how to quickly and easily include AMCLIB into any MCUXpresso SDK example or new SDK project using MCUXpresso IDE. The SDK based project uses RTCESL from SDK package.
Adding RTCESL component to project

The MCUXpresso SDK package is necessary to add any example or new project and RTCESL component. In case the package has not been downloaded go to mcuxpresso.nxp.com, build the final MCUXpresso SDK package for required board and download it.

After package is downloaded, open the MCUXpresso IDE and drag&drop the SDK package in zip format to the Installed SDK window of the MCUXpresso IDE. After SDK package is dropped the message accepting window appears as can be show in following figure.

![Figure 1. MCUXpresso IDE - importing the SDK package to MCUXpresso IDE](image)

Click OK to confirm the SDK package import. Find the Quickstart panel in left bottom part of the MCUXpresso IDE and click New project... item or Import SDK example(s)... to add rtcesl component to the project.
Then select your board, and click Next button.

Find the Middleware tab in the Components part of the window and click on the checkbox to be the rtcesl component ticked. Last step is to click the Finish button and wait for project creating with all RTCESL libraries and include paths.
Figure 4. MCUXpresso IDE - selecting rtcesl component

Type the #include syntax into the code where you want to call the library functions. In the left-hand dialog, open the required .c file. After the file opens, include the following lines into the #include section:

```
#include "mlib.h"
#include "gflib.h"
#include "gdflib.h"
#include "gmclib.h"
#include "amclib.h"
```

When you click the Build icon (hammer), the project is compiled without errors.

1.3 Library integration into project (Keil µVision)

This section provides a step-by-step guide on how to quickly and easily include AMCLIB into an empty project or any MCUXpresso SDK example or demo application projects using Keil µVision. This example uses the default installation path (C:\NXP\RTCESL\CM4_RTCESL_4.6_KEIL). If you have a different installation path, use that path instead. If any MCUXpresso SDK project is intended to use (for example hello_world project) go to Linking the files into the project chapter otherwise read next chapter.

NXP pack installation for new project (without MCUXpresso SDK)

This example uses the NXP MKV46F256xxx15 part, and the default installation path (C:\NXP\RTCESL\CM4_RTCESL_4.6_KEIL) is supposed. If the compiler has never been used to create any NXP MCU-based projects before, check whether the NXP MCU pack for the particular device is installed. Follow these steps:

1. Launch Keil µVision.
2. In the main menu, go to Project > Manage > Pack Installer….
3. In the left-hand dialog (under the Devices tab), expand the All Devices > Freescale (NXP) node.
4. Look for a line called "KVxx Series" and click it.
5. In the right-hand dialog (under the Packs tab), expand the Device Specific node.

6. Look for a node called "Keil::Kinetis_KVxx_DFP." If there are the Install or Update options, click the button to install/update the package. See Figure 5.

7. When installed, the button has the "Up to date" title. Now close the Pack Installer.

---

**New project (without MCUXpresso SDK)**

To start working on an application, create a new project. If the project already exists and is opened, skip to the next section. Follow these steps to create a new project:

1. Launch Keil µVision.

2. In the main menu, select Project > New µVision Project…, and the Create New Project dialog appears.

3. Navigate to the folder where you want to create the project, for example C:\KeilProjects\MyProject01. Type the name of the project, for example MyProject01. Click Save. See Figure 6.

---

**Figure 5. Pack Installer**

---

**Figure 6. Create New Project dialog**

---

4. In the next dialog, select the Software Packs in the very first box.

5. Type 'kv4' into the Search box, so that the device list is reduced to the KV4x devices.

6. Expand the KV4x node.

7. Click the MKV46F256xxx15 node, and then click OK. See Figure 7.
8. In the next dialog, expand the Device node, and tick the box next to the Startup node. See Figure 8.

9. Expand the CMSIS node, and tick the box next to the CORE node.

10. Click OK, and a new project is created. The new project is now visible in the left-hand part of Keil µVision. See Figure 9.
In the main menu, go to Project > Options for Target 'Target1'…, and a dialog appears.

Select the Target tab.

Select Not Used in the Floating Point Hardware option. See Figure 9.

Linking the files into the project

AMCLIB requires MLIB and GDFLIB and GFLIB and GMCLIB to be included too. The following steps show how to include all dependent modules.

To include the library files in the project, create groups and add them.

1. Right-click the Target 1 node in the left-hand part of the Project tree, and select Add Group… from the menu. A new group with the name New Group is added.

2. Click the newly created group, and press F2 to rename it to RTCESL.

3. Right-click the RTCESL node, and select Add Existing Files to Group ‘RTCESL’… from the menu.
4. Navigate into the library installation folder C:\NXP\RTCESL\CM4_RTCESL_4.6_KEIL\MLIB\Include, and select the mlib.h file. If the file does not appear, set the Files of type filter to Text file. Click Add. See Figure 11.

![Figure 11. Adding .h files dialog](image)

5. Navigate to the parent folder C:\NXP\RTCESL\CM4_RTCESL_4.6_KEIL\MLIB, and select the mlib.lib file. If the file does not appear, set the Files of type filter to Library file. Click Add. See Figure 12.

![Figure 12. Adding .lib files dialog](image)

6. Navigate into the library installation folder C:\NXP\RTCESL\CM4_RTCESL_4.6_KEIL\GFLIB\Include, and select the gflib.h file. If the file does not appear, set the Files of type filter to Text file. Click Add.

7. Navigate to the parent folder C:\NXP\RTCESL\CM4_RTCESL_4.6_KEIL\GFLIB, and select the gflib.lib file. If the file does not appear, set the Files of type filter to Library file. Click Add.
8. Navigate into the library installation folder C:\NXP\RTCESL\CM4_RTCESL_4.6_KEIL\GDFLIB\Include, and select the gdflib.h file. If the file does not appear, set the Files of type filter to Text file. Click Add.

9. Navigate to the parent folder C:\NXP\RTCESL\CM4_RTCESL_4.6_KEIL\GDFLIB, and select the gdflib.lib file. If the file does not appear, set the Files of type filter to Library file. Click Add.

10. Navigate into the library installation folder C:\NXP\RTCESL\CM4_RTCESL_4.6_KEIL\GMCLIB\Include, and select the gmclib.h file. If the file does not appear, set the Files of type filter to Text file. Click Add.

11. Navigate to the parent folder C:\NXP\RTCESL\CM4_RTCESL_4.6_KEIL\GMCLIB, and select the gmclib.lib file. If the file does not appear, set the Files of type filter to Library file. Click Add.

12. Navigate into the library installation folder C:\NXP\RTCESL\CM4_RTCESL_4.6_KEIL\AMCLIB\Include, and select the amclib.h file. If the file does not appear, set the Files of type filter to Text file. Click Add.

13. Navigate to the parent folder C:\NXP\RTCESL\CM4_RTCESL_4.6_KEIL\AMCLIB, and select the amclib.lib file. If the file does not appear, set the Files of type filter to Library file. Click Add.

14. Now, all necessary files are in the project tree; see Figure 13. Click Close.

Figure 13. Project workspace

Library path setup

The following steps show the inclusion of all dependent modules.

1. In the main menu, go to Project > Options for Target 'Target1'…, and a dialog appears.

2. Select the C/C++ tab. See Figure 14.

3. In the Include Paths text box, type the following paths (if there are more paths, they must be separated by ';' or add them by clicking the … button next to the text box:
4. Click OK.

5. Click OK in the main dialog.

Type the #include syntax into the code. Include the library into a source file. In the new project, it is necessary to create a source file:

1. Right-click the Source Group 1 node, and Add New Item to Group 'Source Group 1'... from the menu.

2. Select the C File (.c) option, and type a name of the file into the Name box, for example 'main.c'. See Figure 15.
3. Click Add, and a new source file is created and opened up.

4. In the opened source file, include the following lines into the #include section, and create a main function:

```c
#include "mlib.h"
#include "gflib.h"
#include "gdflib.h"
#include "gmclib.h"
#include "amclib.h"

int main(void)
{
    while(1);
}
```

When you click the Build (F7) icon, the project will be compiled without errors.

### 1.4 Library integration into project (IAR Embedded Workbench)

This section provides a step-by-step guide on how to quickly and easily include the AMCLIB into an empty project or any MCUXpresso SDK example or demo application projects using IAR Embedded Workbench. This example uses the default installation path (C:\NXP\RTCESL\CM4_RTCESL_4.6_IAR). If you have a different installation path, use that path instead. If any MCUXpresso SDK project is intended to use (for example hello_world project) go to Linking the files into the project chapter otherwise read next chapter.

#### New project (without MCUXpresso SDK)

This example uses the NXP MKV46F256xxx15 part, and the default installation path (C:\NXP\RTCESL\CM4_RTCESL_4.6_IAR) is supposed. To start working on an application, create a new project. If the project already exists and is opened, skip to the next section. Perform these steps to create a new project:
1. Launch IAR Embedded Workbench.

2. In the main menu, select Project > Create New Project… so that the "Create New Project" dialog appears. See Figure 16.

![Create New Project dialog](image1)

**Figure 16. Create New Project dialog**

3. Expand the C node in the tree, and select the "main" node. Click OK.

4. Navigate to the folder where you want to create the project, for example, C:\IARProjects\MyProject01. Type the name of the project, for example, MyProject01. Click Save, and a new project is created. The new project is now visible in the left-hand part of IAR Embedded Workbench. See Figure 17.

![New project](image2)

**Figure 17. New project**

5. In the main menu, go to Project > Options…, and a dialog appears.

6. In the Target tab, select the Device option, and click the button next to the dialog to select the MCU. In this example, select NXP > KV4x > NXP MKV46F256xxx15. Select None in the FPU option. Click OK. See Figure 18.

![Target tab](image3)

**Figure 18. Target tab**
Library path variable

To make the library integration easier, create a variable that will hold the information about the library path.

1. In the main menu, go to Tools > Configure Custom Argument Variables…, and a dialog appears.
2. Click the New Group button, and another dialog appears. In this dialog, type the name of the group PATH, and click OK. See Figure 19.
3. Click on the newly created group, and click the Add Variable button. A dialog appears.

4. Type this name: RTCESL_LOC

5. To set up the value, look for the library by clicking the ‘…” button, or just type the installation path into the box: C:\NXP\RTCESL\CM4_RTCESL_4.6_IAR. Click OK.

6. In the main dialog, click OK. See Figure 20.

Linking the files into the project
AMCLIB requires MLIB and GDFLIB and GFLIB and GMCLIB to be included too. The following steps show the inclusion of all dependent modules.

To include the library files into the project, create groups and add them.

1. Go to the main menu Project > Add Group…
2. Type RTCESL, and click OK.
3. Click on the newly created node RTCESL, go to Project > Add Group..., and create a MLIB subgroup.
4. Click on the newly created node MLIB, and go to the main menu Project > Add Files… See Figure 22.
5. Navigate into the library installation folder C:\NXP\RTCESL\CM4_RTCESL_4.6_IAR\MLIB\Include, and select the `mlib.h` file. (If the file does not appear, set the file-type filter to Source Files.) Click Open. See Figure 21.

6. Navigate into the library installation folder C:\NXP\RTCESL\CM4_RTCESL_4.6_IAR\MLIB, and select the `mlib.a` file. If the file does not appear, set the file-type filter to Library / Object files. Click Open.

7. Click on the RTCESL node, go to Project > Add Group…, and create a GFLIB subgroup.

8. Click on the newly created node GFLIB, and go to the main menu Project > Add Files….

9. Navigate into the library installation folder C:\NXP\RTCESL\CM4_RTCESL_4.6_IAR\GFLIB\Include, and select the `gflib.h` file. (If the file does not appear, set the file-type filter to Source Files.) Click Open.

10. Navigate into the library installation folder C:\NXP\RTCESL\CM4_RTCESL_4.6_IAR\GFLIB, and select the `gflib.a` file. If the file does not appear, set the file-type filter to Library / Object files. Click Open.

11. Click on the RTCESL node, go to Project > Add Group…, and create a GDFLIB subgroup.

12. Click on the newly created node GDFLIB, and go to the main menu Project > Add Files….

13. Navigate into the library installation folder C:\NXP\RTCESL\CM4_RTCESL_4.6_IAR\GDFLIB\Include, and select the `gdflib.h` file. (If the file does not appear, set the file-type filter to Source Files.) Click Open.

14. Navigate into the library installation folder C:\NXP\RTCESL\CM4_RTCESL_4.6_IAR\GDFLIB, and select the `gdflib.a` file. If the file does not appear, set the file-type filter to Library / Object files. Click Open.

15. Click on the RTCESL node, go to Project > Add Group…, and create a GMCLIB subgroup.

16. Click on the newly created node GMCLIB, and go to the main menu Project > Add Files….

17. Navigate into the library installation folder C:\NXP\RTCESL\CM4_RTCESL_4.6_IAR\GMCLIB\Include, and select the `gmclib.h` file. If the file does not appear, set the file-type filter to Source Files. Click Open.

18. Navigate into the library installation folder C:\NXP\RTCESL\CM4_RTCESL_4.6_IAR\GMCLIB, and select the `gmclib.a` file. If the file does not appear, set the file-type filter to Library / Object files. Click Open.

19. Click on the RTCESL node, go to Project > Add Group…, and create an AMCLIB subgroup.

20. Click on the newly created node AMCLIB, and go to the main menu Project > Add Files….

21. Navigate into the library installation folder C:\NXP\RTCESL\CM4_RTCESL_4.6_IAR\AMCLIB\Include, and select the `amclib.h` file. If the file does not appear, set the file-type filter to Source Files. Click Open.

22. Navigate into the library installation folder C:\NXP\RTCESL\CM4_RTCESL_4.6_IAR\AMCLIB, and select the `amclib.a` file. If the file does not appear, set the file-type filter to Library / Object files. Click Open.

23. Now you will see the files added in the workspace. See Figure 22.
Library path setup

The following steps show the inclusion of all dependent modules:

1. In the main menu, go to Project > Options…, and a dialog appears.
2. In the left-hand column, select C/C++ Compiler.
3. In the right-hand part of the dialog, click on the Preprocessor tab (it can be hidden in the right; use the arrow icons for navigation).
4. In the text box (at the Additional include directories title), type the following folder (using the created variable):
   
   • $RTCESL_LOC\MLIB\Include
   • $RTCESL_LOC\GFLIB\Include
   • $RTCESL_LOC\GDFLIB\Include
   • $RTCESL_LOC\GMCLIB\Include
   • $RTCESL_LOC\AMCLIB\Include

5. Click OK in the main dialog. See Figure 23.
Type the #include syntax into the code. Include the library included into the main.c file. In the workspace tree, double-click the main.c file. After the main.c file opens up, include the following lines into the #include section:

```c
#include "mlib.h"
#include "gflib.h"
#include "gdflib.h"
#include "gmclib.h"
#include "amclib.h"
```

When you click the Make icon, the project will be compiled without errors.
Chapter 2
Algorithms in detail

2.1 AMCLIB_AngleTrackObsrv

The AMCLIB_TrackObsrv function calculates an angle-tracking observer for determination of angular speed and position of the input signal. It requires two input arguments as sine and cosine samples. The practical implementation of the angle-tracking observer algorithm is described below.

The angle-tracking observer compares values of the input signals - sin(θ), cos(θ) with their corresponding estimations. As in any common closed-loop systems, the intent is to minimize the observer error towards zero value. The observer error is given here by subtracting the estimated resolver rotor angle from the actual rotor angle.

The tracking-observer algorithm uses the phase-locked loop mechanism. It is recommended to call this function at every sampling period. It requires a single input argument as phase error. A phase-tracking observer with standard PI controller used as the loop compensator is shown in Figure 1.

![Figure 24. Block diagram of proposed PLL scheme for position estimation](image)

Note that the mathematical expression of the observer error is known as the formula of the difference between two angles:

\[
\sin(\theta - \hat{\theta}) = \sin(\theta) \cdot \cos(\hat{\theta}) - \cos(\theta) \cdot \sin(\hat{\theta})
\]

If the deviation between the estimated and the actual angle is very small, then the observer error may be expressed using the following equation:

\[
\sin(\theta - \hat{\theta}) = \theta - \hat{\theta}
\]

The primary benefit of the angle-tracking observer utilization, in comparison with the trigonometric method, is its smoothing capability. This filtering is achieved by the integrator and the proportional and integral controllers, which are connected in series and closed by a unit feedback loop. This block diagram tracks the actual rotor angle and speed, and continuously updates their estimations. The angle-tracking observer transfer function is expressed as follows:

\[
\frac{\hat{\theta}(s)}{\theta(s)} = \frac{K_f(1 + sK_p)}{s^2 + sK_pK_f + K_f}
\]

The characteristic polynomial of the angle-tracking observer corresponds to the denominator of the following transfer function:

\[
s^2 + sK_fK_2 + K_f
\]
Appropriate dynamic behavior of the angle-tracking observer is achieved by the placement of the poles of characteristic polynomial. This general method is based on matching the coefficients of characteristic polynomial with the coefficients of a general second-order system.

The analog integrators in the previous figure (marked as 1 / s) are replaced by an equivalent of the discrete-time integrator using the backward Euler integration method. The discrete-time block diagram of the angle-tracking observer is shown in the following figure:

The essential equations for implementing the angle-tracking observer (according to this block scheme) are as follows:

\[
e(k) = \sin(\theta(k)) \cdot \cos(\hat{\theta}(k - 1)) - \cos(\theta(k)) \cdot \sin(\hat{\theta}(k - 1))
\]

\[
\alpha(k) = T_s \cdot K_1 \cdot e(k) + \alpha(k - 1)
\]

\[
a_2(k) = T_s \cdot a_2(k) + a_2(k - 1)
\]

\[
\hat{\theta}(k) = K_2 \cdot \omega(k) + a_2(k)
\]

where:
- \(K_1\) is the integral gain of the I controller
- \(K_2\) is the proportional gain of the PI controller
- \(T_s\) is the sampling period [s]
- \(e(k)\) is the position error in step \(k\)
- \(\omega(k)\) is the rotor speed [rad / s] in step \(k\)
- \(\omega(k - 1)\) is the rotor speed [rad / s] in step \(k - 1\)
- \(a(k)\) is the integral output of the PI controller [rad / s] in step \(k\)
- \(a(k - 1)\) is the integral output of the PI controller [rad / s] in step \(k - 1\)
- \(\theta(k)\) is the rotor angle [rad] in step \(k\)
- \(\theta(k - 1)\) is the rotor angle [rad] in step \(k - 1\)
- \(\hat{\theta}(k)\) is the estimated rotor angle [rad] in step \(k\)
- \(\hat{\theta}(k - 1)\) is the estimated rotor angle [rad] in step \(k - 1\)

In the fractional arithmetic, AMCLIB_AngleTrackObsrv_Eq5 to AMCLIB_AngleTrackObsrv_Eq8 are as follows:
\[ e_{sc}(k) = \omega_{s}(k) - \omega_{s}(k-1) \]
\[ \omega_{sc}(k) = T_s \cdot K_i \cdot e(k) + \omega_{ac}(k-1) \]
\[ a_{2ac}(k) = T_s \cdot \omega_{ac}(k) \cdot \omega_{max} + a_{2ac}(k-1) \]
\[ \hat{\theta}_{sc}(k) = K_2 \cdot \omega_{ac}(k) \cdot \omega_{max} + a_{2ac}(k) \cdot \theta_{max} \]

where:
- \( e_{sc}(k) \) is the scaled position error in step \( k \)
- \( \omega_{s}(k) \) is the scaled rotor speed \([\text{rad} / \text{s}]\) in step \( k \)
- \( \omega_{ac}(k-1) \) is the scaled rotor speed \([\text{rad} / \text{s}]\) in step \( k - 1 \)
- \( a_{sc}(k) \) is the integral output of the PI controller \([\text{rad} / \text{s}]\) in step \( k \)
- \( a_{ac}(k-1) \) is the integral output of the PI controller \([\text{rad} / \text{s}]\) in step \( k - 1 \)
- \( \theta_{ac}(k) \) is the scaled rotor angle \([\text{rad}]\) in step \( k \)
- \( \theta_{ac}(k-1) \) is the scaled rotor angle \([\text{rad}]\) in step \( k - 1 \)
- \( \theta_{sc}(k) \) is the scaled rotor angle \([\text{rad}]\) in step \( k \)
- \( \theta_{sc}(k-1) \) is the scaled rotor angle \([\text{rad}]\) in step \( k - 1 \)
- \( \omega_{max} \) is the maximum speed
- \( \theta_{max} \) is the maximum rotor angle (typically \( \pi \))

2.1.1 Available versions

The function is available in the following versions:
- Fractional output - the output is the fractional portion of the result; the result is within the range \(-1 ; 1\).

The available versions of the \texttt{AMCLIB\_AngleTrackObsrv} function are shown in the following table:

Table 2. Init versions

<table>
<thead>
<tr>
<th>Function name</th>
<th>Init angle</th>
<th>Parameters</th>
<th>Result type</th>
</tr>
</thead>
<tbody>
<tr>
<td>AMCLIB_AngleTrackObsrvInit_F16</td>
<td>frac16_t</td>
<td>AMCLIB_ANGLE_TRACK_OBSRV_T_F32 *</td>
<td>void</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The input is a 16-bit fractional value of the angle normalized to the range (-1 ; 1) that represents an angle in (radians) within the range (-\pi ; \pi).</td>
<td></td>
</tr>
</tbody>
</table>

Table 3. Function versions

<table>
<thead>
<tr>
<th>Function name</th>
<th>Input type</th>
<th>Parameters</th>
<th>Result type</th>
</tr>
</thead>
<tbody>
<tr>
<td>AMCLIB_AngleTrackObsrv_F16</td>
<td>GMCLIB_2COOR_SINCOS_T_F16 *</td>
<td>AMCLIB_ANGLE_TRACK_OBSRV_T_F32 *</td>
<td>frac16_t</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Angle-tracking observer with a two-component (sin/cos) 16-bit fractional position input within the range (-1 ; 1). The output from the observer is a 16-bit fractional position normalized to the range (-1 ; 1) that represents an angle (in radians) within the range (-\pi ; \pi).</td>
<td></td>
</tr>
</tbody>
</table>
### 2.1.2 AMCLIB_ANGLE_TRACK_OBSRV_T_F32

<table>
<thead>
<tr>
<th>Variable name</th>
<th>Input type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>f32Speed</td>
<td>frac32_t</td>
<td>Estimated speed as the output of the first numerical integrator. The parameter is within the range (-1 ; 1). Controlled by the AMCLIB_AngleTrackObsrv_F16 algorithm; cleared by the AMCLIB_AngleTrackObsrvInit_F16 function.</td>
</tr>
<tr>
<td>f32A2</td>
<td>frac32_t</td>
<td>Output of the second numerical integrator. The parameter is within the range (-1 ; 1). Controlled by the AMCLIB_AngleTrackObsrv_F16 and AMCLIB_AngleTrackObsrvInit_F16 algorithms.</td>
</tr>
<tr>
<td>f16Theta</td>
<td>frac16_t</td>
<td>Estimated position as the output of the observer. The parameter is normalized to the range (-1 ; 1) that represents an angle (in radians) within the range (-\pi ; \pi). Controlled by the AMCLIB_AngleTrackObsrv_F16 and AMCLIB_AngleTrackObsrvInit_F16 algorithms.</td>
</tr>
<tr>
<td>f16SinEstim</td>
<td>frac16_t</td>
<td>Sine of the estimated position as the output of the actual step. Keeps the sine of the position for the next step. The parameter is within the range (-1 ; 1). Controlled by the AMCLIB_AngleTrackObsrv_F16 and AMCLIB_AngleTrackObsrvInit_F16 algorithms.</td>
</tr>
<tr>
<td>f16CosEstim</td>
<td>frac16_t</td>
<td>Cosine of the estimated position as the output of the actual step. Keeps the cosine of the position for the next step. The parameter is within the range (-1 ; 1). Controlled by the AMCLIB_AngleTrackObsrv_F16 and AMCLIB_AngleTrackObsrvInit_F16 algorithms.</td>
</tr>
<tr>
<td>f16K1Gain</td>
<td>frac16_t</td>
<td>Observer K1 gain is set up according to Equation 9 as: $T_s \cdot K_1 \cdot \frac{\Theta_{max}}{\Theta_{min}} \cdot 2^{-K1sh}$ The parameter is a 16-bit fractional type within the range (0 ; 1). Set by the user.</td>
</tr>
<tr>
<td>i16K1GainSh</td>
<td>int16_t</td>
<td>Observer K2 gain shift takes care of keeping the f16K1Gain variable within the fractional range (-1 ; 1). The shift is determined as: $\log_2(T_s \cdot K_1 \cdot \frac{\Theta_{max}}{\Theta_{min}}) - \log_2(K1sh) - \log_2(0.5)$ The parameter is a 16-bit integer type within the range (-15 ; 15). Set by the user.</td>
</tr>
<tr>
<td>f16K2Gain</td>
<td>frac16_t</td>
<td>Observer K2 gain is set up according to Equation 11 as: $K_2 \cdot \frac{\Theta_{max}}{\Theta_{min}} \cdot 2^{-K2sh}$ The parameter is a 16-bit fractional type within the range (0 ; 1). Set by the user.</td>
</tr>
<tr>
<td>i16K2GainSh</td>
<td>int16_t</td>
<td>Observer K2 gain shift takes care of keeping the f16K2Gain variable within the fractional range (-1 ; 1). The shift is determined as: $\log_2(K_2 \cdot \frac{\Theta_{max}}{\Theta_{min}}) - \log_2(K2sh) - \log_2(0.5)$ The parameter is a 16-bit integer type within the range (-15 ; 15). Set by the user.</td>
</tr>
<tr>
<td>f16A2Gain</td>
<td>frac16_t</td>
<td>Observer A2 gain for the output position is set up according to Equation 10 as: $T_s \cdot \frac{\Theta_{max}}{\Theta_{min}} \cdot 2^{-A2sh}$ The parameter is a 16-bit fractional type within the range (0 ; 1). Set by the user.</td>
</tr>
<tr>
<td>i16A2GainSh</td>
<td>int16_t</td>
<td>Observer A2 gain shift for the position integrator takes care of keeping the f16A2Gain variable within the fractional range (-1 ; 1). The shift is determined as:</td>
</tr>
</tbody>
</table>

*Table continues on the next page...*
2.1.3 Declaration

The available AMCLIB_AngleTrackObsrvInit functions have the following declarations:

```c
void AMCLIB_AngleTrackObsrvInit_F16(frac16_t f16ThetaInit, AMCLIB_ANGLE_TRACK_OBSRV_T_F32 *psCtrl)
```

The available AMCLIB_AngleTrackObsrv functions have the following declarations:

```c
frac16_t AMCLIB_AngleTrackObsrv_F16(const GMCLIB_2COOR_SINCOS_T_F16 *psAnglePos, AMCLIB_ANGLE_TRACK_OBSRV_T_F32 *psCtrl)
```

2.1.4 Function use

The use of the AMCLIB_AngleTrackObsrvInit and AMCLIB_AngleTrackObsrv functions is shown in the following example:

```c
#include "amclib.h"

static AMCLIB_ANGLE_TRACK_OBSRV_T_F32  sAto;
static GMCLIB_2COOR_SINCOS_T_F16 sAnglePos;
static frac16_t      f16PositionEstim, f16PositionInit;

void Isr(void);

void main(void)
{
   sAto.f16K1Gain    = FRAC16(0.6434);
   sAto.i16K1GainSh  = -9;
   sAto.f16K2Gain    = FRAC16(0.6801);
   sAto.i16K2GainSh  = -2;
   sAto.f16A2Gain    = FRAC16(0.6400);
   sAto.i16A2GainSh  = -4;
   f16PositionInit  = FRAC16(0.0);
   AMCLIB_AngleTrackObsrvInit_F16(f16PositionInit, &sAto);
   sAnglePos.f16Sin  = FRAC16(0.0);
   sAnglePos.f16Cos  = FRAC16(1.0);
}
```
2.2 AMCLIB_CtrlFluxWkng

The **AMCLIB_CtrlFluxWkng** function controls the motor magnetizing flux for a speed exceeding above the nominal speed of the motor. Where a higher maximum motor speed is required, the flux (field) weakening technique must be used. The basic task of the function is to maintain the motor magnetizing flux below the nominal level which does not require a higher supply voltage when the motor rotates above the nominal motor speed. The lower magnetizing flux is provided by maintaining the flux-producing current component $i_D$ in the flux-weakening region, as shown in Figure 1).

![Flux weakening operating range](image)

**Figure 26. Flux weakening operating range**

The **AMCLIB_CtrlFluxWkng** function processes the magnetizing flux by the PI controller function with the anti-windup functionality and output limitation. The controller integration can be stopped if the system is saturated by the input flag pointer in the flux-weakening controller structure. The flux-weakening controller algorithm is executed in the following steps:

1. The voltage error calculation from the voltage limit and the required voltage.

   \[
   u_{err} = (u_{QLim} - |u_{Qreq}|) \cdot \frac{I_{gain}}{U_{gain}}
   \]

   **Figure 27.**

   where:
   - $u_{err}$ is the voltage error
   - $u_{QLim}$ is the Q voltage limit component
   - $u_{Qreq}$ is the Q required voltage component
   - $I_{gain}$ is the voltage scale - max. value (for fraction gain = 1)
   - $U_{gain}$ is the current scale - max. value (for fraction gain = 1)

2. The input Q current error component must be positive and filtered by the infinite impulse response first-order filter.
where:

- $i_{QerrIIR}$ is the Q current error component filtered by the first-order IIR
- $i_{Qerr}$ is the input Q current error component (calculated before calling the AMCLIB_CtrlFluxWkng function from the measured and limited required Q current component value).

3. The flux error is obtained from the previously calculated voltage and current errors as follows:

$$i_{err} = i_{QerrIIR} - u_{err}$$

where:

- $i_{err}$ is the Q current error component for the flux PI controller
- $i_{QerrIIR}$ is the current error component filtered by the first-order IIR
- $u_{err}$ is the voltage error for the flux PI controller

4. Finally, the flux error (corresponding the $i_D$) is processed by the flux PI controller:

$$i_{Dreq} = CtrlPI_{pAW}(i_{err})$$

where:

- $i_{Dreq}$ is the required D current component for the current control
- $i_{err}$ is the flux error (corresponding the D current component) for the flux PI controller

The controller output should be used as the required D current component in the fast control loop and concurrently used as an input for the GFLIB_VectorLimit1 function which limits the $i_Q$ controller as follows:

$$i_{Qreq} \leq \sqrt{i_{max}^2 - i_{Dreq}^2}$$

where:

- $i_{Qreq}$ is the required Q current component for the current control
- $i_{max}$ is application current limit
- $i_{Dreq}$ is the required D current component for the current control

The following figure shows an example of applying the flux-weakening controller function in the control structure. The flux controller starts to operate when the $i_Q$ controller is not able to compensate the $i_{Qerr}$ and creates a deviation between its input and output. The flux controller processes the deviation and decreases the flux excitation (for ACIM, or starts to create the flux excitation against a permanent magnet flux in case of PMSM). A lower BEMF causes a higher $i_Q$ and the motor speed increases. The speed controller with $i_{Qreq}$ on the output should be limited by the vector limit1 function because a part of the current is used for flux excitation.
2.2.1 Available versions

This function is available in the following versions:

- Fractional output - the output is the fractional portion of the result; the result is within the range <-1 ; 1) in case of no limitation.
  The parameters are of fractional or accumulator types.

The available versions of the AMCLIB_CtrlFluxWkngInit function are shown in the following table:

<table>
<thead>
<tr>
<th>Function name</th>
<th>Input type</th>
<th>Parameters</th>
<th>Result type</th>
</tr>
</thead>
<tbody>
<tr>
<td>AMCLIB_CtrlFluxWkngInit_F16</td>
<td>frac16_t</td>
<td>AMCLIB_CtrlFluxWkngInit_A32*</td>
<td>void</td>
</tr>
</tbody>
</table>

The inputs are a 16-bit fractional initial value for the flux PI controller integrating the part state and a pointer to the flux-weakening controller’s parameters structure. The function initializes the flux PI controller and the IIR1 filter.

The available versions of the AMCLIB_CtrlFluxWkng function are shown in the following table:

<table>
<thead>
<tr>
<th>Function name</th>
<th>Input type</th>
<th>Parameters</th>
<th>Result type</th>
</tr>
</thead>
<tbody>
<tr>
<td>AMCLIB_CtrlFluxWkng_F16</td>
<td>frac16_t</td>
<td>frac16_t</td>
<td>AMCLIB_CTRL_FLUX_WKNG_T_A32*</td>
</tr>
</tbody>
</table>

The Q current error component value input (Iq controller input) and the Q required voltage value input (Iq controller output) are 16-bit fractional values within the range <-1 ; 1). The Q voltage limit value input (constant value) is a 16-bit fractional value within the range (0 ; 1). The parameters are pointed to by an input pointer. The function returns a 16-bit fractional value in the range <f16LowerLim ; f16UpperLim>. 
2.2.2 AMCLIB_CTRL_FLUX_WKNG_T_A32

<table>
<thead>
<tr>
<th>Variable name</th>
<th>Input type</th>
<th>Description</th>
</tr>
</thead>
</table>
| sFWPIParam      | GFLIB_CTRL_PI_P_AW_T_A32 | The input pointer for the flux PI controller parameter structure. The flux controller output should be negative. Therefore, set at least the following parameters:  
|                 |                    | • a32PGain - proportional gain, the range is <0 ; 65536.0).  
|                 |                    | • a32IGain - integral gain, the range is <0 ; 65536.0).  
|                 |                    | • f16UpperLim - upper limit, the zero value should be set.  
|                 |                    | • f16LowerLim - the lower limit, the range is <-1; 0).  |
| slqErrIIR1Para m | GDLIB_FILTER_IIR1_T_F32 | The input pointer for the IIR1 filter parameter structure. The IIR1 filters the absolute value of the Q current error component for the flux controller. Set at least the following parameters:  
|                 |                    | • sFltCoeff.f32B0 - B0 coefficient, must be divided by 2.  
|                 |                    | • sFltCoeff.f32B1 - B1 coefficient, must be divided by 2.  
|                 |                    | • sFltCoeff.f32A1 - A1 (sign-inverted) coefficient, must be divided by -2 (negative two).  |
| f16IQErrIIR1    | frac32_t           | The IQ current error component, filtered by the IIR1 filter for the flux PI controller, as shown in Equation 2. The output value calculated by the algorithm. |
| f16UFWErr       | frac16_t           | The voltage error, as shown in Equation 1. The output value calculated by the algorithm.                                                   |
| f16FWErr        | frac16_t           | The flux-weakening error, as shown in Equation 3. The output value calculated by the algorithm.                                              |
| *bStopIntegFla g | frac16_t           | The integration of the PI controller is suspended if the stop flag is set. When it is cleared, the integration continues. The pointer is set by the user and controlled by the application. |

2.2.3 Declaration

The available AMCLIB_CtrlFluxWkngInit functions have the following declarations:

```c
void AMCLIB_CtrlFluxWkngInit_F16(frac16_t f16InitVal, AMCLIB_CTRL_FLUX_WKNG_T_A32 *psParam)
```

The available AMCLIB_CtrlFluxWkng functions have the following declarations:

```c
frac16_t AMCLIB_CtrlFluxWkng_F16(frac16_t f16IQErr, frac16_t f16UReq, frac16_t f16ULim,  
AMCLIB_CTRL_FLUX_WKNG_T_A32 *psParam)
```

2.2.4 Function use

The use of the AMCLIB_CtrlFluxWkngInit and AMCLIB_CtrlFluxWkng functions is shown in the following examples:
### Fixed-point version:

```c
#include "amclib.h"

static AMCLIB_CTRL_FLUX_WKNG_T_A32 sCtrl;
static frac16_t f16IQErr, f16UQReq, f16UQLim;
static frac16_t f16IdReq, f16InitVal;
static bool_t bStopIntegFlag;

void Isr(void);

void main(void)
{
    /* Associate input stop integration flag */
    bStopIntegFlag = FALSE;
    sCtrl.bStopIntegFlag = &bStopIntegFlag;

    /* Set PI controller and IIR1 parameters */
    sCtrl.sFWPiParam.a32PGain = ACC32(0.1);
    sCtrl.sFWPiParam.a32IGain = ACC32(0.2);
    sCtrl.sFWPiParam.f16UpperLim = FRAC16(0.);
    sCtrl.sFWPiParam.f16LowerLim = FRAC16(-0.9);
    sCtrl.sIqErrII1Param.sFltCoeff.f32B0 = FRAC32(0.245237275252786 / 2.0);
    sCtrl.sIqErrII1Param.sFltCoeff.f32B1 = FRAC32(0.245237275252786 / 2.0);
    sCtrl.sIqErrII1Param.sFltCoeff.f32A1 = FRAC32(-0.509525449494429 / -2.0);

    /* Flux weakening controller initialization */
    f16InitVal = FRAC16(0.0);
    AMCLIB_CtrlFluxWkngInit_F16(f16InitVal, &sCtrl);

    /* Assign input variable */
    f16IQErr = FRAC16(-0.1);
    f16UQReq = FRAC16(-0.2);
    f16UQLim = FRAC16(0.8);
}

/* Periodical function or interrupt */
void Isr()
{
    /* Flux weakening controller calculation */
    f16Result = AMCLIB_CtrlFluxWkng_F16(f16IQErr, f16UQReq, f16UQLim, &sCtrl);
}
```

### 2.3 AMCLIB_PMSMBemfObsrvDQ

The **AMCLIB_PMSMBemfObsrvDQ** function calculates the algorithm of back-electro-motive force observer in a rotating reference frame. The method for estimating the rotor position and angular speed is based on the mathematical model of an interior PMSM motor with an extended electro-motive force function, which is realized in an estimated quasi-synchronous reference frame $\gamma$-$\delta$ as shown in **Figure 1**.
The back-EMF observer detects the generated motor voltages induced by the permanent magnets. A tracking observer uses the back-EMF signals to calculate the position and speed of the rotor. The transformed model is then derived as follows:

\[
\begin{bmatrix}
    u_d \\
    u_q
\end{bmatrix} = \begin{bmatrix}
    R_s + sL_D & -\omega_rL_Q \\
    \omega_rL_Q & R_s + sL_D
\end{bmatrix} \begin{bmatrix}
    i_d \\
    i_q
\end{bmatrix} + \begin{bmatrix}
    \delta & -\sin(\theta_{error}) \\
    \omega_r & \cos(\theta_{error})
\end{bmatrix} - \begin{bmatrix}
    \Psi_m \\
    -\Psi_m \omega_r
\end{bmatrix}
\]

where:
- \(R_s\) is the stator resistance
- \(L_D\) and \(L_Q\) are the D-axis and Q-axis inductances
- \(\Psi_m\) is the back-EMF constant
- \(\omega_r\) is the angular electrical rotor speed
- \(u_d\) and \(u_q\) are the estimated stator voltages
- \(i_d\) and \(i_q\) are the estimated stator currents
- \(\theta_{error}\) is the error between the actual D-Q frame and the estimated frame position
- \(s\) is the operator of the derivative

The block diagram of the observer in the estimated reference frame is shown in Figure 1. The observer compensator is substituted by a standard PI controller with following equation in the fractional arithmetic.

\[
i_{sc}(k) \cdot i_{max} = K_p \cdot e_{sc}(k) \cdot e_{max} + T_s \cdot K_i \cdot e_{sc}(k) \cdot e_{max} + i_{sc}(k - 1) \cdot i_{max}
\]

where:
- \(K_p\) is the observer proportional gain [-]
- \(K_i\) is the observer integral gain [-]
- \(i_{sc}(k) = [i_\gamma, i_\delta]\) is the scaled stator current vector in the actual step
- \(i_{sc}(k - 1) = [i_\gamma, i_\delta]\) is the scaled stator current vector in the previous step
- \(e_{sc}(k) = [e_\gamma, e_\delta]\) is the scaled stator back-EMF voltage vector in the actual step
- \(i_{max}\) is the maximum current [A]
- \(e_{max}\) is the maximum back-EMF voltage [V]
- \(T_s\) is the sampling time [s]

As shown in Figure 1, the observer model and hence also the PI controller gains in both axes are identical to each other.
The position estimation can now be performed by extracting the $\theta_{error}$ term from the model, and adjusting the position of the estimated reference frame to achieve $\theta_{error} = 0$. Because the $\theta_{error}$ term is only included in the saliency-based EMF component of both $u_\gamma$ and $u_\delta$ axis voltage equations, the Luenberger-based disturbance observer is designed to observe the $u_\gamma$ and $u_\delta$ voltage components. The position displacement information $\theta_{error}$ is then obtained from the estimated back-EMFs as follows:

$$\theta_{error} = \tan\left(-\frac{e_\gamma}{e_\delta}\right)$$

The estimated position

$$\hat{\theta}$$

can be obtained by driving the position of the estimated reference frame to achieve zero displacement $\theta_{error} = 0$. The phase-locked-loop mechanism can be adopted, where the loop compensator ensures correct tracking of the actual rotor flux position by keeping the error signal $\theta_{error}$ zeroed, $\theta_{error} = 0$.

A perfect match between the actual and estimated motor model parameters is assumed, and then the back-EMF transfer function can be simplified as follows:

$$\dot{E}_{\alpha\beta}(s) = -E_{\alpha\beta}(s) \cdot \frac{F_c(s)}{sL_D + R_S + F_c(s)}$$

The appropriate dynamic behavior of the back-EMF observer is achieved by the placement of the poles of the stator current observer characteristic polynomial. This general method is based on matching the coefficients of the characteristic polynomial with the coefficients of the general second-order system.

The back-EMF observer is a Luenberger-type observer with a motor model, which is implemented using the backward Euler transformation as follows:

$$i(k) = \frac{T_s}{L_D + T_sR_S} \cdot u(k) + \frac{T_s}{L_D + T_sR_S} \cdot e(k) + \frac{L_D T_s}{L_D + T_sR_S} \cdot \alpha_\beta(k) \cdot i'(k) + \frac{L_D}{L_D + T_sR_S} \cdot i(k - 1)$$

where:

- $i(k) = [i_\gamma, i_\delta]$ is the stator current vector in the actual step
- $i(k - 1) = [i_\gamma, i_\delta]$ is the stator current vector in the previous step

Figure 34. Block diagram of proposed Luenberger-type stator current observer acting as state filter for back-EMF
• $u(k) = [u_\gamma, u_\delta]$ is the stator voltage vector in the actual step
• $e(k) = [e_\gamma, e_\delta]$ is the stator back-EMF voltage vector in the actual step
• $i'(k) = [i_\gamma, -i_\delta]$ is the complementary stator current vector in the actual step
• $\omega_{n}(k)$ is the electrical angular speed in the actual step
• $T_S$ is the sampling time [s]

This equation is transformed into the fractional arithmetic as follows:

$$i_{sc}(k) \cdot i_{max} = \frac{T_S}{L_D + \frac{T_S}{T_I R_S}} \cdot u_{sc}(k) \cdot u_{max} + \frac{T_S}{L_D + \frac{T_S}{T_I R_S}} \cdot e_{sc}(k) \cdot e_{max} + \frac{L_D T_S}{L_D + \frac{T_S}{T_I R_S}} \cdot \omega_{esc}(k) \cdot \omega_{max} \cdot i_{sc}(k) \cdot i_{max} + \frac{L_D}{L_D + \frac{T_S}{T_I R_S}} \cdot i_{sc}(k-1) \cdot i_{max}$$

where:
• $i_{sc}(k) = [i_\gamma, i_\delta]$ is the scaled stator current vector in the actual step
• $i_{sc}(k-1) = [i_\gamma, i_\delta]$ is the scaled stator current vector in the previous step
• $u_{sc}(k) = [u_\gamma, u_\delta]$ is the scaled stator voltage vector in the actual step
• $e_{sc}(k) = [e_\gamma, e_\delta]$ is the scaled stator back-EMF voltage vector in the actual step
• $i'_sc(k) = [i_\gamma, -i_\delta]$ is the scaled complementary stator current vector in the actual step
• $\omega_{esc}(k)$ is the scaled electrical angular speed in the actual step
• $i_{max}$ is the maximum current [A]
• $e_{max}$ is the maximum back-EMF voltage [V]
• $u_{max}$ is the maximum stator voltage [V]
• $\omega_{max}$ is the maximum electrical angular speed in [rad / s]

If the Luenberger-type stator current observer is properly designed in the stationary reference frame, the back-EMF can be estimated as a disturbance produced by the observer controller. However, this is only valid when the back-EMF term is not included in the observer model. The observer is a closed-loop current observer, therefore it acts as a state filter for the back-EMF term.

The estimate of the extended EMF term can be derived from AMCLIB_PMSMBemfObsrvDQ_Eq3 as follows:

$$\dot{E}_{obs}(s) = \frac{s K_p + K_I}{s^2 L_D + s R_S + s K_p + K_I} E_{obs}(s)$$

The observer controller can be designed by comparing the closed-loop characteristic polynomial with that of a standard second-order system as follows:

$$s^2 + \frac{K_p}{L_D} s + \frac{K_I}{L_D} = s^2 + 2\xi \omega_0 s + \omega_0^2$$

where:
• $\omega_0$ is the natural frequency of the closed-loop system (loop bandwith)
• $\xi$ is the loop attenuation
• $K_p$ is the proportional gain
• $K_I$ is the integral gain

2.3.1 Available versions

This function is available in the following versions:
• Fractional output - the output is the fractional portion of the result; the result is within the range <-1 ; 1). The parameters use the accumulator types.

• Accumulator output with floating-point inputs - the output is the accumulator result; the result is within the range <-1 ; 1). The inputs are 32-bit single precision floating-point values.

The available versions of the AMCLIB_PMSMBemfObsrvDQ function are shown in the following table:

### Table 6. Init versions

<table>
<thead>
<tr>
<th>Function name</th>
<th>Parameters</th>
<th>Result type</th>
</tr>
</thead>
<tbody>
<tr>
<td>AMCLIB_PMSMBemfObsrvDQInit_F16</td>
<td>AMCLIB_BEMF_OBSRV_DQ_T_A32 *</td>
<td>void</td>
</tr>
<tr>
<td>Initialization does not have any input.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Table 7. Function versions

<table>
<thead>
<tr>
<th>Function name</th>
<th>Input/output type</th>
<th>Result type</th>
</tr>
</thead>
<tbody>
<tr>
<td>AMCLIB_PMSMBemfObsrvDQ_F16</td>
<td>Input GMCLIB_2COOR_DQ_T_F16 * GMCLIB_2COOR_DQ_T_F16 *</td>
<td>frac16_t frac16_t</td>
</tr>
<tr>
<td>Parameters AMCLIB_BEMF_OBSRV_DQ_T_A32 *</td>
<td>Back-EMF observer with a 16-bit fractional input D-Q current and voltage, and a 16-bit electrical speed. All are within the range &lt;-1 ; 1).</td>
<td></td>
</tr>
</tbody>
</table>

#### 2.3.2 AMCLIB_BEMF_OBSRV_DQ_T_A32 type description

<table>
<thead>
<tr>
<th>Variable name</th>
<th>Data type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>sEObsrv</td>
<td>GMCLIB_2COOR_DQ_T_F32</td>
<td>Estimated back-EMF voltage structure.</td>
</tr>
<tr>
<td>sIObsrv</td>
<td>GMCLIB_2COOR_DQ_T_F32</td>
<td>Estimated current structure.</td>
</tr>
<tr>
<td>sCtrl</td>
<td>f32ID_1 frac32_t</td>
<td>State variable in the alpha part of the observer, integral part at step k - 1. The variable is within the range &lt;-1 ; 1).</td>
</tr>
<tr>
<td></td>
<td>f32IQ_1 frac32_t</td>
<td>State variable in the beta part of the observer, integral part at step k - 1. The variable is within the range &lt;-1 ; 1).</td>
</tr>
<tr>
<td>a32PGain</td>
<td>acc32_t</td>
<td>The observer proportional gain is set up according to Equation 7 as: $$2\xi_0 L_D - R_s \frac{i_{\text{max}}}{e_{\text{max}}}$$ The parameter is within the range &lt;0 ; 65536.0). Set by the user.</td>
</tr>
<tr>
<td>a32IGain</td>
<td>acc32_t</td>
<td>The observer integral gain is set up according to Equation 7 as: $$\omega_0^2 L_D T_s \frac{i_{\text{max}}}{e_{\text{max}}}$$</td>
</tr>
</tbody>
</table>

Table continues on the next page...
### Table continued from the previous page...

<table>
<thead>
<tr>
<th>Variable name</th>
<th>Data type</th>
<th>Description</th>
</tr>
</thead>
</table>
| a32IGain      | acc32_t   | The current coefficient gain is set up according to Equation 5 as: \[ \frac{L_D}{L_D + T_s R_s} \]

The parameter is within the range <0 ; 65536.0). Set by the user.

| a32UGain      | acc32_t   | The voltage coefficient gain is set up according to Equation 5 as: \[ \frac{T_s}{L_D + T_s R_s} \cdot \frac{u_{\text{max}}}{l_{\text{max}}} \]

The parameter is within the range <0 ; 65536.0). Set by the user.

| a32WIGain     | acc32_t   | The angular speed coefficient gain is set up according to Equation 5 as: \[ \frac{L_Q T_s}{L_D + T_s R_s} \cdot \omega_{\text{max}} \]

The parameter is within the range <0 ; 65536.0). Set by the user.

| a32EGain      | acc32_t   | The back-EMF coefficient gain is set up according to Equation 5 as: \[ \frac{T_s}{L_D + T_s R_s} \cdot \frac{e_{\text{max}}}{l_{\text{max}}} \]

The parameter is within the range <0 ; 65536.0). Set by the user.

| f16Error      | frac16_t  | Output - estimated phase error between a real D / Q frame system and an estimated D / Q reference system. The error is within the range <-1 ; 1). |

### 2.3.3 Declaration

The available AMCLIB_PMSMBemfObsrvDQInit functions have the following declarations:

```c
void AMCLIB_PMSMBemfObsrvDQInit_F16(AMCLIB_BEMF_OBSRV_DQ_T_A32 *psCtrl)
```

The available AMCLIB_PMSMBemfObsrvDQ functions have the following declarations:

```c
frac16_t AMCLIB_PMSMBemfObsrvDQ_F16(const GMCLIB_2COOR_DQ_T_F16 *psIDQ, const GMCLIB_2COOR_DQ_T_F16 *psUDQ, frac16_t f16Speed, AMCLIB_BEMF_OBSRV_DQ_T_A32 *psCtrl)
```
2.3.4 Function use

The use of the `AMCLIB_PMSMBemfObsrvDQ` function is shown in the following example:

```c
#include "amclib.h"

static GMCLIB_2COOR_DQ_T_F16       sIdq, sUdq;
static AMCLIB_BEMF_OBSRV_DQ_T_A32  sBemfObsrv;
static frac16_t f16Speed, f16Error;

void Isr(void);

void main (void)
{
    sBemfObsrv.sCtrl.a32PGain= ACC32(1.697);
    sBemfObsrv.sCtrl.a32IGain= ACC32(0.134);
    sBemfObsrv.a32IGain = ACC32(0.986);
    sBemfObsrv.a32UGain = ACC32(0.170);
    sBemfObsrv.a32WIGain= ACC32(0.110);
    sBemfObsrv.a32EGain = ACC32(0.116);

    /* Initialization of the observer's structure */
    AMCLIB_PMSMBemfObsrvDQInit_F16(&sBemfObsrv);

    sIdq.f16D = FRAC16(0.05);
    sIdq.f16Q = FRAC16(0.1);
    sUdq.f16D = FRAC16(0.2);
    sUdq.f16Q = FRAC16(-0.1);
}

/* Periodical function or interrupt */
void Isr(void)
{
    /* BEMF Observer calculation */
    f16Error = AMCLIB_PMSMBemfObsrvDQ_F16(&sIdq, &sUdq, f16Speed, &sBemfObsrv);
}
```

2.4 AMCLIB_PMSMBemfObsrvAB

The `AMCLIB_PMSMBemfObsrvAB` function calculates the algorithm of the back-electro-motive force (back-EMF) observer in a stationary reference frame. The estimation method for the rotor position and the angular speed is based on the mathematical model of an interior PMSM motor with an extended electro-motive force function, which is realized in the alpha/beta stationary reference frame.

The back-EMF observer detects the generated motor voltages, induced by the permanent magnets. The angle-tracking observer uses the back-EMF signals to calculate the position and speed of the rotor. The transformed model is then derived as:

\[
\begin{bmatrix}
    i_d \\
    i_q
\end{bmatrix} = \begin{bmatrix}
    R_s + sL_d & \omega_r L_T \\
    -\omega_r L_T & R_s + sL_d
\end{bmatrix} \begin{bmatrix}
    i_d \\
    i_q
\end{bmatrix} + \frac{1}{L_s} \begin{bmatrix}
    \omega_r \\
    \dot{\theta}_r
\end{bmatrix} \left( i_d D - \phi_d \right) + \frac{1}{L_s} \begin{bmatrix}
    - \sin(\theta_r) \\
    \cos(\theta_r)
\end{bmatrix}
\]

Where:

- \( R_s \) is the stator resistance
- \( L_d \) and \( L_q \) are the D-axis and Q-axis inductances
- \( \Delta L = L_d - L_q \) is the motor saliency
• $\Psi_m$ is the back-EMF constant
• $\omega_r$ is the angular electrical rotor speed
• $u_\alpha$ and $u_\beta$ are the estimated stator voltages
• $i_\alpha$ and $i_\beta$ are the estimated stator currents
• $\theta_e$ is the estimated rotor electrical position
• $s$ is the operator of the derivative

This extended back-EMF model includes both the position information from the conventionally defined back-EMF and the stator inductance as well. This enables extracting the rotor position and velocity information by estimating the extended back-EMF only.

Both the alpha and beta axes consist of the stator current observer based on the RL motor circuit which requires the motor parameters.

The current observer input is the sum of the actual applied motor voltage and the cross-coupled rotational term, which corresponds to the motor saliency ($L_D - L_Q$) and the compensator corrective output. The observer provides the back-EMF signals as a disturbance because the back-EMF is not included in the observer model.

The block diagram of the observer in the estimated reference frame is shown in Figure 1. The observer compensator is substituted by a standard PI controller with following equation in the fractional arithmetic.

$$i_{sc}(k) \cdot i_{\text{max}} = K_p \cdot e_{sc}(k) \cdot e_{\text{max}} + T_s \cdot K_i \cdot e_{sc}(k) \cdot e_{\text{max}} + i_{sc}(k - 1) \cdot i_{\text{max}}$$

where:
• $K_p$ is the observer proportional gain [-]
• $K_i$ is the observer integral gain [-]
• $i_{sc}(k) = [i_{\gamma}, i_{\delta}]$ is the scaled stator current vector in the actual step
• $i_{sc}(k - 1) = [i_{\gamma}, i_{\delta}]$ is the scaled stator current vector in the previous step
• $e_{sc}(k) = [e_{\gamma}, e_{\delta}]$ is the scaled stator back-EMF voltage vector in the actual step
• $i_{\text{max}}$ is the maximum current [A]
• $e_{\text{max}}$ is the maximum back-EMF voltage [V]
• $T_s$ is the sampling time [s]

As shown in Figure 1, the observer model and hence also the PI controller gains in both axes are identical to each other.
It is obvious that the accuracy of the back-EMF estimates is determined by the correctness of the motor parameters used (R, L), the fidelity of the reference stator voltage, and the quality of the compensator, such as the bandwidth, phase lag, and so on.

The appropriate dynamic behavior of the back-EMF observer is achieved by the placement of the poles of the stator current observer characteristic polynomial. This general method is based on matching the coefficients of the characteristic polynomial to the coefficients of the general second-order system.

The back-EMF observer is a Luenberger-type observer with a motor model, which is implemented using the backward Euler transformation as:

\[
\dot{E}_{eq}(s) = -E_{eq}(s) \cdot \frac{F_c(s)}{sL_D + R_S + F_c(s)}
\]

This equation is transformed into the fractional arithmetic as:

\[
i(k) = \frac{T_s}{L_D + T_s R_S} \cdot u(k) + \frac{T_s}{L_D + T_s R_S} \cdot e(k) - \frac{AL T_s}{L_D + T_s R_S} \cdot \omega_e(k) \cdot i'(k) + \frac{L_p}{L_D + T_s R_S} \cdot i(k - 1)
\]

Where:

- \(i(k) = [i_\gamma, i_\delta]\) is the stator current vector in the actual step
- \(i(k - 1) = [i_\gamma, i_\delta]\) is the stator current vector in the previous step
- \(u(k) = [u_\gamma, u_\delta]\) is the stator voltage vector in the actual step
- \(e(k) = [e_\gamma, e_\delta]\) is the stator back-EMF voltage vector in the actual step
- \(i'(k) = [i_\gamma, -i_\delta]\) is the complementary stator current vector in the actual step
- \(\omega_e(k)\) is the electrical angular speed in the actual step
- \(T_S\) is the sampling time [s]

This equation is transformed into the fractional arithmetic as:
Where:

- $i_{sc}(k) = [i_\gamma, i_\delta]$ is the scaled stator current vector in the actual step
- $i_{sc}(k - 1) = [i_\gamma, i_\delta]$ is the scaled stator current vector in the previous step
- $u_{sc}(k) = [u_\gamma, u_\delta]$ is the scaled stator voltage vector in the actual step
- $e_{sc}(k) = [e_\gamma, e_\delta]$ is the scaled stator back-EMF voltage vector in the actual step
- $i'_{sc}(k) = [i_\gamma, -i_\delta]$ is the scaled complementary stator current vector in the actual step
- $\omega_{esc}(k)$ is the scaled electrical angular speed in the actual step
- $i_{max}$ is the maximum current [A]
- $e_{max}$ is the maximum back-EMF voltage [V]
- $u_{max}$ is the maximum stator voltage [V]
- $\omega_{max}$ is the maximum electrical angular speed in [rad / s]

If the Luenberger-type stator current observer is properly designed in the stationary reference frame, the back-EMF can be estimated as a disturbance produced by the observer controller. However, this is only valid when the back-EMF term is not included in the observer model. The observer is a closed-loop current observer, therefore, it acts as a state filter for the back-EMF term.

The estimate of the extended EMF term can be derived from $\text{AMCLIB_PMSMBemfObsrvAB}_\text{Eq1}$ as:

\[
- \frac{\dot{E}_{sc}(s)}{E_{sc}(s)} = \frac{sK_p + K_i}{s^2L_D + sR_S + sK_p + K_i}
\]

The observer controller can be designed by comparing the closed-loop characteristic polynomial to that of a standard second-order system as:

\[
s^2 + \frac{K_p}{L_D} + \frac{R_S}{s} + \frac{K_i}{L_D} = s^2 + 2\xi\omega_0s + \omega_0^2
\]

where:

- $\omega_0$ is the natural frequency of the closed-loop system (loop bandwidth)
- $\xi$ is the loop attenuation
- $K_p$ is the proportional gain
- $K_i$ is the integral gain

### 2.4.1 Available versions

This function is available in the following versions:

- Fractional output - the output is the fractional portion of the result; the result is within the range <-1 ; 1). The parameters use the accumulator types.

The available versions of the $\text{AMCLIB_PMSMBemfObsrvAB}$ function are shown in the following table:
Table 8. Init versions

<table>
<thead>
<tr>
<th>Function name</th>
<th>Parameters</th>
<th>Result type</th>
</tr>
</thead>
<tbody>
<tr>
<td>AMCLIB_PMSMBemfObsrvABInit_F16</td>
<td>AMCLIB_BEMF_OBSRV_AB_T_A32 *</td>
<td>void</td>
</tr>
<tr>
<td></td>
<td>The initialization does not have an input.</td>
<td></td>
</tr>
</tbody>
</table>

The available versions of the AMCLIB_PMSMBemfObsrvAB function are shown in the following table:

Table 9. Function versions

<table>
<thead>
<tr>
<th>Function name</th>
<th>Input/output type</th>
<th>Result type</th>
</tr>
</thead>
<tbody>
<tr>
<td>AMCLIB_PMSMBemfObsrvAB_F16</td>
<td>Input GMCLIB_2COOR_ALBE_T_F16</td>
<td>void</td>
</tr>
<tr>
<td></td>
<td>Input GMCLIB_2COOR_ALBE_T_F16</td>
<td>void</td>
</tr>
<tr>
<td></td>
<td>frac16_t</td>
<td></td>
</tr>
<tr>
<td>Parameters</td>
<td>AMCLIB_BEMF_OBSRV_AB_T_A32 *</td>
<td></td>
</tr>
<tr>
<td></td>
<td>The back-EMF observer with a 16-bit fractional input Alpha/Beta current and voltage, and a 16-bit electrical speed. All are within the range &lt;-1 ; 1).</td>
<td></td>
</tr>
</tbody>
</table>

2.4.2 AMCLIB_BEMF_OBSRV_AB_T_A32 type description

<table>
<thead>
<tr>
<th>Variable name</th>
<th>Data type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>sEObsrv</td>
<td>GMCLIB_2COOR_ALBE_T_F32</td>
<td>The estimated back-EMF voltage structure.</td>
</tr>
<tr>
<td>sIObsrv</td>
<td>GMCLIB_2COOR_ALBE_T_F32</td>
<td>The estimated current structure.</td>
</tr>
<tr>
<td>sCtrl</td>
<td>f32IAlpha_1</td>
<td>frac32_t</td>
</tr>
<tr>
<td>f32IBeta_1</td>
<td>frac32_t</td>
<td></td>
</tr>
<tr>
<td>a32PGain</td>
<td>acc32_t</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>a32IGain</td>
<td>acc32_t</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>a32IGain</td>
<td>acc32_t</td>
<td></td>
</tr>
</tbody>
</table>

Table continues on the next page...
Table continued from the previous page...

<table>
<thead>
<tr>
<th>Variable name</th>
<th>Data type</th>
<th>Description</th>
</tr>
</thead>
</table>
| a32UGain      | acc32_t   | The voltage coefficient gain is set up according to Equation 5 as:  
\[
\frac{L_D}{L_D + T_s R_S} \cdot \frac{u_{max}}{i_{max}}
\]  
The parameter is within the range <0 ; 65536.0). Set by the user. |
| a32WIGain     | acc32_t   | The angular speed coefficient gain is set up according to Equation 5 as:  
\[
\frac{\Delta T_s}{L_D + T_s R_S} \cdot \omega_{max}
\]  
The parameter is within the range <0 ; 65536.0). Set by the user. |
| a32EGain      | acc32_t   | The back-EMF coefficient gain is set up according to Equation 5 as:  
\[
\frac{T_s}{L_D + T_s R_S} \cdot \frac{e_{max}}{i_{max}}
\]  
The parameter is within the range <0 ; 65536.0). Set by the user. |
| sUnityVctr    | GMCLIB_2COOR_SINCOS_T_F16 | The output - estimated angle as the sin/cos vector. |

2.4.3 Declaration

The available AMCLIB_PMSMBemfObsrvABInit functions have the following declarations:

```c
void AMCLIB_PMSMBemfObsrvABInit_F16(AMCLIB_BEMF_OBSRV_AB_T_A32 *psCtrl)
```

The available AMCLIB_PMSMBemfObsrvAB functions have the following declarations:

```c
void AMCLIB_PMSMBemfObsrvAB_F16(const GMCLIB_2COOR_ALBE_T_F16 *psIAlBe, const GMCLIB_2COOR_ALBE_T_F16 *psUAlBe, frac16_t f16Speed, AMCLIB_BEMF_OBSRV_AB_T_A32 *psCtrl)
```

2.4.4 Function use

The use of the AMCLIB_PMSMBemfObsrvAB function is shown in the following examples:
Fixed-point version:

```c
#include "amlib.h"

static GMCLIB_2COOR_ALBE_T_F16 sIAlBe, sUAlBe;
static AMCLIB_BEMF_OBSRV_AB_T_A32 sBemfObsrv;
static frac16_t f16Speed;

void Isr(void);

void main (void)
{
    sBemfObsrv.sCtrl.a32PGain= ACC32(1.697);
    sBemfObsrv.sCtrl.a32IGain= ACC32(0.134);
    sBemfObsrv.a32IGain = ACC32(0.986);
    sBemfObsrv.a32UGain = ACC32(0.170);
    sBemfObsrv.a32WIGain= ACC32(0.110);
    sBemfObsrv.a32EGain = ACC32(0.116);

    /* Initialization of the observer's structure */
    AMCLIB_PMSMBemfObsrvABInit_F16(&sBemfObsrv);
    sIAlBe.f16Alpha = FRAC16(0.05);
    sIAlBe.f16Beta  = FRAC16(0.1);
    sUAlBe.f16Alpha = FRAC16(0.2);
    sUAlBe.f16Beta  = FRAC16(-0.1);
}

/* Periodical function or interrupt */
void Isr(void)
{
    /* BEMF Observer calculation */
    AMCLIB_PMSMBemfObsrvAB_F16(&sIAlBe, &sUAlBe, f16Speed, &sBemfObsrv);
}
```

2.5 AMCLIB_TrackObsrv

The AMCLIB_TrackObsrv function calculates a tracking observer for the determination of angular speed and position of the input error functional signal. The tracking-observer algorithm uses the phase-locked-loop mechanism. It is recommended to call this function at every sampling period. It requires a single input argument as a phase error. A phase-tracking observer with a standard PI controller used as the loop compensator is shown in Figure 1.

![Figure 36. Block diagram of proposed PLL scheme for position estimation](image)

The depicted tracking observer structure has the following transfer function:
The controller gains $K_p$ and $K_i$ are calculated by comparing the characteristic polynomial of the resulting transfer function to a standard second-order system polynomial.

The essential equations for implementation of the tracking observer according to the block scheme in Figure 1 are as follows:

\[
\hat{\theta}(s) = \frac{sK_p + K_i}{s^2 + sK_p + K_i}
\]

where:

- $K_p$ is the proportional gain
- $K_i$ is the integral gain
- $T_s$ is the sampling period [s]
- $e(k)$ is the position error in step $k$
- $\omega(k)$ is the rotor speed [rad / s] in step $k$
- $\omega(k - 1)$ is the rotor speed [rad / s] in step $k - 1$
- $\theta(k)$ is the rotor angle [rad] in step $k$
- $\theta(k - 1)$ is the rotor angle [rad] in step $k - 1$

In the fractional arithmetic, AMCLIB_TrackObsrv_Eq1 and AMCLIB_TrackObsrv_Eq2 are as follows:

\[
\omega_{sc}(k) = K_p \cdot e_{sc}(k) + T_s \cdot K_i \cdot e_{sc}(k) + \omega_{sc}(k - 1) \cdot \omega_{max}
\]

\[
\theta_{sc}(k) = T_s \cdot \omega_{sc}(k) + \theta_{sc}(k - 1) \cdot \theta_{max}
\]

where:

- $e_{sc}(k)$ is the scaled position error in step $k$
- $\omega_{sc}(k)$ is the scaled rotor speed [rad / s] in step $k$
- $\omega_{sc}(k - 1)$ is the scaled rotor speed [rad / s] in step $k - 1$
- $\theta_{sc}(k)$ is the scaled rotor angle [rad] in step $k$
- $\theta_{sc}(k - 1)$ is the scaled rotor angle [rad] in step $k - 1$
- $\omega_{max}$ is the maximum speed
- $\theta_{max}$ is the maximum rotor angle (typically)

2.5.1 Available versions

The function is available in the following versions:

- Fractional output - the output is the fractional portion of the result; the result is within the range $<-1 ; 1>$.

The available versions of the AMCLIB_TrackObsrv function are shown in the following table:
Table 10. Init versions

<table>
<thead>
<tr>
<th>Function name</th>
<th>Init angle</th>
<th>Parameters</th>
<th>Result type</th>
</tr>
</thead>
<tbody>
<tr>
<td>AMCLIB_TrackObsrvInit_F16</td>
<td>frac16_t</td>
<td>AMCLIB_TRACK_OBSRV_T_F32 *</td>
<td>void</td>
</tr>
</tbody>
</table>

The input is a 16-bit fractional value of the angle normalized to the range <-1; 1) that represents an angle (in radians) within the range <-\pi; \pi>.

Table 11. Function versions

<table>
<thead>
<tr>
<th>Function name</th>
<th>Input type</th>
<th>Parameters</th>
<th>Result type</th>
</tr>
</thead>
<tbody>
<tr>
<td>AMCLIB_TrackObsrv_F16</td>
<td>frac16_t</td>
<td>AMCLIB_TRACK_OBSRV_T_F32 *</td>
<td>frac16_t</td>
</tr>
</tbody>
</table>

Tracking observer with a 16-bit fractional position error input divided by \pi. The output from the observer is a 16-bit fractional position normalized to the range <-1; 1) that represents an angle (in radians) within the range <-\pi; \pi>.

2.5.2 AMCLIB_TRACK_OBSRV_T_F32

<table>
<thead>
<tr>
<th>Variable name</th>
<th>Input type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>f32Theta</td>
<td>frac32_t</td>
<td>Estimated position as the output of the second numerical integrator. The parameter is within the range &lt;-1; 1). Controlled by the algorithm.</td>
</tr>
<tr>
<td>f32Speed</td>
<td>frac32_t</td>
<td>Estimated speed as the output of the first numerical integrator. The parameter is within the range &lt;-1; 1). Controlled by the algorithm.</td>
</tr>
<tr>
<td>f32I_1</td>
<td>frac32_t</td>
<td>State variable in the controller part of the observer; integral part at step k - 1. The parameter is within the range &lt;-1; 1). Controlled by the algorithm.</td>
</tr>
</tbody>
</table>
| f16IGain      | frac16_t   | The observer integral gain is set up according to Equation 4 as:  
\[ T_s \cdot K_I \cdot \frac{1}{\alpha_{max}} \cdot 2^{-ish} \]  
The parameter is a 16-bit fractional type within the range <0; 1). Set by the user. |
| i16IGainSh    | int16_t    | The observer integral gain shift takes care of keeping the f16IGain variable within the fractional range <-1; 1). The shift is determined as:  
\[ \log_2(T_s \cdot K_I \cdot \frac{1}{\alpha_{max}}) - \log_2(1) < Ish \leq \log_2(T_s \cdot K_I \cdot \frac{1}{\alpha_{max}}) - \log_2(0.5) \]  
The parameter is a 16-bit integer type within the range <-15; 15>. Set by the user. |
| f16PGain      | frac16_t   | The observer proportional gain is set up according to Equation 4 as:  
\[ K_P \cdot \frac{1}{\alpha_{max}} \cdot 2^{-psh} \]  
The parameter is a 16-bit fractional type within the range <0; 1). Set by the user. |
| i16PGainSh    | int16_t    | The observer proportional gain shift takes care of keeping the f16PGain variable within the fractional range <-1; 1). The shift is determined as:  
\[ \log_2(K_P \cdot \frac{1}{\alpha_{max}}) - \log_2(1) < Psh \leq \log_2(K_P \cdot \frac{1}{\alpha_{max}}) - \log_2(0.5) \]  
The parameter is a 16-bit integer type within the range <-15; 15>. Set by the user. |

Table continues on the next page...
Table continued from the previous page...

<table>
<thead>
<tr>
<th>Variable name</th>
<th>Input type</th>
<th>Description</th>
</tr>
</thead>
</table>
| f16ThGain     | frac16_t   | The observer gain for the output position integrator is set up according to Equation 5 as: 
\[ T_s \frac{0_{\text{max}}}{\theta_{\text{max}}} \cdot 2^{-T_{\text{sh}}} \]
The parameter is a 16-bit fractional type within the range <0 ; 1). Set by the user. |
| i16ThGainSh   | int16_t    | The observer gain shift for the position integrator takes care of keeping the f16ThGain variable within the fractional range <-1 ; 1). The shift is determined as: 
\[ \log_2(T_s \frac{0_{\text{max}}}{\theta_{\text{max}}}) - \log_2(1 < T_{\text{sh}} \leq \log_2(T_s \frac{0_{\text{max}}}{\theta_{\text{max}}}) - \log_20.5 \]
The parameter is a 16-bit integer type within the range <-15 ; 15>. Set by the user. |

2.5.3 Declaration

The available AMCLIB_TrackObsrvInit functions have the following declarations:

```c
void AMCLIB_TrackObsrvInit_F16(frac16_t f16ThetaInit, AMCLIB_TRACK_OBSRV_T_F32 *psCtrl)
```

The available AMCLIB_TrackObsrv functions have the following declarations:

```c
frac16_t AMCLIB_TrackObsrv_F16(frac16_t f16Error, AMCLIB_TRACK_OBSRV_T_F32 *psCtrl)
```

2.5.4 Function use

The use of the AMCLIB_TrackObsrv function is shown in the following example:

```c
#include "amclib.h"

static AMCLIB_TRACK_OBSRV_T_F32  sTo;
static frac16_t      f16ThetaError;
static frac16_t      f16PositionEstim;

void Isr(void);

void main(void)
{
    sTo.f16IGain     = FRAC16(0.6434);
    sTo.i16IGainSh   = -9;
    sTo.f16PGain     = FRAC16(0.6801);
    sTo.i16PGainSh   = -2;
    sTo.f16ThGain    = FRAC16(0.6400);
    sTo.i16ThGainSh  = -4;

    AMCLIB_TrackObsrvInit_F16(FRAC16(0.0), &sTo);

    f16ThetaError    = FRAC16(0.5);
}

/* Periodical function or interrupt */
void Isr(void)
{
/* Tracking observer calculation */
fl6PositionEstim = AMCLIB_TrackObsrv_F16(f16ThetaError, &sTo);
}
Appendix A
Library types

A.1 bool_t

The bool_t type is a logical 16-bit type. It is able to store the boolean variables with two states: TRUE (1) or FALSE (0). Its definition is as follows:

\[
\text{typedef unsigned short bool_t;}
\]

The following figure shows the way in which the data is stored by this type:

Table 12. Data storage

<table>
<thead>
<tr>
<th>Value</th>
<th>Unused</th>
<th>Logical</th>
</tr>
</thead>
<tbody>
<tr>
<td>TRUE</td>
<td>00000000</td>
<td>00000000</td>
</tr>
<tr>
<td>FALSE</td>
<td>00000000</td>
<td>00000000</td>
</tr>
</tbody>
</table>

To store a logical value as bool_t, use the FALSE or TRUE macros.

A.2 uint8_t

The uint8_t type is an unsigned 8-bit integer type. It is able to store the variables within the range <0 ; 255>. Its definition is as follows:

\[
\text{typedef unsigned char uint8_t;}
\]

The following figure shows the way in which the data is stored by this type:

Table 13. Data storage

<table>
<thead>
<tr>
<th>Value</th>
<th>Integer</th>
<th>Logical</th>
</tr>
</thead>
<tbody>
<tr>
<td>255</td>
<td>11111111</td>
<td>1111111</td>
</tr>
</tbody>
</table>

Table continues on the next page...
The uint16_t type is an unsigned 16-bit integer type. It is able to store the variables within the range <0 ; 65535>. Its definition is as follows:

```c
typedef unsigned short uint16_t;
```

The following figure shows the way in which the data is stored by this type:

<table>
<thead>
<tr>
<th>Value</th>
<th>Integer</th>
</tr>
</thead>
<tbody>
<tr>
<td>65535</td>
<td>1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 F F F F</td>
</tr>
<tr>
<td>5</td>
<td>0 0 0 0 0 0 0 0 0 0 0 0 0 1 0 1</td>
</tr>
<tr>
<td>15518</td>
<td>0 0 1 1 1 1 0 0 1 0 0 1 1 1 1 0</td>
</tr>
<tr>
<td>40768</td>
<td>1 0 0 1 1 1 1 0 1 0 0 0 0 0 0</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Value</th>
<th>Integer</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0</td>
</tr>
<tr>
<td>124</td>
<td>0 1 1 1 1 1 1 1 0 0</td>
</tr>
<tr>
<td>159</td>
<td>1 0 0 1 1 1 1 1 1 1</td>
</tr>
<tr>
<td>11</td>
<td>0 0 0 0 1 1 1 1 1 1</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Value</th>
<th>Integer</th>
</tr>
</thead>
<tbody>
<tr>
<td>15</td>
<td>1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1</td>
</tr>
<tr>
<td>14</td>
<td>0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0</td>
</tr>
<tr>
<td>13</td>
<td>0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0</td>
</tr>
<tr>
<td>12</td>
<td>0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0</td>
</tr>
<tr>
<td>11</td>
<td>0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0</td>
</tr>
<tr>
<td>10</td>
<td>0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0</td>
</tr>
<tr>
<td>9</td>
<td>0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0</td>
</tr>
<tr>
<td>8</td>
<td>0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0</td>
</tr>
<tr>
<td>7</td>
<td>0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0</td>
</tr>
<tr>
<td>6</td>
<td>0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0</td>
</tr>
<tr>
<td>5</td>
<td>0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0</td>
</tr>
<tr>
<td>4</td>
<td>0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0</td>
</tr>
<tr>
<td>3</td>
<td>0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0</td>
</tr>
<tr>
<td>2</td>
<td>0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0</td>
</tr>
<tr>
<td>1</td>
<td>0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0</td>
</tr>
<tr>
<td>0</td>
<td>0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0</td>
</tr>
</tbody>
</table>
**A.4 uint32_t**

The `uint32_t` type is an unsigned 32-bit integer type. It is able to store the variables within the range \(0 \leq \text{value} < 4294967296\). Its definition is as follows:

```c
typedef unsigned long uint32_t;
```

The following figure shows the way in which the data is stored by this type:

<table>
<thead>
<tr>
<th>Value</th>
<th>Integer</th>
</tr>
</thead>
<tbody>
<tr>
<td>4294967295</td>
<td>F F F F F F F</td>
</tr>
<tr>
<td>2147483648</td>
<td>8 0 0 0 0 0 0 0</td>
</tr>
<tr>
<td>55977296</td>
<td>0 5 6 2 5 5 0 0</td>
</tr>
<tr>
<td>3451051828</td>
<td>C D B 2 D F 3 4</td>
</tr>
</tbody>
</table>

**A.5 int8_t**

The `int8_t` type is a signed 8-bit integer type. It is able to store the variables within the range \(-128 \leq \text{value} \leq 127\). Its definition is as follows:

```c
typedef char int8_t;
```

The following figure shows the way in which the data is stored by this type:

<table>
<thead>
<tr>
<th>Value</th>
<th>Sign</th>
<th>Integer</th>
</tr>
</thead>
<tbody>
<tr>
<td>127</td>
<td>0 1 1 1 1 1 1 1</td>
<td></td>
</tr>
<tr>
<td>-128</td>
<td>1 0 0 0 0 0 0 0</td>
<td></td>
</tr>
<tr>
<td>60</td>
<td>0 0 1 1 1 1 0 0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>3</td>
<td>C</td>
</tr>
</tbody>
</table>

Table continues on the next page...
**Table 16. Data storage (continued)**

<table>
<thead>
<tr>
<th>-97</th>
<th>1</th>
<th>0</th>
<th>0</th>
<th>1</th>
<th>1</th>
<th>1</th>
<th>1</th>
<th>1</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>9</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>F</td>
</tr>
</tbody>
</table>

**A.6 int16_t**

The int16_t type is a signed 16-bit integer type. It is able to store the variables within the range <-32768 ; 32767>. Its definition is as follows:

```c
typedef short int16_t;
```

The following figure shows the way in which the data is stored by this type:

**Table 17. Data storage**

<table>
<thead>
<tr>
<th>Value</th>
<th>Sign</th>
<th>Integer</th>
</tr>
</thead>
<tbody>
<tr>
<td>32767</td>
<td>7</td>
<td>F</td>
</tr>
<tr>
<td></td>
<td>F</td>
<td>F</td>
</tr>
<tr>
<td>-32768</td>
<td>8</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td></td>
<td>0</td>
</tr>
<tr>
<td>15518</td>
<td>3</td>
<td>C</td>
</tr>
<tr>
<td></td>
<td>9</td>
<td>E</td>
</tr>
<tr>
<td>-24768</td>
<td>9</td>
<td>F</td>
</tr>
<tr>
<td></td>
<td>4</td>
<td>0</td>
</tr>
</tbody>
</table>

**A.7 int32_t**

The int32_t type is a signed 32-bit integer type. It is able to store the variables within the range <-2147483648 ; 2147483647>. Its definition is as follows:

```c
typedef long int32_t;
```

The following figure shows the way in which the data is stored by this type:

**Table 18. Data storage**

*Table continues on the next page...*
### Table 18. Data storage (continued)

<table>
<thead>
<tr>
<th>Value</th>
<th>S</th>
<th>Integer</th>
</tr>
</thead>
<tbody>
<tr>
<td>2147483647</td>
<td>7</td>
<td>F</td>
</tr>
<tr>
<td>-2147483648</td>
<td>8</td>
<td>0</td>
</tr>
<tr>
<td>55977296</td>
<td>0</td>
<td>3</td>
</tr>
<tr>
<td>-843915468</td>
<td>C</td>
<td>D</td>
</tr>
</tbody>
</table>

### A.8 frac8_t

The `frac8_t` type is a signed 8-bit fractional type. It is able to store the variables within the range `(-1 ; 1)`. Its definition is as follows:

```c
typedef char frac8_t;
```

The following figure shows the way in which the data is stored by this type:

### Table 19. Data storage

<table>
<thead>
<tr>
<th>Value</th>
<th>Sign</th>
<th>Fractional</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.99219</td>
<td>0</td>
<td>1 1 1 1 1 1 1</td>
</tr>
<tr>
<td>-1.0</td>
<td>1</td>
<td>0 0 0 0 0 0 0</td>
</tr>
<tr>
<td>0.46875</td>
<td>0</td>
<td>0 1 1 1 1 1 0 0</td>
</tr>
<tr>
<td>-0.75781</td>
<td>1</td>
<td>0 0 1 1 1 1 1 1</td>
</tr>
</tbody>
</table>

To store a real number as `frac8_t`, use the `FRAC8` macro.
A.9 frac16_t

The frac16_t type is a signed 16-bit fractional type. It is able to store the variables within the range <-1 ; 1). Its definition is as follows:

```c
type short frac16_t;
```

The following figure shows the way in which the data is stored by this type:

Table 20. Data storage

<table>
<thead>
<tr>
<th>Value</th>
<th>Sign</th>
<th>Fractional</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.99997</td>
<td>1</td>
<td>1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1</td>
</tr>
<tr>
<td>-1.0</td>
<td>1</td>
<td>1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0</td>
</tr>
<tr>
<td>0.47357</td>
<td>0</td>
<td>0 1 1 1 1 1 0 0 1 0 0 1 1 1 1 0</td>
</tr>
<tr>
<td>-0.75586</td>
<td>1</td>
<td>1 0 0 1 1 1 1 0 1 0 0 0 0 0 0 0</td>
</tr>
</tbody>
</table>

To store a real number as frac16_t, use the FRAC16 macro.

A.10 frac32_t

The frac32_t type is a signed 32-bit fractional type. It is able to store the variables within the range <-1 ; 1). Its definition is as follows:

```c
type long frac32_t;
```

The following figure shows the way in which the data is stored by this type:

Table 21. Data storage

<table>
<thead>
<tr>
<th>Value</th>
<th>Sign</th>
<th>Fractional</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.9999999995</td>
<td>1</td>
<td>1 1 1 1 1 1 1 1</td>
</tr>
</tbody>
</table>

Table continues on the next page...
Table 21. Data storage (continued)

<table>
<thead>
<tr>
<th></th>
<th>8</th>
<th>0</th>
<th>0</th>
<th>0</th>
<th>0</th>
<th>0</th>
<th>0</th>
<th>0</th>
</tr>
</thead>
<tbody>
<tr>
<td>-1.0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>0.02606645970</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>-0.3929787632</td>
<td>C</td>
<td>D</td>
<td>B</td>
<td>2</td>
<td>D</td>
<td>F</td>
<td>3</td>
<td>4</td>
</tr>
</tbody>
</table>

To store a real number as frac32_t, use the FRAC32 macro.

A.11 acc16_t

The acc16_t type is a signed 16-bit fractional type. It is able to store the variables within the range <-256 ; 256). Its definition is as follows:

```c
typedef short acc16_t;
```

The following figure shows the way in which the data is stored by this type:

Table 22. Data storage

<table>
<thead>
<tr>
<th>Value</th>
<th>15</th>
<th>14</th>
<th>13</th>
<th>12</th>
<th>11</th>
<th>10</th>
<th>9</th>
<th>8</th>
<th>7</th>
<th>6</th>
<th>5</th>
<th>4</th>
<th>3</th>
<th>2</th>
<th>1</th>
<th>0</th>
</tr>
</thead>
<tbody>
<tr>
<td>255.9921875</td>
<td>0</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>7</td>
<td>F</td>
<td>F</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>-256.0</td>
<td>1</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>8</td>
<td>0</td>
<td>0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1.0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>8</td>
<td>0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>-1.0</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>F</td>
<td>F</td>
<td>8</td>
<td>0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13.7890625</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>1</td>
<td>1</td>
<td>0</td>
<td>1</td>
<td>1</td>
<td>0</td>
<td>0</td>
<td>1</td>
<td>0</td>
<td>1</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>0</td>
<td>6</td>
<td>E</td>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>-89.71875</td>
<td>1</td>
<td>1</td>
<td>0</td>
<td>1</td>
<td>0</td>
<td>0</td>
<td>1</td>
<td>1</td>
<td>0</td>
<td>0</td>
<td>1</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>D</td>
<td>3</td>
<td>2</td>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
To store a real number as acc16_t, use the ACC16 macro.

A.12 acc32_t

The acc32_t type is a signed 32-bit accumulator type. It is able to store the variables within the range <-65536 ; 65536). Its definition is as follows:

```c
typedef long acc32_t;
```

The following figure shows the way in which the data is stored by this type:

Table 23. Data storage

<table>
<thead>
<tr>
<th>Value</th>
<th>31</th>
<th>24</th>
<th>23</th>
<th>16</th>
<th>15</th>
<th>8</th>
<th>7</th>
<th>0</th>
</tr>
</thead>
<tbody>
<tr>
<td>65535.999969</td>
<td>7</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td></td>
</tr>
<tr>
<td>-65536.0</td>
<td>8</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>1.0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>8</td>
<td>0</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>-1.0</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>F</td>
<td>8</td>
<td>0</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>23.789734</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>B</td>
<td>E</td>
<td>5</td>
<td>1</td>
<td>6</td>
</tr>
<tr>
<td>-1171.306793</td>
<td>F</td>
<td>D</td>
<td>B</td>
<td>6</td>
<td>5</td>
<td>8</td>
<td>B</td>
<td>C</td>
</tr>
</tbody>
</table>

To store a real number as acc32_t, use the ACC32 macro.

A.13 GMCLIB_3COOR_T_F16

The GMCLIB_3COOR_T_F16 structure type corresponds to the three-phase stationary coordinate system, based on the A, B, and C components. Each member is of the frac16_t data type. The structure definition is as follows:

```c
typedef struct
{
    frac16_t f16A;
    frac16_t f16B;
    frac16_t f16C;
} GMCLIB_3COOR_T_F16;
```

The structure description is as follows:

Table 24. GMCLIB_3COOR_T_F16 members description

<table>
<thead>
<tr>
<th>Type</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>frac16_t</td>
<td>f16A</td>
<td>A component; 16-bit fractional type</td>
</tr>
<tr>
<td>frac16_t</td>
<td>f16B</td>
<td>B component; 16-bit fractional type</td>
</tr>
<tr>
<td>frac16_t</td>
<td>f16C</td>
<td>C component; 16-bit fractional type</td>
</tr>
</tbody>
</table>
A.14 GMCLIB_2COOR_ALBE_T_F16

The GMCLIB_2COOR_ALBE_T_F16 structure type corresponds to the two-phase stationary coordinate system, based on the Alpha and Beta orthogonal components. Each member is of the frac16_t data type. The structure definition is as follows:

```c
typedef struct
{
    frac16_t f16Alpha;
    frac16_t f16Beta;
} GMCLIB_2COOR_ALBE_T_F16;
```

The structure description is as follows:

Table 25. GMCLIB_2COOR_ALBE_T_F16 members description

<table>
<thead>
<tr>
<th>Type</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>frac16_t</td>
<td>f16Alpha</td>
<td>α-component; 16-bit fractional type</td>
</tr>
<tr>
<td>frac16_t</td>
<td>f16Beta</td>
<td>β-component; 16-bit fractional type</td>
</tr>
</tbody>
</table>

A.15 GMCLIB_2COOR_DQ_T_F16

The GMCLIB_2COOR_DQ_T_F16 structure type corresponds to the two-phase rotating coordinate system, based on the D and Q orthogonal components. Each member is of the frac16_t data type. The structure definition is as follows:

```c
typedef struct
{
    frac16_t f16D;
    frac16_t f16Q;
} GMCLIB_2COOR_DQ_T_F16;
```

The structure description is as follows:

Table 26. GMCLIB_2COOR_DQ_T_F16 members description

<table>
<thead>
<tr>
<th>Type</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>frac16_t</td>
<td>f16D</td>
<td>D-component; 16-bit fractional type</td>
</tr>
<tr>
<td>frac16_t</td>
<td>f16Q</td>
<td>Q-component; 16-bit fractional type</td>
</tr>
</tbody>
</table>

A.16 GMCLIB_2COOR_DQ_T_F32

The GMCLIB_2COOR_DQ_T_F32 structure type corresponds to the two-phase rotating coordinate system, based on the D and Q orthogonal components. Each member is of the frac32_t data type. The structure definition is as follows:

```c
typedef struct
{
    frac32_t f32D;
    frac32_t f32Q;
} GMCLIB_2COOR_DQ_T_F32;
```

The structure description is as follows:
**Table 27. GMCLIB_2COOR_DQ_T_F32 members description**

<table>
<thead>
<tr>
<th>Type</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>frac32_t</td>
<td>f32D</td>
<td>D-component; 32-bit fractional type</td>
</tr>
<tr>
<td>frac32_t</td>
<td>f32Q</td>
<td>Q-component; 32-bit fractional type</td>
</tr>
</tbody>
</table>

**A.17 GMCLIB_2COOR_SINCOS_T_F16**

The GMCLIB_2COOR_SINCOS_T_F16 structure type corresponds to the two-phase coordinate system, based on the Sin and Cos components of a certain angle. Each member is of the frac16_t data type. The structure definition is as follows:

```c
typedef struct
{
    frac16_t f16Sin;
    frac16_t f16Cos;
} GMCLIB_2COOR_SINCOS_T_F16;
```

The structure description is as follows:

**Table 28. GMCLIB_2COOR_SINCOS_T_F16 members description**

<table>
<thead>
<tr>
<th>Type</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>frac16_t</td>
<td>f16Sin</td>
<td>Sin component; 16-bit fractional type</td>
</tr>
<tr>
<td>frac16_t</td>
<td>f16Cos</td>
<td>Cos component; 16-bit fractional type</td>
</tr>
</tbody>
</table>

**A.18 FALSE**

The FALSE macro serves to write a correct value standing for the logical FALSE value of the bool_t type. Its definition is as follows:

```c
#define FALSE    ((bool_t)0)
```

```c
#include "mlib.h"
static bool_t bVal;
void main(void)
{
    bVal = FALSE;               /* bVal = FALSE */
}
```

**A.19 TRUE**

The TRUE macro serves to write a correct value standing for the logical TRUE value of the bool_t type. Its definition is as follows:

```c
#define TRUE     ((bool_t)1)
```

```c
#include "mlib.h"
static bool_t bVal;
```
A.20 FRAC8

The FRAC8 macro serves to convert a real number to the frac8_t type. Its definition is as follows:

```c
#define FRAC8(x) ((frac8_t)((x) < 0.9921875 ? ((x) >= -1 ? (x)*0x80 : 0x80) : 0x7F))
```

The input is multiplied by 128 (=2^7). The output is limited to the range <0x80 ; 0x7F>, which corresponds to <-1.0 ; 1.0-2^-7>.

```c
#include "mlib.h"
static frac8_t f8Val;
void main(void)
{
    f8Val = FRAC8(0.187); /* f8Val = 0.187 */
}
```

A.21 FRAC16

The FRAC16 macro serves to convert a real number to the frac16_t type. Its definition is as follows:

```c
#define FRAC16(x) ((frac16_t)((x) < 0.999969482421875 ? ((x) >= -1 ? (x)*0x8000 : 0x8000) : 0x7FFF))
```

The input is multiplied by 32768 (=2^15). The output is limited to the range <0x8000 ; 0x7FFF>, which corresponds to <-1.0 ; 1.0-2^-15>.

```c
#include "mlib.h"
static frac16_t f16Val;
void main(void)
{
    f16Val = FRAC16(0.736); /* f16Val = 0.736 */
}
```

A.22 FRAC32

The FRAC32 macro serves to convert a real number to the frac32_t type. Its definition is as follows:

```c
#define FRAC32(x) ((frac32_t)((x) < 1 ? ((x) >= -1 ? (x)*0x80000000 : 0x80000000) : 0x7FFFFFFF))
```
The input is multiplied by $2^{31}$. The output is limited to the range $<0x80000000 ; 0x7FFFFFFF>$, which corresponds to $<-1.0 ; 1.0-2^{-31}>$.

```c
#include "mlib.h"
static frac32_t f32Val;
void main(void)
{
    f32Val = FRAC32(-0.1735667);  // f32Val = -0.1735667
}
```

### A.23 ACC16

The ACC16 macro serves to convert a real number to the acc16_t type. Its definition is as follows:

```c
#define ACC16(x) ((acc16_t)((x) < 255.9921875 ? ((x) >= -256 ? (x)*0x80 : 0x8000) : 0x7FFF))
```

The input is multiplied by $2^7$. The output is limited to the range $<0x8000 ; 0x7FFF>$ that corresponds to $<-256.0 ; 255.9921875>$.  

```c
#include "mlib.h"
static acc16_t a16Val;
void main(void)
{
    a16Val = ACC16(19.45627);  // a16Val = 19.45627
}
```

### A.24 ACC32

The ACC32 macro serves to convert a real number to the acc32_t type. Its definition is as follows:

```c
#define ACC32(x) ((acc32_t)((x) < 65535.999969482421875 ? ((x) >= -65536 ? (x)*0x8000 : 0x80000000) : 0x7FFFFFFF))
```

The input is multiplied by $2^{15}$. The output is limited to the range $<0x80000000 ; 0x7FFFFFFF>$, which corresponds to $<-65536.0 ; 65536.0-2^{-15}>$.  

```c
#include "mlib.h"
static acc32_t a32Val;
void main(void)
{
    a32Val = ACC32(-13.654437);  // a32Val = -13.654437
}