Freescale™ and the Freescale logo are trademarks of Freescale Semiconductor, Inc. CodeWarrior is a trademark or registered trademark of Freescale Semiconductor, Inc. in the United States and/or other countries. All other product or service names are the property of their respective owners.

Copyright © 2006–2008 by Freescale Semiconductor, Inc. All rights reserved.

Information in this document is provided solely to enable system and software implementers to use Freescale Semiconductor products. There are no express or implied copyright licenses granted hereunder to design or fabricate any integrated circuits or integrated circuits based on the information in this document.

Freescale Semiconductor reserves the right to make changes without further notice to any products herein. Freescale Semiconductor makes no warranty, representation or guarantee regarding the suitability of its products for any particular purpose, nor does Freescale Semiconductor assume any liability arising out of the application or use of any product or circuit, and specifically disclaims any and all liability, including without limitation consequential or incidental damages. “Typical” parameters that may be provided in Freescale Semiconductor data sheets and/or specifications can and do vary in different applications and actual performance may vary over time. All operating parameters, including “Typicals”, must be validated for each customer application by customer's technical experts. Freescale Semiconductor does not convey any license under its patent rights nor the rights of others. Freescale Semiconductor products are not designed, intended, or authorized for use as components in systems intended for surgical implant into the body, or other applications intended to support or sustain life, or for any other application in which the failure of the Freescale Semiconductor product could create a situation where personal injury or death may occur. Should Buyer purchase or use Freescale Semiconductor products for any such unintended or unauthorized application, Buyer shall indemnify and hold Freescale Semiconductor and its officers, employees, subsidiaries, affiliates, and distributors harmless against all claims, costs, damages, and expenses, and reasonable attorney fees arising out of, directly or indirectly, any claim of personal injury or death associated with such unintended or unauthorized use, even if such claim alleges that Freescale Semiconductor was negligent regarding the design or manufacture of the part.

How to Contact Us

<table>
<thead>
<tr>
<th>Corporate Headquarters</th>
<th>Freescale Semiconductor, Inc.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>7700 West Parmer Lane</td>
</tr>
<tr>
<td></td>
<td>Austin, TX 78729</td>
</tr>
<tr>
<td></td>
<td>U.S.A.</td>
</tr>
<tr>
<td>World Wide Web</td>
<td><a href="http://www.freescale.com/codewarrior">http://www.freescale.com/codewarrior</a></td>
</tr>
<tr>
<td>Technical Support</td>
<td><a href="http://www.freescale.com/support">http://www.freescale.com/support</a></td>
</tr>
</tbody>
</table>
# Table of Contents

1 **Overview** .................................................. 5
   - About the mwClearCase Plug-in ................................. 5
   - System Requirements ........................................... 5
   - Learning More About ClearCase ............................... 6

2 **Setting Up the mwClearCase Plug-in** .................. 7
   - Obtaining the mwClearCase Plug-in .......................... 7
   - Installing the mwClearCase Plug-in ......................... 8
   - Activating the mwClearCase Plug-in ......................... 8
   - Deactivating the mwClearCase Plug-in ...................... 15

3 **Using the mwClearCase Plug-in** ....................... 17
   - Preparation ..................................................... 17
   - The Project Window ........................................... 17
     - The Project Window and the Plug-in ...................... 18
   - mwClearCase Plug-in Command Locations .................. 19
     - The IDE’s VCS Menu ....................................... 19
     - The Project Window’s Context Menu ...................... 20
     - The Editor Window’s VCS Menu ............................ 21
   - mwClearCase Plug-in Command Reference .................. 22
     - About ......................................................... 24
     - Add ......................................................... 24
     - Add: ......................................................... 26
     - Checkin ...................................................... 28
     - Checkout .................................................... 30
     - Connect ..................................................... 31
     - Difference ................................................. 31
     - Disconnect .................................................. 32
     - Get ......................................................... 32
     - History ...................................................... 33
     - Properties ................................................. 35
     - Status ....................................................... 37
## Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Synchronize Selection</td>
<td>38</td>
</tr>
<tr>
<td>Synchronize Status</td>
<td>39</td>
</tr>
<tr>
<td>Undo Checkout</td>
<td>39</td>
</tr>
<tr>
<td>Variables</td>
<td>40</td>
</tr>
</tbody>
</table>

## 4 Tutorial

- Creating a Default Plug-in Configuration ......................... 43
- Checking out a File .................................................. 45
- Checking out a Project ............................................... 46
- Checking in a File .................................................... 47
- Checking in a Project ................................................ 48

## Index

- mwClearCase Plug-in User's Guide 49
Overview

This chapter is an overview of the CodeWarrior™ ClearCase plug-in tool, also known as the mwClearCase plug-in. This tool allows the CodeWarrior™ Integrated Development Environment (IDE) to interact with a ClearCase® version-control system.

This chapter has these topics:

- About the mwClearCase Plug-in
- System Requirements
- Learning More About ClearCase

About the mwClearCase Plug-in

The mwClearCase plug-in lets you perform these tasks from within the CodeWarrior IDE:

- Execute common ClearCase commands
- View the ClearCase status of projects and files

By using the mwClearCase plug-in, you avoid having to run a separate program in order to work with a ClearCase system.

System Requirements

To use the mwClearCase plug-in, make sure you meet the requirements listed in Table 1.1.

Table 1.1  System Requirements for the mwClearCase Plug-in

<table>
<thead>
<tr>
<th>Component</th>
<th>Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>Computer</td>
<td>IBM®-compatible PC</td>
</tr>
<tr>
<td>Processor</td>
<td>Pentium® class</td>
</tr>
<tr>
<td>Memory</td>
<td>128 MB minimum</td>
</tr>
<tr>
<td>Operating system</td>
<td>Windows® 98, Windows® ME, Windows NT®, Windows® 2000, or Windows® XP</td>
</tr>
</tbody>
</table>
Overview
Learning More About ClearCase

Table 1.1 System Requirements for the mwClearCase Plug-in (continued)

<table>
<thead>
<tr>
<th>Component</th>
<th>Requirement</th>
</tr>
</thead>
<tbody>
<tr>
<td>ClearCase® system</td>
<td>ClearCase for Windows version 3.2 or later</td>
</tr>
<tr>
<td>CodeWarrior IDE</td>
<td>Version 5.1.1 or later (Windows-hosted version only)</td>
</tr>
</tbody>
</table>

Learning More About ClearCase

This document explains how to use the features of the mwClearCase plug-in. It does not cover software-configuration management concepts or the ClearCase product itself. For information of this type, refer to the ClearCase product documentation.
Setting Up the mwClearCase Plug-in

This chapter explains how to obtain, install, activate, and deactivate the mwClearCase plug-in.

The chapter has these topics:

- Obtaining the mwClearCase Plug-in
- Installing the mwClearCase Plug-in
- Activating the mwClearCase Plug-in
- Deactivating the mwClearCase Plug-in

Obtaining the mwClearCase Plug-in

To obtain the latest version of the mwClearCase plug-in, follow these steps:

1. Exit the CodeWarrior IDE.
2. Go to Freescale’s CodeWarrior Development Tools page by clicking the URL below (or by typing it into your web browser).
   www.codewarrior.com
   Your browser starts and displays the CodeWarrior Development Tools page.
3. From the menu on the left of this page, select Downloads > Version Control Tools.
   The Version Control Tools page appears.
4. Follow the instructions on this page to download the .zip file that contains the mwClearCase plug-in.
5. Exit the web browser.

You now have a local copy of the .zip file that contains the latest version of the mwClearCase plug-in.
Installing the mwClearCase Plug-in

This section explains how to install the mwClearCase plug-in.

NOTE  Some CodeWarrior products ship with the mwClearCase plug-in pre-installed. To update the pre-installed plug-in to the latest version, complete the steps in “Obtaining the mwClearCase Plug-in” on page 7, then complete the steps in this section.

To install the mwClearCase plug-in, follow these steps:

1. Use WinZip to decompress the mwClearCase.zip archive.
   WinZip extracts these files from the archive:
   • mwClearCase.pdf
   • mwClearCase_Release_Notes_win32i.txt
   • VCSClearCase.dll

2. Copy the VCSClearCase.dll file to this directory, where CodeWarrior represents the path to your CodeWarrior installation:
   CodeWarrior\Bin\Plugins\version control\

The mwClearCase plug-in is now installed.

NOTE  Be sure to read the mwClearCase_Release_Notes_win32i.txt file for the latest information about the mwClearCase plug-in.

Activating the mwClearCase Plug-in

Before you can use the mwClearCase plug-in, you must first activate and configure it. You use the VCS Setup settings panel in the CodeWarrior IDE to complete these tasks. Figure 2.1 shows the VCS Setup settings panel. Table 2.1 explains each item in this panel.

This section has these tasks:

• Opening the VCS Setup Settings Panel
• Creating a Default mwClearCase Plug-in Configuration
• Creating a Project-specific mwClearCase Plug-in Configuration
Opening the VCS Setup Settings Panel

Follow these steps to open the VCS Setup settings panel:
1. Start the CodeWarrior IDE.
2. From the IDE’s menu bar, select Edit > Version Control Settings...

The VCS Settings window appears. The VCS Setup panel (Figure 2.1) is visible in this window.

![Figure 2.1 The VCS Setup Settings Panel of the VCS Settings Window](image)

<table>
<thead>
<tr>
<th>Item</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use Version Control</td>
<td>Check to have the IDE use a version-control system plug-in. Clear to have the IDE not use a version control system plug-in. <strong>NOTE:</strong> If you override the default plug-in configuration, the checkbox label is <strong>Use custom project</strong> instead of <strong>Use Version Control</strong>.</td>
</tr>
</tbody>
</table>
Setting Up the mwClearCase Plug-in

Activating the mwClearCase Plug-in

Table 2.1 VCS Setup Settings Panel—Items (continued)

<table>
<thead>
<tr>
<th>Item</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Method menu</td>
<td>Select the version control system that you want to activate. For example, select MW ClearCase to activate the mwClearCase plug-in.</td>
</tr>
<tr>
<td>Use global settings as default check box</td>
<td>Check to use the default mwClearCase plug-in configuration. Clear to specify your own plug-in configuration. <strong>NOTE:</strong> This check box appears if no projects were open at the time you opened the VCS Settings window.</td>
</tr>
<tr>
<td>Login Settings group box</td>
<td>Groups login-related items into a ClearCase view. The bulleted items below explain each item in this group. <strong>NOTE:</strong> For the plug-in to connect to ClearCase successfully, you must enter the login settings exactly as specified below.</td>
</tr>
<tr>
<td>• Username text box</td>
<td>Leave this text box blank.</td>
</tr>
<tr>
<td>• Password text box</td>
<td>Leave this text box blank.</td>
</tr>
<tr>
<td>• Connect on open check box</td>
<td>Always check this check box.</td>
</tr>
<tr>
<td>• Remember password check box</td>
<td>Always check this check box.</td>
</tr>
<tr>
<td>• Always show login dialog check box</td>
<td>Never check this check box.</td>
</tr>
<tr>
<td>Database Path group box</td>
<td>Groups items that pertain to the location of the ClearCase view that the plug-in uses. The bulleted items below explain each of these items.</td>
</tr>
<tr>
<td>• Choose... button</td>
<td>Click to open the Select an Access Path dialog box. Use this dialog box to select the directory that contains the ClearCase view that you want to use. You can specify an absolute, compiler-relative, or system-relative path. Also, if a project is open, you can specify a project-relative path. <strong>NOTE:</strong> You must specify the same ClearCase view for Database Path and for Local Path (explained below).</td>
</tr>
</tbody>
</table>
Setting Up the mwClearCase Plug-in
Activating the mwClearCase Plug-in

You can configure mwClearCase plug-in settings in two different ways:

- Default configuration—the settings that you specify become default settings for projects that use the mwClearCase plug-in. You can override these default settings for individual projects.

- Project-specific configuration—the settings that you specify apply to the current project only. These settings override any default settings from the default configuration.

Creating a Default mwClearCase Plug-in Configuration

This section explains how to create a default configuration. The IDE applies this default configuration to all projects for which you do not specify a custom configuration.

<table>
<thead>
<tr>
<th>Item</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Database Path text box</strong></td>
<td>Shows the name of the selected ClearCase view. This text box is read-only.</td>
</tr>
<tr>
<td><strong>Try to mount shared volume check box</strong></td>
<td>Never check this check box.</td>
</tr>
<tr>
<td><strong>Local Path group box</strong></td>
<td>Groups items that pertain to the location of the ClearCase view that the plug-in uses. The bulleted items below explain each of these items. <strong>NOTE:</strong> You must specify the same ClearCase view for <strong>Local Path</strong> and for <strong>Database Path</strong> (explained above).</td>
</tr>
<tr>
<td><strong>Choose... button</strong></td>
<td>Click to open the <strong>Select an Access Path</strong> dialog box. Use this dialog box to select the same ClearCase view that you selected for <strong>Database Path</strong> (explained above). You can specify an absolute, compiler-relative, or system-relative path. Also, if a project is open, you can specify a project-relative path. <strong>NOTE:</strong> You must specify the same ClearCase view for <strong>Local Path</strong> and for <strong>Database Path</strong> (explained above).</td>
</tr>
<tr>
<td><strong>Path text box</strong></td>
<td>Shows the selected local path. This text box is read-only.</td>
</tr>
</tbody>
</table>
### Setting Up the mwClearCase Plug-in

#### Activating the mwClearCase Plug-in

| Note | The default configuration is for your convenience; the IDE does not require it. For example, if all of your projects use the same ClearCase settings, you can create a default configuration that the IDE applies to all projects. If, however, each of your projects uses different ClearCase settings, you can instead specify project-specific configurations. See “Creating a Project-specific mwClearCase Plug-in Configuration” on page 13 for more information. |
|-------|

To create the default mwClearCase plug-in configuration, follow these steps:

1. Start the CodeWarrior IDE.
2. Close any open projects.
3. Choose Edit > Version Control Settings...
   
   The VCS Settings window appears. The VCS Setup panel (Figure 2.1 on page 9) is visible in this window.
4. Check the Use Version Control check box.
   
   The IDE enables the Method menu and the Use global settings as default check box.
5. Select MW ClearCase from the Method menu.
   
   The IDE enables additional items in the VCS Setup panel.
6. Check Use global settings as default check box.
   
   This setting makes the current plug-in configuration the default configuration.

| Note | Because no CodeWarrior project is open, the VCS Setup panel displays the Use global settings as default check box. If a project is open, the VCS Setup panel does not display this check box. |
|-------|

7. Specify the path to the ClearCase view.
   
   a. Click the Choose... button in the Database Path group box.
      
      The Select an Access Path dialog box appears.
   b. Use the dialog box to select the directory that contains the ClearCase view that you want to make the default view.

| Note | If you are using a dynamic view, you must start the view before its directory appears in the Select an Access Path dialog box. See the ClearCase documentation for instructions on how to start a dynamic view. If you are using a snapshot view, its directory appears in the Select an Access Path dialog box automatically. |
|-------|
c. Click the OK button.
The selected path appears in the read-only text box to the left of the Choose... button.

8. Specify the local path that you want to make the default local path.
a. Click the Choose... button in the Local Path group box.

The Select an Access Path dialog box appears.
b. Use this dialog box to select the same ClearCase view that you selected in step 7.

NOTE You must select the same view for Local Path and Database Path.

c. Click the OK button.
The selected path appears in the read-only text box to the left of the Choose... button.

9. Click the OK button.
The VCS Settings window closes. The IDE activates the mwClearCase plug-in globally and adds the VCS menu to its menu bar.

See “Using the mwClearCase Plug-in” on page 17 for instructions on using each feature of the plug-in.

Creating a Project-specific mwClearCase Plug-in Configuration

A project-specific plug-in configuration applies to the current CodeWarrior project. This configuration does not apply to any other project.

To create a project-specific plug-in configuration, follow these steps:

1. Start the CodeWarrior IDE.

2. Open or bring forward the CodeWarrior project to which you want to assign a custom plug-in configuration.

3. Choose Edit > Version Control Settings...

   The VCS Settings window appears. The VCS Setup panel (Figure 2.1 on page 9) is visible in this window.

NOTE Because a project is open, the VCS Settings panel does not display the Use global settings as default check box. This happens because the IDE assigns the plug-in configuration to the current project.

4. Check the Use Version Control check box.
Setting Up the mwClearCase Plug-in

Activating the mwClearCase Plug-in

NOTE If you defined a default plug-in configuration, this check box is labeled Use custom project instead of Use Version Control. In this case, the new plug-in configuration overrides the default plug-in configuration.

5. Select MW ClearCase from the Method menu.
   The IDE enables additional items in the VCS Setup panel.
6. Specify the path to the ClearCase view that contains the open project and its source files.
   a. Click the Choose... button in the Database Path group box.
      The Select an Access Path dialog box appears.
   b. Use the dialog box to select the directory of the ClearCase view that contains the open project.

NOTE If you are using a dynamic view, you must start the view before its directory appears in the Select an Access Path dialog box. See the ClearCase documentation for instructions on how to start a dynamic view.

   If you are using a snapshot view, its directory appears in the Select an Access Path dialog box automatically.

   c. Click the OK button.
      The selected path appears in the read-only text box to the left of the Choose... button.
7. Specify the local path.
   a. Click the Choose... button in the Local Path group box.
      The Select an Access Path dialog box appears.
   b. Use this dialog box to select the same ClearCase view that you selected in step 6.

NOTE You must select the same view for Local Path and Database Path.

   c. Click the OK button.
      The selected path appears in the read-only text box to the left of the Choose... button.
   d. Click the OK button.
      The selected path appears in the read-only text box to the left of the Choose... button.
Setting Up the mwClearCase Plug-in

Deactivating the mwClearCase Plug-in

8. Click the OK button.
   The VCS Settings window closes. The IDE activates the mwClearCase plug-in for the current project.

**NOTE**  The VCS menu appears in the IDE’s menu bar when you select a project for which you activated the plug-in. This menu disappears when you select a project for which you did not activate the plug-in.

Refer to “Using the mwClearCase Plug-in” on page 17 for instructions on how to use each feature of the mwClearCase plug-in.

Deactivating the mwClearCase Plug-in

To deactivate the mwClearCase plug-in, follow these steps:

1. Start the CodeWarrior IDE.
2. If you are deactivating the default plug-in configuration, close all projects.
   If you are deactivating the plug-in configuration for a specific CodeWarrior project, open or bring forward that project.
3. Choose Edit > Version Control Settings...
   The VCS Settings window appears. The VCS Setup panel (Figure 2.1 on page 9) is visible in this window.
4. Select None from the Method menu.
5. If you are deactivating the default plug-in configuration, clear the Use global settings as default check box.

**NOTE**  Because no CodeWarrior project is open, the VCS Setup panel displays the Use global settings as default check box. If a project is open, the VCS Setup panel does not display this check box.

6. Clear the Use Version Control check box.
   The IDE disables the rest of the items in the VCS Setup panel.

**NOTE**  If the default plug-in configuration exists, this check box is labeled Use custom project instead of Use Version Control.

7. Click the OK button.
   The VCS Settings window closes. The IDE deactivates the plug-in and removes the VCS menu from its menu bar.
Setting Up the mwClearCase Plug-in

Deactivating the mwClearCase Plug-in

NOTE

If no projects were open when you clicked the OK button, the IDE deactivates the default plug-in configuration.

If a project was open, the IDE deactivates the plug-in for just that project.
Using the mwClearCase Plug-in

This chapter explains how to use the mwClearCase plug-in.

The chapter has these topics:

- Preparation
- The Project Window
- mwClearCase Plug-in Command Locations
- mwClearCase Plug-in Command Reference

Preparation

Before you can use the mwClearCase plug-in with a CodeWarrior™ project, you must create a ClearCase view that contains your project. Also, if you use a dynamic ClearCase view, you must start this view before you can use it with the plug-in. Refer to the ClearCase documentation for instructions on how to accomplish these tasks.

After you set up your ClearCase view, open a CodeWarrior project in the CodeWarrior IDE. If you created the default plug-in configuration or assigned a custom configuration to the project, you can now use the mwClearCase plug-in with this project.

See “Creating a Default mwClearCase Plug-in Configuration” on page 11 and “Creating a Project-specific mwClearCase Plug-in Configuration” on page 13 for instructions on how to configure the mwClearCase plug-in.

The Project Window

To use the mwClearCase plug-in, you must understand how the plug-in interacts with the project window of a CodeWarrior project. The project window:

- shows you the ClearCase status of each file in the project and of the project itself
- lets you apply ClearCase commands to files in the project and to the project itself
- shows the results of ClearCase commands
Using the mwClearCase Plug-in
The Project Window

The Project Window and the Plug-in

After you activate the mwClearCase plug-in, a new column appears in the project window. If you created a default plug-in configuration, the new column appears in all project windows. Otherwise, the new column appears in the current project window. This column contains icons that signify the check out status of each file in the project. In addition, an icon in the lower-left corner of the project window indicates the check out status of the project file itself (the .mcp file).

Figure 3.1 shows the project window of a project that has an active mwClearCase plug-in configuration.

Table 3.1 explains how to interpret each check out status icon.

Figure 3.1  A Project Window with an Active mwClearCase Plug-in Configuration

Table 3.1  Check Out Status Icons: Interpretation

<table>
<thead>
<tr>
<th>Icon</th>
<th>Check Out Status</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="File not added to ClearCase. File is writable." /></td>
<td>File has not been added to ClearCase. File is writable.</td>
</tr>
<tr>
<td><img src="image" alt="File not added to ClearCase. File is read-only." /></td>
<td>File has not been added to ClearCase. File is read-only.</td>
</tr>
<tr>
<td><img src="image" alt="File not checked out of ClearCase. File is read-only." /></td>
<td>File has not been checked out of ClearCase. File is read-only.</td>
</tr>
</tbody>
</table>
The mwClearCase plug-in lets you apply common ClearCase commands to a CodeWarrior project and to its files. This section explains how to find and use these commands in the CodeWarrior IDE.

The mwClearCase plug-in makes ClearCase commands available in these places:

- **The IDE’s VCS Menu**
- **The Project Window’s Context Menu**
- **The Editor Window’s VCS Menu**

### mwClearCase Plug-in Command Locations

The IDE enables individual commands in the VCS menu depending on the check out status of the current project or currently selected project file.

**Figure 3.2** shows the VCS menu.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Check Out Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Icon]</td>
<td>File has not been checked out of ClearCase. File is writable.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>File has been checked out of ClearCase. File is writable.</td>
</tr>
</tbody>
</table>

**Table 3.1 Check Out Status Icons: Interpretation (continued)**
The Project Window’s Context Menu

To display a project window’s context menu, right-click inside the project window. Figure 3.3 shows a project window context menu.

If the current project has an active mwClearCase configuration, the bottom of the context menu shows ClearCase commands. Unlike the VCS menu, the context menu shows only relevant ClearCase commands, depending on the check out status of the selected project file.

For example, because the file selected in Figure 3.3 is checked out, the context menu shows just the Get, Undo Checkout, Checkin, and Difference commands. Only these commands are relevant to a checked-out file.
Using the mwClearCase Plug-in

mwClearCase Plug-in User’s Guide

Figure 3.3 The Project Window’s Context Menu

![Project Window’s Context Menu](image)

The Editor Window’s VCS Menu

If the mwClearCase plug-in is active for a project, the editor window toolbar includes a VCS menu.

A checkout status icon identifies the editor window’s VCS menu. The icon that appears corresponds to the checkout status of the file shown in the editor window. Table 3.1 on page 18 explains how to interpret each checkout status icon. Figure 3.4 shows a CodeWarrior editor window.

Click the checkout status icon in the editor window toolbar to display a menu of ClearCase commands. Unlike the VCS menu, the editor’s VCS menu contains only relevant ClearCase commands, depending on the checkout status of the open file.

For example, because the file in Figure 3.4 is checked out, the menu shows just the Get, Undo Checkout, Connect, and Difference commands. Only these commands are relevant to a checked-out file.
Using the mwClearCase Plug-in

mwClearCase Plug-in Command Reference

Figure 3.4  The Editor Window’s VCS Menu

This section explains the purpose and effect of each command that the mwClearCase plug-in supports.

There are four supported categories of ClearCase commands:

- **File Commands**
  These commands apply to the selected files in the selected project.
  You issue file commands from the IDE’s VCS menu, from a project’s context menu, and from an editor window’s VCS menu.

- **Project Commands**
  These commands apply to the selected project.
  You issue project commands from the Project submenu of the IDE’s VCS menu.

- **Miscellaneous Commands**
  These commands are *not* ClearCase commands. The miscellaneous commands perform a variety of actions. See the reference entry for each miscellaneous command for more information.

*Table 3.2* lists supported commands, along with their locations and types.
## Table 3.2 mwClearCase Plug-in: Supported Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Command Locations</th>
<th>Command Types</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>VCS Menu</td>
<td>Project Window Context Menu</td>
</tr>
<tr>
<td>About</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Add</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Add...</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Checkin</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Checkout</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Connect</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Difference</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Disconnect</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Get</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>History</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Properties</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Status</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Synchronize Selection</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Synchronize Status</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Undo Checkout</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Variables</td>
<td>•</td>
<td>•</td>
</tr>
</tbody>
</table>
Using the mwClearCase Plug-in

mwClearCase Plug-in Command Reference

About

Select this command to display the mwClearCase plug-in’s About box. This box shows the version number of the plug-in, along with other identification information.

Select VCS > About to display the About box (Figure 3.5).

**NOTE**  The About command is available in just the IDE’s VCS menu.

**Figure 3.5 About Box for the mwClearCase Plug-in**

Add

You can apply this command to a file or a project.

If applied to a file, the Add command adds the selected file to ClearCase.

If applied to an open project, the Add command adds the project file (that is, the .mcp file) to ClearCase.

Adding a File

To add a file to ClearCase, follow these steps:

1. Start the CodeWarrior IDE.
2. Open the project that contains the file you want to add to ClearCase.
   The CodeWarrior IDE displays the project window for this project.
3. In the project window, click the name of the file you want to add.
   The IDE highlights this file name.
To add several files at once, first highlight the name of each file you want to add, then issue the Add command.

4. Select VCS > Add.
   The Comment dialog box (Figure 3.6) appears.

Figure 3.6 Comment Dialog Box

5. Optionally, enter a comment in the Comment dialog box.
6. Click OK.
   The Comment dialog box closes. The plug-in adds the selected file and any comment to ClearCase and changes the file’s check out status icon to

Adding a Project

To add a project to ClearCase, follow these steps:
1. Start the CodeWarrior IDE.
2. Open the CodeWarrior project whose project file you want to add to ClearCase.
   The CodeWarrior IDE displays the project window for this project.
3. Select VCS > Project > Add.
   The Comment dialog box (Figure 3.6 on page 25) appears.
4. Optionally, enter a comment in the Comment dialog box.
5. Click OK.
   The Comment dialog box closes. The plug-in adds the project file and any comment to ClearCase and changes the project’s check out status icon to . This icon is in the lower-left corner of the project window.
Add...

This command applies to a file or a project.
If applied to a file, the \texttt{Add\ldots} command adds the selected file to ClearCase.
If applied to an open project, the \texttt{Add\ldots} command adds the project file (that is, the project's \texttt{.mcp} file) to ClearCase.

\textbf{NOTE} \quad The \texttt{Add\ldots} command is different from the \texttt{Add} command. The \texttt{Add\ldots} command gives you more control over how a file gets added to ClearCase.

See “Add" on page 24 for an explanation of the \texttt{Add} command.

---

**Adding a File using the Add... Command**

To add a file to ClearCase using the \texttt{Add\ldots} command, follow these steps:

1. Start the CodeWarrior IDE.
2. Open the project that contains the file you want to add to ClearCase.
   \quad The CodeWarrior IDE displays the project window for this project.
3. In the project window, click the name of the file you want to add.
   \quad The IDE highlights this file name.

\textbf{TIP} \quad To add several files at once, first highlight the name of each file you want to add, then issue the \texttt{Add\ldots} command.

4. Select VCS > Add...
   \quad The \texttt{Comment} dialog box (Figure 3.7) appears.
5. Optionally, enter a comment in the **Comment** dialog box.

6. Click **OK**

   The **Comment** dialog box closes. The **ClearCase Add File** dialog box (Figure 3.8) appears.

**Figure 3.8 ClearCase Add File Dialog Box**

7. Use the **ClearCase Add File** dialog box to select the ClearCase file-addition options you want.

8. Click **OK**

   The **ClearCase Add File** dialog box closes. The plug-in adds the selected file and any comment to ClearCase and changes the file’s check out status icon to ☑.
Adding a Project using the Add... Command

To add a project to ClearCase using the Add... command, follow these steps:
1. Start the CodeWarrior IDE.
2. Open the CodeWarrior project whose project file you want to add to ClearCase.
   The CodeWarrior IDE displays the project window for this project.
3. Select VCS > Project > Add...
   The Comment dialog box (Figure 3.6 on page 25) appears.
4. Optionally, enter a comment in the Comment dialog box.
5. Click OK
   The Comment dialog box closes. The ClearCase Add File dialog box (Figure 3.8 on page 27) appears.
6. Use the ClearCase Add File dialog box to select the ClearCase file addition options you want.
7. Click OK
   The ClearCase Add File dialog box closes. The plug-in adds the project file and any comment to ClearCase and changes the project’s check out status icon to . This icon is in the lower-left corner of the project window.

Checkin

This command applies to a file or a project.
If applied to a file, the Checkin command checks in the changes made to the selected file into ClearCase.
If applied to a project, the Checkin command checks the changes made to the project file (that is, to the .mcp file) into ClearCase.

Checking in a File

To check in a file, follow these steps:
1. Start the CodeWarrior IDE.
2. Open the project that contains the file you want to check in.
   The CodeWarrior IDE displays the project window for this project.
Using the mwClearCase Plug-in

mwClearCase Plug-in User’s Guide

3. In the project window, click the name of the file you want to check in.
   The IDE highlights this file name.

   **TIP** To check in several files at once, first highlight the name of each file you want to check in, then issue the **Checkin** command.

4. Select VCS > **Checkin**.
5. The **Comment** dialog box (Figure 3.9) appears.

**Figure 3.9 Comment Dialog Box**

6. Optionally, enter a comment in the **Comment** dialog box.
7. Click **OK**.
   The **Comment** dialog box closes. The plug-in checks in the selected file and changes its check out status icon to 

   **NOTE** If you try to check in a file that has not changed, the check in fails. In this case, apply the **Undo Checkout** command to the file.

---

**Checking in a Project**

To check a project into ClearCase, follow these steps:

1. Start the CodeWarrior IDE.
2. Open the CodeWarrior project whose project file you want to check in.
   The CodeWarrior IDE displays the project window for this project.
3. Select VCS > **Project > Checkin**.
   The **Comment** dialog box (Figure 3.9 on page 29) appears.
4. Optionally, enter a comment in the Comment dialog box.
5. Click OK.

The Comment dialog box closes. The plug-in checks the project file and any comment into ClearCase and changes the project’s check out status icon to . This icon is in the lower-left corner of the project window.

**NOTE** If you try to check in a project file that has not changed, the check in fails. In this case, apply the Undo Checkout command to the project file.

---

**Checkout**

This command applies to a file or a project.

If applied to a file, the Checkout command creates a modifiable copy of the file in the plug-in’s ClearCase view.

If applied to a project, the Checkout command creates a modifiable version of the project file (that is, of the .mcp file) in the plug-in’s ClearCase view.

See “Checkin” on page 28 for instructions on how to check in a file that you checked out.

---

**Checking Out a File**

To check out a file, follow these steps:

1. Start the CodeWarrior IDE.
2. Open the project that contains the file you want to check out.
   The CodeWarrior IDE displays the project window for this project.
3. In the project window, click the name of the file that you want to check out.
   The IDE highlights this file name.

**TIP** To check out several files at once, first highlight the name of each file you want to check out, then issue the Checkout command.

4. Select VCS > Checkout
   The plug-in checks out the selected file and changes its check out status icon to .

---
Checking Out a Project

To check out a project, follow these steps:
1. Start the CodeWarrior IDE.
2. Open the project that you want to check out.
   The CodeWarrior IDE displays the project window for this project.
3. Select VCS > Project > Checkout.
   The plug-in checks out the project (that is, the project’s .mcp file) and changes the project’s check out status icon to . This icon appears in the lower-left corner of the project window.

Connect

Although this command appears in the IDE’s VCS menu, it is redundant. When necessary, the mwClearCase plug-in automatically connects to the ClearCase view specified in its configuration.

Difference

This command applies to a single file only. You cannot apply it to multiple files, to a project, or recursively.

The Difference command displays the differences between the copy of the selected file in the plug-in’s ClearCase view and the latest version of this file in ClearCase.

To use the Difference command, follow these steps:
1. Start the CodeWarrior IDE.
2. Open the project that contains the file to which you want to apply the Difference command.
   The CodeWarrior IDE displays the project window for this project.
3. In the project window, click the name of the file to which to apply the Difference command.
   The IDE highlights this file name.
4. Select VCS > Difference.

The plug-in compares the local copy of the selected file to the latest version of this file in ClearCase. The plug-in then displays the results in the ClearCase Diff Merge window (Figure 3.10). Refer to the ClearCase documentation for instructions that explain how to use this window.

Figure 3.10 The ClearCase Diff Merge Window

---

Disconnect

Although this command appears in the IDE’s VCS menu, it is redundant. When necessary, the plug-in automatically disconnects from the ClearCase view specified in its configuration.

---

Get

This command applies to a file or a project.

If applied to a file, the Get command copies the latest version of the file from ClearCase into the plug-in’s ClearCase view.

If applied to a project, the Get command copies the latest version of the project file (that is, of the .mcp file) from ClearCase into the plug-in’s ClearCase view.
Getting a File

To get the latest version of a file, follow these steps:

1. Start the CodeWarrior IDE.
2. Open the project that contains the file for which you want to get the latest version.
   The CodeWarrior IDE displays the project window for this project.
3. In the project window, click the name of the file for which to get the latest version.
   The IDE highlights this file name.

   **TIP** To get the latest version of several files at once, first highlight the name of each file, then issue the Get command.

4. Select **VCS > Get**.
   The plug-in copies the latest version of the selected file into the plug-in’s ClearCase view.

Getting a Project

To get the latest version of a project, follow these steps:

1. Start the CodeWarrior IDE.
2. Open the project for which you want to get the latest version.
   The CodeWarrior IDE displays the project window for this project.
3. Select **VCS > Project > Get**.
   The plug-in copies the latest version of the project (that is, of the project’s `.mcp` file) from ClearCase into the plug-in’s ClearCase view.

History

This command applies to a file or to a project. You cannot apply it recursively.

If applied to a file, the History command lists each revision and check-in comment made to the file since it was first added to ClearCase.

If applied to a project, the History command lists each revision and check-in comment made to the project’s `.mcp` file since it was first added to ClearCase.
Displaying the Revision History of a File

To display the revision history of a file, follow these steps:

1. Start the CodeWarrior IDE.
2. Open the project that contains the file for which you want to obtain a revision history.
   The CodeWarrior IDE displays the project window for this project.
3. In the project window, click the name of the file for which you want to obtain a revision history.
   The IDE highlights this file name.

   **TIP** To get the revision history of several files at once, first highlight the name of each file, then issue the *History* command.

4. Select VCS > History.
   The plug-in displays the file’s revision history in the *ClearCase History Browser* window (Figure 3.11).

**Figure 3.11 The ClearCase History Browser Window**
Displaying the Revision History of a Project

To display the revision history of a project, follow these steps:
1. Start the CodeWarrior IDE.
2. Open the project for which you want to obtain a revision history.
   The CodeWarrior IDE displays the project window for this project.
3. Select VCS > History.
   The plug-in displays the revision history of the project’s .mcp file in the ClearCase History Browser window (Figure 3.11 on page 34).

Properties

This command applies to a single file or a project. You cannot apply it to multiple files or recursively.
The Properties command displays the ClearCase property dialog box for the selected file or project.

Displaying the Properties of a File

To display a file’s properties, follow these steps:
1. Start the CodeWarrior IDE.
2. Open the project that contains the file whose properties you want to display.
   The CodeWarrior IDE displays the project window for this project.
3. In the project window, click the name of the file whose properties you want to display.
   The IDE highlights this file name.
4. Select VCS > Properties.
   The plug-in displays the file’s properties in the ClearCase Properties dialog box (Figure 3.12).
Using the mwClearCase Plug-in

mwClearCase Plug-in Command Reference

Figure 3.12 The ClearCase Properties Dialog Box

NOTE Refer to the ClearCase documentation for instructions on how to use the ClearCase Properties Dialog Box.

Displaying the Properties of a Project

To display a project’s properties, follow these steps:

1. Start the CodeWarrior IDE.
2. Open the project whose properties you want to display.

   The CodeWarrior IDE displays the project window for this project.


   The plug-in displays the project’s properties (that is, the properties of the project’s .mcp file) in the ClearCase Properties dialog box (Figure 3.12 on page 36).

NOTE Refer to the ClearCase documentation for instructions on how to use the ClearCase Properties Dialog Box.
**Status**

This command applies to a file or a project. You cannot apply it recursively.

The `Status` command reports the ClearCase status of the selected file or project.

**Displaying the Status of a File**

To display the status of a file, follow these steps:

1. Start the CodeWarrior IDE.
2. Open the project that contains the file for which you want to obtain status.
   The CodeWarrior IDE displays the project window for this project.
3. In the project window, click the name of the file for which you want to obtain status.
   The IDE highlights this file name.

   **TIP** To get the status of several files at once, first highlight the name of each file, then issue the `Status` command.

4. Select **VCS > Status**.

   The plug-in displays the file’s status in the **VCS Messages** window ([Figure 3.11](#)).

**Figure 3.13 The Status Window**

![VCS Messages window](image)
Using the mwClearCase Plug-in
mwClearCase Plug-in Command Reference

Displaying the Status of a Project

To display the status of a project, follow these steps:

1. Start the CodeWarrior IDE.
2. Open the project for which you want to obtain status.
   The CodeWarrior IDE displays the project window for this project.
3. Select **VCS > Project > Status**.
   The plug-in displays the status of the project (that is, of the project’s .mcp file) in the **VCS Messages** window (Figure 3.13 on page 37).

Synchronize Selection

This command applies to a file or to files in a project. You cannot apply it to a project or recursively.

This command verifies that the check out status icon displayed in the project window for the selected file matches the status of that file in ClearCase. If there is a discrepancy, the plug-in displays the correct check out status icon.

The mwClearCase plug-in can display the wrong check out status icon if you change the check out status of a file outside of the CodeWarrior IDE (for example, by using the Rational ClearCase Explorer program). You can use the Synchronize Selection command to correct discrepancies that might occur.

To issue the Synchronize Selection command, follow these steps:

1. Start the CodeWarrior IDE.
2. Open the project that contains the file for which to synchronize status.
   The CodeWarrior IDE displays the project window for this project.
3. In the project window, click the name of the file for which to synchronize status.
   The IDE highlights this file name.

   **TIP** To synchronize the status of several files at once, first highlight the name of each file, then issue the Synchronize Selection command.

4. Select **VCS > Synchronize Selection**.
   The plug-in verifies that the check out status icon displayed for the selected file is correct. If not, the plug-in displays the correct check out status icon.
Synchronize Status

This command applies to all files in a project and to the project itself. You cannot apply it
to an individual file or recursively.

This command updates the check out status icon of each file in the project and of the
project file itself (that is, of the project’s .mcp file).

The mwClearCase plug-in can sometimes display incorrect check out status icons. For
example, if you change the check out status of a file or project outside of the CodeWarrior
IDE (for example, by using the Rational ClearCase Explorer program), the plug-in might
display incorrect status icons. Use the Synchronize Status command to correct
discrepancies that might occur.

To issue the Synchronize Status command, follow these steps:

1. Start the CodeWarrior IDE.
2. Open the project whose status you want to synchronize.
   The CodeWarrior IDE displays the project window for this project.
   The plug-in updates the check out status icon for each file for which it finds a
discrepancy.

Undo Checkout

This command applies to a file or project.

If applied to a checked out file, the Undo Checkout command changes the ClearCase
status of the file to “not checked out.” All changes made to the file are lost.

If applied to a checked out project, the Undo Checkout command changes the
ClearCase status of the project file (that is, of the project’s .mcp file) to “not checked
out.” All changes made the project file are lost.

Undoing a File Check Out

To undo a file check out, follow these steps:

1. Start the CodeWarrior IDE.
2. Open the project that contains the file for which to undo the check out.
   The CodeWarrior IDE displays the project window for this project.
Using the mwClearCase Plug-in

3. In the project window, click the name of the file for which to undo the check out.
   The IDE highlights this file name.

   **TIP** To undo the check out for several files at once, first highlight the name of each
   file, then issue the **Undo Checkout** command.

4. Select **VCS > Undo Checkout**.
   The plug-in undoes the check out of the selected file and changes its check out status
   icon to ✗.

**Undoing a Project Check Out**

To undo a project check out, follow these steps:

1. Start the CodeWarrior IDE.
2. Open the project for which to undo the check out.
   The CodeWarrior IDE displays the project window for this project.
3. Select **VCS > Project > Undo Checkout**.
   The plug-in undoes the check out of the selected project and changes its check out
   status icon to ✗. This icon appears in the lower-left corner of the project window.

**Variables**

This command displays the username, database path, and local path assigned to the
mwClearCase plug-in.

To issue the **Variables** command, select **VCS > Variables**. The Freescale ClearCase
Variables dialog box (Figure 3.14) appears.

**Figure 3.14 Variables Dialog Box for the mwClearCase Plug-in**
Tutorial

This chapter has a multi-part tutorial. The purpose of this tutorial is to show you how to
• create a default configuration for the mwClearCase plug-in
• use the plug-in to perform common ClearCase tasks from within the
  CodeWarrior™ IDE.

NOTE To complete the sections in this tutorial, you must have a ClearCase view
  available. Also, if you use a dynamic ClearCase view, you must start this view
  before starting the tutorial.

The tutorial has these lessons:
• Creating a Default Plug-in Configuration
• Checking out a File
• Checking out a Project
• Checking in a File
• Checking in a Project

Creating a Default Plug-in Configuration

Although you can create a custom plug-in configuration for every CodeWarrior project,
you might find it more convenient to create a default plug-in configuration. The default
configuration works for all of your CodeWarrior projects.

To create a default plug-in configuration, follow these steps:
1. Start the CodeWarrior IDE.
2. Close any open projects.
3. Select Edit > VCS Settings...
   The VCS Settings window appears. The VCS Setup panel (Figure 4.1) is visible in
   this window.
4. Check the *Use Version Control* check box.

   The *Method* menu and the *Use global settings as default* check box activate.

5. Select *MW ClearCase* from the *Method* menu.

   The IDE activates additional items in the *VCS Setup* panel.

6. Check *Use global settings as default* check box.

   This setting makes this plug-in configuration the default configuration. The IDE uses this configuration for each CodeWarrior project you open that does not have a custom plug-in configuration.

7. Leave the *Username* text box empty.

8. Check the *Connect on open* check box.

9. Check *Remember password* check box.

   The plug-in enables the *Password* text box.

10. Leave the *Password* text box empty.

11. Clear the *Always show login dialog* check box.

12. Assign a ClearCase view to the default plug-in configuration.

   a. Click the *Choose...* button in the *Database Path* group box.

   The *Select an Access Path* dialog box appears.
b. Use this dialog box to select the ClearCase view that you want to use for the rest of this tutorial.

c. Leave the Try to mount shared volume check box unchecked.

d. Click OK.

The full path to the selected ClearCase view appears in the read-only text box to the left of the Choose... button.

13. Assign a local path to the default plug-in configuration.

   a. Click the Choose... button in the Local Path group box.

The Select an Access Path dialog box appears.

   b. Use this dialog box to select the same ClearCase view that you selected for Database Path.

   **NOTE** You must select the same ClearCase view for Database Path and for Local Path. Otherwise, the mwClearCase plug-in will not work.

   c. Click OK.

   The full path to the selected ClearCase view appears in the read-only text box to the left of the Choose... button.

14. Click OK.

   The VCS Settings window closes. The IDE activates the mwClearCase plug-in globally and adds the VCS menu to the IDE’s menu bar.

You have finished creating the default mwClearCase plug-in configuration.

### Checking out a File

Now that you created a default plug-in configuration, you can use the plug-in to check out files from a CodeWarrior project while remaining inside the IDE.

To check out a file, follow these steps:

1. Start the CodeWarrior IDE.

2. Open one of the CodeWarrior projects in the ClearCase view selected in the last section of this tutorial.

   The IDE displays the project window of the selected project.
Tutorial
Checking out a Project


The project window displays the check out status icon for each file in the project and for the project itself.

Figure 4.2 shows the project window for a CodeWarrior project. Table 3.1 on page 18 explains how to interpret each of the check out status icons.

Figure 4.2 A CodeWarrior Project Window

4. In the project window, click the name of one of the files in the project. The project window highlights this file name.

5. Select VCS > Checkout.

The plug-in does these things:
    a. Copies the latest version of the selected file into its ClearCase view.
    b. Makes the file writable and marks it “checked out.”
    c. Changes the file’s check out status icon to .

The selected file is now checked out. You can now use the CodeWarrior editor to modify the file.

Checking out a Project

To check out a project (that is, a project’s .mcp file), follow these steps:
1. Start the CodeWarrior IDE.
2. Open the project that you want to check out.

    The IDE displays the project window for this project.
3. Select VCS > Project > Checkout.

   The plug-in does these things:
   a. Copies the latest version of the project’s .mcp file into its ClearCase view.
   b. Makes the .mcp file writable and marks it “checked out.”
   c. Changes the project’s check out status icon to . This icon is in the lower-left
      corner of the project window.

   The project is now checked out. You can change the project’s configuration as necessary.

Checking in a File

   After you finish changing a file that you previously checked out, you can check it back in.
   To check a file in to ClearCase, follow these steps:
   1. Start the CodeWarrior IDE.
   2. Open the CodeWarrior project that contains the file you want to check in.
      The IDE displays the project window of the selected project.
   3. In the project window, click the name of the file you want to check in.
      The project window highlights this file name.
   4. Select VCS > Checkin.
      The plug-in displays the Comment dialog box (Figure 4.3).

Figure 4.3 Comment Dialog Box

   ![Comment Dialog Box](image-url)
Checking in a Project

After you finish changing a project’s configuration, you can check it back in.

To check a project into ClearCase, follow these steps:

1. Start the CodeWarrior IDE.
2. Open the CodeWarrior project that you want to check in.
   The IDE displays the project window of the selected project.
3. Select VCS > Project > Checkin.
   The plug-in displays the Comment dialog box (Figure 4.3 on page 47).
4. Optionally, enter a checkin comment.
5. Click OK
   The plug-in instructs ClearCase to do these things:
   a. Create a new version of the project file being checked in.
   b. Mark the project file “not checked out.”
   The plug-in then changes the project’s check out status icon to 🛠. This icon is in the lower-left corner of the project window.

   **NOTE** If you check out a project, do not change it, and then check it back in, the Check in command fails. Use the Undo Checkout command in this case.
Index

A
about
ClearCase 6
the mwClearCase plug-in 5
about command 24
activating the mwClearCase plug-in 8–15
add command 24
add... command 26
Always show login dialog configuration option 10

C
check out status icons
in a project window 17
interpretation 18
checkin command 28
checkout command 30
ClearCase
learning more about 6
command locations 19–22
editor window 21
project window context menu 20
VCS menu 19
commands
about 24
add 24
add... 26
checkin 28
checkout 30
connect 31
difference 31
disconnect 32
get 32
history 33
project window context menu 20
properties 35
status 37
synchronize selection 38
synchronize status 39
undo checkout 39
variables 40
commands supported by the plug-in 22–40
configuration options
Always show login dialog 10
Connect on open 10
Database Path 10
Local Path 11
Login Settings 10
Method 10
Password 10
Remember password 10
Try to mount shared volume 11
Use global settings as default 10
Use Version Control 9
Username 10
connect command 31
Connect on open configuration option 10
creating a project-specific plug-in configuration 13–15
creating the default plug-in configuration 11–13

D
Database Path configuration option 10
deactivating the mwClearCase plug-in 15–16
default plug-in configuration, creating 11–13
difference command 31
disconnect command 32

G
general ClearCase information 6
get command 32

H
history command 33
how to
activate the mwClearCase plug-in 8–15
check in a file 47–48
check in a project 48
check out a file 45–46
check out a project 46–47
create a default plug-in configuration 11–13, 43–45
create a project-specific plug-in configuration 13–15
deactivate the mwClearCase plug-in 15–16
install the mwClearCase plug-in 8
interpret the check out status icons 18
obtain the mwClearCase plug-in 7

I
information about ClearCase 6
installing the mwClearCase plug-in 8

L
learning about ClearCase 6
Local Path configuration option 11
location of commands 19–22
Login Settings configuration option 10

M
meaning of check out status icons 18
menu, VCS 19
Method configuration option 10
more information about ClearCase 6
mwClearCase and project window 18
mwClearCase plug-in
about 5
activating 8–15
for a specific project 13–15
globally 11–13
command locations 19–22
difference 31
disconnect 32
distributor 24
edit 24
edit... 26
editor window 21
editor window and mwClearCase 17
executing 31
get 32
history 33
properties 35
status 37
synchronize selection 38
synchronize status 39
undo checkout 39
variables 40

deactivating 15–16
installing 8
obtaining 7
overview 5–6
preparation 17
project window
check out status icons 17
project window context menu commands 20
setting up 7–16
system requirements 5
tutorial 43–48
checking in a file 47–48
checking in a project 48
checking out a file 45–46
checking out a project 46–47
default plug-in configuration,
creating 43–45
using 17–40

O
obtaining the mwClearCase plug-in 7
overview of the mwClearCase plug-in 5–6

P
Password configuration option 10
plug-in preparation 17
plug-in tutorial 43–48
preparation 17
project specific plug-in configuration,
creating 13–15
project window
and mwClearCase plug-in 18
check out status icons 17
cleanup menu 20
context menu and ClearCase commands 20
project window context menu 20
properties command 35

R
Remember password option 10
requirements for using the mwClearCase plug-in 5

S
setting up the mwClearCase plug-in 7–16
settings panels
VCS Setup 9
status command 37
synchronize selection command 38
synchronize status command 39
system requirements 5

T
tasks
activating the mwClearCase plug-in 8–15
creating a default plug-in configuration 11–13
creating a project-specific plug-in configuration 13–15
deactivating the mwClearCase plug-in 15–16
installing the mwClearCase plug-in 8
obtaining the mwClearCase plug-in 7
Try to mount shared volume configuration option 11
tutorial
checking in a file 47–48
checking in a project 48
checking out a file 45–46
checking out a project 46–47
default plug-in configuration, creating 43–45

U
undo checkout command 39
Use global settings as default configuration option 10
Use Version Control configuration option 9
Username configuration option 10

using the mwClearCase plug-in 17–40

V
variables command 40
VCS menu 19
VCS Setup settings panel
explanation of options 9–11
figure 9
options
Always show login dialog 10
Connect on open 10
Database Path 10
Local Path 11
Login Settings 10
Method 10
Password 10
Remember password 10
Try to mount shared volume 11
Use global settings as default 10
Use Version Control 9
Username 10