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1. Power Measurement Overview
The Power measurement tool enables the measurement of power usage on the
LPCXpresso boards that incorporate the power measurement circuit – for example the
LPCXpresso 54102 board. The power measurement tool is composed of three parts:
1. An LPCXpresso board featuring the power measurement circuit
2. The Power measurement firmware
3. LPCXpresso Power Measurement plug-in (part of LPCXpresso IDE 7.7.2 and above)
Note For Windows systems we require that Windows 7 and Internet Explorer 9 or higher
needs to be installed. We recommend that you install the most recent version of Internet
Explorer available for your Windows OS.
The tool can capture a burst of detailed high resolution power usage data or continuously
measure average power data. It can capture a burst of samples at up to 200ksps of either
the target current usage, the target supply voltage or the shield current. This information is
displayed in a graph and can be exported for further analysis. The average values of the
collected data can also be displayed.
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2. Quick Start
In this quick start guide you’ll learn how to collect current measurements from the
LPC54102 using the bridged version of the CMSIS-DAP bridge probe firmware.
1. On the LPCXpresso 54102 (LQFP) board make sure that the jumper JP5 (DFULink)
beside the Link USB socket is closed. This jumper puts the Link into DFU mode and
allows the Power measurement firmware to be downloaded.
2. Connect the Link USB socket on the board to your computer.
3. In LPCXpresso, switch to the Power Measurement view by either:
• typing “power ” in the Quick Access search box and selecting Power Measurement
Tool or
• using the menus: Window->Show view -> other -> Power Measurement -> Power
Measurement View)
4. Configure LPCXpresso to use the CMSIS-DAP power probe:
• Open the preferences page from the main menu bar
• Windows and Linux: Window -> Preferences
• Mac: LPCxpresso -> Preferences
• Locate the Redlink / LinkServer Options page by expanding the LPCXpresso item.
• Select “CMSIS-DAP (Default)” from the LPC-Link 2 boot type options.
•

5.

Download the firmware to the probe by pressing the Boot Debug Probe button
• If there is a probe in DFU mode the following dialog box will appear.
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•

• check the box next to CMSIS-DAP and press OK
• If the probe is not connected or the probe is not in DFU mode you will see this dialog
after the previous step:
•

• Double check that the board is connected using the USB socket labeled Link (not
Target) and that the jumper JP5 is closed, then power cycle the board and retry.
• Note: the firmware must be re-downloaded every time the probe is power cycled.
This will be done automatically if you are using debugging with the LPCXpresso IDE
6. The firmware:
•
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7. Once the firmware is downloaded you can download your code to the target if it is not
already in flash.
8. Select the data source from the drop down box: the target’s VDD or current, or the
shield’s current
• Note that the only shields designed to work with the power measurement will work
(currently only NXP’s sensor shield Rev 3).
9. Choose a sample rate between 50ksps and 200ksps
10.Choose a collection period in seconds
11.Press Start Capture
The tool will capture a burst of samples and display them in a chart.
Once all the data is collected you can explore it by double clicking on the chart to show
all the data and clicking and dragging to zoom into selected regions. For more information
about using the graph see the Graph [8] and Toolbar [8] sections.
The data can be exported as a CSV file using the save data button
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3. Power Measurement Firmware
3.1 Overview
The power measurement tool requires the latest version of the LPC-Link2 firmware to be
installed on the probe. This firmware provides a data channel through which the power
usage information is sent to be displayed in LPCXpresso.
The firmware is downloaded via the DFU mechanism. Since it resides in RAM you need
to re-download it every time the board is power cycles. LPCXpresso will perform this step
automatically, but first you need to choose the version of the probe to use.
The LPC-Link2 CMSIS-DAP firmware comes in two flavors: the “bridge probes” which
support the Power and SWO data channels in addition to the trace channel and the “nonbridged” which only provides the trace channel. The non-bridged versions are provided for
customers who experience USB bandwidth issues. If you are unable to debug your part
with the bridged firmware try switching to the non-bridged firmware – you will not be able
to use the power measurement tool, but should be able to do everything else.

3.1.1 Which firmware should I use?
There are two firmware choices:
1. CMSIS-DAP (Default)
2. CMSIS-DAP (Non-bridged – Debug only)
Choose the CMSIS-DAP (Default) option if you want to use the power measurement or
SWO trace. If you debug in another tool chain, this option will allow LPCXpresso to capture
the power data – even without a debug connection. Note that LPCXpresso does not need
to be debugging the target to be able to use the power tool with this option. For example
you could be tracking the power usage in LPCXpresso and debugging your code in Keil
uVision using this firmware. It also includes the SWO functionality and the serial I/O bridge.
The CMSIS-DAP (Non-bridged – Debug only) option excludes the power tool, SWO trace
and Serial I/O bridge extensions. This version uses less USB bandwidth and should be used
if you experience USB issues. Power measurement and SWO trace will be unavailable.

Note
Version 5.147 or later of the NXP CMSIS-DAP firmware is required to use the
power measurement functionality.

3.1.2 How to choose the firmware and download it
1. On the LPCXpresso board or LPC-Link2 make sure that the jumper beside the Link USB
socket is closed. This jumper puts the Link into DFU mode and allows new firmware to
be downloaded.
2. Connect the Link USB socket on the board to your computer.
3. Open the LPCXpresso preferences page from the main menu bar
• Windows and Linux: Window -> Preferences
• Mac: LPCxpresso -> Preferences
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4. Locate the Redlink / LinkServer Options page by expanding the LPCXpresso item.
• Select “CMSIS-DAP (Default)” from the LPC-Link2 boot type options.
•

5.

Download the firmware to the probe by pressing the Boot Debug Probe button
• If there is a probe in DFU mode the following dialog box will appear.
•

• check the box next to CMSIS-DAP and press OK
• If the probe is not connected or the probe is not in DFU mode you will see this dialog
after the previous step:
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•

• Double check that the board is connected using the USB socket labeled Link (not
Target) and that the jumper JP5 is closed, then power cycle the board and retry.
6. The firmware will then be downloaded
•

Note
The firmware must be re-downloaded every time the probe is power cycled.
This is done automatically if you are debugging with LPCXpresso IDE
otherwise you need to use the Boot Debug Probe button

each time.

3.1.3 Troubleshooting
• Time-out when downloading CMSIS-DAP probe on windows - There is a conflict
between the latest CMSIS-DAP probe drive and an older driver. To resolve, please see
the FAQ ‘LPC-Link2 fails to enumerate with CMSIS-DAP firmware’:
• https://community.nxp.com/message/630660
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4. Power measurement tool view
Use the Power measurement tool view to collect and analyze bursts of high frequency
samples. From this view you can choose and configure the measurement source; and then
explore a graph of the collected data. See the “Average Power view”#AveragePowerView
for continuous monitoring of the power usage.

4.1 Toolbar
This section contains a brief description of each button in the toolbar.
•

Starts collection of detailed data (using previous configuration if available)

•

Stops collection of data

•

Configures the board settings

•

Clears the captured data from memory, clearing the graph and average data

•

Export the collected data to a CSV file

•

Zoom in on the center of the graph (also see zooming [8] )

•

Zoom in out of the graph (also see zooming [8] )

•

Reset the zoom level to show all data (also see zooming [8] )

•

Set Y-axis to run from zero to maximum plotted value

•

Set Y-axis to run from minimum to maximum plotted value

•

Open the Average Power [11] view

•

Display about page and link to help

4.2 Graph
The collected data is displayed here.

4.2.1 Zooming
You can interact with the graph using the mouse by clicking and dragging on the graph:
• Zoom in on x-axis: click and drag horizontally to highlight the region to zoom into
• Zoom in on y-axis: click and drag vertically to highlight the region to zoom into
• Zoom out to see all data: double click in graph
• Pan left and right: hold down shift as you click and drag on the graph
Additionally, there are the zoom buttons in the toolbar [8]:
• x-axis zoom:
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• y-axis zoom:

4.2.2 Axes
The y-axis can be configured to start from zero or from the minimum value in the visible
data. Use these two buttons in the toolbar to switch between these modes:
The x-axis uses relative labeling – it always starts from zero no matter how far through
your time series you are. Hover the mouse over a point to see the position of that point
in the whole time series.

4.2.3 Point label
When the mouse cursor is in the graph a label appears in the top right corner indicating the
time and value corresponding to the point at that position on the x-axis.
In order to show small differences in time throughout the collected data the time is
represented as the sum of the time for the first point on the displayed x-axis plus the
difference between that point and the highlighted point. Note the different units used for
the two numbers.

4.3 Configuration
The configuration dialog box in the Power Measurement Tool allows you to set the
measurement source, the sense resistors, the sample rate and the number of samples to
capture.

4.3.1 Board hardware configuration
There are two different power measurement circuits supported by the tool: the version on
the LPCXpresso 54104 board and the later revision which was used on the other boards.
The choose the circuit corresponding to the board that you are using.
Resistors: The values of the sense resistors across which the target and shield currents
are measured can be adjusted here. They are initialize to match the LPC54102 board
configuration. This setting allows the tool to be calibrated to adjust for the tolerance in those
resistor values.

4.3.2 Capture details mode
There three options to configure for a capture.
The data source can be one of:
• Target Vdd
• Target Current
• Shield Current (requires the target shield to include current measurement hardware).
Sample Rate: The ADC reading the current can sample at rates of between 50 and 200
thousand samples per second (50ksps – 200ksps). The following sample rates can be
selected (these are chosen to provide a whole number of microseconds between readings):
• 50ksps (20us period)
• 62.5ksps (16us period)
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• 100ksps (10us period)
• 125ksps (8us period)
• 200ksps (5us period)
It is recommended to use lower sample rates to capture longer time periods.
Sample period defines the length of time to collect samples for in seconds.

Memory usage
A 60s capture at 200ksps collects 12 million samples, this takes up about 80MB
of RAM. The longer the sample period, the more memory is required. The
amount of memory allocated to a JAVA application is set when they start. When
you start a capture this tool tries to preallocate the required amount of memory.
If more memory is required than is available you will see an error message.
Either reduce the sample period or increase the amount of memory allocated
using the guide in the Appendix [15] .
The Start Capture button will apply the configuration and capture a burst of samples.
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5. Average Power View
5.1 Overview
The Average Power View displays the average of the collected samples. It continuously
switches between sampling from each available measurement source and displays an
average for each. Compared with the detailed graphical view provided in the Power
measurement tool [8], the Average Power view uses minimal resources on your host
computer and the debug probe. Given the low overhead, the average power measurement
and just be left running.
This view will also show the average of the chosen source when detailed data is being
collected in the Power Measurement view.
It also shows the number of samples collected in the most recent collection and the number
of breaks in the data.
The breaks occur when a packet of data is not collected from the probe before it gets
overwritten. These can be reduced by increasing the amount of memory available or
reducing the sample period.

Figure 5.1. The Average Power view

5.2 Opening the Average Power View
Open the Average Power view by typing “Average Power” into the Quick Access search
box in the top right of the IDE and selecting the Average Power view. You can also open
it using the menus: Window -> Show View -> Other and then typing “power” in filter text
box and finally selecting “Average Power”.
It can also be opened by pressing the Average Power button
graph tool.

in the Power Measurement

5.3 Toolbar
This section contains a brief description of each button in the Average Power view’s toolbar.
•

Starts collection of average data.

•

Stops collection of data.
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•

Configures the board settings

•

Clears the captured data from memory, clearing the graph and average data

•

Open the Power measurement tool [8] graph view

•

Display about page and link to help

5.4 Configuration
The power measurement probe hardware comes and different configurations and can be
reconfigured by end users. The Power tool in the LPCXpresso IDE need to be set up to
match the board. This information is entered in the Configuration dialog box. This dialog
box is opened the first time the start button is pressed and whenever the Configuration
button is pressed (see figure Figure 5.2).

Figure 5.2. The hardware configuration for Average Power

5.4.1 Power probe circuit
There are two version of the circuit which are used on different LPCXpresso development
boards. If you are using an LPCXpresso 54102 board choose “LPCXpresso54102” board,
otherwise select “Other boards”.
Note that users of the LPCXpresso 5411x boards should select “Other boards”.

5.4.2 Target resistor
Choose the resistance which matches the sense resistor on the LPXpresso board which
has the target MCU on it. The standard options are provided in the drop-down list. If you
have replaced the sense resistor with a different one you can directly type it into the box.
Note that all resistances must be entered in Ohms in decimal format.

LPCXpresso IDE Power Measurement Guide -

User Guide

All information provided in this document is subject to legal disclaimers

Rev. 8.1 — 3 June, 2016

© 2013-2016 NXP Semiconductors. All rights reserved.

12

NXP Semiconductors

LPCXpresso IDE Power Measurement Guide

5.4.3 Shield resistor
Choose the resistance which matches the sense resistor on the LPXpresso shield board.
The standard options are provided in the drop-down list. If you have replaced the sense
resistor with a different one, you can directly type it into the box.
Note that all resistances must be entered in Ohms in decimal format.

5.5 Usage
To collect average power information from all available measurement sources:
1. Open the Average power view
2. Ensure that your development board is connected
3. Ensure that the LPCXpresso CMSIS-DAP probe version 5.147 or later is booted. See
Probe Firmware [5] for detailed instructions.
4. Press the Start button
5. Configure the tool for your board and hit “Start” in the dialog box.
The view should start sequentially updating the average readings for each of the available
sources. The samples collected box will start incrementing.

5.6 Sampling information
Each measurement source is sampled for approximately one second at a rate of 200ksps,
before moving onto the next. A moving average of the data collected for each is kept, with
a window size of 199626 samples (to match internal buffer boundaries). Since there are
typically three measurement sources (target Vdd, target current and shield current) 2s of
data out of 3s is missed from these averages. For more precise power usage the Power
Measurement Tool graph view should be used.
The total number of samples collected from all sources is display in the “Samples Collected”
row.
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6. Precision and accuracy
The power measurement hardware uses an ADC with 12-bit precision. For the target’s
current this provides step sizes of 3.9uA, up to a maximum of 16mA. The sensor shield
board has a step size of 3.2uA and a maximum current of 13.2mV. The target’s Vdd has
a step size of 806uV and a maximum of 3.3V.
The maximum measurable current depends on the sense resistor Rs (Ohms) and the
target’s voltage VDD (V). It can be calculated as: I = (VDD - 0.1V) / (25 * Rs)
Higher currents cannot be measured and will be recorded as the maximum, resulting in
underestimation of the current usage. Change the sense resistor to a smaller resistance to
increase the maximum measurable current.
Table 6.1. Maximum measurable currents
Sense Resistor (Ohms)
4.12
8.2
10

Vdd = 1.8V
16.5mA
8.29mA
6.8mA

Vdd = 3.3V
30.1mA
15.6mA
12.8mA

The power numbers can be expected to be accurate to within 2%. The major sources of
error are the the gain amplifier (MAX9634TEUK+T) used by the Target current and the
Shield current, and the tolerance of the sense resistors.
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7. Appendix
7.1 Increasing memory
The LPCXpresso IDE is a Java application. Low memory can result in gaps in your trace
or prevent you from being able to capture as much data as you need to.
This appendix shows how to increase the amount of Java memory available for each error
type.

7.1.1 The INI file
When the IDE starts, it loads Java configuration information from the ini file:

<install>/

lpcxpresso/lpcxpresso.ini

This file contains the parameter that control how the application uses memory.
-vmargs
-Xms128m
-Xmx512m
Description of the arguments:
•

-Xms128m

This defines the initial amount of heap space available to the Java runtime.
This is dynamically allocated space and you should increase if you have a large number
of files or projects in your workspace. The default is normally 128m; 256m would make
it 256Mb.

•

-Xmx512m This defines the maximum amount of Heap space available to Java. This value
must be greater than or equal to the value used in -Xms .

7.1.2 Not enough memory to capture n samples
If you see an out of memory error when attempting to start a data capture try increasing
the maximum heap size in the ini file. For example by changing -Xmx512m to -Xmx768m would
increase the maximum heap size from 512mb to 768mb.
Restart the IDE for the changes to take effect.

7.1.3 Gaps in trace
Increasing the initial heap space can help to reduce the number of gaps in the trace. Try
setting the -Xms parameter to be equal to the -Xmx value. The value for -Xmx must always
be greater than or equal to the value for -Xms.
Restart the IDE for the changes to take effect.

7.1.4 Keeping track of memory usage
You may also wish to enable the workspace preference such that the Java heap status is
displayed in the IDE status bar (bottom right of Window). To do this, select:
Window -> Preferences -> General -> Show heap status
A full discussion on the options available in the file can be found at http://wiki.eclipse.org/
Eclipse.ini
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