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LPC1837 High-Performance Cortex-M3 
 

        
 180 MHz 

 1MB dual-bank Flash 

 High Speed USB: on-chip HS PHY, dual HS USB host capable 

 BGA256/180/100, LQFP208/144 

 Pin compatible to LPC4300 
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Demo 1: Dual USB demo 
This demo shows both USB controllers on the LPC1837 running at the same time. The demo requires a 

Windows PC with two USB ports. 

Setup the Dual USB demo: 

1. Confirm the Micro SD card is inserted 

2. Plug the ear buds into J5 

3. Connect both USB ports on the board to a Windows PC 
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Run the Dual USB demo: 

1. Set the “NXP Audio Out Demo” playback device as the default playback device in the Sound 
control panel.  

 

                                                                                    

 

2. Select one of the MP3 files on the NXP drive and open it (double click) 

 

 

3. Listen to the MP3 music using the ear buds.  
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How this demo works: 

The PC streams the MP3 file stored on the Micro SD card over a Hi-Speed USB connection (USB0), 
decodes it with Media Player on the PC, and then streams it back to the Full Speed USB connection 
(USB1) where it is played through the ear buds.  

 

 

USB0 enumerates as a high speed mass storage class device. 

The operating system displays this device as a drive in File Explorer. 

The files displayed in File Explorer are stored on the Micro SD card. 

USB1 enumerates as a full speed Audio class device (UAC 1.0) 

The operating system displays this as a playback device in the Sound control panel. 

This Sound control panel is used to set the Audio class device as the default audio playback device. 

 

Note: The Micro SD card must remain inserted during the demo. If it is removed and reinserted the board must be reset. 
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Demo 2: High speed USB Host demo 
 

This demo shows high speed USB host mode operation by copying files from the Micro SD card 

to a USB flash drive. 

 

Setup the USB Host demo: 

1. Insert the Micro SD card 

2. Connect the USB flash drive to USB0 on the board using the special USB host cable 

3. Connect USB1 on the board to a laptop or PC to power the board 
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Run the Hi-Speed USB Host demo: 

1. Press the button labeled SW2 to toggle USB0 between host and device mode. 

2. Verify the green LED (D2) is lit indicating that USB0 is in host mode 

3. A flashing blue LED (D3) indicates files are being copied. 

4. Three blinks of the blue LED indicate that file copying is complete. 

5. Confirm the audio files have copied to the Flash drive by inserting into your PC.  

 

 

Note: the FAT file system used in this demo is not configured to support extended file names so the files 

copied to the USB flash drive will all have shortened names of the old 8.3 DOS format. 

Only files in the root directory are copied. Folders are not copied. 
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How this demo works: 

The LPC1837 microcontroller runs a file system on both storage devices. 

When the SWD button is pressed the application reads the root directory on the Micro SD card 

to get a file list. Then all the files on the list are copied one at a time to the USB flash drive.  

Files are transferred in 8K chunks using internal memory of the microcontroller.  
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Building the demos / Source Code 
 

Getting the source 

You will find complete source code to the two USB demos on the Micro SD card that came with your 

board. This source, as well as all the files on the Micro SD card, can also be found at the LPC1837 Xplorer 

board website here: http://lpcware.com/content/devboard/lpc1837-xplorer-board 

Building the demo 

The demos include project files for the following two compilers: 

Keil uVision v4.70 
  http://www.keil.com/arm/mdk.asp 
  Main project workspace file: <Micro SD card>/USBDemos.uvmpw 
  Note: The total size of the binary image exceeds the 32K limit of the free version of this compiler. 

To build the demos using uVision: 
1. Double click on the project workspace file. 
2. Click on Project->Batch Build->Select All 
3. Click on Project->Batch Build->Build 
4. Binary image, map file, etc., can be found in 

applications\lpc18xx_43xx\examples\LPCUSBlib\lpcusblib_DualDeviceAudioMSC\keil_output\ifl
ash_ngx_xplorer_1837 or spifi_ngx_xplorer_1837 

 

NXP LPCXpresso v6 

  http://lpcware.com/lpcxpresso/home 

 

  To build the demos using LPCXpresso: 
1. Startup LPCXpresso 
2. Click on File->Import->General->Existing Projects into Workspace->Next 
3. Check the Select root directory radio button 
4. In this field enter the root directory of the source code and press Browse… 
5. Three projects should show up: 

 lpc18xx_ngx_xplorer_1830_board_lib 
 ngx_xplorer_1830_usblib_hostdevice 
 ngx_xplorer_1830_lpcusblib_DualDeviceAudioMSC 

6. Click on Select All->Finish 
7. Click on Project->Build All 
8. Binary image, map file, etc., can be found in 

 applications\lpc18xx_43xx\xpresso_projects\LPCUSBlib\lpcusblib_DualDeviceAudioMSC\Debug 

 

http://lpcware.com/content/devboard/lpc1837-xplorer-board
http://www.keil.com/arm/mdk.asp
http://lpcware.com/lpcxpresso/home
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Resources 
 

Demo board information 

 LPC1837 product page - http://www.lpcware.com/content/device/lpc18xx 

 LPC1837 Xplorer board - http://lpcware.com/content/devboard/lpc1837-xplorer-board 

 NGX board quick start guide - 

http://shop.ngxtechnologies.com/download/user_manual/Xplorer/Quick_Start_Guide_Xplorer_LPC183

0.pdf 

 

Tools 

 Keil uVision IDE - http://www.keil.com/arm/mdk.asp 

 LPCXpresso IDE - http://lpcware.com/lpcxpresso/home 

 

USB related links 

 USB Implementers Forum - http://www.usb.org/home 

 USB in a nutshell - http://www.beyondlogic.org/usbnutshell/usb1.shtml 

 USB made simple - http://www.usbmadesimple.co.uk/ 

 NXP’s VID/PID program - http://www.lpcware.com/content/project/usb-vid-pid-program 

  

http://www.lpcware.com/content/device/lpc18xx
http://lpcware.com/content/devboard/lpc1837-xplorer-board
http://shop.ngxtechnologies.com/download/user_manual/Xplorer/Quick_Start_Guide_Xplorer_LPC1830.pdf
http://shop.ngxtechnologies.com/download/user_manual/Xplorer/Quick_Start_Guide_Xplorer_LPC1830.pdf
http://www.keil.com/arm/mdk.asp
http://lpcware.com/lpcxpresso/home
http://www.usb.org/home
http://www.beyondlogic.org/usbnutshell/usb1.shtml
http://www.usbmadesimple.co.uk/
http://www.lpcware.com/content/project/usb-vid-pid-program
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Legal information 
 

Definitions 

Draft — The document is a draft version only. The content is still under internal review and subject to formal approval, which may result in 

modifications or additions. NXP Semiconductors does not give any representations or warranties as to the accuracy or completeness of information 

included herein and shall have no liability for the consequences of use of such information. 

 

Disclaimers 

Limited warranty and liability — Information in this document is believed to be accurate and reliable. However, NXP Semiconductors does not give 

any representations or warranties, expressed or implied, as to the accuracy or completeness of such information and shall have no liability for the 

consequences of use of such information. 

In no event shall NXP Semiconductors be liable for any indirect, incidental, punitive, special or consequential damages (including - without limitation - 

lost profits, lost savings, business interruption, costs related to the removal or replacement of any products or rework charges) whether or not such 

damages are based on tort (including negligence), warranty, breach of contract or any other legal theory. 

Notwithstanding any damages that customer might incur for any reason whatsoever, NXP Semiconductors’ aggregate and cumulative liability towards 

customer for the products described herein shall be limited in accordance with the Terms and conditions of commercial sale of NXP Semiconductors. 

Right to make changes — NXP Semiconductors reserves the right to make changes to information published in this document, including without 

limitation specifications and product descriptions, at any time and without notice. This document supersedes and replaces all information supplied prior 

to the publication hereof. 

Suitability for use — NXP Semiconductors products are not designed, authorized or warranted to be suitable for use in life support, life-critical or 

safety-critical systems or equipment, nor in applications where failure or malfunction of an NXP Semiconductors product can reasonably be expected 

to result in personal injury, death or severe property or environmental damage. NXP Semiconductors accepts no liability for inclusion and/or use of 

NXP Semiconductors products in such equipment or applications and therefore such inclusion and/or use is at the customer’s own risk.  

Applications — Applications that are described herein for any of these products are for illustrative purposes only. NXP Semiconductors makes no 

representation or warranty that such applications will be suitable for the specified use without further testing or modification.  

Customers are responsible for the design and operation of their applications and products using NXP Semiconductors products, and NXP 

Semiconductors accepts no liability for any assistance with applications or customer product design. It is customer’s sole responsibility to determine 

whether the NXP Semiconductors product is suitable and fit for the customer’s applications and products planned, as well as for the planned 

application and use of customer’s third party customer(s). Customers should provide appropriate design and operating safeguards to minimize the risks 

associated with their applications and products.  

NXP Semiconductors does not accept any liability related to any default, damage, costs or problem which is based on any weakness or default in the 

customer’s applications or products, or the application or use by customer’s third party customer(s). Customer is responsible for doing all necessary 

testing for the customer’s applications and products using NXP Semiconductors products in order to avoid a default of the applications and the 

products or of the application or use by customer’s third party customer(s). NXP does not accept any liability in this respect. 

Export control — This document as well as the item(s) described herein may be subject to export control regulations. Export might require a prior 

authorization from competent authorities. 

Evaluation products — This product is provided on an “as is” and “with all faults” basis for evaluation purposes only. NXP Semiconductors, its 

affiliates and their suppliers expressly disclaim all warranties, whether express, implied or statutory, including but not limited to the implied warranties of 

non-infringement, merchantability and fitness for a particular purpose. The entire risk as to the quality, or arising out of the use or performance, of this 

product remains with customer. 

In no event shall NXP Semiconductors, its affiliates or their suppliers be liable to customer for any special, indirect, consequential, punitive or incidental 

damages (including without limitation damages for loss of business, business interruption, loss of use, loss of data or information, and the like) arising 

out the use of or inability to use the product, whether or not based on tort (including negligence), strict liability, breach of contract, breach of warranty or 

any other theory, even if advised of the possibility of such damages.  

Notwithstanding any damages that customer might incur for any reason whatsoever (including without limitation, all damages referenced above and all 

direct or general damages), the entire liability of NXP Semiconductors, its affiliates and their suppliers and customer’s exclusive remedy for all of the 

foregoing shall be limited to actual damages incurred by customer based on reasonable reliance up to the greater of the amount actually paid by 

customer for the product or five dollars (US$5.00). The foregoing limitations, exclusions and disclaimers shall apply to the maximum extent permitted 

by applicable law, even if any remedy fails of its essential purpose. 

 


