1 Introduction

This document describes how to use 5W low power multi-coil Wireless Charging Transmitter reference board with WPC A28 solution designed by Freescale. The A28 Reference solution is compliant with WPC Qi V1.1 specification. It is low cost reference solution, which can be easy customized through the FreeMASTER GUI tool.

Figure 1 WCT-5WTXMULTI (A28) reference board
2 System Features

The A28 reference board has the following features:

- Reference design compliant with low power WPC Qi version 1.1 Specification.
- Integrated digital demodulation in chip.
- Supports multiple types Rx modulation signals (AC capacitor, AC resistor and DC resistor).
- Supports Qi power loss FOD feature.
- Supports Qi 1.1 receiver with 5 V DC@1A output power capability.
- Low standby power by analog ping.
- Full bridge topology with frequency modulation power control strategy.
- Multi-coils, can achieve large charging area.
- Supports LED to indicate power transfer status.
- Input voltage/current, coil current and coil temperature sensing for protection.
- FreeMASTER GUI tool to enable customization and calibration.
- Supports the FO detection method before power transfer.

3 Package Checklist

<table>
<thead>
<tr>
<th>Name</th>
<th>Count</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCT-SWTXMULTI A28 Tx board with Tx coil</td>
<td>1</td>
</tr>
<tr>
<td>5V/2.4A DC power adapter</td>
<td>1</td>
</tr>
<tr>
<td>Osjtag board and cables for debugging</td>
<td>1</td>
</tr>
</tbody>
</table>

4 System Block Diagram

Multi-coil Tx runs with Rx, as shown in Figure 2, to transfer power from the primary to the secondary side.

Figure 2 Wireless Charging System Overview

Get WPC Qi information from: [www.wirelesspowerconsortium.com/developers/](http://www.wirelesspowerconsortium.com/developers/)
5 **Hardware Description**

5.1 **Reference board block diagram**

![Block Diagram](image)

**Figure 3** WCT-5WTXMULTI A28 board block diagram
5.2 Modules description

- **Controller**
  Freescale MWCT1101CLH chip is the central controller of the WCT-5WTXMULTI A28 board. It has rich I/O modules but with low power consumption. It processes communication signals, controls power transfer start/stop, controls the coil switched circuit, and controls full bridge PWM inverter for output power control.
  These are I/O modules used in this application:
  o Two PWM channels for full-bridge DC/AC inverter control.
  o Three Timers for system timers and communication.
  o ADC for input voltage, current, coil current and temperature sampling.
  o GPIOs for pre-drivers control, low power, coils switched, and LED control.
  o Two SCI for serial port debugging.
  o Low cost GPIO touch feature to decrease the standby power.

- **Inverter**
  The full bridge PWM control inverter converts input 5 V DC voltage to a higher AC voltage. The PWM frequency follows WPC Qi specification, in 115 KHz–205 KHz range. PWM duty is 50%, and starts duty control (50%–10%) when frequency is 205 KHz. Lower frequency gets larger output power.
  Input voltage range: 4.75 V DC – 5.25 V DC
  Output voltage range: 5 V AC – 20 V AC
• Communication
  The communication of 2 Kbps signal is demodulated from high frequency coil current AC signal (110 KHz–205 KHz). The RC sensing circuit gets resonant coil current and input to ADC for sampling. Digital demodulation module processes on the input samples and extracts communication packets.

• GPIO Touch sensing for low power mode
  The board supports super low power mode by Freescale touch technology. When it is not charging, controller shuts down analog circuit power supply, and start the GPIO touch sensing for every 400mS, when the Receiver is placed on the TX coil surface if will be sensed by the touch feature, and start the wireless charging process.
6 Getting Started

Freescale provides an SW package to modify WCT A28 functions. The user can modify system parameters or configurations to maintain system functionalities. For example, when Tx coil or main power components are changed, it is better to do calibration to get FOD working. This manual describes basic debugging environment on WCT1101. For Multi-coil SW details, see the WCT1101 A28 Library User’s Guide (WCT1101LIBUG).

6.1 System developing environment

Tx board debugging uses CodeWarrior and the FreeMASTER tool. Set up the debugging connection as shown in Figure 5. The debugger and debugging board is between the PC and Tx board. Connect a debugger (OSJTAG, USBTAP or P&E-Multilink FX) to the JTAG port of a debugging board, and connect the debugging board to a Tx board through a 14-pins cable.

Figure 5 shows the connection and Figure 6 shows a real image.
Figure 6 Developing environment

For details on the USB TAP debugger, see freescale.com and then search for “USB TAP for Once DSC”.

For details on the P&E-Multilink FX debugger, see freescale.com and then search for “U-MULTILINK-FX”. It will take you to the “U-MULTILINK-FX: Universal Multilink FX High-Speed Development Interface” page.
6.2 Downloading and debugging firmware with CodeWarrior 10 IDE

6.2.1 Connecting the JTAG debugger

After CW10 is installed, connect the Freescale MCU JTAG debugger, OSJTAG, USB TAP or P&E Multilink to the A28 board.

The cable plug-in direction is shown in Figure 7, OSJTAG board is default used.

![Figure 7 Cable plug-in direction](image-url)
When the debugger is plugged onto the PC, the device can be found in Windows “Device Manager”, as shown in the following figures.

![OSJTAG](image)

**Figure 8** OSJTAG debugger plugged in
Figure 9  USB TAP debugger plugged in

Figure 10  P&E multilink debugger plugged in
6.2.2 Downloading an existing WCT1101 project with CW10

To download an existing A28 project with CW10, perform the following steps (Tested CW tool version is CW10.6):

1. Set the CW10 Workspace.
   
   Open CW10, and set the workspace to multi-coil example project, WCTA28demo.
2. Install the WCT service packet.
   Choose Help → Install New Software.

Figure 13 Installing new software
3. Click “Add” and “Archive”, and then select “com.freescale.mcu10_6.WCT_WCT100x_WCT1100x_WCT1200x.win.sp.v1.0.1.zip” (CW MCU v10.6 Wireless Charging MWCT1xxx Service Pack). Download address: http://www.freescale.com/webapp/sps/site/overview.jsp?code=CW_UPDATES_MCU_10_6&fsrc=1&sr=1&pageNum=1

Figure 14 Selecting the service pack
4. Select “MCU v10.6 DSC Service Packs”, and then click “Next”.

![Figure 15 Selecting MCU v10.6 DSC service packs](image1)

5. Click “Next”.

![Figure 16 Installing the pack](image2)
6. Review the license terms. If you agree with the license terms, select “I accept the terms of the license agreement”, and then click “Finish”.

Figure 17 Installation finished
7. **Import a project.**

Right-click in the “CodeWarrior Projects” window and choose “Import” to import an existing project, as shown in the following figures. If the “CodeWarrior Projects” window is not displayed, open it through Window → Show View → CodeWarrior Projects.

![Figure 18 Importing a project (1)](image1.png)

**Figure 18 Importing a project (1)**

![Figure 19 Importing a project (2)](image2.png)

**Figure 19 Importing a project (2)**
Select the project directory, as shown in Figure.

Figure 20 Importing a project (3)

Select the project found by CW10.

Figure 21 Importing a project (5)
8. Build a project.

You can select build configurations → Debug or Release build, by clicking the project name in the project window shown in Figure. Debug build includes more debug information.

![Figure 22 Building a project (1)](image)

Right-click the project name “WCTA28demo: SDM_Debug”, and then select “Build Project”, “Clean Project”, or “Close Project”. You can also perform building from “Project”.
Download the project.

After the project is built, the MCU binary files are generated to a folder, with the same name as the build configuration name, “SDM_Debug”.

Download the project from the “Debug” drop-down list, or from “Run –> Debug”.

In “Debug Configurations”, select a download configuration according to your build configurations and debugger type, OSJTAG, USB TAP, or PnE Multilink.
Figure 24 Downloading the project
After the project is downloaded, the MCU stops at start up code. Press F8 to let MCU go.

Go Pause Stop Step

Watching window for Variables, Registers, Memory, and Breakpoints

Source code

Disassembly

Figure 25 Project Downloaded

6.2.3 Downloading an existing WCT1101 bin file (.s) with CW10

To flash an “.s” file, perform the following steps:

1. From the Flash Programmer drop-down list, select “Flash File to Target”.

Figure 26 Bin file download
2. Click “New” to create a new connection.

![Figure 27 Bin file download](image1)

3. Enter a connection name and click “New” to create a target.

![Figure 28 Bin file download](image2)
4. Enter a target name, and then select “WCT1101” from the “Target type” drop-down list.

![Figure 29 Bin file download](image-url)


Freescale Semiconductor
5. Select “Execute reset” and “Initialize target”, set the initialization file path to the CW10 installation folder, and select “MWCT1101.tcl” for the WCT1101 chip.

![Figure 30 Bin file download](image)
6. Set the memory configuration file path. For the WCT1101 chip, it is “MWCT1101.mem”, located under the CW10 installation folder. Then click “Finish”.

![Figure 31 Bin file download](image-url)
7. Select “P&E DSC Multilink\Multilink Universal\Cyclone Pro\OSJTAG” or “USB TAP” for the connection type. Then click “Finish”.

![Figure 32 Bin file download](image)

8. Set the Bin file path (The location is `\...\WCT_5W_MultiCoils_V2.0_RC5\A28\WCTA28demo.elf.S`). Before downloading, you can save the configuration to the workspace for next-time downloading. Click “Erase and Program”. NOTE: To download an “.elf” file, please do “Erase Whole Devices” before “Erase and Program”. Otherwise it may fail.
9. The flashing progress is displayed in the CW10 console window. After flashing is completed, reset the board to make WCT1101 running.
6.2.4 Setting up FreeMASTER connection to target board

1. Set symbol file for your project (Tested Freemaster tool version is V1.4.2.3):
   Select symbol file in FreeMASTER Project → Options → MAP Files in Freemaster tool, as shown in Figure.

   ![Figure 35 Selecting symbol file](image)

2. Perform settings for using the SCI/OSJTAG debugger.
   1) By default, SCI is used for Freemaster connection in A28 demo, and the baud rate is 19200. Before connecting Freemaster, confirm that the baud rate of the computer com port is 19200. It can be found in Computer → Manage → System Tools → Device Manager → Ports. Right-click “OSBDM/OSJTAG” and choose “Properties”. Then the baud rate can be changed as shown in Figure.
2) Select “FreeMASTER BDM JTAG/OnCE” in Project → Options → Comm in Freemaster tool, as shown in Figure.

3) Click the “Start/Stop” button to make the Freemaster connection work.

3. Perform settings for using the USB TAP/ P&E Multilink FX debugger.
   
   As SCI is used for Freemaster connection in current A28 demo by default, if other debuggers are used, some changes are needed. Perform the following steps to enable the USB TAP/P&E Multilink FX debugger connection:
1) Import WCTA28demo in CW10. Disable macro “FMSTR_USE_SCI” and enable “FMSTR_USE_JTAG”. They are defined in WCTA28demo -> Sources -> Application -> freemaster_cfg.h as follows:

#define FMSTR_USE_SCI 0 /* To select SCI communication interface */
#define FMSTR_USE_JTAG 1 /* 56F8xxx: use JTAG interface */

2) Rebuild the demo, and download it according to the used debugger type USB TAP/P&E Multilink FX.

3) For the USB TAP debugger, keep the CW10 connected, and select “JTAG/OnCE” in Freemaster Project -> Options -> Comm in Freemaster tool as shown in Figure.

4) For P&E Multilink FX debugger, disconnect the CW10, select “JTAG/OnCE” in Freemaster Project -> Options -> Comm in the Freemaster tool as shown in Figure.
Click the “Start/Stop” button to make the Freemaster connection work.
6.2.5 Using FreeMASTER GUI for calibration

Freescale provides the FreeMASTER GUI tool for calibration and parameters tuning. Freemaster configuration file WCTA28demo.pmp is saved under \A28\example\WCTxxx\WCTA28demo. See the *WCT1101 A28 Reference Design Calibration User’s Guide* (WCT1101CALUG) for calibration. See the *WCT1101 A28 Run-Time Debug User’s Guide* (WCT1101RTDUG) for Multi-coil parameters tuning. For the FreeMASTER tool, see freescale.com/Freemaster.

![Figure 40 FreeMASTER GUI tool](image-url)
6.2.6 Enabling the RS FOD function

RS-FOD (Resonance Shift FOD) is one optional solution to detect FO in standby mode, when Rx is not on the surface of Tx. This can ensure that the charging never starts power transfer if FO is present. It does not belong to Qi 1.1, so the feature is disabled in the demo image. However, you can enable it by the following steps if the feature is required.

The steps of enabling this function are as follows:

1. Right-click the project, and choose “Properties”.

![Image of choosing the properties of project]

*Figure 41 Choosing the properties of project*
2. Choose C/C++ Build -> Setting -> DSC Linker -> Input, as shown in the following figure.

![Figure 42 Finding the additional libraries option](image)

3. Double click “.../wct_mp1_SDM_Debug.lib” in “Additional Libraries”, and change to “wct_a28_RSFOD_SDM_Debug.lib”. Then click “OK” and exit.

![Figure 43 Modifying the relevant library](image)

4. Set the macro RESONANCE_SHIFT_FOD to TRUE in wct_LibStruct.h. Rebuild the project to make the RS FOD function work.
6.2.7 Enabling or disabling board functions

Freescale provides full-featured wireless charging functions on the reference board. If you do not need a function, you can disable it by definitions in the header file or by parameters in the FreeMASTER GUI.

The following header files are used to enable or disable functions, and to configure low-level driver.

A28\lib\A28\ wct_hal_cfg.h

A28\example\WCTxxxx\ WCTA28demo\cw10\Sources\application_cfg.h, peripheral_cfg.h

In application_cfg.h, you can configure the following functions:

- Low power mode by analog ping enable/disable
  #define LOW_POWER_MODE_SUPPORTED TRUE // FALSE for calibration or debug on FreeMASTER GUI.
  #define LOW_POWER_MODE_BY_ANALOG_PING TRUE // FALSE for calibration or debug on FreeMASTER GUI.

- Freemaster support enable/disable
  #define FREEMASTER_SUPPORTED TRUE // FALSE if disable Freemaster connection.

Note: ** Touch sensor should be disabled when low power mode by analog ping is enabled.
6.3 Test

6.3.1 Basic charging test

When software work is prepared, power on the A28 demo board with standard 5V adapter to make it work. Put the standard QI receiver on the charging pad, and make sure the coil is aligned and the load is in the allowed range—5W. Then the Tx will charge the Rx normally.

![Working system](image)

Figure 44 Working system

The defined LED display mode for different Tx working states is shown in below table:

<table>
<thead>
<tr>
<th>LED Configure Option</th>
<th>Description</th>
<th>LED #</th>
<th>LED Operational States</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>LED2</td>
<td>Standby: Blink slow, Charging: On, Charge Complete: On, Power Limit: Blink fast, FOD Fault: Off, TX Fault: Off, RX Fault: Off</td>
</tr>
<tr>
<td>Option-1</td>
<td>Choice-1</td>
<td>LED1</td>
<td>Standby: Off, Charging: Blink slow, Charge Complete: On, Power Limit: Off, FOD Fault: Off, TX Fault: Off, RX Fault: Off</td>
</tr>
<tr>
<td></td>
<td></td>
<td>LED2</td>
<td>Standby: Off, Charging: Off, Charge Complete: Off, Power Limit: Blink fast, FOD Fault: Blink fast, TX Fault: Blink fast, RX Fault: Blink fast</td>
</tr>
<tr>
<td></td>
<td></td>
<td>LED2</td>
<td>Standby: Off, Charging: Off, Charge Complete: Off, Power Limit: Blink fast, FOD Fault: On, TX Fault: Blink slow, RX Fault: Blink slow</td>
</tr>
<tr>
<td>Option-3</td>
<td>Choice-3</td>
<td>LED1</td>
<td>Standby: Off, Charging: Blink slow, Charge Complete: On, Power Limit: Blink fast, FOD Fault: Blink fast, TX Fault: Blink fast, RX Fault: Blink fast</td>
</tr>
<tr>
<td></td>
<td></td>
<td>LED2</td>
<td>Standby: Off, Charging: Off, Charge Complete: Off, Power Limit: Blink fast, FOD Fault: Off, TX Fault: Off, RX Fault: Off</td>
</tr>
</tbody>
</table>
6.3.2 Signals on the board

Main signals on A28 board are shown in the figure below.

![Figure 45 Test points on 5WTXMLTI A28](image)

- TP1: Vcc, controller input voltage 3.3V
- TP13: Coil current sensing
- GC10,GE2,GF3: GPIO touch pad
- TP18: Input current sensing
- TP20&21: PWM1&2, PWM signals to pre-driver
- TP33: LC-Resonant voltage on the coil
- TP6,TP16,TP17: Touch sensing signal to an external electrode
- TP22: VCC-SW 9~10V for coil switched drive circuits.
6.3.3 Test environment

Set up the A28 test environment as shown in Figure by using the DC power supply and electronic load for input source and output load. Get system efficiency by measuring input and output power.

Figure 46 Test environment
6.3.4 Measurements

These are the examples for measuring signals on the board.

1. Measure the signals when Tx board works under ping and stand by states, when Tx wakes up for charging, and from charging to power stop.

   Ch1: PWM       Ch2: Coil Current

![Digital Ping for 3 Coils](image)

Figure 47 Signals from Ping to Sleep

The AC signal frequency changes to adjust the output power when the load changes.

   Ch1: Rx communication signal       Ch2: TP20 PWM1
   Ch3: TP21 PWM2                    Ch4: Coil current
Figure 48  PWM frequency on 0.5 W power output

Figure 49  PWM frequency when 5W power output
2. System response measurement for load dump and load step test.

<table>
<thead>
<tr>
<th>Channel</th>
<th>Signal Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ch1</td>
<td>Rx communication signal</td>
</tr>
<tr>
<td>Ch2</td>
<td>TP9 PWM1</td>
</tr>
<tr>
<td>Ch3</td>
<td>TP10 coil voltage</td>
</tr>
<tr>
<td>Ch4</td>
<td>Coil current</td>
</tr>
</tbody>
</table>

Figure 50 System response on load dump

Figure 51 System response on load step
7 References

- Freescale wireless charging solution page: freescale.com/wirelesscharging
- Freescale Codewarrior 10 IDE page: freescale.com/codewarrior
- Freescale Freemaster tool page: freescale.com/Freemaster
- WPC page: www.wirelesspowerconsortium.com
- WCT1101 Documents:
  - WCT1101 A28 Reference Design System User’s Guide (WCT1101SYSUG), this document
  - WCT1101 Library User’s Guide (WCT1101LIBUG)
  - WCT1101 A28 Run-Time Debug User’s Guide (WCT1101RTDUG)
  - WCT1101 A28 V2.0 Release Notes (WCT1101RN)
Information in this document is provided solely to enable system and software implementers to use Freescale products. There are no express or implied copyright licenses granted hereunder to design or fabricate any integrated circuits based on the information in this document.

Freescale reserves the right to make changes without further notice to any products herein. Freescale makes no warranty, representation, or guarantee regarding the suitability of its products for any particular purpose, nor does Freescale assume any liability arising out of the application or use of any product or circuit, and specifically disclaims any and all liability, including without limitation consequential or incidental damages. ‘Typical’ parameters that may be provided in Freescale data sheets and/or specifications can and do vary in different applications, and actual performance may vary over time. All operating parameters, including “typicals,” must be validated for each customer application by customer’s technical experts. Freescale does not convey any license under its patent rights nor the rights of others. Freescale sells products pursuant to standard terms and conditions of sale, which can be found at the following address: freescale.com/SalesTermsandConditions.

Freescale and the Freescale logo are trademarks of Freescale Semiconductor, Inc., Reg. U.S. Pat. & Tm. Off. All other product or service names are the property of their respective owners.

©2014 Freescale Semiconductor, Inc.