Get Started with the S32K144EVB

Out of the Box

Applies for the S32K144EVB evaluation board (REV B)

1.1 Get to Know Your Evaluation Board

1.2 Understanding the Header/Pinout

1.3 Understanding the HMI Mapping:

Component S32K144
Red LED PTD15 (FTM0 CH0)
Blue LED PTD0 (FTM0 CH2)
Green LED PTD16 (FTM0 CH1)
Potentiometer PTC14 (ADC0_SE12)
SW2 PTC12
SW3 PTC13
OpenSDA UART Tx PTC7 (LPUART1_TX)
OpenSDA UART Rx PTC6 (LPUART1_RX)
CAN Tx PTE5 (CAN0_TX)
CAN Rx PTE4 (CAN0_RX)
LIN Tx PTD7 (LPUART2_TX)
LIN Rx PTD6 (LPUART2_RX)
SBC_SCK PTB14 (LPSPI1_SCK)
SBC_MISO PTB15 (LPSPI1_SIN)
SBC_MOSI PTB16 (LPSPI1_SOUT)
SBC_CS PTB17 (LPSPI1_PCS3)

Get Software

2.1 Integrated Development Environment (IDE)

S32K144EVB performs better when using S32 Design Studio for Arm v1.3.

Note: Check the S32 Design Studio page for the latest version.

2.2 Run-Time Debugging Tool

S32K144EVB evaluation board performs better when using the FreeMASTER tool for run-time debugging. You can also download and install the FreeMASTER Communication Driver (source code already included in the example project).

Note: Check the FreeMASTER page for the latest version.

Plug It In

3.1 Set Up jumpers in S32K144EVB evaluation board

Jumper Setting Description
J104 1-2 Reset signal to OpenSDA, use to enter into OpenSDA Bootloader mode
2-3 (Default) Reset signal direct to the MCU, use to reset S32K144
J107 1-2 S32K144 powered by 12 V power source
2-3 (Default) S32K144 powered by USB micro connector
J109/J108 1-2 (Default) Removes CAN termination resistor

Watch the video or use the step-by-step guide, below.


3.2 Plug In the 12 V Power Supply

The S32K144EVB evaluation board powers from a USB or external 12 V power supply. By default USB power is enabled with J107 jumper (2-3 closed).

Connect the USB cable to a PC using a USB cable and connect other end of USB cable (microUSB) to mini-B port on to J7 on your S32K144EVB.

Allow the PC to automatically configure the USB drivers if needed. Debug is done using OpenSDA through J7.

Note: When powered through USB, LEDs D2 and D3 should light green.

Once the board is recognized, it should appear as a mass storage device in your PC with the name EVB-S32K144.

The S32K144EVB evaluation board is preloaded with a software in which red, blue and green LEDS will toggle at different rates:

Build and Load

Let’s take it for a test drive.

4.1 Communicate with Run-Time Debugger

1. Launch the FreeMASTER application:

2. Configure the communication port through OpenSDA with a 115200 b/s speed rate:

  • Manually = Project > Options > Comm

  • Automatically = Tools > Connection Wizard

Learn more about OpenSDA at Projects and Tutorials.

4.2 FreeMASTER JumpStart project download

The FreeMASTER JumpStart project will be automatically downloaded from NXP Semiconductors once the FreeMASTER application detects the web address stored as an TSA active content in the flash.

4.3 FreeMASTER JumpStart Project Loaded

The FreeMASTER JumpStart project description:

Learn more about the FreeMASTER JumpStart project features at Projects and Tutorials.

4.4 Import and Debug the Project to IDE

Watch the video to create a new project and load a code example to blink an LDE. The video also covers hoe to build and debug your project. You can also use the step-by-step guide.


Launch the S32 Design Studio for Arm and select a default Workspace or specify a new one, then click OK.

Note: Uncheck the box Use this as default and do not ask again.

To create a new project, select File > New > Project

Choose a project name and then select a project type, then click Next.

Note: You can select the project type in the executable or library folder.

Select Debugger and Library, then click Finish.

4.5 Set Up Debug Configuration

Select OpenSDA to debug with it.

Select your project, and click on Debug Configuration.

Select the debug configuration under GDB PEMicro Interface Debugging, click the Debugger tab.

In Interface, select OpenSDA. If your board is plugged in, it should appear in Port. To finish, click Apply then Debug.

Debug

5.1 Debug Basics

Step, Run, Suspend, Resume

Step Into (F5)

Step Over (F6)

Step Return (F7)

Run

Suspend

Resume (F8)

View Variables

Click the Variables tab. To enter different values, click in the Value field.

View and Alter Registers

To see CPU registers, click the Registers tab. To enter different values, click in the Value field.

View peripheral registers in the EmbSys Registers tab:

View and Alter Memory

Select Add Memory Monitor and then select the base address to: 40000000

View Memory

Breakpoints

To add break points, point and click in the desired location.

Note: The blue dot indicates the debugger breakpoint.

Reset and Terminate the Debug Session

To reset the program counter, select Terminate (Ctrl+F2).

5.2 Debug with FreeMASTER

Debug configuration is only required once. Subsequent starting of debugger does not require those steps.

There are three options to start debugging:

  • If the Debug Configuration is still open, click Debug on the bottom right.
  • Select Run – Debug (or hit F11)

    Note: This method currently selects the desktop target (project.elf) and gives an error. Do not use until this is changed.

  • Select the bug icon and select …_debug.elf target

    Note: This is the recommended option.

Learn more about debugging basics at Projects and Tutorials.

Optional - P&E Debug Configuration

1. Select Debug Configurations:

2. Create a new P&E launch configuration:

Click to create a new P&E launch and then click Debugger.

3. Select a S32K144 device and then click Apply and debug your application.

FreeMASTER JumpStart

To display the main project panel, go to: Project > View > Project Tree

To display real-time oscilloscope graph examples, select Potentiometer or Touch Sense Electrodes:

  • Analog values from potentiometer:
  • Responses from touch sense electrodes:

Introduction to OpenSDA

OpenSDA is an open-standard serial and debug adapter. It bridges serial and debug communications between a USB host and an embedded target processor. OpenSDA software includes a flash-resident USB mass-storage device (MSD) bootloader and a collection of OpenSDA applications.

The S32K144EVB comes with the MSD Flash Programmer OpenSDA Application preinstalled.

Follow these instructions to run the OpenSDA Bootloader and update or change the installed OpenSDA Application.

Enter OpenSDA Bootloader Mode Load an OpenSDA Application
  1. Unplug the USB cable if attached.
  2. Set J104 on position 1-2.
  3. Press and hold the Reset (SW5)
  4. Plug in a USB cable (not included) between a USB host and the OpenSDA USB connector (labeled “SDA”).
  5. Release Reset

A removable drive should now be visible in the host file system with a volume label of BOOTLOADER. You are now in OpenSDA Bootloader mode.

Note: Follow the “Load an OpenSDA Application” instructions to update the MSD Flash Programmer on your S32K144EVB to the latest version.

  1. While in OpenSDA Bootloader mode, double-click SDA_INFO.HTML in the BOOTLOADER drive. A web browser will open the OpenSDA homepage containing the name and version of the installed application. This information can also be read as text directly from SDA_INFO.HTML.
  2. Locate the OpenSDA applications.
  3. Copy and paste or drag and drop the MSD Flash Programmer Application to the BOOTLOADER drive
  4. Unplug the USB cable and plug it in again. The new OpenSDA Application should now be running and a S32K144 EVB drive should be visible in the host file system.

You are now running the latest version of the MSD Flash Programmer. Use this same procedure to load other OpenSDA Applications.

The MSD Flash Programmer is a composite USB application that provides a virtual serial port and an easy and convenient way to program applications into the KEA MCU. It emulates a FAT16 file system, appearing as a removable drive in the host file system with a volume label of EVB-S32K144. Raw binary and Motorola S-record files that are copied to the drive are programmed directly into the flash of the KEA and executed automatically. The virtual serial port enumerates as a standard serial port device that can be opened with standard serial terminal applications.

Using the MSD Flash Programmer Using the Virtual Serial Port
  1. Locate the .srec file of your project, file is under the Debug folder of the S32DS project.
  2. Copy and paste or drag and drop one of the .srec files to the EVB-S32K144 drive.

The new application should now be running on the S32K144EVB. Starting with v1.03 of the MSD Flash Programmer, you can program repeatedly without the need to unplug and reattach the USB cable before reprogramming.

Drag one of the .srec code for the S32K144 the S32K144EVB board over USB to reprogram the preloaded code example to another example.

  1. Determine the symbolic name assigned to the EVB-S32K144 virtual serial port. In Windows open Device Manager and look for the COM port named PEMicro/Freescale – CDC Serial Port.
  2. Open the serial terminal emulation program of your choice.

    Note: For Windows you can use Tera Term, PuTTY or HyperTerminal

  3. Press and release Reset (SW0) at any time to restart the example application. Resetting the embedded application will not affect the connection of the virtual serial port to the terminal program.
  4. It is possible to debug and communicate with the serial port at the same time. There is no need to stop the debug.

Note: Refer to the OpenSDA User’s Guide for a description of a known Windows issue when disconnecting a virtual serial port while the COM port is in use

Using Processor Expert

Watch the video to create a new project and load a code example to make a blinking LED. The video also covers how to build and debug your project. You can also use the step-by-step guide.

Get help

Forums

Connect with other engineers and get expert advice on designing with the S32K144EVB on one of our community sites.